-o rhv-upload: Improve conversion performance
resolves: rhbz#2039255 -o rhv-upload: Keep connections alive resolves: rhbz#2032324 -o rhv-upload: Replace -oo rhv-direct with -oo rhv-proxy resolves: rhbz#2033096 - Fix log line wrapping making log parsing difficult (1820221)
This commit is contained in:
parent
991b284375
commit
b4302313b9
0001-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch0002-RHEL-v2v-Disable-the-qemu-boot-oo-qemu-boot-option-R.patch0003-RHEL-Fix-list-of-supported-sound-cards-to-match-RHEL.patch0004-RHEL-Fixes-for-libguestfs-winsupport.patch0005-RHEL-v2v-i-disk-force-VNC-as-display-RHBZ-1372671.patch0006-RHEL-v2v-do-not-mention-SUSE-Xen-hosts-RHBZ-1430203.patch0007-RHEL-point-to-KB-for-supported-v2v-hypervisors-guest.patch0008-RHEL-Disable-o-glance.patch0009-RHEL-Remove-the-in-place-option.patchsourcesvirt-v2v.spec
@ -1,4 +1,4 @@
|
||||
From c35ce051106e727244e006647a5a0285fda822ae Mon Sep 17 00:00:00 2001
|
||||
From 5b3653332be7b739755f53cca19ce10768585a61 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 28 Sep 2014 19:14:43 +0100
|
||||
Subject: [PATCH] RHEL: v2v: Select correct qemu binary for -o qemu mode
|
||||
@ -16,18 +16,18 @@ support cases.
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/output/output_qemu.ml b/output/output_qemu.ml
|
||||
index 10ec8904..67f7cbcf 100644
|
||||
index f8d2e171..700de058 100644
|
||||
--- a/output/output_qemu.ml
|
||||
+++ b/output/output_qemu.ml
|
||||
@@ -119,7 +119,7 @@ and qemu_finalize dir source inspect target_meta
|
||||
* module deals with shell and qemu comma quoting.
|
||||
*)
|
||||
let cmd = Qemuopts.create () in
|
||||
- Qemuopts.set_binary_by_arch cmd (Some guestcaps.gcaps_arch);
|
||||
+ Qemuopts.set_binary cmd "/usr/libexec/qemu-kvm";
|
||||
@@ -137,7 +137,7 @@ module QEMU = struct
|
||||
* module deals with shell and qemu comma quoting.
|
||||
*)
|
||||
let cmd = Qemuopts.create () in
|
||||
- Qemuopts.set_binary_by_arch cmd (Some guestcaps.gcaps_arch);
|
||||
+ Qemuopts.set_binary cmd "/usr/libexec/qemu-kvm";
|
||||
|
||||
let flag = Qemuopts.flag cmd
|
||||
and arg = Qemuopts.arg cmd
|
||||
let flag = Qemuopts.flag cmd
|
||||
and arg = Qemuopts.arg cmd
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 635fe323354faf2d3eb790c4fe8caddfd7422e7b Mon Sep 17 00:00:00 2001
|
||||
From b896dab3d8d4226b246e2e90d07235a38b6c8a79 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 30 Sep 2014 10:50:27 +0100
|
||||
Subject: [PATCH] RHEL: v2v: Disable the --qemu-boot / -oo qemu-boot option
|
||||
@ -44,10 +44,10 @@ index a5f155cb..3a2e6238 100644
|
||||
=item B<-o json -os> C<DIRECTORY>
|
||||
|
||||
diff --git a/docs/virt-v2v.pod b/docs/virt-v2v.pod
|
||||
index 615c6eff..41417856 100644
|
||||
index f50d27a0..9b1e44a1 100644
|
||||
--- a/docs/virt-v2v.pod
|
||||
+++ b/docs/virt-v2v.pod
|
||||
@@ -141,11 +141,6 @@ Since F<guest-domain.xml> contains the path(s) to the guest disk
|
||||
@@ -140,11 +140,6 @@ Since F<guest-domain.xml> contains the path(s) to the guest disk
|
||||
image(s) you do not need to specify the name of the disk image on the
|
||||
command line.
|
||||
|
||||
@ -59,7 +59,7 @@ index 615c6eff..41417856 100644
|
||||
=head1 OPTIONS
|
||||
|
||||
=over 4
|
||||
@@ -510,9 +505,6 @@ This is similar to I<-o local>, except that a shell script is written
|
||||
@@ -509,9 +504,6 @@ This is similar to I<-o local>, except that a shell script is written
|
||||
which you can use to boot the guest in qemu. The converted disks and
|
||||
shell script are written to the directory specified by I<-os>.
|
||||
|
||||
@ -69,7 +69,7 @@ index 615c6eff..41417856 100644
|
||||
=item B<-o> B<rhev>
|
||||
|
||||
This is the same as I<-o rhv>.
|
||||
@@ -768,10 +760,6 @@ Print information about the source guest and stop. This option is
|
||||
@@ -765,10 +757,6 @@ Print information about the source guest and stop. This option is
|
||||
useful when you are setting up network and bridge maps.
|
||||
See L</Networks and bridges>.
|
||||
|
||||
@ -81,21 +81,21 @@ index 615c6eff..41417856 100644
|
||||
|
||||
=item B<--quiet>
|
||||
diff --git a/output/output_qemu.ml b/output/output_qemu.ml
|
||||
index 67f7cbcf..376de27d 100644
|
||||
index 700de058..3ad98a58 100644
|
||||
--- a/output/output_qemu.ml
|
||||
+++ b/output/output_qemu.ml
|
||||
@@ -52,6 +52,9 @@ and qemu_parse_options options =
|
||||
) options.output_options;
|
||||
let qemu_boot = !qemu_boot in
|
||||
@@ -63,6 +63,9 @@ module QEMU = struct
|
||||
) options.output_options;
|
||||
let qemu_boot = !qemu_boot in
|
||||
|
||||
+ if qemu_boot then
|
||||
+ error (f_"-o qemu: the -oo qemu-boot option cannot be used in RHEL");
|
||||
+ if qemu_boot then
|
||||
+ error (f_"-o qemu: the -oo qemu-boot option cannot be used in RHEL");
|
||||
+
|
||||
(* -os must be set to a directory. *)
|
||||
let output_storage =
|
||||
match options.output_storage with
|
||||
(* -os must be set to a directory. *)
|
||||
let output_storage =
|
||||
match options.output_storage with
|
||||
diff --git a/v2v/v2v.ml b/v2v/v2v.ml
|
||||
index f18f5680..fea69545 100644
|
||||
index 7bd47c1e..a66fa285 100644
|
||||
--- a/v2v/v2v.ml
|
||||
+++ b/v2v/v2v.ml
|
||||
@@ -277,8 +277,6 @@ let rec main () =
|
||||
|
@ -1,4 +1,4 @@
|
||||
From f066cbf7f6ad2f7e3c48b079a062d90e5d699567 Mon Sep 17 00:00:00 2001
|
||||
From 3745743d97bc432854750afd6d04d6391f19bf2f Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Fri, 24 Apr 2015 09:45:41 -0400
|
||||
Subject: [PATCH] RHEL: Fix list of supported sound cards to match RHEL qemu
|
||||
|
@ -1,4 +1,4 @@
|
||||
From f92a657fe3889af3ab1f1abaa62de9ed3ee9d5aa Mon Sep 17 00:00:00 2001
|
||||
From f7ed42f475271291d126084cb92157974ea274c6 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 30 Aug 2015 03:21:57 -0400
|
||||
Subject: [PATCH] RHEL: Fixes for libguestfs-winsupport.
|
||||
@ -14,10 +14,10 @@ In virt-v2v helpers we must set the program name to virt-v2v.
|
||||
5 files changed, 17 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/convert/convert.ml b/convert/convert.ml
|
||||
index f78e87ef..d61d7fb4 100644
|
||||
index 87fca725..5e0e6c2b 100644
|
||||
--- a/convert/convert.ml
|
||||
+++ b/convert/convert.ml
|
||||
@@ -53,6 +53,7 @@ let rec convert dir options source =
|
||||
@@ -51,6 +51,7 @@ let rec convert dir options source =
|
||||
|
||||
message (f_"Opening the source");
|
||||
let g = open_guestfs ~identifier:"v2v" () in
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 8711440e202048a9d7dfc471e33966ca98cd426e Mon Sep 17 00:00:00 2001
|
||||
From 46c843f5d5f19aad7bbfe155d20d5d9f26f8a030 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 2 Mar 2017 14:21:37 +0100
|
||||
Subject: [PATCH] RHEL: v2v: -i disk: force VNC as display (RHBZ#1372671)
|
||||
@ -9,18 +9,18 @@ The SDL output mode is not supported in RHEL's qemu-kvm.
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/input/input_disk.ml b/input/input_disk.ml
|
||||
index 2b21950a..524a44bc 100644
|
||||
index 9fd08639..dc3bed6f 100644
|
||||
--- a/input/input_disk.ml
|
||||
+++ b/input/input_disk.ml
|
||||
@@ -70,7 +70,7 @@ let rec disk_source dir options args =
|
||||
s_features = [ "acpi"; "apic"; "pae" ];
|
||||
s_firmware = UnknownFirmware; (* causes virt-v2v to autodetect *)
|
||||
s_display =
|
||||
- Some { s_display_type = Window; s_keymap = None; s_password = None;
|
||||
+ Some { s_display_type = VNC; s_keymap = None; s_password = None;
|
||||
s_listen = LNoListen; s_port = None };
|
||||
s_sound = None;
|
||||
s_disks = s_disks;
|
||||
@@ -76,7 +76,7 @@ module Disk = struct
|
||||
s_features = [ "acpi"; "apic"; "pae" ];
|
||||
s_firmware = UnknownFirmware; (* causes virt-v2v to autodetect *)
|
||||
s_display =
|
||||
- Some { s_display_type = Window; s_keymap = None; s_password = None;
|
||||
+ Some { s_display_type = VNC; s_keymap = None; s_password = None;
|
||||
s_listen = LNoListen; s_port = None };
|
||||
s_sound = None;
|
||||
s_disks = s_disks;
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 9144b6272f14e149efb2fe2d8792ef91f94d3d14 Mon Sep 17 00:00:00 2001
|
||||
From 70b8b26867ca0c4a142f3fb436e4dbb66a01f187 Mon Sep 17 00:00:00 2001
|
||||
From: Pino Toscano <ptoscano@redhat.com>
|
||||
Date: Wed, 8 Mar 2017 11:03:40 +0100
|
||||
Subject: [PATCH] RHEL: v2v: do not mention SUSE Xen hosts (RHBZ#1430203)
|
||||
|
@ -1,4 +1,4 @@
|
||||
From b14e17c2cfbf5bcb8880cf5972612bcac46e52f7 Mon Sep 17 00:00:00 2001
|
||||
From fa8028afa670c3575f31b838f1d15ed7ee16f26a Mon Sep 17 00:00:00 2001
|
||||
From: Pino Toscano <ptoscano@redhat.com>
|
||||
Date: Tue, 26 Mar 2019 09:42:25 +0100
|
||||
Subject: [PATCH] RHEL: point to KB for supported v2v hypervisors/guests
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 415b9b0bff55a349145027349ab7c9b421696154 Mon Sep 17 00:00:00 2001
|
||||
From 95640bac1c00014f94bec5539907fd92d7379ad2 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 30 Jun 2021 11:15:52 +0100
|
||||
Subject: [PATCH] RHEL: Disable -o glance
|
||||
@ -100,10 +100,10 @@ index f5a3abad..1ab356e8 100644
|
||||
=head1 AUTHOR
|
||||
|
||||
diff --git a/docs/virt-v2v.pod b/docs/virt-v2v.pod
|
||||
index 41417856..c7def4f7 100644
|
||||
index 9b1e44a1..a1e00db8 100644
|
||||
--- a/docs/virt-v2v.pod
|
||||
+++ b/docs/virt-v2v.pod
|
||||
@@ -432,14 +432,6 @@ See L</Networks and bridges> below.
|
||||
@@ -431,14 +431,6 @@ See L</Networks and bridges> below.
|
||||
|
||||
This is the same as I<-o local>.
|
||||
|
||||
@ -118,7 +118,7 @@ index 41417856..c7def4f7 100644
|
||||
=item B<-o> B<json>
|
||||
|
||||
Set the output method to I<json>.
|
||||
@@ -1167,11 +1159,6 @@ and output methods may use disk space, as outlined in the table below.
|
||||
@@ -1170,11 +1162,6 @@ and output methods may use disk space, as outlined in the table below.
|
||||
This temporarily places a full copy of the uncompressed source disks
|
||||
in C<$VIRT_V2V_TMPDIR> (or F</var/tmp>).
|
||||
|
||||
@ -130,7 +130,7 @@ index 41417856..c7def4f7 100644
|
||||
=item I<-o local>
|
||||
|
||||
=item I<-o qemu>
|
||||
@@ -1355,13 +1342,6 @@ instance.
|
||||
@@ -1358,13 +1345,6 @@ instance.
|
||||
Because of how Cinder volumes are presented as F</dev> block devices,
|
||||
using I<-o openstack> normally requires that virt-v2v is run as root.
|
||||
|
||||
@ -169,7 +169,7 @@ index c0db9115..074b5e16 100755
|
||||
set -e
|
||||
set -x
|
||||
diff --git a/v2v/v2v.ml b/v2v/v2v.ml
|
||||
index fea69545..a1c7a7c7 100644
|
||||
index a66fa285..c9ddce36 100644
|
||||
--- a/v2v/v2v.ml
|
||||
+++ b/v2v/v2v.ml
|
||||
@@ -205,7 +205,6 @@ let rec main () =
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 3eb3474d4f2b94cffd593995cdadc8d4e559b54f Mon Sep 17 00:00:00 2001
|
||||
From c7c14141d1c985dbba8749f9209b78d96200c2b3 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 2 Dec 2021 11:56:05 +0000
|
||||
Subject: [PATCH] RHEL: Remove the --in-place option
|
||||
@ -11,7 +11,7 @@ wish to support in RHEL.
|
||||
2 files changed, 57 deletions(-)
|
||||
|
||||
diff --git a/docs/virt-v2v.pod b/docs/virt-v2v.pod
|
||||
index c7def4f7..942e5991 100644
|
||||
index a1e00db8..a3fc3dc8 100644
|
||||
--- a/docs/virt-v2v.pod
|
||||
+++ b/docs/virt-v2v.pod
|
||||
@@ -8,10 +8,6 @@ virt-v2v - Convert a guest to use KVM
|
||||
@ -38,7 +38,7 @@ index c7def4f7..942e5991 100644
|
||||
=head2 Other virt-v2v topics
|
||||
|
||||
L<virt-v2v-support(1)> — Supported hypervisors, virtualization
|
||||
@@ -290,20 +280,6 @@ For I<-i disk> only, this specifies the format of the input disk
|
||||
@@ -289,20 +279,6 @@ For I<-i disk> only, this specifies the format of the input disk
|
||||
image. For other input methods you should specify the input
|
||||
format in the metadata.
|
||||
|
||||
@ -59,7 +59,7 @@ index c7def4f7..942e5991 100644
|
||||
=item B<-io> OPTION=VALUE
|
||||
|
||||
Set input option(s) related to the current input mode or transport.
|
||||
@@ -1414,31 +1390,6 @@ that instead.
|
||||
@@ -1417,31 +1393,6 @@ that instead.
|
||||
</devices>
|
||||
</domain>
|
||||
|
||||
@ -92,7 +92,7 @@ index c7def4f7..942e5991 100644
|
||||
|
||||
The I<--machine-readable> option can be used to make the output more
|
||||
diff --git a/v2v/v2v.ml b/v2v/v2v.ml
|
||||
index a1c7a7c7..44ba6fae 100644
|
||||
index c9ddce36..6859a02c 100644
|
||||
--- a/v2v/v2v.ml
|
||||
+++ b/v2v/v2v.ml
|
||||
@@ -183,7 +183,6 @@ let rec main () =
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (virt-v2v-1.45.98.tar.gz) = a709ae109675064b0b96f8fa7e9d2ef37d9f557f1aa9d8f9152bb15a814e5539af4d5569b44a10229dbf7e62ff4d6f6361f71393ac6a614e3d737548ee131746
|
||||
SHA512 (virt-v2v-1.45.98.tar.gz.sig) = 1e98fb61bcdfcf2f8b9a3ab3b39d2b2dee73cdd40a43aefb97fe4671afa121373f7d8ba111e6a39a001e50901508341fed76ed0bd313df3991c81f1ead2868f2
|
||||
SHA512 (virt-v2v-1.45.99.tar.gz) = 46fd087e584fee94a95f229ef860220201f75b85cf4cb4137349cc64e447094d5c1db192121095779f99a997336aa547ba7d2aed2d1778e381cd003a8ab83327
|
||||
SHA512 (virt-v2v-1.45.99.tar.gz.sig) = d34ca220bc2161357ddf32ccb46117fdbcb98347384e284027a02e67c2ebe9851b1e5deb3e59607d84916bb689dd5e053462d862aff3a813021493fd33f1f1b9
|
||||
|
@ -14,7 +14,7 @@
|
||||
|
||||
Name: virt-v2v
|
||||
Epoch: 1
|
||||
Version: 1.45.98
|
||||
Version: 1.45.99
|
||||
Release: 1%{?dist}
|
||||
Summary: Convert a virtual machine to run on KVM
|
||||
|
||||
@ -145,6 +145,7 @@ Requires: nbdkit-ssh-plugin
|
||||
%ifarch x86_64
|
||||
Requires: nbdkit-vddk-plugin
|
||||
%endif
|
||||
Requires: nbdkit-blocksize-filter
|
||||
Requires: nbdkit-cacheextents-filter
|
||||
Requires: nbdkit-cow-filter >= 1.26.5-1.el9
|
||||
Requires: nbdkit-rate-filter
|
||||
@ -301,14 +302,19 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 10 2022 Richard W.M. Jones <rjones@redhat.com> - 1:1.45.98-1
|
||||
- Rebase to upstream 1.45.98.
|
||||
* Tue Feb 15 2022 Richard W.M. Jones <rjones@redhat.com> - 1:1.45.99-1
|
||||
- Rebase to upstream 1.45.99.
|
||||
- Add check for sufficient free space in the host
|
||||
resolves: rhbz#2051394
|
||||
- Update documentation of -ip for conversions from VMware over HTTPS
|
||||
related: rhbz#1960087
|
||||
- -o rhv-upload: Keep connections alive (2032324)
|
||||
- -o rhv-upload: Improve conversion performance (2039255)
|
||||
- -o rhv-upload: Keep connections alive
|
||||
resolves: rhbz#2032324
|
||||
- -o rhv-upload: Improve conversion performance
|
||||
resolves: rhbz#2039255
|
||||
- -o rhv-upload: Replace -oo rhv-direct with -oo rhv-proxy
|
||||
resolves: rhbz#2033096
|
||||
- Fix log line wrapping making log parsing difficult (1820221)
|
||||
|
||||
* Wed Feb 2 2022 Laszlo Ersek <lersek@redhat.com> - 1:1.45.97-4
|
||||
- v2v import from vCenter fails when using interactive password because
|
||||
|
Loading…
Reference in New Issue
Block a user