New upstream version 1.43.5.
This commit is contained in:
parent
d81b7720bf
commit
989dd6b636
@ -1,62 +0,0 @@
|
||||
From 7a346548c052d535015f98874ea52dee4b392947 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 30 Mar 2021 12:41:58 +0100
|
||||
Subject: [PATCH] tests: Prefer xorriso over genisoimage to generate test.iso
|
||||
|
||||
This Debian page explains the upstream situation:
|
||||
https://wiki.debian.org/genisoimage
|
||||
|
||||
On Fedora, xorriso provides a compatibility program called "mkisofs".
|
||||
However this is not present in Debian. Hence the choice to look for
|
||||
the program called "xorrisofs".
|
||||
|
||||
(cherry picked from commit 2216ab2e328457ef172d6bfa534272edf2f81a3a)
|
||||
---
|
||||
m4/guestfs-progs.m4 | 6 +++---
|
||||
test-data/Makefile.am | 2 +-
|
||||
test-data/fake-virtio-win/Makefile.am | 2 +-
|
||||
3 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/m4/guestfs-progs.m4 b/m4/guestfs-progs.m4
|
||||
index 4575a72a9..8f34faefa 100644
|
||||
--- a/m4/guestfs-progs.m4
|
||||
+++ b/m4/guestfs-progs.m4
|
||||
@@ -39,10 +39,10 @@ AC_PROG_AWK
|
||||
|
||||
AC_PROG_LN_S
|
||||
|
||||
-dnl Check for genisoimage/mkisofs
|
||||
-AC_PATH_PROGS([GENISOIMAGE],[genisoimage mkisofs],[no],
|
||||
+dnl Check for xorriso/genisoimage/mkisofs.
|
||||
+AC_PATH_PROGS([MKISOFS],[xorrisofs genisoimage mkisofs],[no],
|
||||
[$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/sbin])
|
||||
-test "x$GENISOIMAGE" = "xno" && AC_MSG_ERROR([genisoimage must be installed])
|
||||
+test "x$MKISOFS" = "xno" && AC_MSG_ERROR([xorriso or genisoimage or mkisofs must be installed])
|
||||
|
||||
dnl po4a for translating man pages and POD files (optional).
|
||||
AC_CHECK_PROG([PO4A_GETTEXTIZE],[po4a-gettextize],[po4a-gettextize],[no])
|
||||
diff --git a/test-data/Makefile.am b/test-data/Makefile.am
|
||||
index 8a60c72f6..69170516e 100644
|
||||
--- a/test-data/Makefile.am
|
||||
+++ b/test-data/Makefile.am
|
||||
@@ -97,6 +97,6 @@ test.iso: $(images_files)
|
||||
cp $(image_files) d/
|
||||
mkdir -p d/directory
|
||||
cd d && ln -sf /10klines abssymlink
|
||||
- cd d && $(GENISOIMAGE) -J -r -o ../$@-t .
|
||||
+ cd d && $(MKISOFS) -J -r -o ../$@-t .
|
||||
rm -rf d
|
||||
mv $@-t $@
|
||||
diff --git a/test-data/fake-virtio-win/Makefile.am b/test-data/fake-virtio-win/Makefile.am
|
||||
index 9851ca07d..55b91a95a 100644
|
||||
--- a/test-data/fake-virtio-win/Makefile.am
|
||||
+++ b/test-data/fake-virtio-win/Makefile.am
|
||||
@@ -598,4 +598,4 @@ check_DATA = fake-virtio-win.iso
|
||||
CLEANFILES += fake-virtio-win.iso
|
||||
|
||||
fake-virtio-win.iso: $(cd_files)
|
||||
- $(GENISOIMAGE) -J -r -o $@ $(srcdir)/cd
|
||||
+ $(MKISOFS) -J -r -o $@ $(srcdir)/cd
|
||||
--
|
||||
2.29.0.rc2
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (virt-v2v-1.43.4.tar.gz) = 3c11ea864b0a1dd579c8dff891295be9200c9ba9e1d804cfd50aa356d626b8aa11a08c70ac2c6e20e5e9e023fea0d46e8f84edc1fca59484521ca273857f5c57
|
||||
SHA512 (virt-v2v-1.43.4.tar.gz.sig) = 292d02fc94888446016b34637e1ea913a753d0f430a130f881b7f101ed4887b13b91c551353c45f9f73d9876b1e3941e846e8ecde5ed3996c999578557bbc944
|
||||
SHA512 (virt-v2v-1.43.5.tar.gz) = 7d9222a98894683d7f399fe62fa9bd2a2d01eebcd68484a38dec1fee0b477f977c56773e3ddb8fd7283f493795217f36e4272bc8d8905484492e6bb38ec1b1f2
|
||||
SHA512 (virt-v2v-1.43.5.tar.gz.sig) = 107c3c6716b13ee7d8482d4a5592fcfd25a39cc6e983fe95da5d712a2316bc3543fc00005abe426b835c7c9a9264c724693c73db2940f787e329460f35e601c8
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
# If there are patches which touch autotools files, set this to 1.
|
||||
%if !0%{?rhel}
|
||||
%global patches_touch_autotools 1
|
||||
%global patches_touch_autotools %{nil}
|
||||
%else
|
||||
# On RHEL the downstream patches always touch autotools files.
|
||||
%global patches_touch_autotools 1
|
||||
@ -14,8 +14,8 @@
|
||||
|
||||
Name: virt-v2v
|
||||
Epoch: 1
|
||||
Version: 1.43.4
|
||||
Release: 5%{?dist}
|
||||
Version: 1.43.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Convert a virtual machine to run on KVM
|
||||
|
||||
License: GPLv2+
|
||||
@ -48,9 +48,6 @@ ExcludeArch: %{ix86}
|
||||
ExclusiveArch: x86_64
|
||||
%endif
|
||||
|
||||
# Upstream patch to replace genisoimage with xorriso.
|
||||
Patch0001: 0001-tests-Prefer-xorriso-over-genisoimage-to-generate-te.patch
|
||||
|
||||
# Downstream (RHEL-only) patches.
|
||||
%if 0%{?rhel}
|
||||
Patch9001: 0001-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
|
||||
@ -287,6 +284,9 @@ rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/virt-v2v-copy-to-local
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 14 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.43.5-1
|
||||
- New upstream version 1.43.5.
|
||||
|
||||
* Thu Apr 01 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.43.4-5
|
||||
- Add upstream patch to depend on xorriso.
|
||||
- Change libguestfs-tools-c -> guestfs-tools.
|
||||
|
Loading…
Reference in New Issue
Block a user