Add upstream patch to depend on xorriso.
This commit is contained in:
parent
bed8938b69
commit
4c68cfae20
@ -0,0 +1,62 @@
|
||||
From 7a346548c052d535015f98874ea52dee4b392947 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 30 Mar 2021 12:41:58 +0100
|
||||
Subject: [PATCH] tests: Prefer xorriso over genisoimage to generate test.iso
|
||||
|
||||
This Debian page explains the upstream situation:
|
||||
https://wiki.debian.org/genisoimage
|
||||
|
||||
On Fedora, xorriso provides a compatibility program called "mkisofs".
|
||||
However this is not present in Debian. Hence the choice to look for
|
||||
the program called "xorrisofs".
|
||||
|
||||
(cherry picked from commit 2216ab2e328457ef172d6bfa534272edf2f81a3a)
|
||||
---
|
||||
m4/guestfs-progs.m4 | 6 +++---
|
||||
test-data/Makefile.am | 2 +-
|
||||
test-data/fake-virtio-win/Makefile.am | 2 +-
|
||||
3 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/m4/guestfs-progs.m4 b/m4/guestfs-progs.m4
|
||||
index 4575a72a9..8f34faefa 100644
|
||||
--- a/m4/guestfs-progs.m4
|
||||
+++ b/m4/guestfs-progs.m4
|
||||
@@ -39,10 +39,10 @@ AC_PROG_AWK
|
||||
|
||||
AC_PROG_LN_S
|
||||
|
||||
-dnl Check for genisoimage/mkisofs
|
||||
-AC_PATH_PROGS([GENISOIMAGE],[genisoimage mkisofs],[no],
|
||||
+dnl Check for xorriso/genisoimage/mkisofs.
|
||||
+AC_PATH_PROGS([MKISOFS],[xorrisofs genisoimage mkisofs],[no],
|
||||
[$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/sbin])
|
||||
-test "x$GENISOIMAGE" = "xno" && AC_MSG_ERROR([genisoimage must be installed])
|
||||
+test "x$MKISOFS" = "xno" && AC_MSG_ERROR([xorriso or genisoimage or mkisofs must be installed])
|
||||
|
||||
dnl po4a for translating man pages and POD files (optional).
|
||||
AC_CHECK_PROG([PO4A_GETTEXTIZE],[po4a-gettextize],[po4a-gettextize],[no])
|
||||
diff --git a/test-data/Makefile.am b/test-data/Makefile.am
|
||||
index 8a60c72f6..69170516e 100644
|
||||
--- a/test-data/Makefile.am
|
||||
+++ b/test-data/Makefile.am
|
||||
@@ -97,6 +97,6 @@ test.iso: $(images_files)
|
||||
cp $(image_files) d/
|
||||
mkdir -p d/directory
|
||||
cd d && ln -sf /10klines abssymlink
|
||||
- cd d && $(GENISOIMAGE) -J -r -o ../$@-t .
|
||||
+ cd d && $(MKISOFS) -J -r -o ../$@-t .
|
||||
rm -rf d
|
||||
mv $@-t $@
|
||||
diff --git a/test-data/fake-virtio-win/Makefile.am b/test-data/fake-virtio-win/Makefile.am
|
||||
index 9851ca07d..55b91a95a 100644
|
||||
--- a/test-data/fake-virtio-win/Makefile.am
|
||||
+++ b/test-data/fake-virtio-win/Makefile.am
|
||||
@@ -598,4 +598,4 @@ check_DATA = fake-virtio-win.iso
|
||||
CLEANFILES += fake-virtio-win.iso
|
||||
|
||||
fake-virtio-win.iso: $(cd_files)
|
||||
- $(GENISOIMAGE) -J -r -o $@ $(srcdir)/cd
|
||||
+ $(MKISOFS) -J -r -o $@ $(srcdir)/cd
|
||||
--
|
||||
2.29.0.rc2
|
||||
|
@ -15,7 +15,7 @@
|
||||
Name: virt-v2v
|
||||
Epoch: 1
|
||||
Version: 1.43.4
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Convert a virtual machine to run on KVM
|
||||
|
||||
License: GPLv2+
|
||||
@ -48,6 +48,9 @@ ExcludeArch: %{ix86}
|
||||
ExclusiveArch: x86_64
|
||||
%endif
|
||||
|
||||
# Upstream patch to replace genisoimage with xorriso.
|
||||
Patch0001: 0001-tests-Prefer-xorriso-over-genisoimage-to-generate-te.patch
|
||||
|
||||
# Downstream (RHEL-only) patches.
|
||||
%if 0%{?rhel}
|
||||
Patch9001: 0001-RHEL-v2v-Select-correct-qemu-binary-for-o-qemu-mode-.patch
|
||||
@ -284,6 +287,9 @@ rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/virt-v2v-copy-to-local
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 01 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.43.4-4
|
||||
- Add upstream patch to depend on xorriso.
|
||||
|
||||
* Tue Mar 30 2021 Richard W.M. Jones <rjones@redhat.com> - 1:1.43.4-3
|
||||
- Add downstream (RHEL-only) patches (RHBZ#1931724).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user