Pull in some upstream patches to fix tests/test-v2v-o-rhv-upload.sh
This commit is contained in:
parent
17d121add7
commit
1bf3000160
85
0001-build-add-an-empty-config.sh.patch
Normal file
85
0001-build-add-an-empty-config.sh.patch
Normal file
@ -0,0 +1,85 @@
|
||||
From c7fd848a51fd53d8cf003d892efdb01e2b7efc0e Mon Sep 17 00:00:00 2001
|
||||
From: Pino Toscano <ptoscano@redhat.com>
|
||||
Date: Mon, 16 Dec 2019 10:42:09 +0100
|
||||
Subject: [PATCH] build: add an empty config.sh
|
||||
|
||||
This helper script will contain variables with results of configure
|
||||
checks, so other scripts can source it.
|
||||
|
||||
Source it automatically in test-functions.sh, so every test can already
|
||||
make use of it.
|
||||
---
|
||||
.gitignore | 1 +
|
||||
config.sh.in | 20 ++++++++++++++++++++
|
||||
configure.ac | 1 +
|
||||
tests/test-functions.sh | 3 +++
|
||||
4 files changed, 25 insertions(+)
|
||||
create mode 100644 config.sh.in
|
||||
|
||||
diff --git a/.gitignore b/.gitignore
|
||||
index ee7e3cf9e..54e5b0ec2 100644
|
||||
--- a/.gitignore
|
||||
+++ b/.gitignore
|
||||
@@ -40,6 +40,7 @@ Makefile.in
|
||||
/config.h
|
||||
/config.h.in
|
||||
/config.log
|
||||
+/config.sh
|
||||
/config.status
|
||||
/config.sub
|
||||
/configure
|
||||
diff --git a/config.sh.in b/config.sh.in
|
||||
new file mode 100644
|
||||
index 000000000..061871a3c
|
||||
--- /dev/null
|
||||
+++ b/config.sh.in
|
||||
@@ -0,0 +1,20 @@
|
||||
+#!/bin/bash -
|
||||
+# (C) Copyright 2019 Red Hat Inc.
|
||||
+# @configure_input@
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
+
|
||||
+# This shell script contains the results of some configure checks,
|
||||
+# mostly used in other shell scripts.
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f7ff742a5..1b8f6a837 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -116,6 +116,7 @@ AC_CONFIG_FILES([Makefile
|
||||
common/qemuopts/Makefile
|
||||
common/utils/Makefile
|
||||
common/windows/Makefile
|
||||
+ config.sh
|
||||
docs/Makefile
|
||||
gnulib/lib/Makefile
|
||||
gnulib/tests/Makefile
|
||||
diff --git a/tests/test-functions.sh b/tests/test-functions.sh
|
||||
index 565c4208d..446b20fe7 100755
|
||||
--- a/tests/test-functions.sh
|
||||
+++ b/tests/test-functions.sh
|
||||
@@ -33,6 +33,9 @@ export LANG=C
|
||||
# parameters, so we eval those to define the variables.
|
||||
while [ $# -ge 1 ]; do eval "$1"; shift; done
|
||||
|
||||
+# Configure check results.
|
||||
+source $abs_top_builddir/config.sh
|
||||
+
|
||||
# Skip if $SKIP_<script_name> environment variable is set.
|
||||
# Every test should call this function first.
|
||||
skip_if_skipped ()
|
||||
--
|
||||
2.24.1
|
||||
|
37
0001-tests-use-the-right-nbdkit-python3-plugin.patch
Normal file
37
0001-tests-use-the-right-nbdkit-python3-plugin.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 3f8897aa36a723fe3fde5b62a6eb9ade427f77b2 Mon Sep 17 00:00:00 2001
|
||||
From: Pino Toscano <ptoscano@redhat.com>
|
||||
Date: Mon, 16 Dec 2019 10:58:38 +0100
|
||||
Subject: [PATCH] tests: use the right nbdkit python3 plugin
|
||||
|
||||
Add the configure result in config.sh, so it can be used as variable.
|
||||
---
|
||||
config.sh.in | 2 ++
|
||||
tests/test-v2v-o-rhv-upload.sh | 2 +-
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/config.sh.in b/config.sh.in
|
||||
index 061871a3c..f32453792 100644
|
||||
--- a/config.sh.in
|
||||
+++ b/config.sh.in
|
||||
@@ -18,3 +18,5 @@
|
||||
|
||||
# This shell script contains the results of some configure checks,
|
||||
# mostly used in other shell scripts.
|
||||
+
|
||||
+export VIRT_V2V_NBDKIT_PYTHON_PLUGIN="@VIRT_V2V_NBDKIT_PYTHON_PLUGIN@"
|
||||
diff --git a/tests/test-v2v-o-rhv-upload.sh b/tests/test-v2v-o-rhv-upload.sh
|
||||
index a2f5b0d5e..e70575c70 100755
|
||||
--- a/tests/test-v2v-o-rhv-upload.sh
|
||||
+++ b/tests/test-v2v-o-rhv-upload.sh
|
||||
@@ -29,7 +29,7 @@ $TEST_FUNCTIONS
|
||||
skip_if_skipped
|
||||
skip_if_backend uml
|
||||
skip_unless python3 --version
|
||||
-skip_unless nbdkit python3 --version
|
||||
+skip_unless nbdkit $VIRT_V2V_NBDKIT_PYTHON_PLUGIN --version
|
||||
skip_unless_phony_guest windows.img
|
||||
|
||||
libvirt_uri="test://$abs_top_builddir/test-data/phony-guests/guests.xml"
|
||||
--
|
||||
2.24.1
|
||||
|
@ -25,6 +25,8 @@ Source2: libguestfs.keyring
|
||||
# Upstream patches.
|
||||
Patch1: 0001-po-Remove-some-POTFILES-ml-which-aren-t-included-in-.patch
|
||||
Patch2: 0002-Add-license-file.patch
|
||||
Patch3: 0001-build-add-an-empty-config.sh.patch
|
||||
Patch4: 0001-tests-use-the-right-nbdkit-python3-plugin.patch
|
||||
|
||||
# libguestfs hasn't been built on i686 for a while since there is no
|
||||
# kernel built for this architecture any longer and libguestfs rather
|
||||
|
Loading…
Reference in New Issue
Block a user