35 lines
946 B
Diff
35 lines
946 B
Diff
From be5e812ea7ea266e0d0ce1c126606c7bd04523c8 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Mon, 27 Mar 2017 12:21:48 +0100
|
|
Subject: [PATCH 07/23] Enable same warnings as libguestfs.
|
|
|
|
In particular 'warning 3' was still enabled before, meaning that the
|
|
code would fail with newer OCaml compilers:
|
|
|
|
File "top.ml", line 377, characters 12-25:
|
|
Warning 3: deprecated: String.create
|
|
Use Bytes.create instead.
|
|
|
|
Since we want to continue using old OCaml for now, don't enable
|
|
this warning.
|
|
---
|
|
src/Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile.in b/src/Makefile.in
|
|
index d29f2e8..d744fd7 100755
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -64,7 +64,7 @@ OBJS += main.cmo
|
|
|
|
XOBJS := $(OBJS:.cmo=.cmx)
|
|
|
|
-OCAMLCFLAGS := -g -warn-error A-3
|
|
+OCAMLCFLAGS := -g -warn-error CDEFLMPSUVYZX-3
|
|
OCAMLCLIBS := -linkpkg
|
|
|
|
OCAMLOPTPACKAGES := $(OCAMLCPACKAGES)
|
|
--
|
|
2.31.1
|
|
|