import virt-top-1.0.9-21.el9
This commit is contained in:
commit
c0500f0a21
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/virt-top-1.0.9.tar.gz
|
1
.virt-top.metadata
Normal file
1
.virt-top.metadata
Normal file
@ -0,0 +1 @@
|
||||
95ba1f8d87223ff8e7f341c8c7cb70b59b9d2408 SOURCES/virt-top-1.0.9.tar.gz
|
@ -0,0 +1,40 @@
|
||||
From 24a461715d5bce47f63cb0097606fc336230589f Mon Sep 17 00:00:00 2001
|
||||
From: Stephane Glondu <steph@glondu.net>
|
||||
Date: Wed, 21 Aug 2019 17:24:47 +0200
|
||||
Subject: [PATCH] libvirt: Handle VIR_DOMAIN_PMSUSPENDED state.
|
||||
|
||||
Fixes FTBFS with ocaml-libvirt 0.6.1.5.
|
||||
|
||||
RWMJ: Added documentation and changed the letter to 'M'.
|
||||
---
|
||||
src/screen.ml | 1 +
|
||||
src/virt-top.pod | 4 ++++
|
||||
2 files changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/screen.ml b/src/screen.ml
|
||||
index 0d847a2..8a66ba6 100644
|
||||
--- a/src/screen.ml
|
||||
+++ b/src/screen.ml
|
||||
@@ -50,3 +50,4 @@ let show_state = function
|
||||
| D.InfoShutdown -> 'D'
|
||||
| D.InfoShutoff -> 'O'
|
||||
| D.InfoCrashed -> 'X'
|
||||
+ | D.InfoPMSuspended -> 'M'
|
||||
diff --git a/src/virt-top.pod b/src/virt-top.pod
|
||||
index 4d81608..76ad3f9 100644
|
||||
--- a/src/virt-top.pod
|
||||
+++ b/src/virt-top.pod
|
||||
@@ -492,6 +492,10 @@ Shutdown.
|
||||
|
||||
Crashed.
|
||||
|
||||
+=item B<M>
|
||||
+
|
||||
+Suspended by guest power management.
|
||||
+
|
||||
=back
|
||||
|
||||
=item B<TIME>
|
||||
--
|
||||
2.22.0
|
||||
|
65
SOURCES/processcsv.py
Executable file
65
SOURCES/processcsv.py
Executable file
@ -0,0 +1,65 @@
|
||||
#!/usr/bin/python3
|
||||
#
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=665817
|
||||
#
|
||||
# Usage:
|
||||
#
|
||||
# virt-top --csv data.csv
|
||||
# processcsv.py < data.csv
|
||||
#
|
||||
# Note this OVERWRITES the following files in the current directory:
|
||||
#
|
||||
# global.csv # all the global data
|
||||
# domain<NN>.csv # data for domain ID <NN> (multiple files)
|
||||
|
||||
import sys
|
||||
import csv
|
||||
|
||||
rows = csv.reader (sys.stdin)
|
||||
|
||||
# Get the header row.
|
||||
header = next(rows)
|
||||
|
||||
# Find the index of the 'Hostname' and 'Time' cols (usually first two).
|
||||
hostname_i = header.index ("Hostname")
|
||||
time_i = header.index ("Time")
|
||||
|
||||
# Find the index of the 'Domain ID' column (i) and the number of
|
||||
# columns per domain (w).
|
||||
i = header.index ("Domain ID")
|
||||
w = len (header) - i
|
||||
|
||||
dom_header = header[i:i+w]
|
||||
dom_header.insert (0, "Hostname")
|
||||
dom_header.insert (1, "Time")
|
||||
|
||||
gfile = open ("global.csv", "w")
|
||||
gfile_writer = csv.writer (gfile)
|
||||
gfile_writer.writerow (header[0:i])
|
||||
|
||||
dfiles = dict()
|
||||
|
||||
# Process all the remaining data rows.
|
||||
for data in rows:
|
||||
# Global data is columns 0..i-1
|
||||
gfile_writer.writerow (data[0:i])
|
||||
|
||||
hostname = data[hostname_i]
|
||||
time = data[time_i]
|
||||
|
||||
# For each domain ...
|
||||
for j in range(i,len(data),w):
|
||||
dom = data[j:j+w]
|
||||
domid = dom[0]
|
||||
|
||||
if domid in dfiles:
|
||||
dfile_writer = dfiles[domid]
|
||||
else:
|
||||
dfile = open ("domain%s.csv" % domid, "w")
|
||||
dfile_writer = csv.writer (dfile)
|
||||
dfile_writer.writerow (dom_header)
|
||||
dfiles[domid] = dfile_writer
|
||||
|
||||
dom.insert (0, hostname)
|
||||
dom.insert (1, time)
|
||||
dfile_writer.writerow (dom)
|
64
SOURCES/processcsv.py.pod
Normal file
64
SOURCES/processcsv.py.pod
Normal file
@ -0,0 +1,64 @@
|
||||
=head1 NAME
|
||||
|
||||
processcsv.py - process virt-top CSV files
|
||||
|
||||
=head1 SUMMARY
|
||||
|
||||
virt-top --csv data.csv
|
||||
processcsv.py < data.csv
|
||||
|
||||
=head1 DESCRIPTION
|
||||
|
||||
virt-top is a L<top(1)>-like utility for showing stats of virtualized
|
||||
domains.
|
||||
|
||||
processcsv.py is a simple Python script that post-processes the output
|
||||
of C<virt-top --csv>.
|
||||
|
||||
It is used like this:
|
||||
|
||||
virt-top --csv data.csv
|
||||
processcsv.py < data.csv
|
||||
|
||||
The second command will B<overwrite> the following files in the
|
||||
current directory:
|
||||
|
||||
=over 4
|
||||
|
||||
=item C<global.csv>
|
||||
|
||||
This contains the global (host) statistics columns from the CSV file.
|
||||
|
||||
=item C<domainI<NN>.csv> (multiple files)
|
||||
|
||||
For each libvirt domain ID I<NN>, a file is created containing
|
||||
the per-domain statistics from the CSV file.
|
||||
|
||||
=back
|
||||
|
||||
=head1 SEE ALSO
|
||||
|
||||
L<virt-top(1)>
|
||||
|
||||
=head1 AUTHORS
|
||||
|
||||
Richard W.M. Jones <rjones @ redhat . com>
|
||||
|
||||
=head1 COPYRIGHT
|
||||
|
||||
(C) Copyright 2007-2012 Red Hat Inc., Richard W.M. Jones
|
||||
http://libvirt.org/
|
||||
|
||||
This program is free software; you can redistribute it and/or modify
|
||||
it under the terms of the GNU General Public License as published by
|
||||
the Free Software Foundation; either version 2 of the License, or
|
||||
(at your option) any later version.
|
||||
|
||||
This program is distributed in the hope that it will be useful,
|
||||
but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
GNU General Public License for more details.
|
||||
|
||||
You should have received a copy of the GNU General Public License
|
||||
along with this program; if not, write to the Free Software
|
||||
Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
26
SOURCES/virt-top-1.0.9-processcsv-documentation.patch
Normal file
26
SOURCES/virt-top-1.0.9-processcsv-documentation.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -ur virt-top-1.0.9.old/src/virt-top.pod virt-top-1.0.9.new/src/virt-top.pod
|
||||
--- virt-top-1.0.9.old/src/virt-top.pod 2020-05-05 12:01:25.069799212 +0100
|
||||
+++ virt-top-1.0.9.new/src/virt-top.pod 2020-05-05 12:02:05.234337666 +0100
|
||||
@@ -129,6 +129,22 @@
|
||||
|
||||
virt-top --csv >(split -d -l 1000 - output.csv.)
|
||||
|
||||
+RHEL provides a short Python script called C<processcsv.py> which
|
||||
+can be used to post-process the CSV output. Run it like this:
|
||||
+
|
||||
+ virt-top --csv data.csv
|
||||
+ processcsv.py < data.csv
|
||||
+
|
||||
+This creates or I<overwrites> the following files in the current
|
||||
+directory:
|
||||
+
|
||||
+ global.csv
|
||||
+ domain<NNN>.csv
|
||||
+
|
||||
+C<global.csv> will contain the global data. One
|
||||
+C<domainE<lt>NNNE<gt>.csv> file will also be created for each domain
|
||||
+with ID C<NNN>, containing the per-domain data.
|
||||
+
|
||||
=item B<--no-csv-cpu>
|
||||
|
||||
Disable domain CPU stats in CSV output.
|
455
SPECS/virt-top.spec
Normal file
455
SPECS/virt-top.spec
Normal file
@ -0,0 +1,455 @@
|
||||
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: virt-top
|
||||
Version: 1.0.9
|
||||
Release: 21%{?dist}
|
||||
Summary: Utility like top(1) for displaying virtualization stats
|
||||
License: GPLv2+
|
||||
|
||||
%if 0%{?rhel}
|
||||
# No qemu-kvm on POWER (RHBZ#1946532).
|
||||
ExcludeArch: %{power64}
|
||||
%endif
|
||||
|
||||
URL: http://people.redhat.com/~rjones/virt-top/
|
||||
Source0: http://people.redhat.com/~rjones/virt-top/files/%{name}-%{version}.tar.gz
|
||||
|
||||
# Post-process output of CSV file (RHBZ#665817, RHBZ#912020).
|
||||
Source1: processcsv.py
|
||||
Source2: processcsv.py.pod
|
||||
|
||||
# Adds a link to processcsv to the man page. This patch is only
|
||||
# included in RHEL builds.
|
||||
Patch0: virt-top-1.0.9-processcsv-documentation.patch
|
||||
|
||||
# Upstream patch to fix FTBFS with ocaml libvirt 0.6.1.5.
|
||||
Patch1: 0001-libvirt-Handle-VIR_DOMAIN_PMSUSPENDED-state.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: ocaml >= 3.10.2
|
||||
BuildRequires: ocaml-ocamldoc
|
||||
BuildRequires: ocaml-findlib-devel
|
||||
# Need the ncurses / ncursesw (--enable-widec) fix.
|
||||
BuildRequires: ocaml-curses-devel >= 1.0.3-7
|
||||
BuildRequires: ocaml-extlib-devel
|
||||
BuildRequires: ocaml-xml-light-devel
|
||||
BuildRequires: ocaml-csv-devel
|
||||
BuildRequires: ocaml-calendar-devel
|
||||
BuildRequires: ocaml-libvirt-devel >= 0.6.1.5
|
||||
|
||||
# Tortuous list of BRs for gettext.
|
||||
BuildRequires: ocaml-gettext-devel >= 0.3.3
|
||||
BuildRequires: ocaml-fileutils-devel
|
||||
# For msgfmt:
|
||||
BuildRequires: gettext
|
||||
|
||||
# Non-OCaml BRs.
|
||||
BuildRequires: libvirt-devel
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(Pod::Perldoc)
|
||||
BuildRequires: gawk
|
||||
|
||||
|
||||
%description
|
||||
virt-top is a 'top(1)'-like utility for showing stats of virtualized
|
||||
domains. Many keys and command line options are the same as for
|
||||
ordinary 'top'.
|
||||
|
||||
It uses libvirt so it is capable of showing stats across a variety of
|
||||
different virtualization systems.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
%patch0 -p1
|
||||
%endif
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
make all
|
||||
%if %opt
|
||||
make opt
|
||||
strip src/virt-top.opt
|
||||
%endif
|
||||
|
||||
# Build translations.
|
||||
make -C po
|
||||
|
||||
# Force rebuild of man page.
|
||||
rm -f src/virt-top.1
|
||||
make -C src virt-top.1
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
# Build processcsv.py.1.
|
||||
pod2man -c "Virtualization Support" --release "%{name}-%{version}" \
|
||||
%{SOURCE2} > processcsv.py.1
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
|
||||
# Install translations.
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/locale
|
||||
make -C po install PODIR="$RPM_BUILD_ROOT%{_datadir}/locale"
|
||||
%find_lang %{name}
|
||||
|
||||
# Install virt-top manpage by hand for now.
|
||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
install -m 0644 src/virt-top.1 $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
# Install processcsv.py.
|
||||
install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
|
||||
|
||||
# Install processcsv.py(1).
|
||||
install -m 0644 processcsv.py.1 $RPM_BUILD_ROOT%{_mandir}/man1/
|
||||
%endif
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc COPYING README TODO ChangeLog
|
||||
%{_bindir}/virt-top
|
||||
%{_mandir}/man1/virt-top.1*
|
||||
%if 0%{?rhel} >= 6
|
||||
%{_bindir}/processcsv.py
|
||||
%{_mandir}/man1/processcsv.py.1*
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.0.9-21
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri May 07 2021 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-20
|
||||
- Do not include the package on POWER on RHEL 9
|
||||
resolves: rhbz#1956935
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.0.9-18
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Sep 01 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-16
|
||||
- OCaml 4.11.1 rebuild
|
||||
|
||||
* Fri Aug 21 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-15
|
||||
- OCaml 4.11.0 rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat May 30 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-13
|
||||
- Rebuild for updated ocaml-extlib (RHBZ#1837823).
|
||||
|
||||
* Tue May 05 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-12
|
||||
- OCaml 4.11.0+dev2-2020-04-22 rebuild
|
||||
|
||||
* Tue May 5 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-11
|
||||
- Fix broken documentation patch (RHEL/ELN only).
|
||||
|
||||
* Wed Apr 22 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-10
|
||||
- OCaml 4.11.0 pre-release attempt 2
|
||||
|
||||
* Thu Apr 09 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-9
|
||||
- Port RHEL 8.3.0 gating test to Fedora.
|
||||
|
||||
* Sat Apr 04 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-7
|
||||
- Update all OCaml dependencies for RPM 4.16.
|
||||
|
||||
* Thu Feb 27 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-6
|
||||
- OCaml 4.10.0 final.
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sun Jan 19 2020 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-4
|
||||
- OCaml 4.10.0+beta1 rebuild.
|
||||
|
||||
* Fri Dec 06 2019 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-3
|
||||
- OCaml 4.09.0 (final) rebuild.
|
||||
|
||||
* Wed Aug 21 2019 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-2
|
||||
- Rebuild against ocaml-libvirt 0.6.1.5.
|
||||
|
||||
* Tue Aug 20 2019 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-1
|
||||
- New upstream version 1.0.9.
|
||||
- Remove patches which are upstream and aarch64 build fix.
|
||||
|
||||
* Fri Aug 16 2019 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-37
|
||||
- OCaml 4.08.1 (final) rebuild.
|
||||
|
||||
* Thu Aug 01 2019 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-36
|
||||
- OCaml 4.08.1 (rc2) rebuild.
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-34
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-33
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jul 11 2018 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-32
|
||||
- OCaml 4.07.0 (final) rebuild.
|
||||
|
||||
* Wed Jun 20 2018 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-31
|
||||
- OCaml 4.07.0-rc1 rebuild.
|
||||
|
||||
* Wed Mar 28 2018 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-30
|
||||
- Modify processcsv.py for Python 3.
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Nov 18 2017 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-28
|
||||
- OCaml 4.06.0 rebuild.
|
||||
|
||||
* Wed Aug 09 2017 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-27
|
||||
- OCaml 4.05.0 rebuild.
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jun 27 2017 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-24
|
||||
- OCaml 4.04.2 rebuild.
|
||||
|
||||
* Sat May 13 2017 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-23
|
||||
- OCaml 4.04.1 rebuild.
|
||||
|
||||
* Tue Mar 28 2017 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-22
|
||||
- Include all upstream patches since 1.0.8 was released.
|
||||
- BR ocaml-libvirt with virConnectGetAllDomainStats API.
|
||||
- Remove execstack hack, no longer needed on any arch.
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Nov 09 2016 Dan Horák <dan@danny.cz> - 1.0.8-20
|
||||
- remove ExcludeArch
|
||||
|
||||
* Sat Nov 05 2016 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-19
|
||||
- Rebuild for OCaml 4.04.0.
|
||||
- Kill further instances of -warn-error.
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-17
|
||||
- OCaml 4.02.3 rebuild.
|
||||
|
||||
* Wed Jun 24 2015 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-16
|
||||
- ocaml-4.02.2 final rebuild.
|
||||
|
||||
* Thu Jun 18 2015 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-15
|
||||
- ocaml-4.02.2 rebuild.
|
||||
|
||||
* Tue Feb 17 2015 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-14
|
||||
- ocaml-4.02.1 rebuild.
|
||||
|
||||
* Sun Aug 31 2014 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-13
|
||||
- ocaml-4.02.0 final rebuild.
|
||||
|
||||
* Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-12
|
||||
- ocaml-4.02.0+rc1 rebuild.
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Aug 02 2014 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-10
|
||||
- ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
|
||||
|
||||
* Sat Aug 02 2014 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-9
|
||||
- Do not warn about immutable strings.
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Aug 05 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-7
|
||||
- Bump and rebuild.
|
||||
|
||||
* Mon Jul 29 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-6
|
||||
- Include processcsv.py script and man page, but on RHEL only
|
||||
(RHBZ#665817, RHBZ#912020)
|
||||
- Clear executable stack flag on PPC, PPC64 (RHBZ#605124).
|
||||
|
||||
* Fri Jun 28 2013 Cole Robinson <crobinso@redhat.com> - 1.0.8-5
|
||||
- Update configure for aarch64 (bz #926701)
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Dec 14 2012 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-3
|
||||
- Rebuild for OCaml 4.00.1.
|
||||
|
||||
* Fri Oct 12 2012 Richard W.M. Jones <rjones@redhat.com> - 1.0.8-2
|
||||
- New upstream version 1.0.8.
|
||||
- Requires tiny change to ocaml-libvirt, hence dep bump.
|
||||
- Clean up the spec file.
|
||||
- Remove explicit BR ocaml-camomile (not used AFAIK).
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Mar 23 2012 Richard W.M. Jones <rjones@redhat.com> - 1.0.7-2
|
||||
- Require fixed ocaml-libvirt.
|
||||
|
||||
* Tue Mar 6 2012 Richard W.M. Jones <rjones@redhat.com> - 1.0.7-1
|
||||
- New upstream version 1.0.7.
|
||||
- Includes true physical CPU reporting (when libvirt supports this).
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Aug 12 2011 Richard W.M. Jones <rjones@redhat.com> - 1.0.6-1
|
||||
- New upstream version 1.0.6.
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Jan 6 2011 Richard W.M. Jones <rjones@redhat.com> - 1.0.5-1
|
||||
- New upstream version 1.0.5.
|
||||
- Rebuild against OCaml 3.12.0.
|
||||
- Project website moved to people.redhat.com.
|
||||
- Remove upstream patches.
|
||||
|
||||
* Wed Dec 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.4-3
|
||||
- Force rebuild against latest ocaml-gettext 0.3.3 (RHBZ#508197#c10).
|
||||
|
||||
* Mon Oct 5 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.4-2
|
||||
- New upstream release 1.0.4.
|
||||
- Includes new translations (RHBZ#493799).
|
||||
- Overall hardware memory is now displayed in CSV file (RHBZ#521785).
|
||||
- Several fixes to Japanese support (RHBZ#508197).
|
||||
- Japanese PO file also has bogus plural forms.
|
||||
- Additional BR on gettext (for msgfmt).
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Apr 16 2009 S390x secondary arch maintainer <fedora-s390x@lists.fedoraproject.org>
|
||||
- ExcludeArch sparc64, s390, s390x as we don't have OCaml on those archs
|
||||
(added sparc64 per request from the sparc maintainer)
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-3
|
||||
- Rebuild for OCaml 3.11.0+rc1.
|
||||
|
||||
* Tue Oct 21 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-2
|
||||
- Fix incorrect sources file.
|
||||
- Remove bogus Plural-Forms line from zh_CN PO file.
|
||||
|
||||
* Tue Oct 21 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-1
|
||||
- New upstream version 1.0.3.
|
||||
|
||||
* Mon May 19 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.1-2
|
||||
- Use RPM percent-configure.
|
||||
- Add list of BRs for gettext.
|
||||
- Use find_lang to find PO files.
|
||||
- Comment out the OCaml dependency generator. Not a library so not
|
||||
needed.
|
||||
|
||||
* Thu May 1 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.1-1
|
||||
- New upstream release 1.0.1.
|
||||
- Don't BR ocaml-gettext-devel, it's not used at the moment.
|
||||
- Don't gzip the manpage, it happens automatically.
|
||||
- Add BR libvirt-devel.
|
||||
- Remove spurious executable bit on COPYING.
|
||||
|
||||
* Thu Apr 17 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2
|
||||
- New upstream release 1.0.0.
|
||||
- Force rebuild of manpage.
|
||||
|
||||
* Tue Mar 18 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.1-1
|
||||
- New upstream release 0.4.1.1.
|
||||
- Move configure to build section.
|
||||
- Pass RPM_OPT_FLAGS.
|
||||
|
||||
* Tue Mar 4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.0-2
|
||||
- Fix source URL.
|
||||
- Install virt-df manpage.
|
||||
|
||||
* Tue Mar 4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.1.0-1
|
||||
- New upstream release 0.4.1.0.
|
||||
- Upstream now requires ocaml-dbus >= 0.06, ocaml-lablgtk >= 2.10.0,
|
||||
ocaml-dbus-devel.
|
||||
- Enable virt-df.
|
||||
|
||||
* Sat Mar 1 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-3
|
||||
- Rebuild for ppc64.
|
||||
|
||||
* Wed Feb 13 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-2
|
||||
- Add BR gtk2-devel
|
||||
|
||||
* Tue Feb 12 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.0.3-1
|
||||
- New upstream version 0.4.0.3.
|
||||
- Rebuild for OCaml 3.10.1.
|
||||
|
||||
* Tue Nov 20 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.4-1
|
||||
- New upstream release 0.3.3.4.
|
||||
- Upstream website is now http://libvirt.org/ocaml/
|
||||
|
||||
* Fri Oct 19 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.0-2
|
||||
- Mistake: BR is ocaml-calendar-devel.
|
||||
|
||||
* Fri Oct 19 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.3.0-1
|
||||
- New upstream release 0.3.3.0.
|
||||
- Added support for virt-df, but disabled it by default.
|
||||
- +BR ocaml-calendar.
|
||||
|
||||
* Mon Sep 24 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.8-1
|
||||
- New upstream release 0.3.2.8.
|
||||
|
||||
* Thu Sep 20 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.7-1
|
||||
- New upstream release 0.3.2.7.
|
||||
- Ship the upstream ChangeLog file.
|
||||
|
||||
* Thu Sep 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.6-2
|
||||
- Force dependency on ocaml >= 3.10.0-7 which has fixed requires/provides
|
||||
scripts.
|
||||
|
||||
* Thu Sep 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.6-1
|
||||
- New upstream version 0.3.2.6.
|
||||
|
||||
* Wed Aug 29 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.5-1
|
||||
- New upstream version 0.3.2.5.
|
||||
- Keep TODO out of the main package, but add (renamed) TODO.libvirt and
|
||||
TODO.virt-top to the devel and virt-top packages respectively.
|
||||
- Add BR gawk.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.4-1
|
||||
- New upstream version 0.3.2.4.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.3-2
|
||||
- build_* macros so we can choose what subpackages to build.
|
||||
|
||||
* Thu Aug 23 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.3-1
|
||||
- Upstream version 0.3.2.3.
|
||||
- Add missing BR libvirt-devel.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.2-1
|
||||
- Upstream version 0.3.2.2.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.1-2
|
||||
- Fix unclosed if-statement in spec file.
|
||||
|
||||
* Wed Aug 22 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.2.1-1
|
||||
- Upstream version 0.3.2.1.
|
||||
- Put HTML documentation in -devel package.
|
||||
|
||||
* Mon Aug 6 2007 Richard W.M. Jones <rjones@redhat.com> - 0.3.1.2-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user