Fix cdrom ordering if added via 'customize' (bz #905439)
Default to spice/qxl for virt-install (bz #911734) Fill in cache and io values for new VMs (bz #967643) Add dep on dconf (bz #1012884)
This commit is contained in:
parent
ae7f39fce2
commit
c5cc51781f
@ -1,29 +0,0 @@
|
|||||||
From 946547fac40aa63f9e30c36d00b17a78f9f1bced Mon Sep 17 00:00:00 2001
|
|
||||||
Message-Id: <946547fac40aa63f9e30c36d00b17a78f9f1bced.1377125803.git.crobinso@redhat.com>
|
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
|
||||||
Date: Wed, 21 Aug 2013 18:56:30 -0400
|
|
||||||
Subject: [PATCH] support: Change ARM checks to match F20 versions
|
|
||||||
|
|
||||||
---
|
|
||||||
virtinst/support.py | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/virtinst/support.py b/virtinst/support.py
|
|
||||||
index b0a84f2..288b7ec 100644
|
|
||||||
--- a/virtinst/support.py
|
|
||||||
+++ b/virtinst/support.py
|
|
||||||
@@ -320,9 +320,9 @@ SUPPORT_CONN_LISTALLSTORAGEPOOLS = _make(
|
|
||||||
args=())
|
|
||||||
SUPPORT_CONN_LISTALLINTERFACES = _make(function="virConnect.listAllInterfaces",
|
|
||||||
args=())
|
|
||||||
-SUPPORT_CONN_VIRTIO_MMIO = _make(version=1001002,
|
|
||||||
+SUPPORT_CONN_VIRTIO_MMIO = _make(version=1001001,
|
|
||||||
drv_version=[("qemu", 1006000)])
|
|
||||||
-SUPPORT_CONN_DISK_SD = _make(version=1001002)
|
|
||||||
+SUPPORT_CONN_DISK_SD = _make(version=1001001)
|
|
||||||
|
|
||||||
|
|
||||||
# Domain checks
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
7cbea0e916f319842f0e85e7bb443da9 virt-manager-a2e52067.tar.gz
|
80dcb1974254309e2d2506fe34c0f2a8 virt-manager-79196cdf.tar.gz
|
||||||
|
@ -8,7 +8,6 @@
|
|||||||
%define libvirt_packages "libvirt-daemon-kvm,libvirt-daemon-config-network"
|
%define libvirt_packages "libvirt-daemon-kvm,libvirt-daemon-config-network"
|
||||||
%define preferred_distros "fedora,rhel"
|
%define preferred_distros "fedora,rhel"
|
||||||
%define kvm_packages "qemu-system-x86"
|
%define kvm_packages "qemu-system-x86"
|
||||||
%define default_graphics "spice"
|
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
%define preferred_distros "rhel,fedora"
|
%define preferred_distros "rhel,fedora"
|
||||||
@ -21,8 +20,8 @@
|
|||||||
|
|
||||||
|
|
||||||
%define _version 0.10.0
|
%define _version 0.10.0
|
||||||
%define _release 3
|
%define _release 4
|
||||||
%define gitcommit a2e52067
|
%define gitcommit 79196cdf
|
||||||
|
|
||||||
# This macro is used for the continuous automated builds. It just
|
# This macro is used for the continuous automated builds. It just
|
||||||
# allows an extra fragment based on the timestamp to be appended
|
# allows an extra fragment based on the timestamp to be appended
|
||||||
@ -50,15 +49,13 @@ URL: http://virt-manager.org/
|
|||||||
Source0: virt-manager-%{gitcommit}.tar.gz
|
Source0: virt-manager-%{gitcommit}.tar.gz
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
Patch0: 0001-support-Change-ARM-checks-to-match-F20-versions.patch
|
|
||||||
|
|
||||||
Requires: virt-manager-common = %{verrel}
|
Requires: virt-manager-common = %{verrel}
|
||||||
Requires: pygobject3
|
Requires: pygobject3
|
||||||
Requires: gtk3
|
Requires: gtk3
|
||||||
Requires: libvirt-glib >= 0.0.9
|
Requires: libvirt-glib >= 0.0.9
|
||||||
Requires: gnome-python2-gconf
|
|
||||||
Requires: libxml2-python
|
Requires: libxml2-python
|
||||||
Requires: vte3
|
Requires: vte3
|
||||||
|
Requires: dconf
|
||||||
|
|
||||||
# For console widget
|
# For console widget
|
||||||
Requires: gtk-vnc2
|
Requires: gtk-vnc2
|
||||||
@ -112,7 +109,6 @@ machine).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{qemu_user}
|
%if %{qemu_user}
|
||||||
@ -139,10 +135,6 @@ machine).
|
|||||||
%define _disable_unsupported_rhel --hide-unsupported-rhel-options
|
%define _disable_unsupported_rhel --hide-unsupported-rhel-options
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{default_graphics}
|
|
||||||
%define _default_graphics --default-graphics=%{default_graphics}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
python setup.py configure \
|
python setup.py configure \
|
||||||
--pkgversion="%{version}" \
|
--pkgversion="%{version}" \
|
||||||
%{?_qemu_user} \
|
%{?_qemu_user} \
|
||||||
@ -150,8 +142,7 @@ python setup.py configure \
|
|||||||
%{?_libvirt_packages} \
|
%{?_libvirt_packages} \
|
||||||
%{?_askpass_package} \
|
%{?_askpass_package} \
|
||||||
%{?_preferred_distros} \
|
%{?_preferred_distros} \
|
||||||
%{?_disable_unsupported_rhel} \
|
%{?_disable_unsupported_rhel}
|
||||||
%{?_default_graphics}
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -224,6 +215,12 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 06 2013 Cole Robinson <crobinso@redhat.com> - 0.10.0-4.git79196cdf
|
||||||
|
- Fix cdrom ordering if added via 'customize' (bz #905439)
|
||||||
|
- Default to spice/qxl for virt-install (bz #911734)
|
||||||
|
- Fill in cache and io values for new VMs (bz #967643)
|
||||||
|
- Add dep on dconf (bz #1012884)
|
||||||
|
|
||||||
* Tue Sep 24 2013 Cole Robinson <crobinso@redhat.com> - 0.10.0-3.gita2e52067
|
* Tue Sep 24 2013 Cole Robinson <crobinso@redhat.com> - 0.10.0-3.gita2e52067
|
||||||
- Sync with git
|
- Sync with git
|
||||||
- Don't try to launch multiple ssh askpass dialogs at once (bz #811346)
|
- Don't try to launch multiple ssh askpass dialogs at once (bz #811346)
|
||||||
|
Loading…
Reference in New Issue
Block a user