Rebased to version 0.9.5
Enable adding virtio-scsi disks (Chen Hanxiao) (bz 887584) Support security auto-relabel setting (Martin Kletzander) Support disk iotune settings (David Shane Holden) Support 'reset' as a reboot option (John Doyle) Don't pull in non-native qemu packages on first run (bz 924469) Don't create LVM volumes with alloc=0, it doesn't work (bz 872162) Fix storage browser hang on KDE (bz 880781) Fix package installation on KDE (bz 882024)
This commit is contained in:
parent
b5ebbb896a
commit
b020addd2d
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ virt-manager-0.8.4.tar.gz
|
||||
/virt-manager-0.9.1.tar.gz
|
||||
/virt-manager-0.9.3.tar.gz
|
||||
/virt-manager-0.9.4.tar.gz
|
||||
/virt-manager-0.9.5.tar.gz
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 6f95a37c1dd600f05b6678d1c142d38050eddf73 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <6f95a37c1dd600f05b6678d1c142d38050eddf73.1351081950.git.crobinso@redhat.com>
|
||||
From: Marc Deslauriers <marc.deslauriers@canonical.com>
|
||||
Date: Wed, 22 Aug 2012 13:25:25 -0400
|
||||
Subject: [PATCH 1/3] virt-manager: Fix KVM_PACKAGES substitution variable
|
||||
|
||||
Hello,
|
||||
|
||||
Commit 68e78244e851f1f3829f711249d1f375103a2a4d changed the HV_PACKAGES
|
||||
variable to KVM_PACKAGES in src/virt-manager.py.in, but the
|
||||
corresponding change was never made to src/Makefile.am.
|
||||
|
||||
Here is a patch to correct the issue.
|
||||
|
||||
Thanks,
|
||||
|
||||
Marc.
|
||||
|
||||
commit 93ba787355736733c189e6809b9108a70f0e02d4
|
||||
Author: Marc Deslauriers <marc.deslauriers@ubuntu.com>
|
||||
Date: Wed Aug 22 13:21:48 2012 -0400
|
||||
|
||||
Fix incorrect substitution variable
|
||||
(cherry picked from commit 2f2ba0acc0a3a3c1a45cd581495f185983f87772)
|
||||
---
|
||||
src/Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index e51d7b2..3f4ee8f 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -65,7 +65,7 @@ endif
|
||||
-e "s,::DEFAULT_QEMU_USER::,$(DEFAULT_QEMU_USER)," \
|
||||
-e "s,::ENABLE_UNSUPPORTED_RHEL_OPTS::,$(ENABLE_UNSUPPORTED_RHEL_OPTS)," \
|
||||
-e "s|::PREFERRED_DISTROS::|$(PREFERRED_DISTROS)|" \
|
||||
- -e "s|::HV_PACKAGES::|$(KVM_PACKAGES)|" \
|
||||
+ -e "s|::KVM_PACKAGES::|$(KVM_PACKAGES)|" \
|
||||
-e "s|::ASKPASS_PACKAGE::|$(ASKPASS_PACKAGE)|" \
|
||||
-e "s|::LIBVIRT_PACKAGES::|$(LIBVIRT_PACKAGES)|" \
|
||||
< $< > $@
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,54 +0,0 @@
|
||||
From 04ba35a12bc5065bfa6f8b3257abf1578707ac56 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <04ba35a12bc5065bfa6f8b3257abf1578707ac56.1351081950.git.crobinso@redhat.com>
|
||||
In-Reply-To: <6f95a37c1dd600f05b6678d1c142d38050eddf73.1351081950.git.crobinso@redhat.com>
|
||||
References: <6f95a37c1dd600f05b6678d1c142d38050eddf73.1351081950.git.crobinso@redhat.com>
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 14 Oct 2012 00:00:38 -0400
|
||||
Subject: [PATCH 2/3] domain: Handle PMSUSPENDED status
|
||||
|
||||
And add a catchall
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=850954
|
||||
(cherry picked from commit 63ba65d374d0cb46d02093d96580f5b53b947005)
|
||||
---
|
||||
src/virtManager/domain.py | 16 +++++++++++-----
|
||||
1 file changed, 11 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/virtManager/domain.py b/src/virtManager/domain.py
|
||||
index 82680b8..d536f77 100644
|
||||
--- a/src/virtManager/domain.py
|
||||
+++ b/src/virtManager/domain.py
|
||||
@@ -1371,19 +1371,25 @@ class vmmDomain(vmmLibvirtObject):
|
||||
self.vcpu_max_count()
|
||||
|
||||
def run_status(self):
|
||||
- if self.status() == libvirt.VIR_DOMAIN_RUNNING:
|
||||
+ status = self.status()
|
||||
+
|
||||
+ if status == libvirt.VIR_DOMAIN_RUNNING:
|
||||
return _("Running")
|
||||
- elif self.status() == libvirt.VIR_DOMAIN_PAUSED:
|
||||
+ elif status == libvirt.VIR_DOMAIN_PAUSED:
|
||||
return _("Paused")
|
||||
- elif self.status() == libvirt.VIR_DOMAIN_SHUTDOWN:
|
||||
+ elif status == libvirt.VIR_DOMAIN_SHUTDOWN:
|
||||
return _("Shutting Down")
|
||||
- elif self.status() == libvirt.VIR_DOMAIN_SHUTOFF:
|
||||
+ elif status == libvirt.VIR_DOMAIN_SHUTOFF:
|
||||
if self.hasSavedImage():
|
||||
return _("Saved")
|
||||
else:
|
||||
return _("Shutoff")
|
||||
- elif self.status() == libvirt.VIR_DOMAIN_CRASHED:
|
||||
+ elif status == libvirt.VIR_DOMAIN_CRASHED:
|
||||
return _("Crashed")
|
||||
+ elif (hasattr(libvirt, "VIR_DOMAIN_PMSUSPENDED") and
|
||||
+ status == libvirt.VIR_DOMAIN_PMSUSPENDED):
|
||||
+ return _("Suspended")
|
||||
+ return _("Unknown")
|
||||
|
||||
def _normalize_status(self, status):
|
||||
if status == libvirt.VIR_DOMAIN_NOSTATE:
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 7eab29ff1d2fb9d26db3102b7ffd6e3dcde640af Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <7eab29ff1d2fb9d26db3102b7ffd6e3dcde640af.1351081950.git.crobinso@redhat.com>
|
||||
In-Reply-To: <6f95a37c1dd600f05b6678d1c142d38050eddf73.1351081950.git.crobinso@redhat.com>
|
||||
References: <6f95a37c1dd600f05b6678d1c142d38050eddf73.1351081950.git.crobinso@redhat.com>
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 14 Oct 2012 00:15:04 -0400
|
||||
Subject: [PATCH 3/3] browse_local: Fix choosing directory of F17
|
||||
|
||||
Seems hiding the dialog before retrieving the directory path stopped
|
||||
working. Remove the needlessness anyways
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=849450
|
||||
(cherry picked from commit 71e5ac2a0a8578f466c74d5100943d44815ab8bd)
|
||||
---
|
||||
src/virtManager/util.py | 23 +++++++++--------------
|
||||
1 file changed, 9 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/src/virtManager/util.py b/src/virtManager/util.py
|
||||
index 6b8a953..b75541c 100644
|
||||
--- a/src/virtManager/util.py
|
||||
+++ b/src/virtManager/util.py
|
||||
@@ -208,11 +208,11 @@ def browse_local(parent, dialog_name, conn, start_folder=None,
|
||||
if choose_button is None:
|
||||
choose_button = gtk.STOCK_OPEN
|
||||
|
||||
- fcdialog = gtk.FileChooserDialog(dialog_name, parent,
|
||||
- dialog_type,
|
||||
- (gtk.STOCK_CANCEL, gtk.RESPONSE_CANCEL,
|
||||
- choose_button, gtk.RESPONSE_ACCEPT),
|
||||
- None)
|
||||
+ fcdialog = gtk.FileChooserDialog(title=dialog_name,
|
||||
+ parent=parent,
|
||||
+ action=dialog_type,
|
||||
+ buttons=(gtk.STOCK_CANCEL, gtk.RESPONSE_CANCEL,
|
||||
+ choose_button, gtk.RESPONSE_ACCEPT))
|
||||
fcdialog.set_default_response(gtk.RESPONSE_ACCEPT)
|
||||
|
||||
# If confirm is set, warn about a file overwrite
|
||||
@@ -245,15 +245,10 @@ def browse_local(parent, dialog_name, conn, start_folder=None,
|
||||
fcdialog.set_current_folder(start_folder)
|
||||
|
||||
# Run the dialog and parse the response
|
||||
- response = fcdialog.run()
|
||||
- fcdialog.hide()
|
||||
- if (response == gtk.RESPONSE_ACCEPT):
|
||||
- filename = fcdialog.get_filename()
|
||||
- fcdialog.destroy()
|
||||
- ret = filename
|
||||
- else:
|
||||
- fcdialog.destroy()
|
||||
- ret = None
|
||||
+ ret = None
|
||||
+ if fcdialog.run() == gtk.RESPONSE_ACCEPT:
|
||||
+ ret = fcdialog.get_filename()
|
||||
+ fcdialog.destroy()
|
||||
|
||||
# Store the chosen directory in gconf if necessary
|
||||
if ret and browse_reason and not ret.startswith("/dev"):
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 983e3b9fcf6d1410396e16bb0141e21939e69da7 Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 28 Oct 2012 20:09:32 -0400
|
||||
Subject: [PATCH] Fix package install with PackageKit 0.8.4 (cherry picked
|
||||
from commit 35bab2cc98ee4aef87f8a908c4951f2717455c8c)
|
||||
|
||||
---
|
||||
src/virtManager/packageutils.py | 15 +++++++++++++--
|
||||
1 file changed, 13 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/virtManager/packageutils.py b/src/virtManager/packageutils.py
|
||||
index 6478360..736b98c 100644
|
||||
--- a/src/virtManager/packageutils.py
|
||||
+++ b/src/virtManager/packageutils.py
|
||||
@@ -135,7 +135,15 @@ def packagekit_install(package_list):
|
||||
timeout=timeout)
|
||||
|
||||
def packagekit_search(session, pk_control, package_name, packages):
|
||||
- tid = pk_control.GetTid()
|
||||
+ newstyle = False
|
||||
+ try:
|
||||
+ tid = pk_control.GetTid()
|
||||
+ except dbus.exceptions.DBusException, e:
|
||||
+ if e.get_dbus_name() != "org.freedesktop.DBus.Error.UnknownMethod":
|
||||
+ raise
|
||||
+ newstyle = True
|
||||
+ tid = pk_control.CreateTransaction()
|
||||
+
|
||||
pk_trans = dbus.Interface(
|
||||
session.get_object("org.freedesktop.PackageKit", tid),
|
||||
"org.freedesktop.PackageKit.Transaction")
|
||||
@@ -160,7 +168,10 @@ def packagekit_search(session, pk_control, package_name, packages):
|
||||
pk_trans.connect_to_signal('ErrorCode', error)
|
||||
pk_trans.connect_to_signal('Package', package)
|
||||
try:
|
||||
- pk_trans.SearchNames("installed", [package_name])
|
||||
+ searchtype = "installed"
|
||||
+ if newstyle:
|
||||
+ searchtype = 2 ** 2
|
||||
+ pk_trans.SearchNames(searchtype, [package_name])
|
||||
except dbus.exceptions.DBusException, e:
|
||||
if e.get_dbus_name() != "org.freedesktop.DBus.Error.UnknownMethod":
|
||||
raise
|
||||
--
|
||||
1.7.12.1
|
||||
|
@ -1,69 +0,0 @@
|
||||
From b8d61f6602f82b6e90199d9ce430f9eebb1c894a Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 28 Oct 2012 20:18:51 -0400
|
||||
Subject: [PATCH] Fix detection of running libvirtd via systemd (cherry picked
|
||||
from commit 2163ba3a3035ea8fccd5113d53d120801ba12040)
|
||||
|
||||
---
|
||||
src/virtManager/engine.py | 6 ++++--
|
||||
src/virtManager/packageutils.py | 5 ++++-
|
||||
2 files changed, 8 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/virtManager/engine.py b/src/virtManager/engine.py
|
||||
index 337fc67..2ec455b 100644
|
||||
--- a/src/virtManager/engine.py
|
||||
+++ b/src/virtManager/engine.py
|
||||
@@ -178,8 +178,11 @@ class vmmEngine(vmmGObject):
|
||||
manager.set_startup_error(msg)
|
||||
return
|
||||
|
||||
+ do_start = not did_install_libvirt
|
||||
if did_install_libvirt:
|
||||
didstart = packageutils.start_libvirtd()
|
||||
+ do_start = didstart
|
||||
+
|
||||
warnmsg = _(
|
||||
"Libvirt was just installed, so the 'libvirtd' service will\n"
|
||||
"will need to be started.\n"
|
||||
@@ -189,8 +192,7 @@ class vmmEngine(vmmGObject):
|
||||
if not didstart:
|
||||
self.err.ok(_("Libvirt service must be started"), warnmsg)
|
||||
|
||||
- self.connect_to_uri(tryuri, autoconnect=True,
|
||||
- do_start=not did_install_libvirt)
|
||||
+ self.connect_to_uri(tryuri, autoconnect=True, do_start=do_start)
|
||||
|
||||
|
||||
def load_stored_uris(self):
|
||||
diff --git a/src/virtManager/packageutils.py b/src/virtManager/packageutils.py
|
||||
index 736b98c..63cf2b5 100644
|
||||
--- a/src/virtManager/packageutils.py
|
||||
+++ b/src/virtManager/packageutils.py
|
||||
@@ -217,7 +217,7 @@ def start_libvirtd():
|
||||
state = props.Get("org.freedesktop.systemd1.Unit", "ActiveState")
|
||||
|
||||
logging.debug("libvirtd state=%s", state)
|
||||
- if state == "Active":
|
||||
+ if str(state).lower() == "active":
|
||||
logging.debug("libvirtd already active, not starting")
|
||||
return True
|
||||
except:
|
||||
@@ -226,12 +226,15 @@ def start_libvirtd():
|
||||
|
||||
# Connect to system-config-services and offer to start
|
||||
try:
|
||||
+ logging.debug("libvirtd not running, asking system-config-services "
|
||||
+ "to start it")
|
||||
scs = dbus.Interface(bus.get_object(
|
||||
"org.fedoraproject.Config.Services",
|
||||
"/org/fedoraproject/Config/Services/systemd1"),
|
||||
"org.freedesktop.systemd1.Manager")
|
||||
scs.StartUnit(unitname, "replace")
|
||||
time.sleep(2)
|
||||
+ logging.debug("Starting libvirtd appeared to succeed")
|
||||
return True
|
||||
except:
|
||||
logging.exception("Failed to talk to system-config-services")
|
||||
--
|
||||
1.7.12.1
|
||||
|
@ -1,45 +0,0 @@
|
||||
From f55c0cefba2a71d4e44003802ac4ca59db0542ad Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Mon, 29 Oct 2012 18:55:51 -0400
|
||||
Subject: [PATCH] domain: Fix more backtraces from PMSUSPEND status (cherry
|
||||
picked from commit
|
||||
538420e03239da7870b5b051c043072109f68fda)
|
||||
|
||||
---
|
||||
src/virtManager/domain.py | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/virtManager/domain.py b/src/virtManager/domain.py
|
||||
index d536f77..56087b4 100644
|
||||
--- a/src/virtManager/domain.py
|
||||
+++ b/src/virtManager/domain.py
|
||||
@@ -1389,6 +1389,8 @@ class vmmDomain(vmmLibvirtObject):
|
||||
elif (hasattr(libvirt, "VIR_DOMAIN_PMSUSPENDED") and
|
||||
status == libvirt.VIR_DOMAIN_PMSUSPENDED):
|
||||
return _("Suspended")
|
||||
+
|
||||
+ logging.debug("Unknown status %d, returning 'Unknown'")
|
||||
return _("Unknown")
|
||||
|
||||
def _normalize_status(self, status):
|
||||
@@ -1429,9 +1431,16 @@ class vmmDomain(vmmLibvirtObject):
|
||||
libvirt.VIR_DOMAIN_SHUTDOWN: "state_shutoff",
|
||||
libvirt.VIR_DOMAIN_SHUTOFF: "state_shutoff",
|
||||
libvirt.VIR_DOMAIN_NOSTATE: "state_running",
|
||||
+ # VIR_DOMAIN_PMSUSPENDED
|
||||
+ 7: "state_paused",
|
||||
}
|
||||
|
||||
- return status_icons[self.status()]
|
||||
+ status = self.status()
|
||||
+ if status not in status_icons:
|
||||
+ logging.debug("Unknown status %d, using NOSTATE")
|
||||
+ status = libvirt.VIR_DOMAIN_NOSTATE
|
||||
+
|
||||
+ return status_icons[status]
|
||||
|
||||
def force_update_status(self):
|
||||
"""
|
||||
--
|
||||
1.7.12.1
|
||||
|
@ -1,96 +0,0 @@
|
||||
From 29ffac229ae7036dc238262d5e733a850b233329 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <29ffac229ae7036dc238262d5e733a850b233329.1355706113.git.crobinso@redhat.com>
|
||||
In-Reply-To: <30282a17091014ba5a96d20f4260df55779933c4.1355706113.git.crobinso@redhat.com>
|
||||
References: <30282a17091014ba5a96d20f4260df55779933c4.1355706113.git.crobinso@redhat.com>
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 28 Oct 2012 18:49:48 -0400
|
||||
Subject: [PATCH 7/8] Add hidden --test-first-run switch for testing PackageKit
|
||||
bits
|
||||
|
||||
Basically stubs out the gconf URI fetching + listing so we don't
|
||||
need to delete anything to trigger it.
|
||||
(cherry picked from commit 96ce9ac0b1257b66d0075c12aa572afe21eae0b0)
|
||||
|
||||
Conflicts:
|
||||
src/virt-manager.py.in
|
||||
---
|
||||
src/virt-manager.py.in | 8 +++++++-
|
||||
src/virtManager/config.py | 11 ++++++++++-
|
||||
2 files changed, 17 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/virt-manager.py.in b/src/virt-manager.py.in
|
||||
index 1f93d22..0cac2c2 100755
|
||||
--- a/src/virt-manager.py.in
|
||||
+++ b/src/virt-manager.py.in
|
||||
@@ -117,6 +117,11 @@ def parse_commandline():
|
||||
optParser.add_option("--profile", dest="profile",
|
||||
help=optparse.SUPPRESS_HELP, metavar="FILE")
|
||||
|
||||
+ # Don't load any connections on startup to test first run
|
||||
+ # PackageKit integration
|
||||
+ optParser.add_option("--test-first-run", dest="testfirstrun",
|
||||
+ help=optparse.SUPPRESS_HELP, action="store_true")
|
||||
+
|
||||
optParser.add_option("-c", "--connect", dest="uri",
|
||||
help="Connect to hypervisor at URI", metavar="URI")
|
||||
optParser.add_option("--debug", action="store_true", dest="debug",
|
||||
@@ -318,7 +323,8 @@ def main():
|
||||
# display access
|
||||
import virtManager.config
|
||||
import virtManager.util
|
||||
- config = virtManager.config.vmmConfig(appname, appversion, ui_dir)
|
||||
+ config = virtManager.config.vmmConfig(appname, appversion, ui_dir,
|
||||
+ options.test_first_run)
|
||||
virtManager.util.running_config = config
|
||||
config.default_qemu_user = default_qemu_user
|
||||
config.rhel6_defaults = rhel_enable_unsupported_opts
|
||||
diff --git a/src/virtManager/config.py b/src/virtManager/config.py
|
||||
index 63cbc15..508fea0 100644
|
||||
--- a/src/virtManager/config.py
|
||||
+++ b/src/virtManager/config.py
|
||||
@@ -88,11 +88,12 @@ class vmmConfig(object):
|
||||
DEFAULT_VIRT_IMAGE_DIR = "/var/lib/libvirt/images"
|
||||
DEFAULT_VIRT_SAVE_DIR = "/var/lib/libvirt"
|
||||
|
||||
- def __init__(self, appname, appversion, ui_dir):
|
||||
+ def __init__(self, appname, appversion, ui_dir, test_first_run=False):
|
||||
self.appname = appname
|
||||
self.appversion = appversion
|
||||
self.conf_dir = "/apps/" + appname
|
||||
self.ui_dir = ui_dir
|
||||
+ self.test_first_run = bool(test_first_run)
|
||||
|
||||
self.conf = gconf.client_get_default()
|
||||
self.conf.add_dir(self.conf_dir, gconf.CLIENT_PRELOAD_NONE)
|
||||
@@ -590,6 +591,9 @@ class vmmConfig(object):
|
||||
|
||||
# Manager view connection list
|
||||
def add_conn(self, uri):
|
||||
+ if self.test_first_run:
|
||||
+ return
|
||||
+
|
||||
uris = self.conf.get_list(self.conf_dir + "/connections/uris",
|
||||
gconf.VALUE_STRING)
|
||||
if uris == None:
|
||||
@@ -619,6 +623,8 @@ class vmmConfig(object):
|
||||
gconf.VALUE_STRING, uris)
|
||||
|
||||
def get_conn_uris(self):
|
||||
+ if self.test_first_run:
|
||||
+ return []
|
||||
return self.conf.get_list(self.conf_dir + "/connections/uris",
|
||||
gconf.VALUE_STRING)
|
||||
|
||||
@@ -638,6 +644,9 @@ class vmmConfig(object):
|
||||
return ((uris is not None) and (uri in uris))
|
||||
|
||||
def set_conn_autoconnect(self, uri, val):
|
||||
+ if self.test_first_run:
|
||||
+ return
|
||||
+
|
||||
uris = self.conf.get_list(self.conf_dir + "/connections/autoconnect",
|
||||
gconf.VALUE_STRING)
|
||||
if uris is None:
|
||||
--
|
||||
1.8.0.2
|
||||
|
@ -1,37 +0,0 @@
|
||||
From a00bcce0a0d3a5af85dbf685aefec5495349328f Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <a00bcce0a0d3a5af85dbf685aefec5495349328f.1355706113.git.crobinso@redhat.com>
|
||||
In-Reply-To: <30282a17091014ba5a96d20f4260df55779933c4.1355706113.git.crobinso@redhat.com>
|
||||
References: <30282a17091014ba5a96d20f4260df55779933c4.1355706113.git.crobinso@redhat.com>
|
||||
From: Michal Privoznik <mprivozn@redhat.com>
|
||||
Date: Tue, 30 Oct 2012 14:22:44 +0100
|
||||
Subject: [PATCH 8/8] Fix --test-first-run
|
||||
|
||||
One of previous patches (96ce9ac0b125) invented this feature. However,
|
||||
in options object it is called testfirstrun not test_first_run.
|
||||
This produces a runtime error.
|
||||
|
||||
(crobinso: add Michal to AUTHORS)
|
||||
(cherry picked from commit d9e8546e8608d0fd0b6af61e9a2236c91b286cdd)
|
||||
|
||||
Conflicts:
|
||||
AUTHORS
|
||||
---
|
||||
src/virt-manager.py.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/virt-manager.py.in b/src/virt-manager.py.in
|
||||
index 0cac2c2..f01c476 100755
|
||||
--- a/src/virt-manager.py.in
|
||||
+++ b/src/virt-manager.py.in
|
||||
@@ -324,7 +324,7 @@ def main():
|
||||
import virtManager.config
|
||||
import virtManager.util
|
||||
config = virtManager.config.vmmConfig(appname, appversion, ui_dir,
|
||||
- options.test_first_run)
|
||||
+ options.testfirstrun)
|
||||
virtManager.util.running_config = config
|
||||
config.default_qemu_user = default_qemu_user
|
||||
config.rhel6_defaults = rhel_enable_unsupported_opts
|
||||
--
|
||||
1.8.0.2
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/Makefile.in b/src/Makefile.in
|
||||
index f3d53be..92a536e 100644
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -814,7 +814,7 @@ uninstall-am: uninstall-binSCRIPTS uninstall-dbusDATA \
|
||||
-e "s,::DEFAULT_QEMU_USER::,$(DEFAULT_QEMU_USER)," \
|
||||
-e "s,::ENABLE_UNSUPPORTED_RHEL_OPTS::,$(ENABLE_UNSUPPORTED_RHEL_OPTS)," \
|
||||
-e "s|::PREFERRED_DISTROS::|$(PREFERRED_DISTROS)|" \
|
||||
- -e "s|::HV_PACKAGES::|$(KVM_PACKAGES)|" \
|
||||
+ -e "s|::KVM_PACKAGES::|$(KVM_PACKAGES)|" \
|
||||
-e "s|::ASKPASS_PACKAGE::|$(ASKPASS_PACKAGE)|" \
|
||||
-e "s|::LIBVIRT_PACKAGES::|$(LIBVIRT_PACKAGES)|" \
|
||||
< $< > $@
|
@ -1,49 +0,0 @@
|
||||
From 820f78af13b564600d600a199d6ef30aecde620e Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <820f78af13b564600d600a199d6ef30aecde620e.1355773837.git.crobinso@redhat.com>
|
||||
In-Reply-To: <8bfad3a2cc1c83e8d0f04f232b0ebe0847fd6bca.1355773837.git.crobinso@redhat.com>
|
||||
References: <8bfad3a2cc1c83e8d0f04f232b0ebe0847fd6bca.1355773837.git.crobinso@redhat.com>
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Mon, 17 Dec 2012 14:48:42 -0500
|
||||
Subject: [PATCH 10/10] network: Fix parsing <ip> blocks with prefix=
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=872814
|
||||
(cherry picked from commit 32f74219b024ddbd6fac5301c58e27540541d569)
|
||||
---
|
||||
src/virtManager/network.py | 20 +++++++++++++++-----
|
||||
1 file changed, 15 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/virtManager/network.py b/src/virtManager/network.py
|
||||
index ae89955..fa3e6ea 100644
|
||||
--- a/src/virtManager/network.py
|
||||
+++ b/src/virtManager/network.py
|
||||
@@ -101,12 +101,22 @@ class vmmNetwork(vmmLibvirtObject):
|
||||
return None
|
||||
addrStr = util.xpath(xml, "/network/ip/@address")
|
||||
netmaskStr = util.xpath(xml, "/network/ip/@netmask")
|
||||
+ prefix = util.xpath(xml, "/network/ip/@prefix")
|
||||
+
|
||||
+ if prefix:
|
||||
+ prefix = int(prefix)
|
||||
+ binstr = ((prefix * "1") + ((32 - prefix) * "0"))
|
||||
+ netmaskStr = str(IP(int(binstr, base=2)))
|
||||
+
|
||||
+ if netmaskStr:
|
||||
+ netmask = IP(netmaskStr)
|
||||
+ gateway = IP(addrStr)
|
||||
+ network = IP(gateway.int() & netmask.int())
|
||||
+ ret = IP(str(network) + "/" + netmaskStr)
|
||||
+ else:
|
||||
+ ret = IP(str(addrStr))
|
||||
|
||||
- netmask = IP(netmaskStr)
|
||||
- gateway = IP(addrStr)
|
||||
-
|
||||
- network = IP(gateway.int() & netmask.int())
|
||||
- return IP(str(network) + "/" + netmaskStr)
|
||||
+ return ret
|
||||
|
||||
def get_ipv4_forward(self):
|
||||
xml = self.get_xml()
|
||||
--
|
||||
1.8.0.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
7f724839749f6d8d2e57ce8bb8a6a76f virt-manager-0.9.4.tar.gz
|
||||
2b622a0f4cd53f83665d9841b5a3cefa virt-manager-0.9.5.tar.gz
|
||||
|
@ -1,14 +1,14 @@
|
||||
# -*- rpm-spec -*-
|
||||
|
||||
%define _package virt-manager
|
||||
%define _version 0.9.4
|
||||
%define _release 5
|
||||
%define virtinst_version 0.600.3
|
||||
%define _version 0.9.5
|
||||
%define _release 1
|
||||
%define virtinst_version 0.600.4
|
||||
|
||||
%define qemu_user "qemu"
|
||||
%define preferred_distros "fedora,rhel"
|
||||
%define kvm_packages "qemu-system-x86"
|
||||
%define libvirt_packages "libvirt-daemon-qemu"
|
||||
%define libvirt_packages "libvirt-daemon-kvm"
|
||||
%define askpass_package "openssh-askpass"
|
||||
%define disable_unsupported_rhel 0
|
||||
|
||||
@ -41,23 +41,6 @@ Group: Applications/Emulators
|
||||
License: GPLv2+
|
||||
URL: http://virt-manager.org/
|
||||
Source0: http://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
|
||||
# Fix KVM package install on app first run
|
||||
Patch1: 0001-virt-manager-Fix-KVM_PACKAGES-substitution-variable.patch
|
||||
# Fix listing domain with 'suspended' state (bz #850954)
|
||||
Patch2: 0002-domain-Handle-PMSUSPENDED-status.patch
|
||||
# Fix 'browse local' behavior when choosing directory (bz #855335)
|
||||
Patch3: 0003-browse_local-Fix-choosing-directory-of-F17.patch
|
||||
# Fix first run packagekit interaction (bz 870851)
|
||||
Patch4: 0004-Fix-package-install-with-PackageKit-0.8.4.patch
|
||||
Patch5: 0005-Fix-detection-of-running-libvirtd-via-systemd.patch
|
||||
# Fix another backtrace if guest is pmsuspended (bz 871237)
|
||||
Patch6: 0006-domain-Fix-more-backtraces-from-PMSUSPEND-status.patch
|
||||
# Use correct KVM package names on first run (bz 873878)
|
||||
Patch7: 0007-Add-hidden-test-first-run-switch-for-testing-Package.patch
|
||||
Patch8: 0008-Fix-test-first-run.patch
|
||||
Patch9: 0009-really-fix-kvm-substitution.patch
|
||||
# network: fix parsing ip blocks with prefix= (bz 872814)
|
||||
Patch10: 0010-network-Fix-parsing-ip-blocks-with-prefix.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
|
||||
@ -157,16 +140,6 @@ Common files used by the different Virtual Machine Manager interfaces.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
%build
|
||||
%if %{qemu_user}
|
||||
@ -289,6 +262,17 @@ update-desktop-database -q %{_datadir}/applications
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 01 2013 Cole Robinson <crobinso@redhat.com> - 0.9.5-1
|
||||
- Rebased to version 0.9.5
|
||||
- Enable adding virtio-scsi disks (Chen Hanxiao) (bz 887584)
|
||||
- Support security auto-relabel setting (Martin Kletzander)
|
||||
- Support disk iotune settings (David Shane Holden)
|
||||
- Support 'reset' as a reboot option (John Doyle)
|
||||
- Don't pull in non-native qemu packages on first run (bz 924469)
|
||||
- Don't create LVM volumes with alloc=0, it doesn't work (bz 872162)
|
||||
- Fix storage browser hang on KDE (bz 880781)
|
||||
- Fix package installation on KDE (bz 882024)
|
||||
|
||||
* Fri Mar 01 2013 Cole Robinson <crobinso@redhat.com> - 0.9.4-5
|
||||
- Add explicit dep on pod2man (bz #914562)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user