Rebased to version 1.0.0

New tool virt-xml: Edit libvirt XML in one shot from the command line
Improved defaults: qcow2, USB2, host CPU model, guest agent channel
Introspect command line options like --disk=? or --network=help
This commit is contained in:
Cole Robinson 2014-02-14 19:13:38 -05:00
parent a31cbb693a
commit a0f0f77114
3 changed files with 23 additions and 83 deletions

View File

@ -1,56 +0,0 @@
From d5a737e728351deeda858527999346d79abdb2f9 Mon Sep 17 00:00:00 2001
Message-Id: <d5a737e728351deeda858527999346d79abdb2f9.1384101775.git.crobinso@redhat.com>
From: Giuseppe Scrivano <gscrivan@redhat.com>
Date: Wed, 30 Oct 2013 17:00:15 +0100
Subject: [PATCH] virtManager: do not call set_cell_data_func with an empty
func
It fixes this exception:
Traceback (most recent call last):
File "src/virt-manager/virtManager/engine.py", line 133, in _activate
self.show_manager()
File "src/virt-manager/virtManager/engine.py", line 867, in show_manager
self._do_show_manager(None)
File "src/virt-manager/virtManager/engine.py", line 811, in _do_show_manager
manager = self.get_manager()
File "src/virt-manager/virtManager/engine.py", line 772, in get_manager
obj = vmmManager()
File "src/virt-manager/virtManager/manager.py", line 173, in __init__
self.init_stats()
File "src/virt-manager/virtManager/manager.py", line 276, in init_stats
self.toggle_host_cpu_usage_visible_widget()
File "src/virt-manager/virtManager/manager.py", line 1026, in toggle_host_cpu_usage_visible_widget
self.host_cpu_usage_img, "menu_view_stats_host_cpu")
File "src/virt-manager/virtManager/manager.py", line 1003, in _toggle_graph_helper
col.set_cell_data_func(img, datafunc, None)
File "/usr/lib/python2.7/site-packages/gi/overrides/Gtk.py", line 1320, in set_cell_data_func
super(TreeViewColumn, self).set_cell_data_func(cell_renderer, func, func_data)
TypeError: When passing None for a callback userdata must also be None
Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1024569
Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>
---
virtManager/manager.py | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/virtManager/manager.py b/virtManager/manager.py
index 114904b..fe5be75 100644
--- a/virtManager/manager.py
+++ b/virtManager/manager.py
@@ -998,9 +998,8 @@ class vmmManager(vmmGObjectUI):
for child in col.get_cells():
if isinstance(child, CellRendererSparkline):
img = child
- datafunc = do_show and datafunc or None
-
- col.set_cell_data_func(img, datafunc, None)
+ if do_show:
+ col.set_cell_data_func(img, datafunc, None)
col.set_visible(do_show)
self.widget(menu).set_active(do_show)
--
1.8.4.2

View File

@ -1 +1 @@
5c82294f7647ba14746a64c947c52b9f virt-manager-1ffcc0cc.tar.gz
8a0585de48d8060a5394aae912342c95 virt-manager-1.0.0.tar.gz

View File

@ -2,7 +2,7 @@
%define with_guestfs 0
%define disable_unsupported_rhel 0
%define stable_defaults 0
%define askpass_package "openssh-askpass"
%define qemu_user "qemu"
%define libvirt_packages "libvirt-daemon-kvm,libvirt-daemon-config-network"
@ -12,16 +12,16 @@
%if 0%{?rhel}
%define preferred_distros "rhel,fedora"
%define kvm_packages "qemu-kvm"
%define disable_unsupported_rhel 1
%define stable_defaults 1
%endif
# End local config
%define _version 0.10.0
%define _release 5
%define gitcommit 1ffcc0cc
%define _version 1.0.0
%define _release 1
# This macro is used for the continuous automated builds. It just
# allows an extra fragment based on the timestamp to be appended
@ -31,28 +31,17 @@
Name: virt-manager
Version: %{_version}
Release: %{_release}.git%{gitcommit}%{_extra_release}
Release: %{_release}%{_extra_release}
%define verrel %{version}-%{release}
Summary: Virtual Machine Manager
Group: Applications/Emulators
License: GPLv2+
URL: http://virt-manager.org/
# To prepare:
#
# git clone git://git.fedorahosted.org/virt-manager.git
# cd virt-manager
# git archive -o ../virt-manager-%{gitcommit}.tar.gz \
# --prefix=virt-manager-%{version}/ %{gitcommit}
#
#Source0: http://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
Source0: virt-manager-%{gitcommit}.tar.gz
# Fix running virt-manager on rawhide (bz #1024569)
# Remove this when pygobject is built with the fix
Patch0001: 0001-virtManager-do-not-call-set_cell_data_func-with-an-e.patch
Source0: http://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
BuildArch: noarch
Requires: virt-manager-common = %{verrel}
Requires: pygobject3
Requires: gtk3
@ -60,6 +49,7 @@ Requires: libvirt-glib >= 0.0.9
Requires: libxml2-python
Requires: vte3
Requires: dconf
Requires: dbus-x11
# For console widget
Requires: gtk-vnc2
@ -103,6 +93,7 @@ Provides: virt-install
Provides: virt-clone
Provides: virt-image
Provides: virt-convert
Provides: virt-xml
Obsoletes: python-virtinst
%description -n virt-install
@ -114,10 +105,6 @@ machine).
%prep
%setup -q
# Fix running virt-manager on rawhide (bz #1024569)
# Remove this when pygobject is built with the fix
%patch0001 -p1
%build
%if %{qemu_user}
%define _qemu_user --qemu-user=%{qemu_user}
@ -139,8 +126,8 @@ machine).
%define _askpass_package --askpass-package-names=%{askpass_package}
%endif
%if %{disable_unsupported_rhel}
%define _disable_unsupported_rhel --hide-unsupported-rhel-options
%if %{stable_defaults}
%define _stable_defaults --stable-defaults
%endif
python setup.py configure \
@ -150,7 +137,7 @@ python setup.py configure \
%{?_libvirt_packages} \
%{?_askpass_package} \
%{?_preferred_distros} \
%{?_disable_unsupported_rhel}
%{?_stable_defaults}
%install
@ -208,6 +195,7 @@ fi
%{_mandir}/man1/virt-install.1*
%{_mandir}/man1/virt-clone.1*
%{_mandir}/man1/virt-convert.1*
%{_mandir}/man1/virt-xml.1*
%{_mandir}/man1/virt-image.1*
%{_mandir}/man5/virt-image.5*
@ -215,14 +203,22 @@ fi
%{_datadir}/%{name}/virt-clone
%{_datadir}/%{name}/virt-image
%{_datadir}/%{name}/virt-convert
%{_datadir}/%{name}/virt-xml
%{_bindir}/virt-install
%{_bindir}/virt-clone
%{_bindir}/virt-image
%{_bindir}/virt-convert
%{_bindir}/virt-xml
%changelog
* Fri Feb 14 2014 Cole Robinson <crobinso@redhat.com> - 1.0.0-1
- Rebased to version 1.0.0
- New tool virt-xml: Edit libvirt XML in one shot from the command line
- Improved defaults: qcow2, USB2, host CPU model, guest agent channel
- Introspect command line options like --disk=? or --network=help
* Sun Nov 10 2013 Cole Robinson <crobinso@redhat.com> - 0.10.0-5.git1ffcc0cc
- Fix running virt-manager on rawhide (bz #1024569)
- Fix vcpu vs. maxvcpu UI (bz #1016318)