Update to latest git

Fix new VM disk image names when VM name changes (bz #1169141)
Fix missing virt-install dep on pygobject (bz #1195794)
Fix changing VM video type away from qxl (bz #1182710)
Don't use vmvga for ubuntu VMs on remote centos hosts (bz #1147662)
Clear vendor field when changing CPU (bz #1190851)
Drop bogus network domain name validation (bz #1195873)
Fix Fedora URL examples in virt-install man page (bz #1172818)
Fix misleading virt-install text after --import install (bz #1180558)
This commit is contained in:
Cole Robinson 2015-03-27 16:49:31 -04:00
parent 8f67ed6229
commit 95364a3205
6 changed files with 18 additions and 135 deletions

View File

@ -1,31 +0,0 @@
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Sun, 9 Nov 2014 22:02:30 +0100
Subject: [PATCH virt-manager] tunnels: do not close unowned fd
The fd is handed to spice-gtk and gtk-vnc. They will close it when no
longer needed. Double closing leads to various race issues, since the
same fd may be opened for a different usage.
Fixes:
https://bugzilla.redhat.com/show_bug.cgi?id=1081227
(cherry picked from commit 5daee287d91080d24c4e7ae8a0eaf4e356331bae)
---
virtManager/sshtunnels.py | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/virtManager/sshtunnels.py b/virtManager/sshtunnels.py
index b6bcf88..3a338a4 100644
--- a/virtManager/sshtunnels.py
+++ b/virtManager/sshtunnels.py
@@ -153,10 +153,7 @@ class _Tunnel(object):
self.outfd and self.outfd.fileno() or self._outfds,
self.errfd and self.errfd.fileno() or self._errfds)
- if self.outfd:
- self.outfd.close()
- elif self._outfds:
- self._outfds[0].close()
+ if self._outfds:
self._outfds[1].close()
self.outfd = None
self._outfds = None

View File

@ -1,31 +0,0 @@
From: Giuseppe Scrivano <gscrivan@redhat.com>
Date: Fri, 31 Oct 2014 20:09:54 +0100
Subject: [PATCH virt-manager] spec: move dependency to libosinfo from
virt-manager to common
Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1159370
(cherry picked from commit 23d2047576b40e9bb3342cf98d05649dd709b91b)
---
virt-manager.spec.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/virt-manager.spec.in b/virt-manager.spec.in
index 6463fa0..607a4b6 100644
--- a/virt-manager.spec.in
+++ b/virt-manager.spec.in
@@ -46,7 +46,6 @@ Requires: libxml2-python
Requires: vte3
Requires: dconf
Requires: dbus-x11
-Requires: libosinfo >= 0.2.10
# For console widget
Requires: gtk-vnc2
@@ -75,6 +74,7 @@ Requires: libvirt-python >= 0.7.0
Requires: libxml2-python
Requires: python-urlgrabber
Requires: python-ipaddr
+Requires: libosinfo >= 0.2.10
%description common
Common files used by the different virt-manager interfaces, as well as

View File

@ -1,23 +0,0 @@
From: Cole Robinson <crobinso@redhat.com>
Date: Wed, 24 Sep 2014 20:12:38 -0400
Subject: [PATCH virt-manager] addhardware: Fix attaching USB/PCI hostdev (bz
1146297)
(cherry picked from commit 3e5a20aaf13b97b2afe4415d3557dae74f89eaf7)
---
virtManager/addhardware.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/virtManager/addhardware.py b/virtManager/addhardware.py
index 7141c21..0c989df 100644
--- a/virtManager/addhardware.py
+++ b/virtManager/addhardware.py
@@ -1744,7 +1744,7 @@ class vmmAddHardware(vmmGObjectUI):
for vm in self.conn.list_vms():
for hostdev in vm.get_hostdev_devices():
if nodedev.compare_to_hostdev(hostdev):
- names.append(vm.name)
+ names.append(vm.get_name())
if names:
res = self.err.yes_no(
_('The device is already in use by other guests %s') %

View File

@ -1,21 +0,0 @@
From: Cole Robinson <crobinso@redhat.com>
Date: Sun, 22 Feb 2015 10:01:43 -0500
Subject: [PATCH virt-manager] spec: Add BuildRequires: python for f22/rawhide
(cherry picked from commit 84decb61f8a5229a9cee961af54a2967f5701bd0)
---
virt-manager.spec.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/virt-manager.spec.in b/virt-manager.spec.in
index 607a4b6..c4b8548 100644
--- a/virt-manager.spec.in
+++ b/virt-manager.spec.in
@@ -52,6 +52,7 @@ Requires: gtk-vnc2
Requires: spice-gtk3
+BuildRequires: python
BuildRequires: intltool
BuildRequires: /usr/bin/pod2man

View File

@ -1 +1 @@
c804e6e37e959e88a6d352d47c5d54fb virt-manager-1.1.0-310f6527.tar.gz
2503ae01449f7fae725bd3c0b83469ef virt-manager-1.1.0-8ca8490c.tar.gz

View File

@ -19,16 +19,11 @@
# End local config
# This macro is used for the continuous automated builds. It just
# allows an extra fragment based on the timestamp to be appended
# to the release. This distinguishes automated builds, from formal
# Fedora RPM builds
%define _extra_release %{?dist:%{dist}}%{?extra_release:%{extra_release}}
%global gitcommit 310f6527
%global gitcommit 8ca8490c
Name: virt-manager
Version: 1.1.0
Release: 5.git%{gitcommit}%{_extra_release}
Release: 6.git%{gitcommit}%{?dist}
%define verrel %{version}-%{release}
Summary: Virtual Machine Manager
@ -40,16 +35,6 @@ BuildArch: noarch
# Generated with: git archive --prefix virt-manager-%{version}/ --output virt-manager-%{version}-%{gitcommit}.tar.gz %{gitcommit}
Source0: virt-manager-%{version}-%{gitcommit}.tar.gz
# Fix crash when rebooting VMs after install (bz #1135546)
Patch0001: 0001-tunnels-do-not-close-unowned-fd.patch
# Fix dep on libosinfo (bz #1159370)
Patch0002: 0002-spec-move-dependency-to-libosinfo-from-virt-manager-.patch
# Fix PCI/USB hotplug (bz #1146297)
Patch0003: 0003-addhardware-Fix-attaching-USB-PCI-hostdev-bz-1146297.patch
# Fix BuildRequires for f22/rawhide
Patch0004: 0004-spec-Add-BuildRequires-python-for-f22-rawhide.patch
Requires: virt-manager-common = %{verrel}
Requires: pygobject3
Requires: gtk3
@ -58,10 +43,9 @@ Requires: libxml2-python
Requires: vte3
Requires: dconf
Requires: dbus-x11
# For console widget
Requires: gtk-vnc2
Requires: spice-gtk3
Requires: gnome-icon-theme
BuildRequires: python
@ -88,6 +72,8 @@ Requires: libxml2-python
Requires: python-urlgrabber
Requires: python-ipaddr
Requires: libosinfo >= 0.2.10
# Required for gobject-introspection infrastructure
Requires: pygobject3-base
%description common
Common files used by the different virt-manager interfaces, as well as
@ -114,15 +100,6 @@ machine).
%prep
%setup -q
# Fix crash when rebooting VMs after install (bz #1135546)
%patch0001 -p1
# Fix dep on libosinfo (bz #1159370)
%patch0002 -p1
# Fix PCI/USB hotplug (bz #1146297)
%patch0003 -p1
# Fix BuildRequires for f22/rawhide
%patch0004 -p1
%build
%if %{qemu_user}
%define _qemu_user --qemu-user=%{qemu_user}
@ -199,6 +176,7 @@ fi
%{_datadir}/appdata/%{name}.appdata.xml
%{_datadir}/applications/%{name}.desktop
%{_datadir}/glib-2.0/schemas/org.virt-manager.virt-manager.gschema.xml
%{_datadir}/GConf/gsettings/org.virt-manager.virt-manager.convert
%files common -f %{name}.lang
@ -227,6 +205,17 @@ fi
%changelog
* Fri Mar 27 2015 Cole Robinson <crobinso@redhat.com> - 1.1.0-6.git8ca8490c
- Update to latest git
- Fix new VM disk image names when VM name changes (bz #1169141)
- Fix missing virt-install dep on pygobject (bz #1195794)
- Fix changing VM video type away from qxl (bz #1182710)
- Don't use vmvga for ubuntu VMs on remote centos hosts (bz #1147662)
- Clear vendor field when changing CPU (bz #1190851)
- Drop bogus network domain name validation (bz #1195873)
- Fix Fedora URL examples in virt-install man page (bz #1172818)
- Fix misleading virt-install text after --import install (bz #1180558)
* Sun Feb 22 2015 Cole Robinson <crobinso@redhat.com> - 1.1.0-5.git310f6527
- Fix BuildRequires for f22/rawhide