Update to 0.8.5

This commit is contained in:
Cole Robinson 2010-08-25 13:23:11 -04:00
parent 5a7f88ce71
commit 65b2b99005
15 changed files with 26 additions and 518 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
virt-manager-0.8.4.tar.gz virt-manager-0.8.4.tar.gz
/virt-manager-0.8.5.tar.gz

View File

@ -1 +1 @@
133723a0495b79669b0903533d4a4671 virt-manager-0.8.4.tar.gz 038668be9e5edcb86ebae2495240b6ff virt-manager-0.8.5.tar.gz

View File

@ -1,20 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1271858884 14400
# Node ID 33ec21628630a9b468150b1eba635b1a83fc8a36
# Parent 41182500ddeff72cb9b875f3884042b922ed8c15
Only close connection on error from 'remote' error domain.
diff -r 41182500ddef -r 33ec21628630 src/virtManager/engine.py
--- a/src/virtManager/engine.py Sun Apr 18 00:15:36 2010 -0500
+++ b/src/virtManager/engine.py Wed Apr 21 10:08:04 2010 -0400
@@ -428,7 +428,8 @@
except KeyboardInterrupt:
raise
except libvirt.libvirtError, e:
- if e.get_error_code() == libvirt.VIR_ERR_SYSTEM_ERROR:
+ if (e.get_error_domain() == libvirt.VIR_FROM_REMOTE and
+ e.get_error_code() == libvirt.VIR_ERR_SYSTEM_ERROR):
logging.exception("Could not refresh connection %s." % uri)
logging.debug("Closing connection since libvirtd "
"appears to have stopped.")

View File

@ -1,28 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1273508425 14400
# Node ID b2a12e3e2691e1dc7f485de58899b232cbc1a880
# Parent f2d3931243fe7576701dec6deddf19cfc0145409
manager: Remove borders from VM list
diff -r f2d3931243fe -r b2a12e3e2691 src/vmm-manager.glade
--- a/src/vmm-manager.glade Thu May 06 13:54:16 2010 -0400
+++ b/src/vmm-manager.glade Mon May 10 12:20:25 2010 -0400
@@ -345,13 +345,16 @@
<widget class="GtkNotebook" id="vm-notebook">
<property name="visible">True</property>
<property name="can_focus">True</property>
+ <property name="show_border">False</property>
+ <property name="tab_border">0</property>
+ <property name="tab_hborder">0</property>
+ <property name="tab_vborder">0</property>
<child>
<widget class="GtkScrolledWindow" id="scrolledwindow1">
<property name="visible">True</property>
<property name="can_focus">True</property>
<property name="hscrollbar_policy">automatic</property>
<property name="vscrollbar_policy">automatic</property>
- <property name="shadow_type">in</property>
<child>
<widget class="GtkTreeView" id="vm-list">
<property name="visible">True</property>

View File

@ -1,93 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1270757920 14400
# Node ID 5e11e6b33fec05dc5cd155ee9931464c2e10ef2b
# Parent 4c80ef09e3f03acdc7e6ec10e70812a263ef8d45
Fix custom icon installation.
diff -r 4c80ef09e3f0 -r 5e11e6b33fec pixmaps/hicolor/16x16/actions/Makefile.am
--- a/pixmaps/hicolor/16x16/actions/Makefile.am Thu Apr 08 10:26:41 2010 +0000
+++ b/pixmaps/hicolor/16x16/actions/Makefile.am Thu Apr 08 16:18:40 2010 -0400
@@ -1,5 +1,5 @@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/16x16/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/16x16/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
diff -r 4c80ef09e3f0 -r 5e11e6b33fec pixmaps/hicolor/22x22/actions/Makefile.am
--- a/pixmaps/hicolor/22x22/actions/Makefile.am Thu Apr 08 10:26:41 2010 +0000
+++ b/pixmaps/hicolor/22x22/actions/Makefile.am Thu Apr 08 16:18:40 2010 -0400
@@ -1,5 +1,5 @@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/22x22/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/22x22/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
diff -r 4c80ef09e3f0 -r 5e11e6b33fec pixmaps/hicolor/24x24/actions/Makefile.am
--- a/pixmaps/hicolor/24x24/actions/Makefile.am Thu Apr 08 10:26:41 2010 +0000
+++ b/pixmaps/hicolor/24x24/actions/Makefile.am Thu Apr 08 16:18:40 2010 -0400
@@ -1,4 +1,4 @@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/24x24/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/24x24/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
diff -r 4c80ef09e3f0 -r 5e11e6b33fec pixmaps/hicolor/32x32/actions/Makefile.am
--- a/pixmaps/hicolor/32x32/actions/Makefile.am Thu Apr 08 10:26:41 2010 +0000
+++ b/pixmaps/hicolor/32x32/actions/Makefile.am Thu Apr 08 16:18:40 2010 -0400
@@ -1,4 +1,4 @@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/32x32/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/32x32/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
diff -rup virt-manager-0.8.4/pixmaps/hicolor/16x16/actions/Makefile.in new/pixmaps/hicolor/16x16/actions/Makefile.in
--- virt-manager-0.8.4/pixmaps/hicolor/16x16/actions/Makefile.in 2010-03-24 11:55:07.000000000 -0400
+++ new/pixmaps/hicolor/16x16/actions/Makefile.in 2010-05-13 14:59:44.281882000 -0400
@@ -184,7 +184,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/16x16/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/16x16/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
all: all-am
diff -rup virt-manager-0.8.4/pixmaps/hicolor/22x22/actions/Makefile.in new/pixmaps/hicolor/22x22/actions/Makefile.in
--- virt-manager-0.8.4/pixmaps/hicolor/22x22/actions/Makefile.in 2010-03-24 11:55:07.000000000 -0400
+++ new/pixmaps/hicolor/22x22/actions/Makefile.in 2010-05-13 14:59:44.416882000 -0400
@@ -184,7 +184,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/22x22/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/22x22/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
all: all-am
diff -rup virt-manager-0.8.4/pixmaps/hicolor/24x24/actions/Makefile.in new/pixmaps/hicolor/24x24/actions/Makefile.in
--- virt-manager-0.8.4/pixmaps/hicolor/24x24/actions/Makefile.in 2010-03-24 11:55:07.000000000 -0400
+++ new/pixmaps/hicolor/24x24/actions/Makefile.in 2010-05-13 14:59:44.547881000 -0400
@@ -184,7 +184,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/24x24/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/24x24/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
all: all-am
diff -rup virt-manager-0.8.4/pixmaps/hicolor/32x32/actions/Makefile.in new/pixmaps/hicolor/32x32/actions/Makefile.in
--- virt-manager-0.8.4/pixmaps/hicolor/32x32/actions/Makefile.in 2010-03-24 11:55:07.000000000 -0400
+++ new/pixmaps/hicolor/32x32/actions/Makefile.in 2010-05-13 14:59:44.676885000 -0400
@@ -184,7 +184,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-pixmapdir = $(pkgdatadir)/pixmaps/hicolor/32x32/action
+pixmapdir = $(pkgdatadir)/pixmaps/hicolor/32x32/actions
pixmap_DATA = $(wildcard *.png)
EXTRA_DIST = $(pixmap_DATA)
all: all-am

View File

@ -1,75 +0,0 @@
diff -rup virt-manager-0.8.4/src/virtManager/create.py new/src/virtManager/create.py
--- virt-manager-0.8.4/src/virtManager/create.py 2010-05-27 15:46:28.064880000 -0400
+++ new/src/virtManager/create.py 2010-05-27 15:47:11.751259000 -0400
@@ -1603,10 +1603,16 @@ class vmmCreate(gobject.GObject):
# out handler, removing the virtinst_guest which
# will force one final restart.
virtinst_guest.continue_install()
+
util.connect_opt_out(vm, "status-changed",
self.check_install_status, None)
return True
+ if vm.get_install_abort():
+ logging.debug("User manually shutdown VM, not restarting "
+ "guest after install.")
+ return True
+
logging.debug("Install should be completed, starting VM.")
vm.startup()
except Exception, e:
diff -rup virt-manager-0.8.4/src/virtManager/domain.py new/src/virtManager/domain.py
--- virt-manager-0.8.4/src/virtManager/domain.py 2010-05-27 15:46:28.008912000 -0400
+++ new/src/virtManager/domain.py 2010-05-27 15:47:48.539183000 -0400
@@ -75,6 +75,7 @@ class vmmDomainBase(vmmLibvirtObject):
self._backend = backend
self.uuid = uuid
+ self._install_abort = False
self._startup_vcpus = None
self._network_traffic = None
@@ -120,6 +121,13 @@ class vmmDomainBase(vmmLibvirtObject):
def get_autostart(self):
raise NotImplementedError()
+ # If manual shutdown or destroy specified, make sure we don't continue
+ # install process
+ def set_install_abort(self, val):
+ self._install_abort = bool(val)
+ def get_install_abort(self):
+ return bool(self._install_abort)
+
# Device/XML altering API
def set_autostart(self, val):
raise NotImplementedError()
@@ -1274,11 +1282,13 @@ class vmmDomain(vmmDomainBase):
reboot_listener, self)
def shutdown(self):
+ self.set_install_abort(True)
self._unregister_reboot_listener()
self._backend.shutdown()
self._update_status()
def reboot(self):
+ self.set_install_abort(True)
self._backend.reboot(0)
self._update_status()
@@ -1298,6 +1308,7 @@ class vmmDomain(vmmDomainBase):
self._update_status()
def save(self, filename, background=True):
+ self.set_install_abort(True)
if background:
conn = util.dup_conn(self.config, self.connection)
vm = conn.lookupByID(self.get_id())
@@ -1308,6 +1319,7 @@ class vmmDomain(vmmDomainBase):
self._update_status()
def destroy(self):
+ self.set_install_abort(True)
self._unregister_reboot_listener()
self._backend.destroy()
self._update_status()

View File

@ -1,22 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1273168456 14400
# Node ID f2d3931243fe7576701dec6deddf19cfc0145409
# Parent beb2272277eecd4bdc4015c905edf0b910bf9fa8
Fix livecd 'customize before install' traceback
diff -r beb2272277ee -r f2d3931243fe src/virtManager/domain.py
--- a/src/virtManager/domain.py Wed May 05 16:46:46 2010 -0400
+++ b/src/virtManager/domain.py Thu May 06 13:54:16 2010 -0400
@@ -1990,7 +1990,10 @@
return libvirt.VIR_DOMAIN_SHUTOFF
def get_xml(self):
- return self._backend.get_config_xml()
+ xml = self._backend.get_config_xml()
+ if not xml:
+ xml = self._backend.get_config_xml(install=False)
+ return xml
def _get_inactive_xml(self):
return self.get_xml()

View File

@ -1,126 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1271861766 14400
# Node ID 679b824e92dc7c8c1966b0a01a37eaaea61ea1ef
# Parent 33ec21628630a9b468150b1eba635b1a83fc8a36
host: storage: Add pool refresh button
diff -r 33ec21628630 -r 679b824e92dc src/virtManager/host.py
--- a/src/virtManager/host.py Wed Apr 21 10:08:04 2010 -0400
+++ b/src/virtManager/host.py Wed Apr 21 10:56:06 2010 -0400
@@ -128,6 +128,7 @@
"on_pool_stop_clicked": self.stop_pool,
"on_pool_start_clicked": self.start_pool,
"on_pool_delete_clicked": self.delete_pool,
+ "on_pool_refresh_clicked": self.pool_refresh,
"on_pool_autostart_toggled": self.pool_autostart_changed,
"on_vol_delete_clicked": self.delete_vol,
"on_vol_list_button_press_event": self.popup_vol_menu,
@@ -604,6 +605,19 @@
self.err.show_err(_("Error deleting pool: %s") % str(e),
"".join(traceback.format_exc()))
+ def pool_refresh(self, src):
+ pool = self.current_pool()
+ if pool is None:
+ return
+
+ try:
+ pool.refresh()
+ self.refresh_current_pool()
+ except Exception, e:
+ self.err.show_err(_("Error refreshing pool '%s': %s") % \
+ (pool.get_name(), str(e)),
+ "".join(traceback.format_exc()))
+
def delete_vol(self, src):
vol = self.current_vol()
if vol is None:
diff -r 33ec21628630 -r 679b824e92dc src/virtManager/storagepool.py
--- a/src/virtManager/storagepool.py Wed Apr 21 10:08:04 2010 -0400
+++ b/src/virtManager/storagepool.py Wed Apr 21 10:56:06 2010 -0400
@@ -25,7 +25,9 @@
from virtManager.storagevol import vmmStorageVolume
class vmmStoragePool(gobject.GObject):
- __gsignals__ = { }
+ __gsignals__ = {
+ "refreshed": (gobject.SIGNAL_RUN_FIRST, gobject.TYPE_NONE, []),
+ }
def __init__(self, config, connection, pool, uuid, active):
self.__gobject_init__()
@@ -40,8 +42,6 @@
self._xml = None # xml cache
self.refresh()
- self._update_xml()
- self.update_volumes()
def set_active(self, state):
self.active = state
@@ -120,9 +120,13 @@
return self._volumes[uuid]
def refresh(self):
- if self.active:
- self.pool.refresh(0)
- self._update_xml()
+ if not self.active:
+ return
+
+ self.pool.refresh(0)
+ self._update_xml()
+ self.update_volumes()
+ self.emit("refreshed")
def update_volumes(self):
if not self.is_active():
diff -r 33ec21628630 -r 679b824e92dc src/vmm-host.glade
--- a/src/vmm-host.glade Wed Apr 21 10:08:04 2010 -0400
+++ b/src/vmm-host.glade Wed Apr 21 10:56:06 2010 -0400
@@ -1229,11 +1229,40 @@
<property name="orientation">vertical</property>
<property name="spacing">3</property>
<child>
- <widget class="GtkLabel" id="label77">
+ <widget class="GtkHBox" id="hbox12">
<property name="visible">True</property>
- <property name="xalign">0</property>
- <property name="label" translatable="yes">&lt;b&gt;Volumes&lt;/b&gt;</property>
- <property name="use_markup">True</property>
+ <property name="spacing">6</property>
+ <child>
+ <widget class="GtkLabel" id="label77">
+ <property name="visible">True</property>
+ <property name="xalign">0</property>
+ <property name="label" translatable="yes">&lt;b&gt;Volumes&lt;/b&gt;</property>
+ <property name="use_markup">True</property>
+ </widget>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <widget class="GtkButton" id="pool-refresh">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <signal name="clicked" handler="on_pool_refresh_clicked"/>
+ <child>
+ <widget class="GtkImage" id="image8">
+ <property name="visible">True</property>
+ <property name="stock">gtk-refresh</property>
+ </widget>
+ </child>
+ </widget>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
</widget>
<packing>
<property name="expand">False</property>

View File

@ -1,45 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1273090006 14400
# Node ID 7b09131ffffcb9a49fbd2a9dae60530786d4d753
# Parent 99cf13a133f304abf4597194070aec5d397234c7
Specify connection when building all virtinst devices
diff -r 99cf13a133f3 -r 7b09131ffffc src/virtManager/addhardware.py
--- a/src/virtManager/addhardware.py Wed May 05 15:57:00 2010 -0400
+++ b/src/virtManager/addhardware.py Wed May 05 16:06:46 2010 -0400
@@ -1222,7 +1222,8 @@
def validate_page_sound(self):
smodel = self.get_config_sound_model()
try:
- self._dev = virtinst.VirtualAudio(model=smodel)
+ self._dev = virtinst.VirtualAudio(conn=self.conn.vmm,
+ model=smodel)
except Exception, e:
return self.err.val_err(_("Sound device parameter error"), str(e))
diff -r 99cf13a133f3 -r 7b09131ffffc src/virtManager/create.py
--- a/src/virtManager/create.py Wed May 05 15:57:00 2010 -0400
+++ b/src/virtManager/create.py Wed May 05 16:06:46 2010 -0400
@@ -1123,7 +1123,7 @@
guest.sound_devs = []
try:
if self.get_config_sound():
- guest.sound_devs.append(virtinst.VirtualAudio())
+ guest.sound_devs.append(virtinst.VirtualAudio(conn=guest.conn))
except Exception, e:
self.err.show_err(_("Error setting up sound device:") + str(e),
"".join(traceback.format_exc()))
diff -r 99cf13a133f3 -r 7b09131ffffc src/virtManager/uihelpers.py
--- a/src/virtManager/uihelpers.py Wed May 05 15:57:00 2010 -0400
+++ b/src/virtManager/uihelpers.py Wed May 05 16:06:46 2010 -0400
@@ -431,7 +431,8 @@
elif nettype == VirtualNetworkInterface.TYPE_USER:
pass
- net = VirtualNetworkInterface(type = nettype,
+ net = VirtualNetworkInterface(conn = conn.vmm,
+ type = nettype,
bridge = bridge,
network = netname,
macaddr = macaddr,

View File

@ -1,25 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1271108805 14400
# Node ID c206b12a8c7aa6946bfdca39cc429dd7fd258f2a
# Parent f09702cfdb03a8902c2dac88d26fec342759f35f
console: Don't through traceback if we can't read error fd.
This is racy and best effort, so don't log errors if we fail.
diff -r f09702cfdb03 -r c206b12a8c7a src/virtManager/console.py
--- a/src/virtManager/console.py Mon Apr 12 17:45:54 2010 -0400
+++ b/src/virtManager/console.py Mon Apr 12 17:46:45 2010 -0400
@@ -573,7 +573,11 @@
errfd = self.vncTunnel[1]
errout = ""
while True:
- new = errfd.recv(1024)
+ try:
+ new = errfd.recv(1024)
+ except:
+ break
+
if not new:
break

View File

@ -1,38 +0,0 @@
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1271108754 14400
# Node ID f09702cfdb03a8902c2dac88d26fec342759f35f
# Parent 82cef5edeb6e4b660cacc603d00df0d0b6f90d66
console: Fix VNC over ssh when using zsh on remote machine
diff -r 82cef5edeb6e -r f09702cfdb03 src/virtManager/console.py
--- a/src/virtManager/console.py Mon Apr 12 17:43:55 2010 -0400
+++ b/src/virtManager/console.py Mon Apr 12 17:45:54 2010 -0400
@@ -521,7 +521,7 @@
"else"
" CMD='nc %(nc_params)s';"
"fi;"
- "$CMD;" % {'nc_params': nc_params}
+ "sh -c $CMD;" % {'nc_params': nc_params}
]
argv += nc_cmd
# HG changeset patch
# User Cole Robinson <crobinso@redhat.com>
# Date 1271109105 14400
# Node ID 907ee61e5558dbf8f0b7194d4882a19e66ee6437
# Parent c206b12a8c7aa6946bfdca39cc429dd7fd258f2a
console: Actually fix SSH with zsh
diff -r c206b12a8c7a -r 907ee61e5558 src/virtManager/console.py
--- a/src/virtManager/console.py Mon Apr 12 17:46:45 2010 -0400
+++ b/src/virtManager/console.py Mon Apr 12 17:51:45 2010 -0400
@@ -521,7 +521,7 @@
"else"
" CMD='nc %(nc_params)s';"
"fi;"
- "sh -c $CMD;" % {'nc_params': nc_params}
+ "sh -c \"$CMD\";" % {'nc_params': nc_params}
]
argv += nc_cmd

View File

@ -7,8 +7,8 @@
%define _extra_release %{?dist:%{dist}}%{!?dist:%{?extra_release:%{extra_release}}} %define _extra_release %{?dist:%{dist}}%{!?dist:%{?extra_release:%{extra_release}}}
Name: virt-manager Name: virt-manager
Version: 0.8.4 Version: 0.8.5
Release: 3%{_extra_release} Release: 1%{_extra_release}
Summary: Virtual Machine Manager Summary: Virtual Machine Manager
Group: Applications/Emulators Group: Applications/Emulators
@ -19,34 +19,17 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch BuildArch: noarch
# Check QEMU permissions against the qemu user # Check QEMU permissions against the qemu user
Patch1: %{name}-%{version}-perms-qemu-user.patch Patch1: %{name}-%{version}-perms-qemu-user.patch
# Fix using a manual 'default' pool (bz 557020) # Virt package names we should ask to install
Patch2: %{name}-%{version}-packagekit-packages.patch Patch2: %{name}-%{version}-packagekit-packages.patch
# Only close connection on specific remote errors
Patch3: %{name}-%{version}-close-remote-error.patch
# Fix weird border in manager UI (bz 583728)
Patch4: %{name}-%{version}-fix-border.patch
# Fix broken icons
Patch5: %{name}-%{version}-fix-icon-install.patch
# Cancel post-install reboot if VM is forced off
Patch6: %{name}-%{version}-install-force-off.patch
# Fix traceback if customizing a livecd install (bz 583712)
Patch7: %{name}-%{version}-livecd-customize.patch
# Add pool refresh button
Patch8: %{name}-%{version}-pool-refresh-button.patch
# Properly autodetect VNC keymap (bz 586201)
Patch9: %{name}-%{version}-vnc-auto-keymap.patch
# Fix traceback when reconnecting to remote VNC console (bz 588254)
Patch10: %{name}-%{version}-vnc-reconnect-traceback.patch
# Fix remote VNC connection with zsh as default shell
Patch11: %{name}-%{version}-vnc-zsh.patch
# Don't override the "ignore deprecation warnings" default, which lead to a # Don't override the "ignore deprecation warnings" default, which lead to a
# C-assertion failure of pygtk2 on startup under python 2.7 (bz 620216): # C-assertion failure of pygtk2 on startup under python 2.7 (bz 620216):
Patch12: %{name}-%{version}-ignore-python27-deprecation-warnings.patch Patch3: %{name}-%{version}-ignore-python27-deprecation-warnings.patch
# These two are just the oldest version tested # These two are just the oldest version tested
Requires: pygtk2 >= 1.99.12-6 Requires: pygtk2 >= 1.99.12-6
Requires: gnome-python2-gconf >= 1.99.11-7 Requires: gnome-python2-gconf >= 1.99.11-7
# Absolutely require this version or newer # This version not strictly required: virt-manager should work with older,
# however varying amounts of functionality will not be enabled.
Requires: libvirt-python >= 0.7.0 Requires: libvirt-python >= 0.7.0
# Definitely does not work with earlier due to python API changes # Definitely does not work with earlier due to python API changes
Requires: dbus-python >= 0.61 Requires: dbus-python >= 0.61
@ -60,8 +43,8 @@ Requires: gnome-keyring >= 0.4.9
Requires: gnome-python2-gnomekeyring >= 2.15.4 Requires: gnome-python2-gnomekeyring >= 2.15.4
# Minimum we've tested with # Minimum we've tested with
Requires: libxml2-python >= 2.6.23 Requires: libxml2-python >= 2.6.23
# Required to install Xen & QEMU guests # Absolutely require this version or later
Requires: python-virtinst >= 0.500.3 Requires: python-virtinst >= 0.500.4
# Required for loading the glade UI # Required for loading the glade UI
Requires: pygtk2-libglade Requires: pygtk2-libglade
# Required for our graphics which are currently SVG format # Required for our graphics which are currently SVG format
@ -103,15 +86,6 @@ management API.
%patch1 -p1 %patch1 -p1
%patch2 -p1 %patch2 -p1
%patch3 -p1 %patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%build %build
%configure %configure
@ -140,12 +114,14 @@ gconftool-2 --makefile-install-rule \
update-desktop-database %{_datadir}/applications update-desktop-database %{_datadir}/applications
if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi # Revive when we update help docs
#if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
%postun %postun
update-desktop-database %{_datadir}/applications update-desktop-database %{_datadir}/applications
if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi # Revive when we update help docs
#if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
%preun %preun
if [ "$1" -eq 0 ]; then if [ "$1" -eq 0 ]; then
@ -163,11 +139,9 @@ fi
%{_mandir}/man1/%{name}.1* %{_mandir}/man1/%{name}.1*
%dir %{_datadir}/%{name}/ %dir %{_datadir}/%{name}
%{_datadir}/%{name}/*.glade %{_datadir}/%{name}/*.glade
%{_datadir}/%{name}/*.py %{_datadir}/%{name}/*.py*
%{_datadir}/%{name}/*.pyc
%{_datadir}/%{name}/*.pyo
%dir %{_datadir}/%{name}/pixmaps/ %dir %{_datadir}/%{name}/pixmaps/
%{_datadir}/%{name}/pixmaps/*.png %{_datadir}/%{name}/pixmaps/*.png
@ -179,17 +153,22 @@ fi
%{_datadir}/%{name}/pixmaps/hicolor/*/*/*.png %{_datadir}/%{name}/pixmaps/hicolor/*/*/*.png
%dir %{_datadir}/%{name}/virtManager/ %dir %{_datadir}/%{name}/virtManager/
%{_datadir}/%{name}/virtManager/*.py %{_datadir}/%{name}/virtManager/*.py*
%{_datadir}/%{name}/virtManager/*.pyc
%{_datadir}/%{name}/virtManager/*.pyo
%{_datadir}/omf/%{name}/ # Revive when we update help docs
%{_datadir}/gnome/help/%{name}/ #%{_datadir}/omf/%{name}/
#%{_datadir}/gnome/help/%{name}
%{_datadir}/applications/%{name}.desktop %{_datadir}/applications/%{name}.desktop
%{_datadir}/dbus-1/services/%{name}.service %{_datadir}/dbus-1/services/%{name}.service
%changelog %changelog
* Wed Aug 25 2010 Cole Robinson <crobinso@redhat.com> - 0.8.5-1.fc15
- Update to 0.8.5
- Improved save/restore support
- Option to view and change disk cache mode
- Configurable VNC keygrab sequence (Michal Novotny)
* Mon Aug 2 2010 David Malcolm <dmalcolm@redhat.com> - 0.8.4-3.fc15 * Mon Aug 2 2010 David Malcolm <dmalcolm@redhat.com> - 0.8.4-3.fc15
- fix python 2.7 incompatibility (bz 620216) - fix python 2.7 incompatibility (bz 620216)