Rebase to latest git
Update translations (bz #1323015) Fix rawhide URL installs (bz #1322011) Update viewer to work with spice GL
This commit is contained in:
parent
b0798ef8f7
commit
65aadae9dc
@ -1,24 +0,0 @@
|
|||||||
From: Cole Robinson <crobinso@redhat.com>
|
|
||||||
Date: Fri, 15 Jan 2016 15:07:58 -0500
|
|
||||||
Subject: [PATCH virt-manager] details: Fix screenshot on F24 rawhide (bz
|
|
||||||
1297988)
|
|
||||||
|
|
||||||
(cherry picked from commit f454798b337aedb881671f62fe3b25fad703b768)
|
|
||||||
---
|
|
||||||
virtManager/details.py | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/virtManager/details.py b/virtManager/details.py
|
|
||||||
index 0bd2569..3dbd82f 100644
|
|
||||||
--- a/virtManager/details.py
|
|
||||||
+++ b/virtManager/details.py
|
|
||||||
@@ -1486,6 +1486,9 @@ class vmmDetails(vmmGObjectUI):
|
|
||||||
# and future proof it a bit
|
|
||||||
if type(ret) is tuple and len(ret) >= 2:
|
|
||||||
ret = ret[1]
|
|
||||||
+ # F24 rawhide, ret[1] is a named tuple with a 'buffer' element...
|
|
||||||
+ if hasattr(ret, "buffer"):
|
|
||||||
+ ret = ret.buffer
|
|
||||||
|
|
||||||
import datetime
|
|
||||||
now = str(datetime.datetime.now()).split(".")[0].replace(" ", "_")
|
|
@ -1,29 +0,0 @@
|
|||||||
From: Cole Robinson <crobinso@redhat.com>
|
|
||||||
Date: Tue, 12 Jan 2016 12:45:02 -0500
|
|
||||||
Subject: [PATCH virt-manager] urlfetcher: Fix URL installs when content-length
|
|
||||||
header missing
|
|
||||||
|
|
||||||
Suggested-by: bduff@sjm.com
|
|
||||||
(cherry picked from commit eae7dc061968a83fef8ebb632c8f939621ff22b1)
|
|
||||||
---
|
|
||||||
virtinst/urlfetcher.py | 7 +++++--
|
|
||||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/virtinst/urlfetcher.py b/virtinst/urlfetcher.py
|
|
||||||
index 6181a5a..3266186 100644
|
|
||||||
--- a/virtinst/urlfetcher.py
|
|
||||||
+++ b/virtinst/urlfetcher.py
|
|
||||||
@@ -186,8 +186,11 @@ class _HTTPURLFetcher(_URLFetcher):
|
|
||||||
"""
|
|
||||||
response = requests.get(url, stream=True)
|
|
||||||
response.raise_for_status()
|
|
||||||
- size = response.headers.get('content-length')
|
|
||||||
- return response, size.isdigit() and int(size) or None
|
|
||||||
+ try:
|
|
||||||
+ size = int(response.headers.get('content-length'))
|
|
||||||
+ except:
|
|
||||||
+ size = None
|
|
||||||
+ return response, size
|
|
||||||
|
|
||||||
def _write(self, urlobj, fileobj):
|
|
||||||
"""
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
6d0436939769b66457034b1ae7040b85 virt-manager-1.3.2.tar.gz
|
8d20f953bab6caa9b347fc702258e55a virt-manager-1.3.2-20160520git2204de62d9.tar.gz
|
||||||
|
@ -1,39 +1,35 @@
|
|||||||
# -*- rpm-spec -*-
|
# -*- rpm-spec -*-
|
||||||
|
|
||||||
|
|
||||||
%define with_guestfs 0
|
%global with_guestfs 0
|
||||||
%define stable_defaults 0
|
%global stable_defaults 0
|
||||||
%define askpass_package "openssh-askpass"
|
%global askpass_package "openssh-askpass"
|
||||||
%define qemu_user "qemu"
|
%global qemu_user "qemu"
|
||||||
%define libvirt_packages "libvirt-daemon-kvm,libvirt-daemon-config-network"
|
%global libvirt_packages "libvirt-daemon-kvm,libvirt-daemon-config-network"
|
||||||
%define kvm_packages ""
|
%global kvm_packages ""
|
||||||
%define preferred_distros "fedora,rhel"
|
%global preferred_distros "fedora,rhel"
|
||||||
%define default_hvs "qemu,xen,lxc"
|
%global default_hvs "qemu,xen,lxc"
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
%define preferred_distros "rhel,fedora"
|
%global preferred_distros "rhel,fedora"
|
||||||
%define stable_defaults 1
|
%global stable_defaults 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
# End local config
|
# End local config
|
||||||
|
%global gittag 20160520git2204de62d9
|
||||||
Name: virt-manager
|
Name: virt-manager
|
||||||
Version: 1.3.2
|
Version: 1.3.2
|
||||||
Release: 3%{?dist}
|
Release: 4.%{gittag}%{?dist}
|
||||||
%define verrel %{version}-%{release}
|
%global verrel %{version}-%{release}
|
||||||
|
|
||||||
Summary: Desktop tool for managing virtual machines via libvirt
|
Summary: Desktop tool for managing virtual machines via libvirt
|
||||||
Group: Applications/Emulators
|
Group: Applications/Emulators
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://virt-manager.org/
|
|
||||||
Source0: http://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
|
|
||||||
|
|
||||||
# Fix screenshot on F24 rawhide (bz #1297988)
|
|
||||||
Patch0001: 0001-details-Fix-screenshot-on-F24-rawhide-bz-1297988.patch
|
|
||||||
# Fix URL installs when content-length header missing (bz #1297900)
|
|
||||||
Patch0002: 0002-urlfetcher-Fix-URL-installs-when-content-length-head.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
URL: http://virt-manager.org/
|
||||||
|
#Source0: http://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
Source0: %{name}-%{version}-%{gittag}.tar.gz
|
||||||
|
|
||||||
|
|
||||||
Requires: virt-manager-common = %{verrel}
|
Requires: virt-manager-common = %{verrel}
|
||||||
@ -111,38 +107,33 @@ machine).
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
# Fix screenshot on F24 rawhide (bz #1297988)
|
|
||||||
%patch0001 -p1
|
|
||||||
# Fix URL installs when content-length header missing (bz #1297900)
|
|
||||||
%patch0002 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{qemu_user}
|
%if %{qemu_user}
|
||||||
%define _qemu_user --qemu-user=%{qemu_user}
|
%global _qemu_user --qemu-user=%{qemu_user}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{kvm_packages}
|
%if %{kvm_packages}
|
||||||
%define _kvm_packages --kvm-package-names=%{kvm_packages}
|
%global _kvm_packages --kvm-package-names=%{kvm_packages}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{preferred_distros}
|
%if %{preferred_distros}
|
||||||
%define _preferred_distros --preferred-distros=%{preferred_distros}
|
%global _preferred_distros --preferred-distros=%{preferred_distros}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{libvirt_packages}
|
%if %{libvirt_packages}
|
||||||
%define _libvirt_packages --libvirt-package-names=%{libvirt_packages}
|
%global _libvirt_packages --libvirt-package-names=%{libvirt_packages}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{askpass_package}
|
%if %{askpass_package}
|
||||||
%define _askpass_package --askpass-package-names=%{askpass_package}
|
%global _askpass_package --askpass-package-names=%{askpass_package}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{stable_defaults}
|
%if %{stable_defaults}
|
||||||
%define _stable_defaults --stable-defaults
|
%global _stable_defaults --stable-defaults
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{default_hvs}
|
%if %{default_hvs}
|
||||||
%define _default_hvs --default-hvs %{default_hvs}
|
%global _default_hvs --default-hvs %{default_hvs}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
python setup.py configure \
|
python setup.py configure \
|
||||||
@ -229,6 +220,12 @@ fi
|
|||||||
%{_bindir}/virt-xml
|
%{_bindir}/virt-xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 20 2016 Cole Robinson <crobinso@redhat.com> - 1.3.2-4.20160520git2204de62d9
|
||||||
|
- Rebase to latest git
|
||||||
|
- Update translations (bz #1323015)
|
||||||
|
- Fix rawhide URL installs (bz #1322011)
|
||||||
|
- Update viewer to work with spice GL
|
||||||
|
|
||||||
* Thu Mar 17 2016 Cole Robinson <crobinso@redhat.com> - 1.3.2-3
|
* Thu Mar 17 2016 Cole Robinson <crobinso@redhat.com> - 1.3.2-3
|
||||||
- Fix screenshot on F24 rawhide (bz #1297988)
|
- Fix screenshot on F24 rawhide (bz #1297988)
|
||||||
- Fix URL installs when content-length header missing (bz #1297900)
|
- Fix URL installs when content-length header missing (bz #1297900)
|
||||||
|
Loading…
Reference in New Issue
Block a user