Fix crash when rebooting VMs after install (bz #1135546)

Fix dep on libosinfo (bz #1159370)
Fix PCI/USB hotplug (bz #1146297)
This commit is contained in:
Cole Robinson 2014-11-16 14:58:58 -05:00
parent 7845ec8762
commit 033fd436da
4 changed files with 106 additions and 2 deletions

View File

@ -0,0 +1,31 @@
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Sun, 9 Nov 2014 22:02:30 +0100
Subject: [PATCH virt-manager] tunnels: do not close unowned fd
The fd is handed to spice-gtk and gtk-vnc. They will close it when no
longer needed. Double closing leads to various race issues, since the
same fd may be opened for a different usage.
Fixes:
https://bugzilla.redhat.com/show_bug.cgi?id=1081227
(cherry picked from commit 5daee287d91080d24c4e7ae8a0eaf4e356331bae)
---
virtManager/sshtunnels.py | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/virtManager/sshtunnels.py b/virtManager/sshtunnels.py
index b6bcf88..3a338a4 100644
--- a/virtManager/sshtunnels.py
+++ b/virtManager/sshtunnels.py
@@ -153,10 +153,7 @@ class _Tunnel(object):
self.outfd and self.outfd.fileno() or self._outfds,
self.errfd and self.errfd.fileno() or self._errfds)
- if self.outfd:
- self.outfd.close()
- elif self._outfds:
- self._outfds[0].close()
+ if self._outfds:
self._outfds[1].close()
self.outfd = None
self._outfds = None

View File

@ -0,0 +1,31 @@
From: Giuseppe Scrivano <gscrivan@redhat.com>
Date: Fri, 31 Oct 2014 20:09:54 +0100
Subject: [PATCH virt-manager] spec: move dependency to libosinfo from
virt-manager to common
Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1159370
(cherry picked from commit 23d2047576b40e9bb3342cf98d05649dd709b91b)
---
virt-manager.spec.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/virt-manager.spec.in b/virt-manager.spec.in
index 6463fa0..607a4b6 100644
--- a/virt-manager.spec.in
+++ b/virt-manager.spec.in
@@ -46,7 +46,6 @@ Requires: libxml2-python
Requires: vte3
Requires: dconf
Requires: dbus-x11
-Requires: libosinfo >= 0.2.10
# For console widget
Requires: gtk-vnc2
@@ -75,6 +74,7 @@ Requires: libvirt-python >= 0.7.0
Requires: libxml2-python
Requires: python-urlgrabber
Requires: python-ipaddr
+Requires: libosinfo >= 0.2.10
%description common
Common files used by the different virt-manager interfaces, as well as

View File

@ -0,0 +1,23 @@
From: Cole Robinson <crobinso@redhat.com>
Date: Wed, 24 Sep 2014 20:12:38 -0400
Subject: [PATCH virt-manager] addhardware: Fix attaching USB/PCI hostdev (bz
1146297)
(cherry picked from commit 3e5a20aaf13b97b2afe4415d3557dae74f89eaf7)
---
virtManager/addhardware.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/virtManager/addhardware.py b/virtManager/addhardware.py
index 7141c21..0c989df 100644
--- a/virtManager/addhardware.py
+++ b/virtManager/addhardware.py
@@ -1744,7 +1744,7 @@ class vmmAddHardware(vmmGObjectUI):
for vm in self.conn.list_vms():
for hostdev in vm.get_hostdev_devices():
if nodedev.compare_to_hostdev(hostdev):
- names.append(vm.name)
+ names.append(vm.get_name())
if names:
res = self.err.yes_no(
_('The device is already in use by other guests %s') %

View File

@ -28,7 +28,7 @@
Name: virt-manager
Version: 1.1.0
Release: 3.git%{gitcommit}%{_extra_release}
Release: 4.git%{gitcommit}%{_extra_release}
%define verrel %{version}-%{release}
Summary: Virtual Machine Manager
@ -40,6 +40,13 @@ BuildArch: noarch
# Generated with: git archive --prefix virt-manager-%{version}/ --output virt-manager-%{version}-%{gitcommit}.tar.gz %{gitcommit}
Source0: virt-manager-%{version}-%{gitcommit}.tar.gz
# Fix crash when rebooting VMs after install (bz #1135546)
Patch0001: 0001-tunnels-do-not-close-unowned-fd.patch
# Fix dep on libosinfo (bz #1159370)
Patch0002: 0002-spec-move-dependency-to-libosinfo-from-virt-manager-.patch
# Fix PCI/USB hotplug (bz #1146297)
Patch0003: 0003-addhardware-Fix-attaching-USB-PCI-hostdev-bz-1146297.patch
Requires: virt-manager-common = %{verrel}
Requires: pygobject3
@ -49,7 +56,6 @@ Requires: libxml2-python
Requires: vte3
Requires: dconf
Requires: dbus-x11
Requires: libosinfo >= 0.2.10
# For console widget
Requires: gtk-vnc2
@ -78,6 +84,7 @@ Requires: libvirt-python >= 0.7.0
Requires: libxml2-python
Requires: python-urlgrabber
Requires: python-ipaddr
Requires: libosinfo >= 0.2.10
%description common
Common files used by the different virt-manager interfaces, as well as
@ -104,6 +111,13 @@ machine).
%prep
%setup -q
# Fix crash when rebooting VMs after install (bz #1135546)
%patch0001 -p1
# Fix dep on libosinfo (bz #1159370)
%patch0002 -p1
# Fix PCI/USB hotplug (bz #1146297)
%patch0003 -p1
%build
%if %{qemu_user}
%define _qemu_user --qemu-user=%{qemu_user}
@ -208,6 +222,11 @@ fi
%changelog
* Sun Nov 16 2014 Cole Robinson <crobinso@redhat.com> - 1.1.0-4.git310f6527
- Fix crash when rebooting VMs after install (bz #1135546)
- Fix dep on libosinfo (bz #1159370)
- Fix PCI/USB hotplug (bz #1146297)
* Tue Sep 23 2014 Cole Robinson <crobinso@redhat.com> - 1.1.0-3.git310f6527
- Fix defaults for arm and aarch64 VMs