import vinagre-3.22.0-23.el8
This commit is contained in:
parent
3b627d2b68
commit
c1345f2039
36
SOURCES/vinagre-3-22.0-allow-multiple-windows.patch
Normal file
36
SOURCES/vinagre-3-22.0-allow-multiple-windows.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From 154c8d5bbdc8a002116262690ef43e810a5eb7eb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Felipe Borges <felipeborges@gnome.org>
|
||||||
|
Date: Mon, 8 Aug 2016 16:14:06 +0200
|
||||||
|
Subject: [PATCH] Allow the launch of multiple application instances
|
||||||
|
|
||||||
|
We advertize the --new-window application option but since the
|
||||||
|
port to GtkApplication we are requesting for a unique application
|
||||||
|
ID, which prevents the launch of new instances.
|
||||||
|
|
||||||
|
The G_APPLICATION_NON_UNIQUE gapplication flag allows the launching
|
||||||
|
of new vinagre instances by not attempting to do any of the typical
|
||||||
|
single-instance application negotiation, even if the application
|
||||||
|
ID is given. The application neither attempts to become the owner
|
||||||
|
of the application ID nor does it check if an existing owner already
|
||||||
|
exists. Everything occurs in the local process.
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=769631
|
||||||
|
---
|
||||||
|
vinagre/vinagre-main.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/vinagre/vinagre-main.c b/vinagre/vinagre-main.c
|
||||||
|
index 9e66b72..91eba77 100644
|
||||||
|
--- a/vinagre/vinagre-main.c
|
||||||
|
+++ b/vinagre/vinagre-main.c
|
||||||
|
@@ -182,7 +182,7 @@ int main (int argc, char **argv) {
|
||||||
|
g_set_application_name (_("Remote Desktop Viewer"));
|
||||||
|
optionstate.new_window = FALSE;
|
||||||
|
|
||||||
|
- app = gtk_application_new ("org.gnome.vinagre", G_APPLICATION_HANDLES_COMMAND_LINE);
|
||||||
|
+ app = gtk_application_new ("org.gnome.vinagre", G_APPLICATION_HANDLES_COMMAND_LINE | G_APPLICATION_NON_UNIQUE);
|
||||||
|
/* https://bugzilla.gnome.org/show_bug.cgi?id=634990 */
|
||||||
|
/* g_application_set_option_context (G_APPLICATION (app), context); */
|
||||||
|
g_signal_connect (app,
|
||||||
|
--
|
||||||
|
2.7.4
|
49
SOURCES/vinagre-3.22.0-rdp-black-screen.patch
Normal file
49
SOURCES/vinagre-3.22.0-rdp-black-screen.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
--- vinagre-3.22.0/configure.ac
|
||||||
|
+++ vinagre-3.22.0/configure.ac
|
||||||
|
@@ -59,7 +59,7 @@ AM_CONDITIONAL([VINAGRE_ENABLE_SSH], [te
|
||||||
|
|
||||||
|
# Whether to enable support for RDP.
|
||||||
|
RDP_DEPS="freerdp x11"
|
||||||
|
-RDP_2_DEPS="freerdp2 x11"
|
||||||
|
+RDP_2_DEPS="freerdp2 >= 2.0.0 x11"
|
||||||
|
AC_ARG_ENABLE([rdp],
|
||||||
|
[AS_HELP_STRING([--disable-rdp],
|
||||||
|
[Disable Remote Desktop Protocol (RDP) support])])
|
||||||
|
--- vinagre-3.22.0/plugins/rdp/vinagre-rdp-tab.c
|
||||||
|
+++ vinagre-3.22.0/plugins/rdp/vinagre-rdp-tab.c
|
||||||
|
@@ -543,34 +543,9 @@ frdp_end_paint (rdpContext *context)
|
||||||
|
static BOOL
|
||||||
|
frdp_pre_connect (freerdp *instance)
|
||||||
|
{
|
||||||
|
+#ifndef HAVE_FREERDP_1_1
|
||||||
|
rdpSettings *settings = instance->settings;
|
||||||
|
|
||||||
|
-#ifdef HAVE_FREERDP_1_1
|
||||||
|
- settings->OrderSupport[NEG_DSTBLT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_PATBLT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_SCRBLT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_OPAQUE_RECT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_DRAWNINEGRID_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_MULTIDSTBLT_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_MULTIPATBLT_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_MULTISCRBLT_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_MULTIOPAQUERECT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_MULTI_DRAWNINEGRID_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_LINETO_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_POLYLINE_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_MEMBLT_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_MEM3BLT_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_MEMBLT_V2_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_MEM3BLT_V2_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_SAVEBITMAP_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_GLYPH_INDEX_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_FAST_INDEX_INDEX] = TRUE;
|
||||||
|
- settings->OrderSupport[NEG_FAST_GLYPH_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_POLYGON_SC_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_POLYGON_CB_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_ELLIPSE_SC_INDEX] = FALSE;
|
||||||
|
- settings->OrderSupport[NEG_ELLIPSE_CB_INDEX] = FALSE;
|
||||||
|
-#else
|
||||||
|
settings->order_support[NEG_DSTBLT_INDEX] = true;
|
||||||
|
settings->order_support[NEG_PATBLT_INDEX] = true;
|
||||||
|
settings->order_support[NEG_SCRBLT_INDEX] = true;
|
@ -4,7 +4,7 @@
|
|||||||
|
|
||||||
Name: vinagre
|
Name: vinagre
|
||||||
Version: 3.22.0
|
Version: 3.22.0
|
||||||
Release: 20%{?dist}
|
Release: 23%{?dist}
|
||||||
Summary: VNC client for GNOME
|
Summary: VNC client for GNOME
|
||||||
|
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -39,6 +39,12 @@ Patch7: vinagre-3.22.0-logoff.patch
|
|||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=1689273
|
# https://bugzilla.gnome.org/show_bug.cgi?id=1689273
|
||||||
Patch8: vinagre-3.22.0-rdp-password-length.patch
|
Patch8: vinagre-3.22.0-rdp-password-length.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1788531
|
||||||
|
Patch9: vinagre-3-22.0-allow-multiple-windows.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1839744
|
||||||
|
Patch10: vinagre-3.22.0-rdp-black-screen.patch
|
||||||
|
|
||||||
%if 0%{?with_spice}
|
%if 0%{?with_spice}
|
||||||
BuildRequires: pkgconfig(spice-client-gtk-3.0)
|
BuildRequires: pkgconfig(spice-client-gtk-3.0)
|
||||||
%endif
|
%endif
|
||||||
@ -96,6 +102,8 @@ Apart from the VNC protocol, vinagre supports Spice and RDP.
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
|
%patch9 -p1
|
||||||
|
%patch10 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -143,6 +151,19 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 5 2020 Marek Kasik <mkasik@redhat.com> - 3.22.0-23
|
||||||
|
- Remove unused variable (CovScan)
|
||||||
|
- Related: #1839744
|
||||||
|
|
||||||
|
* Fri Jun 5 2020 Marek Kasik <mkasik@redhat.com> - 3.22.0-22
|
||||||
|
- Rebuild due to new version of FreeRDP
|
||||||
|
- Fix an issue when RDP connection shows just black screen
|
||||||
|
- Resolves: #1839744
|
||||||
|
|
||||||
|
* Thu Jan 16 2020 Felipe Borges <feborges@redhat.com> - 3.22.0-21
|
||||||
|
- Allow the launch of multiple application instances
|
||||||
|
- Related: #1788531
|
||||||
|
|
||||||
* Tue May 21 2019 Marek Kasik <mkasik@redhat.com> - 3.22.0-20
|
* Tue May 21 2019 Marek Kasik <mkasik@redhat.com> - 3.22.0-20
|
||||||
- Rebuild due to RPMDiff (missing languages
|
- Rebuild due to RPMDiff (missing languages
|
||||||
- in vinagre.appdata.xml on x86_64)
|
- in vinagre.appdata.xml on x86_64)
|
||||||
|
Loading…
Reference in New Issue
Block a user