vim-crypto-warning.patch: Update for patchlevel 4460
This commit is contained in:
parent
6fcdf8a4bf
commit
f76a7bbf31
@ -1,11 +1,10 @@
|
||||
diff -up vim82/src/config.h.in.fips-warning vim82/src/config.h.in
|
||||
--- vim82/src/config.h.in.fips-warning 2022-01-10 14:14:44.000000000 +0100
|
||||
+++ vim82/src/config.h.in 2022-01-10 14:18:55.997105654 +0100
|
||||
@@ -507,3 +507,12 @@
|
||||
|
||||
--- vim82/src/config.h.in.fips-warning 2022-02-24 08:13:59.017280243 +0100
|
||||
+++ vim82/src/config.h.in 2022-02-24 08:14:33.085580298 +0100
|
||||
@@ -508,5 +508,14 @@
|
||||
/* Define if _SC_SIGSTKSZ is available via sysconf() */
|
||||
#undef HAVE_SYSCONF_SIGSTKSZ
|
||||
+
|
||||
|
||||
+/* Do we need FIPS warning? */
|
||||
+#undef HAVE_FIPS_WARNING
|
||||
+
|
||||
@ -14,10 +13,13 @@ diff -up vim82/src/config.h.in.fips-warning vim82/src/config.h.in
|
||||
+
|
||||
+/* Link to fips_enabled file */
|
||||
+#undef FIPS_ENABLED_FILE_LINK
|
||||
+
|
||||
/* Define if you want to load libgpm dynamically */
|
||||
#undef DYNAMIC_GPM
|
||||
diff -up vim82/src/configure.ac.fips-warning vim82/src/configure.ac
|
||||
--- vim82/src/configure.ac.fips-warning 2022-01-10 14:18:55.998105657 +0100
|
||||
+++ vim82/src/configure.ac 2022-01-10 14:20:11.030342249 +0100
|
||||
@@ -577,6 +577,38 @@ else
|
||||
--- vim82/src/configure.ac.fips-warning 2022-02-24 08:13:59.014280304 +0100
|
||||
+++ vim82/src/configure.ac 2022-02-24 08:13:59.018280222 +0100
|
||||
@@ -583,6 +583,38 @@ else
|
||||
AC_SUBST(XDIFF_OBJS_USED)
|
||||
fi
|
||||
|
||||
@ -57,9 +59,9 @@ diff -up vim82/src/configure.ac.fips-warning vim82/src/configure.ac
|
||||
AC_MSG_CHECKING(--enable-luainterp argument)
|
||||
AC_ARG_ENABLE(luainterp,
|
||||
diff -up vim82/src/crypt.c.fips-warning vim82/src/crypt.c
|
||||
--- vim82/src/crypt.c.fips-warning 2022-01-10 14:14:44.000000000 +0100
|
||||
+++ vim82/src/crypt.c 2022-01-10 14:18:55.999105660 +0100
|
||||
@@ -603,6 +603,21 @@ crypt_check_method(int method)
|
||||
--- vim82/src/crypt.c.fips-warning 2022-02-24 08:09:29.000000000 +0100
|
||||
+++ vim82/src/crypt.c 2022-02-24 08:13:59.018280222 +0100
|
||||
@@ -740,6 +740,21 @@ crypt_check_method(int method)
|
||||
msg_scroll = TRUE;
|
||||
msg(_("Warning: Using a weak encryption method; see :help 'cm'"));
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user