- patchlevel 177
This commit is contained in:
parent
c331934aab
commit
f55f5976df
1
.gitignore
vendored
1
.gitignore
vendored
@ -210,3 +210,4 @@
|
|||||||
/vim-8.1-115.tar.bz2
|
/vim-8.1-115.tar.bz2
|
||||||
/vim-8.1-117.tar.bz2
|
/vim-8.1-117.tar.bz2
|
||||||
/vim-8.1-119.tar.bz2
|
/vim-8.1-119.tar.bz2
|
||||||
|
/vim-8.1-177.tar.bz2
|
||||||
|
@ -1,130 +0,0 @@
|
|||||||
From 1e36677f8d4c57bb0e90b8a1136c392cc3b301c7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bram Moolenaar <Bram@vim.org>
|
|
||||||
Date: Thu, 28 Jun 2018 12:05:11 +0200
|
|
||||||
Subject: [PATCH] patch 8.1.0121: crash when using ballooneval related to
|
|
||||||
'vartabstop'
|
|
||||||
|
|
||||||
Problem: Crash when using ballooneval related to 'vartabstop'.
|
|
||||||
Solution: Initialize balloonEval->vts to NULL. (Markus Braun)
|
|
||||||
---
|
|
||||||
src/ex_cmds2.c | 2 +-
|
|
||||||
src/gui.c | 5 +++++
|
|
||||||
src/gui_beval.c | 11 +----------
|
|
||||||
src/gui_w32.c | 9 +--------
|
|
||||||
src/version.c | 2 ++
|
|
||||||
5 files changed, 10 insertions(+), 19 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/ex_cmds2.c b/src/ex_cmds2.c
|
|
||||||
index 01bc357f4..5f58fedfb 100644
|
|
||||||
--- a/src/ex_cmds2.c
|
|
||||||
+++ b/src/ex_cmds2.c
|
|
||||||
@@ -1419,7 +1419,7 @@ check_due_timer(void)
|
|
||||||
bevalexpr_due_set = FALSE;
|
|
||||||
if (balloonEval == NULL)
|
|
||||||
{
|
|
||||||
- balloonEval = (BalloonEval *)alloc(sizeof(BalloonEval));
|
|
||||||
+ balloonEval = (BalloonEval *)alloc_clear(sizeof(BalloonEval));
|
|
||||||
balloonEvalForTerm = TRUE;
|
|
||||||
}
|
|
||||||
if (balloonEval != NULL)
|
|
||||||
diff --git a/src/gui.c b/src/gui.c
|
|
||||||
index 87ea5ce2b..f51b81f86 100644
|
|
||||||
--- a/src/gui.c
|
|
||||||
+++ b/src/gui.c
|
|
||||||
@@ -745,7 +745,12 @@ gui_init(void)
|
|
||||||
/* Always create the Balloon Evaluation area, but disable it when
|
|
||||||
* 'ballooneval' is off. */
|
|
||||||
if (balloonEval != NULL)
|
|
||||||
+ {
|
|
||||||
+# ifdef FEAT_VARTABS
|
|
||||||
+ vim_free(balloonEval->vts);
|
|
||||||
+# endif
|
|
||||||
vim_free(balloonEval);
|
|
||||||
+ }
|
|
||||||
balloonEvalForTerm = FALSE;
|
|
||||||
# ifdef FEAT_GUI_GTK
|
|
||||||
balloonEval = gui_mch_create_beval_area(gui.drawarea, NULL,
|
|
||||||
diff --git a/src/gui_beval.c b/src/gui_beval.c
|
|
||||||
index 7e4625080..49694cfdd 100644
|
|
||||||
--- a/src/gui_beval.c
|
|
||||||
+++ b/src/gui_beval.c
|
|
||||||
@@ -111,28 +111,19 @@ gui_mch_create_beval_area(
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
- beval = (BalloonEval *)alloc(sizeof(BalloonEval));
|
|
||||||
+ beval = (BalloonEval *)alloc_clear(sizeof(BalloonEval));
|
|
||||||
if (beval != NULL)
|
|
||||||
{
|
|
||||||
#ifdef FEAT_GUI_GTK
|
|
||||||
beval->target = GTK_WIDGET(target);
|
|
||||||
- beval->balloonShell = NULL;
|
|
||||||
- beval->timerID = 0;
|
|
||||||
#else
|
|
||||||
beval->target = (Widget)target;
|
|
||||||
- beval->balloonShell = NULL;
|
|
||||||
- beval->timerID = (XtIntervalId)NULL;
|
|
||||||
beval->appContext = XtWidgetToApplicationContext((Widget)target);
|
|
||||||
#endif
|
|
||||||
beval->showState = ShS_NEUTRAL;
|
|
||||||
- beval->x = 0;
|
|
||||||
- beval->y = 0;
|
|
||||||
beval->msg = mesg;
|
|
||||||
beval->msgCB = mesgCB;
|
|
||||||
beval->clientData = clientData;
|
|
||||||
-#ifdef FEAT_VARTABS
|
|
||||||
- beval->vts = NULL;
|
|
||||||
-#endif
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Set up event handler which will keep its eyes on the pointer,
|
|
||||||
diff --git a/src/gui_w32.c b/src/gui_w32.c
|
|
||||||
index 855381108..147d98b39 100644
|
|
||||||
--- a/src/gui_w32.c
|
|
||||||
+++ b/src/gui_w32.c
|
|
||||||
@@ -8922,28 +8922,21 @@ gui_mch_create_beval_area(
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
- beval = (BalloonEval *)alloc(sizeof(BalloonEval));
|
|
||||||
+ beval = (BalloonEval *)alloc_clear(sizeof(BalloonEval));
|
|
||||||
if (beval != NULL)
|
|
||||||
{
|
|
||||||
beval->target = s_textArea;
|
|
||||||
- beval->balloon = NULL;
|
|
||||||
|
|
||||||
beval->showState = ShS_NEUTRAL;
|
|
||||||
- beval->x = 0;
|
|
||||||
- beval->y = 0;
|
|
||||||
beval->msg = mesg;
|
|
||||||
beval->msgCB = mesgCB;
|
|
||||||
beval->clientData = clientData;
|
|
||||||
-#ifdef FEAT_VARTABS
|
|
||||||
- beval->vts = NULL;
|
|
||||||
-#endif
|
|
||||||
|
|
||||||
InitCommonControls();
|
|
||||||
cur_beval = beval;
|
|
||||||
|
|
||||||
if (p_beval)
|
|
||||||
gui_mch_enable_beval_area(beval);
|
|
||||||
-
|
|
||||||
}
|
|
||||||
return beval;
|
|
||||||
}
|
|
||||||
diff --git a/src/version.c b/src/version.c
|
|
||||||
index a7a96b396..563a70be6 100644
|
|
||||||
--- a/src/version.c
|
|
||||||
+++ b/src/version.c
|
|
||||||
@@ -789,6 +789,8 @@ static char *(features[]) =
|
|
||||||
|
|
||||||
static int included_patches[] =
|
|
||||||
{ /* Add new patch number below this line */
|
|
||||||
+/**/
|
|
||||||
+ 121,
|
|
||||||
/**/
|
|
||||||
119,
|
|
||||||
/**/
|
|
||||||
--
|
|
||||||
2.14.4
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (vim-8.1-119.tar.bz2) = cde0a6adf4bd52b4d19396d1c81787702667fe7dabb20672303f78e6b5ce5de09e3531b83231585ee98e64b14a7132a8d9d2f1329bb154944717075dbf593e11
|
SHA512 (vim-8.1-177.tar.bz2) = 82e76c147cdf814812b4e423d79e5f80658f31b9b26fb1eadfa2f8e59d4f0536447f89ce8a68ef3a7aba2945d25e98b556a33bc650212bb981b921fb51cd528c
|
||||||
|
@ -78,7 +78,7 @@ cp -f vim-upstream/dist/vim-${UPSTREAMMAJOR}-${LASTPLFILLED}.tar.bz2 .
|
|||||||
#wget https://raw.githubusercontent.com/ignatenkobrain/vim-spec-plugin/master/ftplugin/spec.vim -O ftplugin-spec.vim
|
#wget https://raw.githubusercontent.com/ignatenkobrain/vim-spec-plugin/master/ftplugin/spec.vim -O ftplugin-spec.vim
|
||||||
#wget https://raw.githubusercontent.com/ignatenkobrain/vim-spec-plugin/master/syntax/spec.vim -O syntax-spec.vim
|
#wget https://raw.githubusercontent.com/ignatenkobrain/vim-spec-plugin/master/syntax/spec.vim -O syntax-spec.vim
|
||||||
if [ $CHANGES -ne 0 ]; then
|
if [ $CHANGES -ne 0 ]; then
|
||||||
CHLOG="* $DATE $PACKAGER - $EPOCH:$UPSTREAMMAJOR"
|
CHLOG="* $DATE $PACKAGER -$EPOCH:$UPSTREAMMAJOR"
|
||||||
$debug sed -i -e "/Release: /cRelease: 1%{?dist}" $SPEC
|
$debug sed -i -e "/Release: /cRelease: 1%{?dist}" $SPEC
|
||||||
if [ "x$MAJORVERSION" != "x$UPSTREAMMAJOR" ]; then
|
if [ "x$MAJORVERSION" != "x$UPSTREAMMAJOR" ]; then
|
||||||
$debug sed -i -s "s/define baseversion $MAJORVERSION/define baseversion $UPSTREAMMAJOR/" $SPEC
|
$debug sed -i -s "s/define baseversion $MAJORVERSION/define baseversion $UPSTREAMMAJOR/" $SPEC
|
||||||
|
17
vim.spec
17
vim.spec
@ -1,4 +1,4 @@
|
|||||||
%define patchlevel 119
|
%define patchlevel 177
|
||||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||||
%define WITH_SELINUX 1
|
%define WITH_SELINUX 1
|
||||||
%endif
|
%endif
|
||||||
@ -24,7 +24,7 @@ Summary: The VIM editor
|
|||||||
URL: http://www.vim.org/
|
URL: http://www.vim.org/
|
||||||
Name: vim
|
Name: vim
|
||||||
Version: %{baseversion}.%{patchlevel}
|
Version: %{baseversion}.%{patchlevel}
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Vim
|
License: Vim
|
||||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
||||||
Source1: vim.sh
|
Source1: vim.sh
|
||||||
@ -68,9 +68,6 @@ Patch3016: vim-8.0-copy-paste.patch
|
|||||||
# migrate shebangs in script to /usr/bin/python3 and use python2 when necessary
|
# migrate shebangs in script to /usr/bin/python3 and use python2 when necessary
|
||||||
Patch3017: vim-python3-tests.patch
|
Patch3017: vim-python3-tests.patch
|
||||||
|
|
||||||
# Upstream patch:
|
|
||||||
Patch3018: 0001-patch-8.1.0121-crash-when-using-ballooneval-related-.patch
|
|
||||||
|
|
||||||
# gcc is no longer in buildroot by default
|
# gcc is no longer in buildroot by default
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
|
|
||||||
@ -252,7 +249,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3014 -p1
|
%patch3014 -p1
|
||||||
%patch3016 -p1
|
%patch3016 -p1
|
||||||
%patch3017 -p1
|
%patch3017 -p1
|
||||||
%patch3018 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?rhel} > 7
|
%if 0%{?rhel} > 7
|
||||||
@ -534,7 +530,7 @@ rm -f %{buildroot}/%{_datadir}/vim/%{vimdir}/tutor/tutor.gr.utf-8~
|
|||||||
)
|
)
|
||||||
|
|
||||||
# Remove not UTF-8 manpages
|
# Remove not UTF-8 manpages
|
||||||
for i in pl.ISO8859-2 it.ISO8859-1 ru.KOI8-R fr.ISO8859-1; do
|
for i in pl.ISO8859-2 it.ISO8859-1 ru.KOI8-R fr.ISO8859-1 da.ISO8859-1 de.ISO8859-1; do
|
||||||
rm -rf %{buildroot}/%{_mandir}/$i
|
rm -rf %{buildroot}/%{_mandir}/$i
|
||||||
done
|
done
|
||||||
|
|
||||||
@ -542,7 +538,7 @@ done
|
|||||||
mv %{buildroot}/%{_mandir}/ru.UTF-8 %{buildroot}/%{_mandir}/ru
|
mv %{buildroot}/%{_mandir}/ru.UTF-8 %{buildroot}/%{_mandir}/ru
|
||||||
|
|
||||||
# Remove duplicate man pages
|
# Remove duplicate man pages
|
||||||
for i in fr.UTF-8 it.UTF-8 pl.UTF-8; do
|
for i in fr.UTF-8 it.UTF-8 pl.UTF-8 da.UTF-8 de.UTF-8; do
|
||||||
rm -rf %{buildroot}/%{_mandir}/$i
|
rm -rf %{buildroot}/%{_mandir}/$i
|
||||||
done
|
done
|
||||||
|
|
||||||
@ -647,6 +643,8 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
|||||||
%{_mandir}/man1/xxd.*
|
%{_mandir}/man1/xxd.*
|
||||||
%{_mandir}/man5/vimrc.*
|
%{_mandir}/man5/vimrc.*
|
||||||
%lang(fr) %{_mandir}/fr/man1/*
|
%lang(fr) %{_mandir}/fr/man1/*
|
||||||
|
%lang(da) %{_mandir}/da/man1/*
|
||||||
|
%lang(de) %{_mandir}/de/man1/*
|
||||||
%lang(it) %{_mandir}/it/man1/*
|
%lang(it) %{_mandir}/it/man1/*
|
||||||
%lang(ja) %{_mandir}/ja/man1/*
|
%lang(ja) %{_mandir}/ja/man1/*
|
||||||
%lang(pl) %{_mandir}/pl/man1/*
|
%lang(pl) %{_mandir}/pl/man1/*
|
||||||
@ -772,6 +770,9 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
|||||||
%{_datadir}/icons/locolor/*/apps/*
|
%{_datadir}/icons/locolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 11 2018 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.177-1
|
||||||
|
- patchlevel 177
|
||||||
|
|
||||||
* Wed Jul 11 2018 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.119-8
|
* Wed Jul 11 2018 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.119-8
|
||||||
- add packager and epoch into update script to have better changelog
|
- add packager and epoch into update script to have better changelog
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user