Merge branch 'f26'
This commit is contained in:
commit
f3985550dc
1
.gitignore
vendored
1
.gitignore
vendored
@ -75,3 +75,4 @@
|
||||
/vim-8.0-617.tar.bz2
|
||||
/vim-8.0-627.tar.bz2
|
||||
/vim-8.0-628.tar.bz2
|
||||
/vim-8.0-636.tar.bz2
|
||||
|
@ -1,3 +1,80 @@
|
||||
commit 56f2db562ddc6c69026d55360f0cfaacd8adc26a
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sun Jun 11 23:09:15 2017 +0200
|
||||
|
||||
patch 8.0.0636: when reading the undo file fails may use uninitialized data
|
||||
|
||||
Problem: When reading the undo file fails may use uninitialized data.
|
||||
Solution: Always clear the buffer on failure.
|
||||
|
||||
commit 3a429efb628a3925d13c3fe415e02a7ce117071f
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sun Jun 11 17:10:32 2017 +0200
|
||||
|
||||
patch 8.0.0635: when 'ignorecase' is set script detection is inaccurate
|
||||
|
||||
Problem: When 'ignorecase' is set script detection is inaccurate.
|
||||
Solution: Enforce matching case for text. (closes #1753)
|
||||
|
||||
commit 875feea6ce223462d55543735143d747dcaf4287
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sun Jun 11 16:07:51 2017 +0200
|
||||
|
||||
patch 8.0.0634: cannot easily get to the last quickfix list
|
||||
|
||||
Problem: Cannot easily get to the last quickfix list.
|
||||
Solution: Add "$" as a value for the "nr" argument of getqflist() and
|
||||
setqflist(). (Yegappan Lakshmanan)
|
||||
|
||||
commit 60964f68740b8abcbb2d3f0f3aeade21d1bacb22
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sat Jun 10 17:06:16 2017 +0200
|
||||
|
||||
patch 8.0.0633: the client-server test is still a bit flaky
|
||||
|
||||
Problem: The client-server test is still a bit flaky.
|
||||
Solution: Wait a bit for the GUI to start. Check that the version number
|
||||
can be obtained.
|
||||
|
||||
commit 1c13c0fe3e7b15750464ffbc39a4648aa5c639be
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sat Jun 10 16:30:32 2017 +0200
|
||||
|
||||
patch 8.0.0632: the quotestar test is still a bit flaky
|
||||
|
||||
Problem: The quotestar test is still a bit flaky.
|
||||
Solution: Kill any existing server to make the retry work. Wait for the
|
||||
register to be filled.
|
||||
|
||||
commit fa4161cb0c266378012d3fde0eca56da8739528d
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sat Jun 10 15:46:23 2017 +0200
|
||||
|
||||
patch 8.0.0631: can't build with Perl 5.26
|
||||
|
||||
Problem: Perl 5.26 also needs S_TOPMARK and S_POPMARK defined.
|
||||
Solution: Define the functions when needed. (Jesin, closes #1748)
|
||||
|
||||
commit f84b122a99da75741ae686fabb6f81b8b4755998
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Sat Jun 10 14:29:52 2017 +0200
|
||||
|
||||
patch 8.0.0630: it is not easy to work on lines without a match
|
||||
|
||||
Problem: The :global command does not work recursively, which makes it
|
||||
difficult to execute a command on a line where one pattern matches
|
||||
and another does not match. (Miles Cranmer)
|
||||
Solution: Allow for recursion if it is for only one line. (closes #1760)
|
||||
|
||||
commit 6b1da3312e15c065b373c9ec2732f31a77cee61f
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Fri Jun 9 21:35:47 2017 +0200
|
||||
|
||||
patch 8.0.0629: checking for ambigous width is not working
|
||||
|
||||
Problem: Checking for ambigous width is not working. (Hirohito Higashi)
|
||||
Solution: Reset "starting" earlier.
|
||||
|
||||
commit f085f4266e07b36279c56d43fd0d73ed080046ae
|
||||
Author: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Wed Jun 7 20:39:47 2017 +0200
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (vim-8.0-628.tar.bz2) = d20f2c5032dd140ddd30559033ff6ece9af5066036046b80a77081fdd87e7bb69ad6081fc0ce04ed13cd9d400b6cfa6b6fac7519e08e6831827001885f657e3f
|
||||
SHA512 (vim-8.0-636.tar.bz2) = 8a6562c2bc84986fe541fbe21f88d327856ae963c55c55163ebe84f558cf4483ebe8b5c58b025e89c8b615c889e7427981b41b4da3cf612d2dc5d5f5a36dc8a5
|
||||
|
@ -1,81 +0,0 @@
|
||||
From 6abca28cf208f4b263b2308a2b4e1e2ace4ae020 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Mon, 29 May 2017 13:57:40 +0200
|
||||
Subject: [PATCH] Restore compatiblity wih Perl 5.26.0
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Since Perl 5.25.4, S_POPMARK() macro is in Perl's inline.h (Perl's commit
|
||||
33a4312b882). But vim decided to define PERL_NO_INLINE_FUNCTIONS to prevent
|
||||
from including inline.h because Perl 5.18.0. And that prevents from having
|
||||
S_POPMARK() available when building against dynamic Perl 5.26.0:
|
||||
|
||||
gcc -L. -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -fstack-protector -rdynamic -Wl,-export-dynamic -Wl,--enable-new-dtags -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -L/usr/local/lib -Wl,--as-needed -o vim objects/arabic.o objects/buffer.o objects/blowfish.o objects/crypt.o objects/crypt_zip.o objects/dict.o objects/diff.o objects/digraph.o objects/edit.o objects/eval.o objects/evalfunc.o objects/ex_cmds.o objects/ex_cmds2.o objects/ex_docmd.o objects/ex_eval.o objects/ex_getln.o objects/farsi.o objects/fileio.o objects/fold.o objects/getchar.o objects/hardcopy.o objects/hashtab.o objects/if_cscope.o objects/if_xcmdsrv.o objects/list.o objects/mark.o objects/memline.o objects/menu.o objects/misc1.o objects/misc2.o objects/move.o objects/mbyte.o objects/normal.o objects/ops.o objects/option.o objects/os_unix.o objects/pathdef.o objects/popupmnu.o objects/quickfix.o objects/regexp.o objects/screen.o objects/search.o objects/sha256.o objects/spell.o objects/spellfile.o objects/syntax.o objects/tag.o objects/term.o objects/ui.o objects/undo.o objects/userfunc.o objects/version.o objects/window.o objects/gui.o objects/gui_gtk.o objects/gui_gtk_x11.o objects/pty.o objects/gui_gtk_f.o objects/gui_beval.o objects/gui_gtk_gresources.o objects/if_lua.o objects/if_perl.o objects/if_perlsfio.o objects/if_python.o objects/if_python3.o objects/if_ruby.o objects/netbeans.o objects/channel.o objects/charset.o objects/json.o objects/main.o objects/memfile.o objects/message.o -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lSM -lICE -lm -lelf -lnsl -lselinux -lncurses -lacl -lattr -lgpm -ldl -Wl,--enable-new-dtags -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -fstack-protector-strong -L/usr/local/lib -L/usr/lib64/perl5/CORE -lperl -lpthread -lresolv -lnsl -ldl -lm -lcrypt -lutil -lc
|
||||
objects/if_perl.o: In function `XS_VIBUF_Count':
|
||||
/home/test/fedora/vim/vim80/src/if_perl.c:2085: undefined reference to `S_POPMARK'
|
||||
objects/if_perl.o: In function `XS_VIBUF_Number':
|
||||
/home/test/fedora/vim/vim80/src/if_perl.c:2054: undefined reference to `S_POPMARK'
|
||||
objects/if_perl.o: In function `XS_VIBUF_Name':
|
||||
/home/test/fedora/vim/vim80/src/if_perl.c:2019: undefined reference to `S_POPMARK'
|
||||
objects/if_perl.o: In function `XS_VIBUF_DESTROY':
|
||||
/home/test/fedora/vim/vim80/src/if_perl.c:1992: undefined reference to `S_POPMARK'
|
||||
objects/if_perl.o: In function `XS_VIBUF_Append':
|
||||
/home/test/fedora/vim/vim80/src/if_perl.c:2299: undefined reference to `S_POPMARK'
|
||||
objects/if_perl.o:/home/test/fedora/vim/vim80/src/if_perl.c:2222: more undefined references to `S_POPMARK' follow
|
||||
collect2: error: ld returned 1 exit status
|
||||
|
||||
This patch removes the PERL_NO_INLINE_FUNCTIONS definition and
|
||||
S_SvREFCNT_dec redefinition from src/if_perl.xs to restore
|
||||
compatibility with Perl 5.26.0.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
src/if_perl.xs | 24 ------------------------
|
||||
1 file changed, 24 deletions(-)
|
||||
|
||||
diff --git a/src/if_perl.xs b/src/if_perl.xs
|
||||
index 2bf72c5..7dedfba 100644
|
||||
--- a/src/if_perl.xs
|
||||
+++ b/src/if_perl.xs
|
||||
@@ -37,13 +37,6 @@
|
||||
|
||||
#include "vim.h"
|
||||
|
||||
-/* Work around for perl-5.18.
|
||||
- * Don't include "perl\lib\CORE\inline.h" for now,
|
||||
- * include it after Perl_sv_free2 is defined. */
|
||||
-#ifdef DYNAMIC_PERL
|
||||
-# define PERL_NO_INLINE_FUNCTIONS
|
||||
-#endif
|
||||
-
|
||||
/* Work around for using MSVC and ActivePerl 5.18. */
|
||||
#ifdef _MSC_VER
|
||||
# define __inline__ __inline
|
||||
@@ -616,23 +609,6 @@ static struct {
|
||||
{"", NULL},
|
||||
};
|
||||
|
||||
-/* Work around for perl-5.18.
|
||||
- * For now, only the definitions of S_SvREFCNT_dec are needed in
|
||||
- * "perl\lib\CORE\inline.h". */
|
||||
-# if (PERL_REVISION == 5) && (PERL_VERSION >= 18)
|
||||
-static void
|
||||
-S_SvREFCNT_dec(pTHX_ SV *sv)
|
||||
-{
|
||||
- if (LIKELY(sv != NULL)) {
|
||||
- U32 rc = SvREFCNT(sv);
|
||||
- if (LIKELY(rc > 1))
|
||||
- SvREFCNT(sv) = rc - 1;
|
||||
- else
|
||||
- Perl_sv_free2(aTHX_ sv, rc);
|
||||
- }
|
||||
-}
|
||||
-# endif
|
||||
-
|
||||
/*
|
||||
* Make all runtime-links of perl.
|
||||
*
|
||||
--
|
||||
2.9.4
|
||||
|
7
vim.spec
7
vim.spec
@ -1,4 +1,4 @@
|
||||
%define patchlevel 628
|
||||
%define patchlevel 636
|
||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||
%define WITH_SELINUX 1
|
||||
%endif
|
||||
@ -69,7 +69,6 @@ Patch3014: vim-7.4-releasestring-1318991.patch
|
||||
Patch3015: vim-8.0-rhbz1365258.patch
|
||||
Patch3016: vim-8.0-copy-paste.patch
|
||||
Patch3017: vim-8.0-bindsyntax.patch
|
||||
Patch3018: vim-8.0-ftbfs-perl526.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
||||
@ -226,7 +225,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch3015 -p1
|
||||
%patch3016 -p1
|
||||
%patch3017 -p1
|
||||
%patch3018 -p1
|
||||
|
||||
%build
|
||||
cp -f %{SOURCE6} .
|
||||
@ -772,6 +770,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/icons/locolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 12 2017 Karsten Hopp <karsten@redhat.com> 8.0.636-1
|
||||
- patchlevel 636, removing perl ftbfs patch
|
||||
|
||||
* Fri Jun 09 2017 Karsten Hopp <karsten@redhat.com> 8.0.628-1
|
||||
- patchlevel 628
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user