fix selinux patch, so that HAVE_SELINUX will not be defined on non-selinux

systems (#137860)
This commit is contained in:
Karsten Hopp 2004-11-02 11:53:07 +00:00
parent 03c1db64c8
commit eb3561fd74
2 changed files with 8 additions and 3 deletions

View File

@ -1,6 +1,6 @@
--- vim62/src/configure.in.selinux 2004-01-20 11:34:17.177103792 -0500
+++ vim62/src/configure.in 2004-01-20 11:34:18.507126105 -0500
@@ -195,6 +195,20 @@
@@ -195,6 +195,21 @@
fi
@ -12,8 +12,9 @@
+ , [enable_selinux="yes"])
+if test "$enable_selinux" = "yes"; then
+ AC_MSG_RESULT(no)
+ AC_CHECK_LIB(selinux, is_selinux_enabled, [LIBS="$LIBS -lselinux"])
+ AC_DEFINE(HAVE_SELINUX)
+ AC_CHECK_LIB(selinux, is_selinux_enabled,
+ [LIBS="$LIBS -lselinux"
+ AC_DEFINE(HAVE_SELINUX)])
+else
+ AC_MSG_RESULT(yes)
+fi

View File

@ -491,6 +491,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Tue Nov 02 2004 Karsten Hopp <karsten@redhat.de> 6.3.030-3
- fix selinux patch, so that HAVE_SELINUX will not be defined on
non-selinux systems (#137860)
* Tue Oct 19 2004 Karsten Hopp <karsten@redhat.de> 6.3.030-3
- fix dependencies on vim-common (#132371)