split spell files in subpackage as they are quite huge and not required for

normal use. Update to patchlevel 99
This commit is contained in:
Karsten Hopp 2006-09-11 15:29:06 +00:00
parent b594b0eae8
commit d427c0e6aa
3 changed files with 127 additions and 13 deletions

View File

@ -111,3 +111,16 @@ Individual patches for Vim 7.0:
5968 7.0.084 garbage collection may free Lists and Dicts still in use
1512 7.0.085 running tests changes the viminfo file
2379 7.0.086 getqflist() uses number zero for empty pattern and text
7382 7.0.087 'acd' doesn't work for ":file fname" and ":saveas fname"
3066 7.0.088 generated prototypes have "extern" when build with Perl
2445 7.0.089 "ga" gave wrong results for non-Unicode multi-byte encoding
2486 7.0.090 need to type Esc twice in console confirm() dialog
1698 7.0.091 winrestview() may leave cursor in the wrong position
2952 7.0.092 (after 7.0.082) list of internal function args is obsolete
2320 7.0.093 matchparen plugin can't handle some values of 'matchpairs'
2394 7.0.094 fileinfo message is given too often after ":buf N"
52575 7.0.095 Greek tutor is not available in utf-8
2561 7.0.096 taglist() does not use path of tags file
2617 7.0.097 tab pages line was not updated for ":tabclose N"
2196 7.0.098 redirection didn't work inside cmdline completion
2189 7.0.099 GUI: scrolling causes problems for the popup menu

View File

@ -1,20 +1,20 @@
--- vim70/runtime/syntax/fstab.vim.fstabsyntax 2006-04-16 18:01:27.000000000 +0200
+++ vim70/runtime/syntax/fstab.vim 2006-06-21 11:52:21.000000000 +0200
@@ -36,7 +36,7 @@
--- vim70/runtime/syntax/fstab.vim.fstabsyntax 2006-09-11 14:03:39.000000000 +0200
+++ vim70/runtime/syntax/fstab.vim 2006-09-11 14:14:34.000000000 +0200
@@ -39,7 +39,7 @@
" Type
syn cluster fsTypeCluster contains=fsTypeKeyword,fsTypeUnknown
syn match fsTypeUnknown /\s\+\zs\w\+/ contained
-syn keyword fsTypeKeyword contained adfs affs atfs audiofs auto autofs befs bfs cd9660 cfs cifs coda cramfs devfs devpts e2compr efs ext2 ext3 fdesc hfs hpfs iso9660 jffs jffs2 jfs kernfs linprocfs mfs minix msdos ncpfs nfs none none ntfs null nwfs ovlfs portal proc procfs qnx4 reiserfs romfs shm smbfs std subfs swap sysfs sysv tcfs tmpfs udf ufs umap umsdos union usbfs userfs vfat vs3fs vxfs wrapfs wvfs xfs zisofs
+syn keyword fsTypeKeyword contained adfs affs atfs audiofs auto autofs befs binfmt_misc bfs cd9660 cfs cifs coda cramfs devfs devpts e2compr efs ext2 ext3 fdesc hfs hpfs iso9660 jffs jffs2 jfs kernfs linprocfs mfs minix msdos ncpfs nfs none ntfs null nwfs ovlfs portal proc procfs qnx4 reiserfs romfs rpc_pipefs shm smbfs std subfs swap sysfs sysv tcfs tmpfs udf ufs umap umsdos union usbfs userfs vfat vs3fs vxfs wrapfs wvfs xfs zisofs
-syn keyword fsTypeKeyword contained adfs ados affs atfs audiofs auto autofs befs bfs cd9660 cfs cifs coda cramfs devfs devpts e2compr efs ext2 ext2fs ext3 fdesc ffs filecore hfs hpfs iso9660 jffs jffs2 jfs kernfs lfs linprocfs mfs minix msdos ncpfs nfs none ntfs null nwfs overlay ovlfs portal proc procfs ptyfs qnx4 reiserfs romfs shm smbfs std subfs swap sysfs sysv tcfs tmpfs udf ufs umap umsdos union usbfs userfs vfat vs3fs vxfs wrapfs wvfs xfs zisofs
+syn keyword fsTypeKeyword contained adfs ados affs atfs audiofs auto autofs befs bfs binfmt_misc cd9660 cfs cifs coda cramfs devfs devpts e2compr efs ext2 ext2fs ext3 fdesc ffs filecore hfs hpfs iso9660 jffs jffs2 jfs kernfs lfs linprocfs mfs minix msdos ncpfs nfs none ntfs null nwfs overlay ovlfs portal proc procfs ptyfs qnx4 reiserfs romfs rpc_pipefs shm smbfs std subfs swap sysfs sysv tcfs tmpfs udf ufs umap umsdos union usbfs userfs vfat vs3fs vxfs wrapfs wvfs xfs zisofs
" Options
" -------
@@ -48,7 +48,7 @@
@@ -51,7 +51,7 @@
syn keyword fsOptionsYesNo yes no
syn cluster fsOptionsCheckCluster contains=fsOptionsExt2Check,fsOptionsFatCheck
syn keyword fsOptionsSize 512 1024 2048
-syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devuid dirsync exec force fstab kudzu loop mand move noatime noauto noclusterr noclusterw nodev nodiratime noexec nomand nosuid nosymfollow nouser owner rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user[s] xx
+syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devuid dirsync exec force fstab kudzu loop managed mand move noatime noauto noclusterr noclusterw nodev nodiratime noexec nomand nosuid nosymfollow nouser owner pamconsole rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user[s] xx
-syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand nosuid nosymfollow nouser owner rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user users xx
+syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop managed mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand nosuid nosymfollow nouser owner pamconsole rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user[s] xx
syn match fsOptionsGeneral /_netdev/
" Options: adfs

111
vim.spec
View File

@ -15,7 +15,7 @@
#used for pre-releases:
%define beta %{nil}
%define vimdir vim70%{?beta}
%define patchlevel 086
%define patchlevel 099
Summary: The VIM editor.
Name: vim
@ -38,6 +38,9 @@ Source11: Changelog.rpm
#Source12: vi-help.txt
# Source at http://www.vim.org/scripts/script.php?script_id=213 :
#Source12: cvim.zip
Source13: runtime-update-20060911.tar.bz2
Source14: vim-spell-files.tar.bz2
Patch2002: vim-7.0-fixkeys.patch
Patch2003: vim-6.2-specsyntax.patch
Patch2004: vim-7.0-crv.patch
@ -131,10 +134,23 @@ Patch083: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.083
Patch084: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.084
Patch085: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.085
Patch086: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.086
Patch087: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.087
Patch088: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.088
Patch089: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.089
Patch090: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.090
Patch091: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.091
Patch092: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.092
Patch093: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.093
Patch094: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.094
Patch095: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.095
Patch096: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.096
Patch097: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.097
Patch098: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.098
Patch099: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.099
Patch3000: vim-7.0-syntax.patch
Patch3001: vim-6.2-rh1.patch
#Patch3001: vim-6.2-rh1.patch
Patch3002: vim-6.1-rh2.patch
Patch3003: vim-6.1-rh3.patch
Patch3004: vim-7.0-rclocation.patch
@ -185,6 +201,15 @@ order to run.
If you are installing vim-enhanced or vim-X11, you'll also need
to install the vim-common package.
%package spell
Summary: The dictionaries for spell checking. This package is optional.
Group: Applications/Editors
Requires: vim-common = %{epoch}:%{version}-%{release}
%description spell
This subpackage contains dictionaries for vim spell checking in
many different languages.
%package minimal
Summary: A minimal version of the VIM editor.
Group: Applications/Editors
@ -244,7 +269,9 @@ vim-common package.
%prep
%setup -q -b 1 -n %{vimdir}
cp -f %{SOURCE6} runtime/ftplugin/spec.vim
%{__tar} xzf %{SOURCE1}
%{__tar} xzf %{SOURCE2}
#cp -f %{SOURCE6} runtime/ftplugin/spec.vim
# fix rogue dependencies from sample code
chmod -x runtime/tools/mve.awk
%patch2002 -p1
@ -351,9 +378,27 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
%patch084 -p0
%patch085 -p0
%patch086 -p0
%patch087 -p0
%patch088 -p0
%patch089 -p0
%patch090 -p0
%patch091 -p0
%patch092 -p0
%patch093 -p0
%patch094 -p0
%patch095 -p0
%patch096 -p0
%patch097 -p0
%patch098 -p0
%patch099 -p0
# Update all runtime files
%{__tar} xjf %{SOURCE13}
# install spell files
%{__tar} xjf %{SOURCE14}
%patch3000 -p1
%patch3001 -p1
#patch3001 -p1
%patch3002 -p1
%patch3003 -p1
%patch3004 -p1
@ -596,7 +641,6 @@ rm -rf $RPM_BUILD_ROOT
/usr/share/vim/%{vimdir}/macros
/usr/share/vim/%{vimdir}/plugin
/usr/share/vim/%{vimdir}/print
/usr/share/vim/%{vimdir}/spell
/usr/share/vim/%{vimdir}/syntax
/usr/share/vim/%{vimdir}/tools
/usr/share/vim/%{vimdir}/tutor
@ -635,6 +679,60 @@ rm -rf $RPM_BUILD_ROOT
%lang(ru) %{_mandir}/ru*
%lang(pl) %{_mandir}/pl*
%files spell
%dir /usr/share/vim/%{vimdir}/spell
/usr/share/vim/vim70/spell/cleanadd.vim
%lang(af) /usr/share/vim/%{vimdir}/spell/af.*
%lang(am) /usr/share/vim/%{vimdir}/spell/am.*
%lang(bg) /usr/share/vim/%{vimdir}/spell/bg.*
%lang(ca) /usr/share/vim/%{vimdir}/spell/ca.*
%lang(cs) /usr/share/vim/%{vimdir}/spell/cs.*
%lang(cy) /usr/share/vim/%{vimdir}/spell/cy.*
%lang(da) /usr/share/vim/%{vimdir}/spell/da.*
%lang(de) /usr/share/vim/%{vimdir}/spell/de.*
%lang(el) /usr/share/vim/%{vimdir}/spell/el.*
%lang(en) /usr/share/vim/%{vimdir}/spell/en.*
%lang(eo) /usr/share/vim/%{vimdir}/spell/eo.*
%lang(es) /usr/share/vim/%{vimdir}/spell/es.*
%lang(fo) /usr/share/vim/%{vimdir}/spell/fo.*
%lang(fr) /usr/share/vim/%{vimdir}/spell/fr.*
%lang(ga) /usr/share/vim/%{vimdir}/spell/ga.*
%lang(gd) /usr/share/vim/%{vimdir}/spell/gd.*
%lang(gl) /usr/share/vim/%{vimdir}/spell/gl.*
%lang(he) /usr/share/vim/%{vimdir}/spell/he.*
%lang(hr) /usr/share/vim/%{vimdir}/spell/hr.*
%lang(hu) /usr/share/vim/%{vimdir}/spell/hu.*
%lang(id) /usr/share/vim/%{vimdir}/spell/id.*
%lang(it) /usr/share/vim/%{vimdir}/spell/it.*
%lang(ku) /usr/share/vim/%{vimdir}/spell/ku.*
%lang(la) /usr/share/vim/%{vimdir}/spell/la.*
%lang(lt) /usr/share/vim/%{vimdir}/spell/lt.*
%lang(lv) /usr/share/vim/%{vimdir}/spell/lv.*
%lang(mg) /usr/share/vim/%{vimdir}/spell/mg.*
%lang(mi) /usr/share/vim/%{vimdir}/spell/mi.*
%lang(ms) /usr/share/vim/%{vimdir}/spell/ms.*
%lang(nb) /usr/share/vim/%{vimdir}/spell/nb.*
%lang(nl) /usr/share/vim/%{vimdir}/spell/nl.*
%lang(nn) /usr/share/vim/%{vimdir}/spell/nn.*
%lang(ny) /usr/share/vim/%{vimdir}/spell/ny.*
%lang(pl) /usr/share/vim/%{vimdir}/spell/pl.*
%lang(pt) /usr/share/vim/%{vimdir}/spell/pt.*
%lang(ro) /usr/share/vim/%{vimdir}/spell/ro.*
%lang(ru) /usr/share/vim/%{vimdir}/spell/ru.*
%lang(rw) /usr/share/vim/%{vimdir}/spell/rw.*
%lang(sk) /usr/share/vim/%{vimdir}/spell/sk.*
%lang(sl) /usr/share/vim/%{vimdir}/spell/sl.*
%lang(sv) /usr/share/vim/%{vimdir}/spell/sv.*
%lang(sw) /usr/share/vim/%{vimdir}/spell/sw.*
%lang(tet) /usr/share/vim/%{vimdir}/spell/tet.*
%lang(th) /usr/share/vim/%{vimdir}/spell/th.*
%lang(tl) /usr/share/vim/%{vimdir}/spell/tl.*
%lang(tn) /usr/share/vim/%{vimdir}/spell/tn.*
%lang(uk) /usr/share/vim/%{vimdir}/spell/uk.*
%lang(yi) /usr/share/vim/%{vimdir}/spell/yi.*
%lang(yi-tr) /usr/share/vim/%{vimdir}/spell/yi-tr.*
%lang(zu) /usr/share/vim/%{vimdir}/spell/zu.*
%files minimal
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/virc
@ -675,6 +773,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/icons/hicolor/*/apps/*
%changelog
* Mon Sep 11 2006 Karsten Hopp <karsten@redhat.de> 7.0.099-1
- Patchlevel 99
* Mon Sep 05 2006 Karsten Hopp <karsten@redhat.de> 7.0.086-1
- Patchlevel 86