Remove downstream patch, it is included in the newest upstream release
See https://github.com/vim/vim/pull/7638
This commit is contained in:
parent
e99dfd6457
commit
c8a7b65903
@ -1,18 +0,0 @@
|
||||
diff --git a/src/if_ruby.c b/src/if_ruby.c
|
||||
index 9e5890214..a8c8379b6 100644
|
||||
--- a/src/if_ruby.c
|
||||
+++ b/src/if_ruby.c
|
||||
@@ -612,11 +612,13 @@ rb_check_type_stub(VALUE obj, int t)
|
||||
{
|
||||
dll_rb_check_type(obj, t);
|
||||
}
|
||||
+# if VIM_SIZEOF_INT < VIM_SIZEOF_LONG // 64 bits only
|
||||
unsigned long
|
||||
rb_num2uint_stub(VALUE x)
|
||||
{
|
||||
return dll_rb_num2uint(x);
|
||||
}
|
||||
+# endif
|
||||
void
|
||||
ruby_malloc_size_overflow_stub(size_t x, size_t y)
|
||||
{
|
2
vim.spec
2
vim.spec
@ -63,7 +63,6 @@ Patch3016: vim-8.0-copy-paste.patch
|
||||
Patch3017: vim-python3-tests.patch
|
||||
# fips warning
|
||||
Patch3018: vim-crypto-warning.patch
|
||||
Patch3019: vim-ruby30ftbfs.patch
|
||||
|
||||
# gcc is no longer in buildroot by default
|
||||
BuildRequires: gcc
|
||||
@ -271,7 +270,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch3016 -p1 -b .copypaste
|
||||
%patch3017 -p1 -b .python-tests
|
||||
%patch3018 -p1
|
||||
%patch3019 -p1 -b .ruby30
|
||||
|
||||
%build
|
||||
cd src
|
||||
|
Loading…
Reference in New Issue
Block a user