fix ssh syntax files
fix %%global in spec.vim (rhbz#1058041)
This commit is contained in:
parent
229ed05040
commit
be47cc26e8
12
vim-7.4-globalsyntax.patch
Normal file
12
vim-7.4-globalsyntax.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up vim74/runtime/syntax/spec.vim.orig vim74/runtime/syntax/spec.vim
|
||||
--- vim74/runtime/syntax/spec.vim.orig 2016-01-12 13:51:55.727569873 +0100
|
||||
+++ vim74/runtime/syntax/spec.vim 2016-01-12 13:53:08.124991178 +0100
|
||||
@@ -114,7 +114,7 @@ syn region specDescriptionArea matchgrou
|
||||
syn region specPackageArea matchgroup=specSection start='^%package' end='^%'me=e-1 contains=specPackageOpts,specPreAmble,specComment
|
||||
|
||||
"%% Scripts Section %%
|
||||
-syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|check\|clean\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
|
||||
+syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|check\|clean\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|global\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
|
||||
|
||||
"%% Changelog Section %%
|
||||
syn region specChangelogArea matchgroup=specSection start='^%changelog' end='^%'me=e-1 contains=specEmail,specURL,specWeekday,specMonth,specNumber,specComment,specLicense
|
@ -1,7 +1,7 @@
|
||||
diff -urN vim74/runtime/syntax/sshconfig.vim vim74_work/runtime/syntax/sshconfig.vim
|
||||
--- vim74/runtime/syntax/sshconfig.vim 2012-02-24 21:28:30.000000000 +0100
|
||||
+++ vim74_work/runtime/syntax/sshconfig.vim 2015-02-11 15:17:16.146626439 +0100
|
||||
@@ -68,8 +68,8 @@
|
||||
diff -up vim74/runtime/syntax/sshconfig.vim.kh vim74/runtime/syntax/sshconfig.vim
|
||||
--- vim74/runtime/syntax/sshconfig.vim.kh 2016-01-12 14:13:15.532558597 +0100
|
||||
+++ vim74/runtime/syntax/sshconfig.vim 2016-01-12 14:16:51.039800172 +0100
|
||||
@@ -69,8 +69,8 @@ syn keyword sshconfigSysLogFacility DAEM
|
||||
syn keyword sshconfigSysLogFacility LOCAL2 LOCAL3 LOCAL4 LOCAL5 LOCAL6 LOCAL7
|
||||
syn keyword sshconfigAddressFamily inet inet6
|
||||
|
||||
@ -12,12 +12,7 @@ diff -urN vim74/runtime/syntax/sshconfig.vim vim74_work/runtime/syntax/sshconfig
|
||||
syn match sshconfigIPQoS "af3[123]"
|
||||
syn match sshconfigIPQoS "af4[123]"
|
||||
syn match sshconfigIPQoS "cs[0-7]"
|
||||
@@ -99,10 +99,15 @@
|
||||
|
||||
" Keywords
|
||||
syn keyword sshconfigHostSect Host
|
||||
+syn keyword sshconfigMatchSect Match
|
||||
|
||||
@@ -106,6 +106,10 @@ syn keyword sshconfigMatch canonical exe
|
||||
syn keyword sshconfigKeyword AddressFamily
|
||||
syn keyword sshconfigKeyword BatchMode
|
||||
syn keyword sshconfigKeyword BindAddress
|
||||
@ -28,7 +23,7 @@ diff -urN vim74/runtime/syntax/sshconfig.vim vim74_work/runtime/syntax/sshconfig
|
||||
syn keyword sshconfigKeyword ChallengeResponseAuthentication
|
||||
syn keyword sshconfigKeyword CheckHostIP
|
||||
syn keyword sshconfigKeyword Cipher
|
||||
@@ -141,6 +146,8 @@
|
||||
@@ -145,6 +149,8 @@ syn keyword sshconfigKeyword HostbasedKe
|
||||
syn keyword sshconfigKeyword IPQoS
|
||||
syn keyword sshconfigKeyword IdentitiesOnly
|
||||
syn keyword sshconfigKeyword IdentityFile
|
||||
@ -37,26 +32,10 @@ diff -urN vim74/runtime/syntax/sshconfig.vim vim74_work/runtime/syntax/sshconfig
|
||||
syn keyword sshconfigKeyword KbdInteractiveAuthentication
|
||||
syn keyword sshconfigKeyword KbdInteractiveDevices
|
||||
syn keyword sshconfigKeyword KexAlgorithms
|
||||
@@ -157,6 +164,7 @@
|
||||
syn keyword sshconfigKeyword PreferredAuthentications
|
||||
syn keyword sshconfigKeyword Protocol
|
||||
syn keyword sshconfigKeyword ProxyCommand
|
||||
+syn keyword sshconfigKeyword ProxyUseFdpass
|
||||
syn keyword sshconfigKeyword PubkeyAuthentication
|
||||
syn keyword sshconfigKeyword RSAAuthentication
|
||||
syn keyword sshconfigKeyword RekeyLimit
|
||||
@@ -211,6 +219,7 @@
|
||||
HiLink sshconfigSpecial Special
|
||||
HiLink sshconfigKeyword Keyword
|
||||
HiLink sshconfigHostSect Type
|
||||
+ HiLink sshconfigMatchSect Type
|
||||
delcommand HiLink
|
||||
endif
|
||||
|
||||
diff -urN vim74/runtime/syntax/sshdconfig.vim vim74_work/runtime/syntax/sshdconfig.vim
|
||||
--- vim74/runtime/syntax/sshdconfig.vim 2011-11-30 12:14:42.000000000 +0100
|
||||
+++ vim74_work/runtime/syntax/sshdconfig.vim 2015-02-11 15:40:38.082148329 +0100
|
||||
@@ -58,8 +58,8 @@
|
||||
diff -up vim74/runtime/syntax/sshdconfig.vim.kh vim74/runtime/syntax/sshdconfig.vim
|
||||
--- vim74/runtime/syntax/sshdconfig.vim.kh 2016-01-12 14:17:06.278889344 +0100
|
||||
+++ vim74/runtime/syntax/sshdconfig.vim 2016-01-12 14:20:12.737980416 +0100
|
||||
@@ -65,8 +65,8 @@ syn keyword sshdconfigSysLogFacility LOC
|
||||
|
||||
syn keyword sshdconfigCompression delayed
|
||||
|
||||
@ -67,17 +46,15 @@ diff -urN vim74/runtime/syntax/sshdconfig.vim vim74_work/runtime/syntax/sshdconf
|
||||
syn match sshdconfigIPQoS "af3[123]"
|
||||
syn match sshdconfigIPQoS "af4[123]"
|
||||
syn match sshdconfigIPQoS "cs[0-7]"
|
||||
@@ -101,6 +101,9 @@
|
||||
syn keyword sshdconfigKeyword AllowGroups
|
||||
@@ -109,6 +109,7 @@ syn keyword sshdconfigKeyword AllowGroup
|
||||
syn keyword sshdconfigKeyword AllowStreamLocalForwarding
|
||||
syn keyword sshdconfigKeyword AllowTcpForwarding
|
||||
syn keyword sshdconfigKeyword AllowUsers
|
||||
+syn keyword sshdconfigKeyword AuthenticationMethods
|
||||
+syn keyword sshdconfigKeyword AuthorizedKeysCommand
|
||||
+syn keyword sshdconfigKeyword AuthorizedKeysCommandUser
|
||||
syn keyword sshdconfigKeyword AuthorizedKeysFile
|
||||
syn keyword sshdconfigKeyword AuthorizedPrincipalsFile
|
||||
syn keyword sshdconfigKeyword Banner
|
||||
@@ -116,12 +119,14 @@
|
||||
syn keyword sshdconfigKeyword AuthorizedKeysCommand
|
||||
syn keyword sshdconfigKeyword AuthorizedKeysCommandUser
|
||||
@@ -126,12 +127,14 @@ syn keyword sshdconfigKeyword DenyUsers
|
||||
syn keyword sshdconfigKeyword ForceCommand
|
||||
syn keyword sshdconfigKeyword GSSAPIAuthentication
|
||||
syn keyword sshdconfigKeyword GSSAPICleanupCredentials
|
||||
@ -89,10 +66,10 @@ diff -urN vim74/runtime/syntax/sshdconfig.vim vim74_work/runtime/syntax/sshdconf
|
||||
syn keyword sshdconfigKeyword HostCertificate
|
||||
syn keyword sshdconfigKeyword HostKey
|
||||
+syn keyword sshdconfigKeyword HostKeyAgent
|
||||
syn keyword sshdconfigKeyword HostKeyAlgorithms
|
||||
syn keyword sshdconfigKeyword HostbasedAcceptedKeyTypes
|
||||
syn keyword sshdconfigKeyword HostbasedAuthentication
|
||||
syn keyword sshdconfigKeyword HostbasedUsesNameFromPacketOnly
|
||||
syn keyword sshdconfigKeyword IPQoS
|
||||
@@ -132,6 +137,7 @@
|
||||
@@ -144,6 +147,7 @@ syn keyword sshdconfigKeyword KerberosAu
|
||||
syn keyword sshdconfigKeyword KerberosGetAFSToken
|
||||
syn keyword sshdconfigKeyword KerberosOrLocalPasswd
|
||||
syn keyword sshdconfigKeyword KerberosTicketCleanup
|
||||
@ -100,27 +77,3 @@ diff -urN vim74/runtime/syntax/sshdconfig.vim vim74_work/runtime/syntax/sshdconf
|
||||
syn keyword sshdconfigKeyword KexAlgorithms
|
||||
syn keyword sshdconfigKeyword KeyRegenerationInterval
|
||||
syn keyword sshdconfigKeyword ListenAddress
|
||||
@@ -148,6 +154,7 @@
|
||||
syn keyword sshdconfigKeyword PermitOpen
|
||||
syn keyword sshdconfigKeyword PermitRootLogin
|
||||
syn keyword sshdconfigKeyword PermitTunnel
|
||||
+syn keyword sshdconfigKeyword PermitTTY
|
||||
syn keyword sshdconfigKeyword PermitUserEnvironment
|
||||
syn keyword sshdconfigKeyword PidFile
|
||||
syn keyword sshdconfigKeyword Port
|
||||
@@ -156,6 +163,7 @@
|
||||
syn keyword sshdconfigKeyword Protocol
|
||||
syn keyword sshdconfigKeyword PubkeyAuthentication
|
||||
syn keyword sshdconfigKeyword RSAAuthentication
|
||||
+syn keyword sshdconfigKeyword RekeyLimit
|
||||
syn keyword sshdconfigKeyword RevokedKeys
|
||||
syn keyword sshdconfigKeyword RhostsRSAAuthentication
|
||||
syn keyword sshdconfigKeyword ServerKeyBits
|
||||
@@ -169,6 +177,7 @@
|
||||
syn keyword sshdconfigKeyword UseLogin
|
||||
syn keyword sshdconfigKeyword UsePAM
|
||||
syn keyword sshdconfigKeyword UsePrivilegeSeparation
|
||||
+syn keyword sshdconfigKeyword VersionAddendum
|
||||
syn keyword sshdconfigKeyword X11DisplayOffset
|
||||
syn keyword sshdconfigKeyword X11Forwarding
|
||||
syn keyword sshdconfigKeyword X11UseLocalhost
|
||||
|
8
vim.spec
8
vim.spec
@ -21,7 +21,7 @@ Summary: The VIM editor
|
||||
URL: http://www.vim.org/
|
||||
Name: vim
|
||||
Version: %{baseversion}.%{patchlevel}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: Vim
|
||||
Group: Applications/Editors
|
||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
||||
@ -60,6 +60,7 @@ Patch3012: vim-7.3-manpage-typo-668894-675480.patch
|
||||
Patch3013: vim-manpagefixes-948566.patch
|
||||
Patch3014: vim-7.4-licensemacro-1151450.patch
|
||||
Patch3015: vim-7.4-ssh-keywords.patch
|
||||
Patch3016: vim-7.4-globalsyntax.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
||||
@ -213,6 +214,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
|
||||
%patch3013 -p1
|
||||
%patch3015 -p1
|
||||
%patch3016 -p1
|
||||
|
||||
%build
|
||||
cp -f %{SOURCE5} .
|
||||
@ -756,6 +758,10 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Di Jan 12 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1087-2
|
||||
- fix ssh syntax files
|
||||
- fix %%global in spec.vim (rhbz#1058041)
|
||||
|
||||
* Mon Jan 11 2016 Karsten Hopp <karsten@redhat.com> 7.4.1087-1
|
||||
- patchlevel 1087
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user