Merge branch 'f26' into f27
This commit is contained in:
commit
bb0fe2c545
1
.gitignore
vendored
1
.gitignore
vendored
@ -138,3 +138,4 @@
|
||||
/vim-8.0-1272.tar.bz2
|
||||
/vim-8.0-1274.tar.bz2
|
||||
/vim-8.0-1283.tar.bz2
|
||||
/vim-8.0-1322.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (vim-8.0-1283.tar.bz2) = 9faf99c020d14b577dcc8eeaea5cd4657805e18885ad47839e2253f95c9da70f8e68288ca7cf1acfc499dafdc262f71abda20b372f8e03a078b4134b16975778
|
||||
SHA512 (vim-8.0-1322.tar.bz2) = 6d4d37c9d503cf9637a1969f33d05dc652a44ccbe848ea5da947f80d52db5bdcb53185c8d72fdd92f29d22c974c13da084a9312adc5d08369f471502a61a4fa8
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- vim74/runtime/syntax/fstab.vim.orig 2013-05-21 16:07:26.000000000 +0200
|
||||
+++ vim74/runtime/syntax/fstab.vim 2013-08-12 15:05:43.682707639 +0200
|
||||
@@ -53,7 +53,7 @@
|
||||
diff -up vim80/runtime/syntax/fstab.vim.fstabsyntax vim80/runtime/syntax/fstab.vim
|
||||
--- vim80/runtime/syntax/fstab.vim.fstabsyntax 2017-11-19 20:32:49.000000000 +0100
|
||||
+++ vim80/runtime/syntax/fstab.vim 2017-11-20 16:01:31.494316342 +0100
|
||||
@@ -56,7 +56,7 @@ syn keyword fsMountPointKeyword containe
|
||||
" Type
|
||||
syn cluster fsTypeCluster contains=fsTypeKeyword,fsTypeUnknown
|
||||
syn match fsTypeUnknown /\s\+\zs\w\+/ contained
|
||||
@ -9,12 +10,12 @@
|
||||
|
||||
" Options
|
||||
" -------
|
||||
@@ -65,7 +65,7 @@
|
||||
@@ -68,7 +68,7 @@ syn match fsOptionsString /[a-zA-Z0-9_-]
|
||||
syn keyword fsOptionsYesNo yes no
|
||||
syn cluster fsOptionsCheckCluster contains=fsOptionsExt2Check,fsOptionsFatCheck
|
||||
syn keyword fsOptionsSize 512 1024 2048
|
||||
-syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand nosuid nosymfollow nouser owner rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user users xx
|
||||
+syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop managed mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand nosuid nosymfollow nouser owner pamconsole rbind rdonly remount ro rq rw suid suiddir supermount sw sync union update user[s] xx
|
||||
-syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand norelatime nosuid nosymfollow nouser owner rbind rdonly relatime remount ro rq rw suid suiddir supermount sw sync union update user users wxallowed xx
|
||||
+syn keyword fsOptionsGeneral async atime auto bind current defaults dev devgid devmode devmtime devuid dirsync exec force fstab kudzu loop managed mand move noatime noauto noclusterr noclusterw nodev nodevmtime nodiratime noexec nomand norelatime nosuid nosymfollow nouser owner pamconsole rbind rdonly relatime remount ro rq rw suid suiddir supermount sw sync union update user users wxallowed xx
|
||||
syn match fsOptionsGeneral /_netdev/
|
||||
|
||||
" Options: adfs
|
||||
|
10
vim-8.0-beval-pro.patch
Normal file
10
vim-8.0-beval-pro.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff -up vim80/src/proto/beval.pro.beval-pro vim80/src/proto/beval.pro
|
||||
--- vim80/src/proto/beval.pro.beval-pro 2017-11-20 18:59:12.364156610 +0100
|
||||
+++ vim80/src/proto/beval.pro 2017-11-20 18:59:50.926848275 +0100
|
||||
@@ -0,0 +1,6 @@
|
||||
+/* beval.c */
|
||||
+int get_beval_info(BalloonEval *beval, int getword, win_T **winp, linenr_T *lnump, char_u **textp, int *colp);
|
||||
+void post_balloon(BalloonEval *beval, char_u *mesg, list_T *list);
|
||||
+int can_use_beval(void);
|
||||
+void general_beval_cb(BalloonEval *beval, int state);
|
||||
+/* vim: set ft=c : */
|
9
vim.spec
9
vim.spec
@ -1,4 +1,4 @@
|
||||
%define patchlevel 1283
|
||||
%define patchlevel 1322
|
||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||
%define WITH_SELINUX 1
|
||||
%endif
|
||||
@ -65,8 +65,8 @@ Patch3011: vim-manpagefixes-948566.patch
|
||||
Patch3012: vim-7.4-licensemacro-1151450.patch
|
||||
Patch3013: vim-7.4-globalsyntax.patch
|
||||
Patch3014: vim-7.4-releasestring-1318991.patch
|
||||
Patch3015: vim-8.0-rhbz1365258.patch
|
||||
Patch3016: vim-8.0-copy-paste.patch
|
||||
Patch3017: vim-8.0-beval-pro.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: python2-devel python3-devel ncurses-devel gettext perl-devel
|
||||
@ -224,8 +224,8 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch3012 -p1
|
||||
%patch3013 -p1
|
||||
%patch3014 -p1
|
||||
%patch3015 -p1
|
||||
%patch3016 -p1
|
||||
%patch3017 -p1 -b .beval-pro
|
||||
|
||||
%build
|
||||
cd src
|
||||
@ -771,6 +771,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/icons/locolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 20 2017 Karsten Hopp <karsten@redhat.com> 8.0.1322-1
|
||||
- patchlevel 1322
|
||||
|
||||
* Fri Nov 10 2017 Karsten Hopp <karsten@redhat.com> 8.0.1283-1
|
||||
- patchlevel 1283
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user