fix the upstream testsuite failure due downstream patch
This commit is contained in:
parent
07acd750fa
commit
b3e48604dd
@ -1,7 +1,8 @@
|
||||
diff -up vim82/runtime/defaults.vim.copypaste vim82/runtime/defaults.vim
|
||||
--- vim82/runtime/defaults.vim.copypaste 2022-01-24 12:13:43.000000000 +0100
|
||||
+++ vim82/runtime/defaults.vim 2022-01-24 12:15:41.050120573 +0100
|
||||
@@ -73,18 +73,6 @@ map Q gq
|
||||
diff --git a/runtime/defaults.vim b/runtime/defaults.vim
|
||||
index f1d5cd1..b08de8e 100644
|
||||
--- a/runtime/defaults.vim
|
||||
+++ b/runtime/defaults.vim
|
||||
@@ -74,18 +74,6 @@ sunmap Q
|
||||
" Revert with ":iunmap <C-U>".
|
||||
inoremap <C-U> <C-G>u<C-U>
|
||||
|
||||
@ -20,9 +21,10 @@ diff -up vim82/runtime/defaults.vim.copypaste vim82/runtime/defaults.vim
|
||||
" Only do this part when Vim was compiled with the +eval feature.
|
||||
if 1
|
||||
|
||||
diff -up vim82/src/testdir/test_balloon.vim.copypaste vim82/src/testdir/test_balloon.vim
|
||||
--- vim82/src/testdir/test_balloon.vim.copypaste 2022-01-24 12:15:41.051120576 +0100
|
||||
+++ vim82/src/testdir/test_balloon.vim 2022-01-24 12:17:02.604372440 +0100
|
||||
diff --git a/src/testdir/test_balloon.vim b/src/testdir/test_balloon.vim
|
||||
index ed0c6c1..90c8c40 100644
|
||||
--- a/src/testdir/test_balloon.vim
|
||||
+++ b/src/testdir/test_balloon.vim
|
||||
@@ -9,6 +9,7 @@ source screendump.vim
|
||||
CheckScreendump
|
||||
|
||||
@ -31,9 +33,10 @@ diff -up vim82/src/testdir/test_balloon.vim.copypaste vim82/src/testdir/test_bal
|
||||
call setline(1, ["one one one", "two tXo two", "three three three"])
|
||||
set balloonevalterm balloonexpr=MyBalloonExpr()..s:trailing balloondelay=100
|
||||
let s:trailing = '<' " check that script context is set
|
||||
diff -up vim82/src/testdir/test_popupwin.vim.copypaste vim82/src/testdir/test_popupwin.vim
|
||||
--- vim82/src/testdir/test_popupwin.vim.copypaste 2022-01-24 12:13:44.000000000 +0100
|
||||
+++ vim82/src/testdir/test_popupwin.vim 2022-01-24 12:18:24.382624989 +0100
|
||||
diff --git a/src/testdir/test_popupwin.vim b/src/testdir/test_popupwin.vim
|
||||
index b91689e..c6b70d1 100644
|
||||
--- a/src/testdir/test_popupwin.vim
|
||||
+++ b/src/testdir/test_popupwin.vim
|
||||
@@ -553,6 +553,7 @@ func Test_popup_drag()
|
||||
" create a popup that covers the command line
|
||||
let lines =<< trim END
|
||||
@ -42,7 +45,15 @@ diff -up vim82/src/testdir/test_popupwin.vim.copypaste vim82/src/testdir/test_po
|
||||
split
|
||||
vsplit
|
||||
$wincmd w
|
||||
@@ -625,6 +626,7 @@ func Test_popup_drag_termwin()
|
||||
@@ -621,6 +622,7 @@ func Test_popup_drag_minwidth()
|
||||
|
||||
" create a popup that does not fit
|
||||
let lines =<< trim END
|
||||
+ set mouse=a
|
||||
call range(40)
|
||||
\ ->map({_,i -> string(i)})
|
||||
\ ->popup_create({
|
||||
@@ -669,6 +671,7 @@ func Test_popup_drag_termwin()
|
||||
let lines =<< trim END
|
||||
set foldmethod=marker
|
||||
call setline(1, range(100))
|
||||
@ -50,7 +61,7 @@ diff -up vim82/src/testdir/test_popupwin.vim.copypaste vim82/src/testdir/test_po
|
||||
for nr in range(7)
|
||||
call setline(nr * 12 + 1, "fold {{{")
|
||||
call setline(nr * 12 + 11, "end }}}")
|
||||
@@ -678,6 +680,7 @@ func Test_popup_close_with_mouse()
|
||||
@@ -722,6 +725,7 @@ func Test_popup_close_with_mouse()
|
||||
|
||||
let lines =<< trim END
|
||||
call setline(1, range(1, 20))
|
||||
@ -58,7 +69,7 @@ diff -up vim82/src/testdir/test_popupwin.vim.copypaste vim82/src/testdir/test_po
|
||||
" With border, can click on X
|
||||
let winid = popup_create('foobar', #{
|
||||
\ close: 'button',
|
||||
@@ -1513,6 +1516,7 @@ func Test_popup_beval()
|
||||
@@ -1557,6 +1561,7 @@ func Test_popup_beval()
|
||||
let lines =<< trim END
|
||||
call setline(1, range(1, 20))
|
||||
call setline(5, 'here is some text to hover over')
|
||||
@ -66,7 +77,7 @@ diff -up vim82/src/testdir/test_popupwin.vim.copypaste vim82/src/testdir/test_po
|
||||
set balloonevalterm
|
||||
set balloonexpr=BalloonExpr()
|
||||
set balloondelay=100
|
||||
@@ -2218,6 +2222,7 @@ func Test_popup_scrollbar()
|
||||
@@ -2262,6 +2267,7 @@ func Test_popup_scrollbar()
|
||||
|
||||
let lines =<< trim END
|
||||
call setline(1, range(1, 20))
|
||||
|
5
vim.spec
5
vim.spec
@ -38,7 +38,7 @@ Summary: The VIM editor
|
||||
URL: http://www.vim.org/
|
||||
Name: vim
|
||||
Version: %{baseversion}.%{patchlevel}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Epoch: 2
|
||||
License: Vim and MIT
|
||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
||||
@ -969,6 +969,9 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Apr 08 2022 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.4701-2
|
||||
- fix the upstream testsuite failure due downstream patch
|
||||
|
||||
* Thu Apr 07 2022 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.4701-1
|
||||
- patchlevel 4701
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user