fix merge conflicts

This commit is contained in:
Karsten Hopp 2016-04-29 12:24:27 +02:00
commit a1a4daa18b
16 changed files with 4145 additions and 270 deletions

44
.gitignore vendored
View File

@ -1,44 +1,2 @@
vim-7.2-extra.tar.gz
vim-7.2-lang.tar.gz
vim-7.2.tar.bz2
/vim-7.3.tar.bz2
/vim-7.4.tar.bz2 /vim-7.4.tar.bz2
/vim-7.4-909.tar.bz2 /vim-7.4-1786.tar.bz2
/vim-7.4-917.tar.bz2
/vim-7.4-922.tar.bz2
/vim-7.4-930.tar.bz2
/vim-7.4-941.tar.bz2
/vim-7.4-942.tar.bz2
/vim-7.4-944.tar.bz2
/vim-7.4-945.tar.bz2
/vim-7.4-947.tar.bz2
/vim-7.4-960.tar.bz2
/vim-7.4-969.tar.bz2
/vim-7.4-970.tar.bz2
/vim-7.4-972.tar.bz2
/vim-7.4-977.tar.bz2
/vim-7.4-979.tar.bz2
/vim-7.4-1087.tar.bz2
/vim-7.4-1089.tar.bz2
/vim-7.4-1090.tar.bz2
/vim-7.4-1101.tar.bz2
/vim-7.4-1112.tar.bz2
/vim-7.4-1129.tar.bz2
/vim-7.4-1131.tar.bz2
/vim-7.4-1143.tar.bz2
/vim-7.4-1147.tar.bz2
/vim-7.4-1152.tar.bz2
/vim-7.4-1153.tar.bz2
/vim-7.4-1246.tar.bz2
/vim-7.4-1257.tar.bz2
/vim-7.4-1261.tar.bz2
/vim-7.4-1265.tar.bz2
/vim-7.4-1273.tar.bz2
/vim-7.4-1290.tar.bz2
/vim-7.4-1293.tar.bz2
/vim-7.4-1297.tar.bz2
/vim-7.4-1301.tar.bz2
/vim-7.4-1304.tar.bz2
/vim-7.4-1308.tar.bz2
/vim-7.4-1317.tar.bz2
/vim-7.4-1320.tar.bz2

File diff suppressed because it is too large Load Diff

1
macros.vim Normal file
View File

@ -0,0 +1 @@
%vimfiles_root %{_datadir}/vim/vimfiles

View File

@ -1 +1 @@
e8ec132f7d0cb1fb5d7d7218b5e1b3be vim-7.4-1320.tar.bz2 164f655af75349e551e06f7db16ec89d vim-7.4-1786.tar.bz2

View File

@ -1,11 +0,0 @@
--- vim64/runtime/syntax/spec.vim.check 2005-10-25 13:18:57.000000000 +0200
+++ vim64/runtime/syntax/spec.vim 2005-10-25 13:20:06.000000000 +0200
@@ -114,7 +114,7 @@
syn region specPackageArea matchgroup=specSection start='^%package' end='^%'me=e-1 contains=specPackageOpts,specPreAmble,specComment
"%% Scripts Section %%
-syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|clean\|pre\|postun\|preun\|post\)\>' skip='^%{\|^%\(define\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
+syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|check\|clean\|pre\|postun\|preun\|post\)\>' skip='^%{\|^%\(define\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
"%% Changelog Section %%
syn region specChangelogArea matchgroup=specSection start='^%changelog' end='^%'me=e-1 contains=specEmail,specURL,specWeekday,specMonth,specNumber,specComment,specLicense

View File

@ -1,11 +0,0 @@
--- vim70c/src/structs.h.warning1 2006-04-04 15:58:16.000000000 +0200
+++ vim70c/src/structs.h 2006-04-04 15:58:20.000000000 +0200
@@ -1082,7 +1082,7 @@
{
typval_T di_tv; /* type and value of the variable */
char_u di_flags; /* flags (only used for variable) */
- char_u di_key[1]; /* key (actually longer!) */
+ char_u di_key[10]; /* key (actually longer!) */
};
typedef struct dictitem_S dictitem_T;

View File

@ -1,10 +0,0 @@
--- vim71/src/ex_docmd.c.nowarnings 2007-06-04 14:43:26.000000000 +0200
+++ vim71/src/ex_docmd.c 2007-06-04 14:43:43.000000000 +0200
@@ -3993,6 +3993,7 @@ get_flags(eap)
ex_ni(eap)
exarg_T *eap;
{
+ return;
if (!eap->skip)
eap->errmsg = (char_u *)N_("E319: Sorry, the command is not available in this version");
}

View File

@ -10,12 +10,3 @@ diff -up vim73/runtime/doc/vim.1.668894 vim73/runtime/doc/vim.1
.TP .TP
\-t {tag} \-t {tag}
The file to edit and the initial cursor position depends on a "tag", a sort The file to edit and the initial cursor position depends on a "tag", a sort
@@ -321,7 +321,7 @@ When N is omitted, open one tab page for
\-R
Read-only mode.
The 'readonly' option will be set.
-You can still edit the buffer, but will be prevented from accidently
+You can still edit the buffer, but will be prevented from accidentally
overwriting a file.
If you do want to overwrite a file, add an exclamation mark to the Ex command,
as in ":w!".

View File

@ -0,0 +1,12 @@
diff -up vim74/runtime/syntax/spec.vim.orig vim74/runtime/syntax/spec.vim
--- vim74/runtime/syntax/spec.vim.orig 2016-01-12 13:51:55.727569873 +0100
+++ vim74/runtime/syntax/spec.vim 2016-01-12 13:53:08.124991178 +0100
@@ -114,7 +114,7 @@ syn region specDescriptionArea matchgrou
syn region specPackageArea matchgroup=specSection start='^%package' end='^%'me=e-1 contains=specPackageOpts,specPreAmble,specComment
"%% Scripts Section %%
-syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|check\|clean\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
+syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|check\|clean\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|global\|patch\d*\|configure\|GNUconfigure\|setup\|find_lang\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
"%% Changelog Section %%
syn region specChangelogArea matchgroup=specSection start='^%changelog' end='^%'me=e-1 contains=specEmail,specURL,specWeekday,specMonth,specNumber,specComment,specLicense

11
vim-7.4-nowarnings.patch Normal file
View File

@ -0,0 +1,11 @@
diff -up vim74/src/ex_docmd.c.e319 vim74/src/ex_docmd.c
--- vim74/src/ex_docmd.c.e319 2016-02-17 14:48:23.033995923 +0100
+++ vim74/src/ex_docmd.c 2016-02-17 14:48:03.712890575 +0100
@@ -4630,6 +4630,7 @@ get_flags(exarg_T *eap)
void
ex_ni(exarg_T *eap)
{
+ return;
if (!eap->skip)
eap->errmsg = (char_u *)N_("E319: Sorry, the command is not available in this version");
}

View File

@ -0,0 +1,14 @@
diff -up vim74/runtime/ftplugin/spec.vim.1318991 vim74/runtime/ftplugin/spec.vim
--- vim74/runtime/ftplugin/spec.vim.1318991 2016-04-26 13:01:33.781838194 +0200
+++ vim74/runtime/ftplugin/spec.vim 2016-04-26 13:02:41.958130012 +0200
@@ -40,8 +40,8 @@ else:
headers = spec.packages[0].header
version = headers['Version']
release = ".".join(headers['Release'].split(".")[:-1])
- vim.command("let ver = " + version)
- vim.command("let rel = " + release)
+ vim.command("let ver = '" + version + "'")
+ vim.command("let rel = '" + release + "'")
PYEND
endif
endfunction

14
vim-7.4-spec_rfc822.patch Normal file
View File

@ -0,0 +1,14 @@
diff -up vim74/runtime/ftplugin/spec.vim.rfc822 vim74/runtime/ftplugin/spec.vim
--- vim74/runtime/ftplugin/spec.vim.rfc822 2016-04-13 12:31:09.856418963 +0200
+++ vim74/runtime/ftplugin/spec.vim 2016-04-13 12:32:22.091802791 +0200
@@ -113,7 +113,10 @@ if !exists("*s:SpecChangelog")
endif
endif
if (chgline != -1)
+ let tmptime = v:lc_time
+ language time C
let parsed_format = "* ".strftime(format)." - ".ver."-".rel
+ execute "language time" tmptime
let release_info = "+ ".name."-".ver."-".rel
let wrong_format = 0
let wrong_release = 0

View File

@ -1,126 +0,0 @@
diff -urN vim74/runtime/syntax/sshconfig.vim vim74_work/runtime/syntax/sshconfig.vim
--- vim74/runtime/syntax/sshconfig.vim 2012-02-24 21:28:30.000000000 +0100
+++ vim74_work/runtime/syntax/sshconfig.vim 2015-02-11 15:17:16.146626439 +0100
@@ -68,8 +68,8 @@
syn keyword sshconfigSysLogFacility LOCAL2 LOCAL3 LOCAL4 LOCAL5 LOCAL6 LOCAL7
syn keyword sshconfigAddressFamily inet inet6
-syn match sshconfigIPQoS "af1[1234]"
-syn match sshconfigIPQoS "af2[23]"
+syn match sshconfigIPQoS "af1[123]"
+syn match sshconfigIPQoS "af2[123]"
syn match sshconfigIPQoS "af3[123]"
syn match sshconfigIPQoS "af4[123]"
syn match sshconfigIPQoS "cs[0-7]"
@@ -99,10 +99,15 @@
" Keywords
syn keyword sshconfigHostSect Host
+syn keyword sshconfigMatchSect Match
syn keyword sshconfigKeyword AddressFamily
syn keyword sshconfigKeyword BatchMode
syn keyword sshconfigKeyword BindAddress
+syn keyword sshconfigKeyword CanonicalDomains
+syn keyword sshconfigKeyword CanonicalizeFallbackLocal
+syn keyword sshconfigKeyword CanonicalizeHostname
+syn keyword sshconfigKeyword CanonicalizeMaxDots
syn keyword sshconfigKeyword ChallengeResponseAuthentication
syn keyword sshconfigKeyword CheckHostIP
syn keyword sshconfigKeyword Cipher
@@ -141,6 +146,8 @@
syn keyword sshconfigKeyword IPQoS
syn keyword sshconfigKeyword IdentitiesOnly
syn keyword sshconfigKeyword IdentityFile
+syn keyword sshconfigKeyword IgnoreUnknown
+syn keyword sshconfigKeyword IPQoS
syn keyword sshconfigKeyword KbdInteractiveAuthentication
syn keyword sshconfigKeyword KbdInteractiveDevices
syn keyword sshconfigKeyword KexAlgorithms
@@ -157,6 +164,7 @@
syn keyword sshconfigKeyword PreferredAuthentications
syn keyword sshconfigKeyword Protocol
syn keyword sshconfigKeyword ProxyCommand
+syn keyword sshconfigKeyword ProxyUseFdpass
syn keyword sshconfigKeyword PubkeyAuthentication
syn keyword sshconfigKeyword RSAAuthentication
syn keyword sshconfigKeyword RekeyLimit
@@ -211,6 +219,7 @@
HiLink sshconfigSpecial Special
HiLink sshconfigKeyword Keyword
HiLink sshconfigHostSect Type
+ HiLink sshconfigMatchSect Type
delcommand HiLink
endif
diff -urN vim74/runtime/syntax/sshdconfig.vim vim74_work/runtime/syntax/sshdconfig.vim
--- vim74/runtime/syntax/sshdconfig.vim 2011-11-30 12:14:42.000000000 +0100
+++ vim74_work/runtime/syntax/sshdconfig.vim 2015-02-11 15:40:38.082148329 +0100
@@ -58,8 +58,8 @@
syn keyword sshdconfigCompression delayed
-syn match sshdconfigIPQoS "af1[1234]"
-syn match sshdconfigIPQoS "af2[23]"
+syn match sshdconfigIPQoS "af1[123]"
+syn match sshdconfigIPQoS "af2[123]"
syn match sshdconfigIPQoS "af3[123]"
syn match sshdconfigIPQoS "af4[123]"
syn match sshdconfigIPQoS "cs[0-7]"
@@ -101,6 +101,9 @@
syn keyword sshdconfigKeyword AllowGroups
syn keyword sshdconfigKeyword AllowTcpForwarding
syn keyword sshdconfigKeyword AllowUsers
+syn keyword sshdconfigKeyword AuthenticationMethods
+syn keyword sshdconfigKeyword AuthorizedKeysCommand
+syn keyword sshdconfigKeyword AuthorizedKeysCommandUser
syn keyword sshdconfigKeyword AuthorizedKeysFile
syn keyword sshdconfigKeyword AuthorizedPrincipalsFile
syn keyword sshdconfigKeyword Banner
@@ -116,12 +119,14 @@
syn keyword sshdconfigKeyword ForceCommand
syn keyword sshdconfigKeyword GSSAPIAuthentication
syn keyword sshdconfigKeyword GSSAPICleanupCredentials
+syn keyword sshdconfigKeyword GSSAPIEnablek5users
syn keyword sshdconfigKeyword GSSAPIKeyExchange
syn keyword sshdconfigKeyword GSSAPIStoreCredentialsOnRekey
syn keyword sshdconfigKeyword GSSAPIStrictAcceptorCheck
syn keyword sshdconfigKeyword GatewayPorts
syn keyword sshdconfigKeyword HostCertificate
syn keyword sshdconfigKeyword HostKey
+syn keyword sshdconfigKeyword HostKeyAgent
syn keyword sshdconfigKeyword HostbasedAuthentication
syn keyword sshdconfigKeyword HostbasedUsesNameFromPacketOnly
syn keyword sshdconfigKeyword IPQoS
@@ -132,6 +137,7 @@
syn keyword sshdconfigKeyword KerberosGetAFSToken
syn keyword sshdconfigKeyword KerberosOrLocalPasswd
syn keyword sshdconfigKeyword KerberosTicketCleanup
+syn keyword sshdconfigKeyword KerberosUseKuserok
syn keyword sshdconfigKeyword KexAlgorithms
syn keyword sshdconfigKeyword KeyRegenerationInterval
syn keyword sshdconfigKeyword ListenAddress
@@ -148,6 +154,7 @@
syn keyword sshdconfigKeyword PermitOpen
syn keyword sshdconfigKeyword PermitRootLogin
syn keyword sshdconfigKeyword PermitTunnel
+syn keyword sshdconfigKeyword PermitTTY
syn keyword sshdconfigKeyword PermitUserEnvironment
syn keyword sshdconfigKeyword PidFile
syn keyword sshdconfigKeyword Port
@@ -156,6 +163,7 @@
syn keyword sshdconfigKeyword Protocol
syn keyword sshdconfigKeyword PubkeyAuthentication
syn keyword sshdconfigKeyword RSAAuthentication
+syn keyword sshdconfigKeyword RekeyLimit
syn keyword sshdconfigKeyword RevokedKeys
syn keyword sshdconfigKeyword RhostsRSAAuthentication
syn keyword sshdconfigKeyword ServerKeyBits
@@ -169,6 +177,7 @@
syn keyword sshdconfigKeyword UseLogin
syn keyword sshdconfigKeyword UsePAM
syn keyword sshdconfigKeyword UsePrivilegeSeparation
+syn keyword sshdconfigKeyword VersionAddendum
syn keyword sshdconfigKeyword X11DisplayOffset
syn keyword sshdconfigKeyword X11Forwarding
syn keyword sshdconfigKeyword X11UseLocalhost

100
vim.spec
View File

@ -1,4 +1,4 @@
%define patchlevel 1320 %define patchlevel 1786
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1} %if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
%define WITH_SELINUX 1 %define WITH_SELINUX 1
%endif %endif
@ -25,7 +25,8 @@ Release: 2%{?dist}
License: Vim License: Vim
Group: Applications/Editors Group: Applications/Editors
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2 Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
Source3: gvim.desktop Source2: gvim.desktop
Source3: vimrc
Source4: vimrc Source4: vimrc
Source5: ftp://ftp.vim.org/pub/vim/patches/README.patches Source5: ftp://ftp.vim.org/pub/vim/patches/README.patches
Source7: gvim16.png Source7: gvim16.png
@ -39,8 +40,9 @@ Source13: vim-spell-files.tar.bz2
%endif %endif
Source14: spec-template Source14: spec-template
Source15: spec-template.new Source15: spec-template.new
Source16: ftplugin-spec.vim Source16: macros.vim
Source17: syntax-spec.vim Source17: ftplugin-spec.vim
Source18: syntax-spec.vim
Patch2002: vim-7.0-fixkeys.patch Patch2002: vim-7.0-fixkeys.patch
Patch2003: vim-6.2-specsyntax.patch Patch2003: vim-6.2-specsyntax.patch
@ -50,18 +52,18 @@ BuildRequires: hunspell-devel
%endif %endif
Patch3000: vim-7.4-syntax.patch Patch3000: vim-7.4-syntax.patch
Patch3002: vim-7.1-nowarnings.patch Patch3002: vim-7.4-nowarnings.patch
Patch3004: vim-7.0-rclocation.patch Patch3004: vim-7.0-rclocation.patch
Patch3006: vim-7.4-checkhl.patch Patch3006: vim-7.4-checkhl.patch
Patch3007: vim-7.4-fstabsyntax.patch Patch3007: vim-7.4-fstabsyntax.patch
Patch3008: vim-7.0-warning.patch Patch3008: vim-7.4-syncolor.patch
Patch3009: vim-7.4-syncolor.patch Patch3009: vim-7.0-specedit.patch
Patch3010: vim-7.0-specedit.patch Patch3010: vim-7.3-manpage-typo-668894-675480.patch
Patch3011: vim72-rh514717.patch Patch3011: vim-manpagefixes-948566.patch
Patch3012: vim-7.3-manpage-typo-668894-675480.patch Patch3012: vim-7.4-licensemacro-1151450.patch
Patch3013: vim-manpagefixes-948566.patch Patch3013: vim-7.4-globalsyntax.patch
Patch3014: vim-7.4-licensemacro-1151450.patch Patch3014: vim-7.4-spec_rfc822.patch
Patch3015: vim-7.4-ssh-keywords.patch Patch3015: vim-7.4-releasestring-1318991.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
@ -208,12 +210,12 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
%patch3006 -p1 %patch3006 -p1
%patch3007 -p1 %patch3007 -p1
%patch3008 -p1 %patch3008 -p1
%patch3009 -p1 #patch3009 -p1
#patch3010 -p1 %patch3010 -p1
%patch3011 -p1 %patch3011 -p1
%patch3012 -p1 %patch3012 -p1
%patch3013 -p1 %patch3013 -p1
%patch3014 -p1
%patch3015 -p1 %patch3015 -p1
%build %build
@ -231,7 +233,7 @@ cp -f os_unix.h os_unix.h.save
cp -f ex_cmds.c ex_cmds.c.save cp -f ex_cmds.c ex_cmds.c.save
perl -pi -e "s/help.txt/vi_help.txt/" os_unix.h ex_cmds.c perl -pi -e "s/help.txt/vi_help.txt/" os_unix.h ex_cmds.c
perl -pi -e "s/\/etc\/vimrc/\/etc\/virc/" os_unix.h perl -pi -e "s/vimrc/virc/" os_unix.h
%configure --prefix=%{_prefix} --with-features=small --with-x=no \ %configure --prefix=%{_prefix} --with-features=small --with-x=no \
--enable-multibyte \ --enable-multibyte \
--disable-netbeans \ --disable-netbeans \
@ -282,6 +284,7 @@ mv -f ex_cmds.c.save ex_cmds.c
%else %else
--disable-luainterp \ --disable-luainterp \
%endif %endif
--enable-termtruecolor
make VIMRCLOC=/etc VIMRUNTIMEDIR=/usr/share/vim/%{vimdir} %{?_smp_mflags} make VIMRCLOC=/etc VIMRUNTIMEDIR=/usr/share/vim/%{vimdir} %{?_smp_mflags}
cp vim gvim cp vim gvim
@ -317,6 +320,7 @@ make clean
%else %else
--disable-luainterp \ --disable-luainterp \
%endif %endif
--enable-termtruecolor
make VIMRCLOC=/etc VIMRUNTIMEDIR=/usr/share/vim/%{vimdir} %{?_smp_mflags} make VIMRCLOC=/etc VIMRUNTIMEDIR=/usr/share/vim/%{vimdir} %{?_smp_mflags}
cp vim enhanced-vim cp vim enhanced-vim
@ -332,8 +336,8 @@ cp -f %{SOURCE15} %{buildroot}/%{_datadir}/%{name}/vimfiles/template.spec
%else %else
cp -f %{SOURCE14} %{buildroot}/%{_datadir}/%{name}/vimfiles/template.spec cp -f %{SOURCE14} %{buildroot}/%{_datadir}/%{name}/vimfiles/template.spec
%endif %endif
cp -f %{SOURCE16} %{buildroot}/%{_datadir}/%{name}/%{vimdir}/ftplugin/spec.vim cp -f %{SOURCE17} %{buildroot}/%{_datadir}/%{name}/%{vimdir}/ftplugin/spec.vim
cp -f %{SOURCE17} %{buildroot}/%{_datadir}/%{name}/%{vimdir}/syntax/spec.vim cp -f %{SOURCE18} %{buildroot}/%{_datadir}/%{name}/%{vimdir}/syntax/spec.vim
cp runtime/doc/uganda.txt LICENSE cp runtime/doc/uganda.txt LICENSE
# Those aren't Linux info files but some binary files for Amiga: # Those aren't Linux info files but some binary files for Amiga:
rm -f README*.info rm -f README*.info
@ -417,11 +421,11 @@ EOF
--vendor fedora \ --vendor fedora \
%endif %endif
--dir %{buildroot}/%{_datadir}/applications \ --dir %{buildroot}/%{_datadir}/applications \
%{SOURCE3} %{SOURCE2}
# --add-category "Development;TextEditor;X-Red-Hat-Base" D\ # --add-category "Development;TextEditor;X-Red-Hat-Base" D\
%else %else
mkdir -p ./%{_sysconfdir}/X11/applnk/Applications mkdir -p ./%{_sysconfdir}/X11/applnk/Applications
cp %{SOURCE3} ./%{_sysconfdir}/X11/applnk/Applications/gvim.desktop cp %{SOURCE2} ./%{_sysconfdir}/X11/applnk/Applications/gvim.desktop
%endif %endif
# ja_JP.ujis is obsolete, ja_JP.eucJP is recommended. # ja_JP.ujis is obsolete, ja_JP.eucJP is recommended.
( cd ./%{_datadir}/%{name}/%{vimdir}/lang; \ ( cd ./%{_datadir}/%{name}/%{vimdir}/lang; \
@ -476,8 +480,13 @@ if ( -x /usr/bin/id ) then
endif endif
EOF EOF
chmod 0644 %{buildroot}/%{_sysconfdir}/profile.d/* chmod 0644 %{buildroot}/%{_sysconfdir}/profile.d/*
install -p -m644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/virc
install -p -m644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/vimrc install -p -m644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/vimrc
install -p -m644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/virc
mkdir -p %{buildroot}%{_libdir}/%{name}
mkdir -p %{buildroot}%{_rpmconfigdir}/macros.d/
install -p -m644 %{SOURCE16} %{buildroot}%{_rpmconfigdir}/macros.d/
(cd %{buildroot}/%{_datadir}/%{name}/%{vimdir}/doc; (cd %{buildroot}/%{_datadir}/%{name}/%{vimdir}/doc;
gzip -9 *.txt gzip -9 *.txt
gzip -d help.txt.gz version7.txt.gz sponsor.txt.gz gzip -d help.txt.gz version7.txt.gz sponsor.txt.gz
@ -560,9 +569,11 @@ rm -rf %{buildroot}
%dir %{_datadir}/%{name} %dir %{_datadir}/%{name}
%{_datadir}/%{name}/vimfiles/template.spec %{_datadir}/%{name}/vimfiles/template.spec
%dir %{_datadir}/%{name}/%{vimdir} %dir %{_datadir}/%{name}/%{vimdir}
%{_datadir}/%{name}/%{vimdir}/rgb.txt
%{_datadir}/%{name}/%{vimdir}/autoload %{_datadir}/%{name}/%{vimdir}/autoload
%{_datadir}/%{name}/%{vimdir}/colors %{_datadir}/%{name}/%{vimdir}/colors
%{_datadir}/%{name}/%{vimdir}/compiler %{_datadir}/%{name}/%{vimdir}/compiler
%{_datadir}/%{name}/%{vimdir}/pack
%{_datadir}/%{name}/%{vimdir}/doc %{_datadir}/%{name}/%{vimdir}/doc
%{_datadir}/%{name}/%{vimdir}/*.vim %{_datadir}/%{name}/%{vimdir}/*.vim
%{_datadir}/%{name}/%{vimdir}/ftplugin %{_datadir}/%{name}/%{vimdir}/ftplugin
@ -721,6 +732,8 @@ rm -rf %{buildroot}
%files filesystem %files filesystem
%defattr(-,root,root) %defattr(-,root,root)
%{_rpmconfigdir}/macros.d/macros.vim
%dir %{_libdir}/%{name}
%dir %{_datadir}/%{name}/vimfiles %dir %{_datadir}/%{name}/vimfiles
%dir %{_datadir}/%{name}/vimfiles/after %dir %{_datadir}/%{name}/vimfiles/after
%dir %{_datadir}/%{name}/vimfiles/after/* %dir %{_datadir}/%{name}/vimfiles/after/*
@ -760,9 +773,34 @@ rm -rf %{buildroot}
%{_datadir}/icons/hicolor/*/apps/* %{_datadir}/icons/hicolor/*/apps/*
%changelog %changelog
* Tue Apr 26 2016 Karsten Hopp <karsten@redhat.com> 7.4.1786-1
- patchlevel 1786
* Tue Apr 26 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1775-2
- fix error in spec.vim (rhbz#1318991)
* Mon Apr 25 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1320-2 * Mon Apr 25 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1320-2
- update ftplugin/spec.vim, syntax/spec.vim (rhbz#1297746) - update ftplugin/spec.vim, syntax/spec.vim (rhbz#1297746)
* Fri Apr 22 2016 Karsten Hopp <karsten@redhat.com> 7.4.1775-1
- patchlevel 1775
* Tue Apr 12 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1718-2
- add vimfiles_root macro (rhbz#844975)
- add %%_libdir/vim directory for plugins (rhbz#1193230)
- vi, rvi, rview, ex, view don't read vimrc anymore. They use virc instead
(rhbz#1045815)
- fix dates in changelogs when spec.vim is used and locale != 'C'
* Fri Apr 08 2016 Karsten Hopp <karsten@redhat.com> 7.4.1718-1
- patchlevel 1718
* Tue Mar 15 2016 Karsten Hopp <karsten@redhat.com> 7.4.1570-1
- patchlevel 1570
* Wed Feb 17 2016 Karsten Hopp <karsten@redhat.com> 7.4.1344-1
- patchlevel 1344
* Mon Feb 15 2016 Karsten Hopp <karsten@redhat.com> 7.4.1320-1 * Mon Feb 15 2016 Karsten Hopp <karsten@redhat.com> 7.4.1320-1
- patchlevel 1320 - patchlevel 1320
@ -793,14 +831,11 @@ rm -rf %{buildroot}
* Sat Feb 06 2016 Karsten Hopp <karsten@redhat.com> 7.4.1265-1 * Sat Feb 06 2016 Karsten Hopp <karsten@redhat.com> 7.4.1265-1
- patchlevel 1265 - patchlevel 1265
* Fri Feb 05 2016 Karsten Hopp <karsten@redhat.com> 7.4.1261-1 * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2:7.4.1229-2
- patchlevel 1261 - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Feb 04 2016 Karsten Hopp <karsten@redhat.com> 7.4.1257-1 * Mon Feb 01 2016 Karsten Hopp <karsten@redhat.com> 7.4.1229-1
- patchlevel 1257 - patchlevel 1229
* Wed Feb 03 2016 Karsten Hopp <karsten@redhat.com> 7.4.1246-1
- patchlevel 1246
* Sat Jan 23 2016 Karsten Hopp <karsten@redhat.com> 7.4.1153-1 * Sat Jan 23 2016 Karsten Hopp <karsten@redhat.com> 7.4.1153-1
- patchlevel 1153 - patchlevel 1153
@ -814,6 +849,9 @@ rm -rf %{buildroot}
* Wed Jan 20 2016 Karsten Hopp <karsten@redhat.com> 7.4.1143-1 * Wed Jan 20 2016 Karsten Hopp <karsten@redhat.com> 7.4.1143-1
- patchlevel 1143 - patchlevel 1143
* Tue Jan 19 2016 Karsten Hopp <karsten@redhat.com> 7.4.1142-1
- patchlevel 1142
* Tue Jan 19 2016 Karsten Hopp <karsten@redhat.com> 7.4.1131-1 * Tue Jan 19 2016 Karsten Hopp <karsten@redhat.com> 7.4.1131-1
- patchlevel 1131 - patchlevel 1131
@ -832,6 +870,10 @@ rm -rf %{buildroot}
* Wed Jan 13 2016 Karsten Hopp <karsten@redhat.com> 7.4.1089-1 * Wed Jan 13 2016 Karsten Hopp <karsten@redhat.com> 7.4.1089-1
- patchlevel 1089 - patchlevel 1089
* Tue Jan 12 2016 Karsten Hopp <karsten@redhat.com> - 7.4.1087-2
- fix ssh syntax files
- fix %%global in spec.vim (rhbz#1058041)
* Mon Jan 11 2016 Karsten Hopp <karsten@redhat.com> 7.4.1087-1 * Mon Jan 11 2016 Karsten Hopp <karsten@redhat.com> 7.4.1087-1
- patchlevel 1087 - patchlevel 1087

View File

@ -1,30 +0,0 @@
diff -up vim72/src/eval.c.rh514717 vim72/src/eval.c
--- vim72/src/eval.c.rh514717 2009-08-03 16:15:42.882375154 +0200
+++ vim72/src/eval.c 2009-08-03 16:34:14.863381780 +0200
@@ -286,13 +286,12 @@ typedef struct
#define VV_RO 2 /* read-only */
#define VV_RO_SBX 4 /* read-only in the sandbox */
-#define VV_NAME(s, t) s, {{t, 0, {0}}, 0, {0}}, {0}
+#define VV_NAME(s, t) s, {{t, 0, {0}}, 0, {0}}
static struct vimvar
{
char *vv_name; /* name of variable, without v: */
dictitem_T vv_di; /* value and name for key */
- char vv_filler[16]; /* space for LONGEST name below!!! */
char vv_flags; /* VV_COMPAT, VV_RO, VV_RO_SBX */
} vimvars[VV_LEN] =
{
diff -up vim72/src/structs.h.rh514717 vim72/src/structs.h
--- vim72/src/structs.h.rh514717 2009-08-03 16:33:35.274870950 +0200
+++ vim72/src/structs.h 2009-08-03 16:33:48.607436706 +0200
@@ -1095,7 +1095,7 @@ struct dictitem_S
{
typval_T di_tv; /* type and value of the variable */
char_u di_flags; /* flags (only used for variable) */
- char_u di_key[10]; /* key (actually longer!) */
+ char_u di_key[18]; /* key */
};
typedef struct dictitem_S dictitem_T;

37
virc Normal file
View File

@ -0,0 +1,37 @@
if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
set fileencodings=ucs-bom,utf-8,latin1
endif
set nocompatible " Use Vim defaults (much better!)
set bs=indent,eol,start " allow backspacing over everything in insert mode
"set ai " always set autoindenting on
"set backup " keep a backup file
set history=50 " keep 50 lines of command line history
set ruler " show the cursor position all the time
" Only do this part when compiled with support for autocommands
if has("autocmd")
augroup fedora
autocmd!
" In text files, always limit the width of text to 78 characters
" autocmd BufRead *.txt set tw=78
" When editing a file, always jump to the last cursor position
autocmd BufReadPost *
\ if line("'\"") > 0 && line ("'\"") <= line("$") |
\ exe "normal! g'\"" |
\ endif
" don't write swapfile on most commonly used directories for NFS mounts or USB sticks
autocmd BufNewFile,BufReadPre /media/*,/run/media/*,/mnt/* set directory=~/tmp,/var/tmp,/tmp
" start with spec file template
autocmd BufNewFile *.spec 0r /usr/share/vim/vimfiles/template.spec
augroup END
endif
filetype plugin on
if &term=="xterm"
set t_Co=8
set t_Sb=[4%dm
set t_Sf=[3%dm
endif