- patchlevel 342
This commit is contained in:
parent
e8763de40a
commit
9faa965280
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
|||||||
/vim-8.0-318.tar.bz2
|
/vim-8.0-318.tar.bz2
|
||||||
/vim-8.0-324.tar.bz2
|
/vim-8.0-324.tar.bz2
|
||||||
/vim-8.0-329.tar.bz2
|
/vim-8.0-329.tar.bz2
|
||||||
|
/vim-8.0-342.tar.bz2
|
||||||
|
129
README.patches
129
README.patches
@ -1,3 +1,132 @@
|
|||||||
|
commit 673911457d6745b6b779eb769c2f41965592d12c
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sun Feb 19 21:07:04 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0342: double free with EXITFREE and setting 'ttytype'
|
||||||
|
|
||||||
|
Problem: Double free when compiled with EXITFREE and setting 'ttytype'.
|
||||||
|
Solution: Avoid setting P_ALLOCED on 'ttytype'. (Dominique Pelle,
|
||||||
|
closes #1461)
|
||||||
|
|
||||||
|
commit d56a79d3396cf70861b7f739a3c400db91ce7b70
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sun Feb 19 15:26:18 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0341: undo does not work properly when using completion
|
||||||
|
|
||||||
|
Problem: When using complete() and typing a character undo is saved after
|
||||||
|
the character was inserted. (Shougo)
|
||||||
|
Solution: Save for undo before inserting the character.
|
||||||
|
|
||||||
|
commit 5acff71d3bd7796ee0a112ceb891af630b59304e
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sun Feb 19 13:55:02 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0340: not checking return valud of dict_add()
|
||||||
|
|
||||||
|
Problem: Not checking return valud of dict_add(). (Coverity)
|
||||||
|
Solution: Handle a failure.
|
||||||
|
|
||||||
|
commit 46522af72424c7fadfa7a4cbba3dd21b82d19131
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sat Feb 18 23:12:01 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0339: illegal memory access with vi'
|
||||||
|
|
||||||
|
Problem: Illegal memory access with vi'
|
||||||
|
Solution: For quoted text objects bail out if the Visual area spans more
|
||||||
|
than one line.
|
||||||
|
|
||||||
|
commit 803452046ba6cda7a2896626572eb78b2358c965
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sat Feb 18 22:43:19 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0338: :recover test fails on MS-Windows
|
||||||
|
|
||||||
|
Problem: :recover test fails on MS-Windows.
|
||||||
|
Solution: Use non-existing directory on MS-Windows.
|
||||||
|
|
||||||
|
commit c525e3a1c20f6b5d9809c8b84f80090a8e416c92
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Sat Feb 18 16:59:02 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0337: invalid memory access in :recover command
|
||||||
|
|
||||||
|
Problem: Invalid memory access in :recover command.
|
||||||
|
Solution: Avoid access before directory name. (Dominique Pelle,
|
||||||
|
closes #1488)
|
||||||
|
|
||||||
|
commit 3df0173fa6d0418e89ef4e9c1d04a97c92eec27c
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 22:47:16 2017 +0100
|
||||||
|
|
||||||
|
Updated runtime files.
|
||||||
|
|
||||||
|
commit 8c50d50b6e19b755d7bad7b2724d14ead29364a7
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 18:28:24 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0336: flags of :substitute not sufficiently tested
|
||||||
|
|
||||||
|
Problem: Flags of :substitute not sufficiently tested.
|
||||||
|
Solution: Test up to two letter flag combinations. (James McCoy, closes
|
||||||
|
#1479)
|
||||||
|
|
||||||
|
commit 507647da3151f7ffccac1b217936240daa79849c
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 16:43:49 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0335: functions test fails
|
||||||
|
|
||||||
|
Problem: Functions test fails.
|
||||||
|
Solution: Use the right buffer number.
|
||||||
|
|
||||||
|
commit 79518e2ace5fce7b9c49060e462a6e935dba0a84
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 16:31:35 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0334: can't access b:changedtick from a dict reference
|
||||||
|
|
||||||
|
Problem: Can't access b:changedtick from a dict reference.
|
||||||
|
Solution: Make changedtick a member of the b: dict. (inspired by neovim
|
||||||
|
#6112)
|
||||||
|
|
||||||
|
commit 226c53429109f24e31c17016aedfd7fbf7a9aa50
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 14:53:15 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0333: illegal memory access when 'complete' ends in a backslash
|
||||||
|
|
||||||
|
Problem: Illegal memory access when 'complete' ends in a backslash.
|
||||||
|
Solution: Check for trailing backslash. (Dominique Pelle, closes #1478)
|
||||||
|
|
||||||
|
commit 4e9dbc74df24dc22d0eeda3741c3fb0e0e7373bf
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 13:44:48 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0332: GUI test fails on some systems
|
||||||
|
|
||||||
|
Problem: GUI test fails on some systems.
|
||||||
|
Solution: Try different language settings. (Kazunobu Kuriyama)
|
||||||
|
|
||||||
|
commit 343b8c042967da82f2f022afa31f2c97a264c1c8
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 12:04:56 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0331: restoring help snapshot accesses freed memory
|
||||||
|
|
||||||
|
Problem: Restoring help snapshot accesses freed memory. (Dominique Pelle)
|
||||||
|
Solution: Don't restore a snapshot when the window closes.
|
||||||
|
|
||||||
|
commit 84b2a381451e9068b09ef6d85f5e8cf1598e7355
|
||||||
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
|
Date: Fri Feb 17 11:40:00 2017 +0100
|
||||||
|
|
||||||
|
patch 8.0.0330: illegal memory access after "vapo"
|
||||||
|
|
||||||
|
Problem: Illegal memory access after "vapo". (Dominique Pelle)
|
||||||
|
Solution: Fix the cursor column.
|
||||||
|
|
||||||
commit 10434674821939222bf552d15d93e0132d13badc
|
commit 10434674821939222bf552d15d93e0132d13badc
|
||||||
Author: Bram Moolenaar <Bram@vim.org>
|
Author: Bram Moolenaar <Bram@vim.org>
|
||||||
Date: Sun Feb 12 19:59:08 2017 +0100
|
Date: Sun Feb 12 19:59:08 2017 +0100
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (vim-8.0-329.tar.bz2) = 3c8ac3459b47da126b3b22d319e004f732729ed6009d90e05437a6b6069882f82f08d7173913f1e6c47ec23ef1027eb723eb9704aadf9536fc511da14d9cc3a2
|
SHA512 (vim-8.0-342.tar.bz2) = 3f8807c7a53d93dc52cb4042a5ed94df78a96421ec5f7345f11274ab2a11f01a31c04cd4a788af3807ea20edfaf11932cefc83ada7d080f07bedf9915876001b
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up vim80/runtime/syntax/tex.vim.missing-bracket vim80/runtime/syntax/tex.vim
|
|
||||||
--- vim80/runtime/syntax/tex.vim.missing-bracket 2017-02-16 13:30:17.881056557 +0100
|
|
||||||
+++ vim80/runtime/syntax/tex.vim 2017-02-16 13:31:20.901494027 +0100
|
|
||||||
@@ -511,7 +511,7 @@ if !exists("g:tex_no_math")
|
|
||||||
if &ambw == "double" || exists("g:tex_usedblwidth")
|
|
||||||
let s:texMathDelimList= s:texMathDelimList + [
|
|
||||||
\ ['\\langle' , '〈'] ,
|
|
||||||
- \ ['\\rangle' , '〉'] ,
|
|
||||||
+ \ ['\\rangle' , '〉']]
|
|
||||||
else
|
|
||||||
let s:texMathDelimList= s:texMathDelimList + [
|
|
||||||
\ ['\\langle' , '<'] ,
|
|
7
vim.spec
7
vim.spec
@ -1,4 +1,4 @@
|
|||||||
%define patchlevel 329
|
%define patchlevel 342
|
||||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||||
%define WITH_SELINUX 1
|
%define WITH_SELINUX 1
|
||||||
%endif
|
%endif
|
||||||
@ -64,7 +64,6 @@ Patch3012: vim-7.4-licensemacro-1151450.patch
|
|||||||
Patch3013: vim-7.4-globalsyntax.patch
|
Patch3013: vim-7.4-globalsyntax.patch
|
||||||
Patch3014: vim-7.4-releasestring-1318991.patch
|
Patch3014: vim-7.4-releasestring-1318991.patch
|
||||||
Patch3015: vim-8.0-copy-paste.patch
|
Patch3015: vim-8.0-copy-paste.patch
|
||||||
Patch3016: vim-8.0-missing-bracket.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
||||||
@ -219,7 +218,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3013 -p1
|
%patch3013 -p1
|
||||||
%patch3014 -p1
|
%patch3014 -p1
|
||||||
%patch3015 -p1
|
%patch3015 -p1
|
||||||
%patch3016 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cp -f %{SOURCE6} .
|
cp -f %{SOURCE6} .
|
||||||
@ -765,6 +763,9 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/icons/locolor/*/apps/*
|
%{_datadir}/icons/locolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 20 2017 Karsten Hopp <karsten@redhat.com> 8.0.342-1
|
||||||
|
- patchlevel 342
|
||||||
|
|
||||||
* Thu Feb 16 2017 Zdenek Dohnal <zdohnal@redhat.com> 8.0.329-1
|
* Thu Feb 16 2017 Zdenek Dohnal <zdohnal@redhat.com> 8.0.329-1
|
||||||
- 1422833 - Syntax error in tex.vim: missing bracket
|
- 1422833 - Syntax error in tex.vim: missing bracket
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user