Desktop file is now shipped in correct /usr/share/applications
This commit is contained in:
parent
19be79e8b4
commit
88614577e6
1
.gitignore
vendored
1
.gitignore
vendored
@ -254,3 +254,4 @@
|
|||||||
/vim-8.1-1137.tar.bz2
|
/vim-8.1-1137.tar.bz2
|
||||||
/vim-8.1-1359.tar.bz2
|
/vim-8.1-1359.tar.bz2
|
||||||
/vim-8.1-1413.tar.bz2
|
/vim-8.1-1413.tar.bz2
|
||||||
|
/vim-8.1-1471.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (vim-8.1-1413.tar.bz2) = 91368a854d0ad310dabd67879561a6c90b00e54d342d44bf841891382e5bb2786ed646f499368f9953a099f32fe7ce4fd3001bd463eb18d482815b5d841e28b6
|
SHA512 (vim-8.1-1471.tar.bz2) = aa2bf83dce8124d4e7970f076b9c9a4baa68124369fe1234f21f2c1626b47ddc190265360dc6200c117f858575c48df2b3bf6009e199d054242e38e0bb414291
|
||||||
|
20
vim-desktop-duplicate-entries.patch
Normal file
20
vim-desktop-duplicate-entries.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff --git a/src/po/gvim.desktop.in b/src/po/gvim.desktop.in
|
||||||
|
index 7d5234851..b547598e8 100644
|
||||||
|
--- a/src/po/gvim.desktop.in
|
||||||
|
+++ b/src/po/gvim.desktop.in
|
||||||
|
@@ -10,7 +10,6 @@ Comment=Edit text files
|
||||||
|
# The translations should come from the po file. Leave them here for now, they will
|
||||||
|
# be overwritten by the po file when generating the desktop.file!
|
||||||
|
GenericName[da]=Teksteditor
|
||||||
|
-GenericName[eo]=Tekstoredaktilo
|
||||||
|
GenericName[fr]=Éditeur de texte
|
||||||
|
GenericName[pl]=Edytor tekstu
|
||||||
|
GenericName[is]=Ritvinnsluforrit
|
||||||
|
@@ -29,7 +28,6 @@ Comment[da]=Rediger tekstfiler
|
||||||
|
Comment[el]=Επεξεργασία αρχείων κειμένου
|
||||||
|
Comment[en_CA]=Edit text files
|
||||||
|
Comment[en_GB]=Edit text files
|
||||||
|
-Comment[eo]=Redakti tekstajn dosierojn
|
||||||
|
Comment[es]=Edita archivos de texto
|
||||||
|
Comment[et]=Redigeeri tekstifaile
|
||||||
|
Comment[eu]=Editatu testu-fitxategiak
|
16
vim.spec
16
vim.spec
@ -1,4 +1,4 @@
|
|||||||
%define patchlevel 1413
|
%define patchlevel 1471
|
||||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||||
%define WITH_SELINUX 1
|
%define WITH_SELINUX 1
|
||||||
%endif
|
%endif
|
||||||
@ -61,6 +61,8 @@ Patch3014: vim-7.4-releasestring-1318991.patch
|
|||||||
Patch3016: vim-8.0-copy-paste.patch
|
Patch3016: vim-8.0-copy-paste.patch
|
||||||
# migrate shebangs in script to /usr/bin/python3 and use python2 when necessary
|
# migrate shebangs in script to /usr/bin/python3 and use python2 when necessary
|
||||||
Patch3017: vim-python3-tests.patch
|
Patch3017: vim-python3-tests.patch
|
||||||
|
# duplicate desktop entries
|
||||||
|
Patch3018: vim-desktop-duplicate-entries.patch
|
||||||
|
|
||||||
# gcc is no longer in buildroot by default
|
# gcc is no longer in buildroot by default
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -253,6 +255,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3014 -p1
|
%patch3014 -p1
|
||||||
%patch3016 -p1
|
%patch3016 -p1
|
||||||
%patch3017 -p1
|
%patch3017 -p1
|
||||||
|
%patch3018 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?rhel} > 7
|
%if 0%{?rhel} > 7
|
||||||
@ -473,17 +476,13 @@ EOF
|
|||||||
ln -sf gvim ./%{_bindir}/gvimdiff
|
ln -sf gvim ./%{_bindir}/gvimdiff
|
||||||
ln -sf gvim ./%{_bindir}/vimx
|
ln -sf gvim ./%{_bindir}/vimx
|
||||||
%if "%{desktop_file}" == "1"
|
%if "%{desktop_file}" == "1"
|
||||||
mkdir -p %{buildroot}/%{_datadir}/applications
|
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
%if 0%{?fedora} && 0%{?fedora} < 19
|
|
||||||
--vendor fedora \
|
|
||||||
%endif
|
|
||||||
--dir %{buildroot}/%{_datadir}/applications \
|
--dir %{buildroot}/%{_datadir}/applications \
|
||||||
%{_builddir}/%{vimdir}/runtime/gvim.desktop
|
%{buildroot}/%{_datadir}/applications/gvim.desktop
|
||||||
# --add-category "Development;TextEditor;X-Red-Hat-Base" D\
|
# --add-category "Development;TextEditor;X-Red-Hat-Base" D\
|
||||||
%else
|
%else
|
||||||
mkdir -p ./%{_sysconfdir}/X11/applnk/Applications
|
mkdir -p ./%{_sysconfdir}/X11/applnk/Applications
|
||||||
cp %{_builddir}/%{vimdir}/runtime/gvim.desktop ./%{_sysconfdir}/X11/applnk/Applications/gvim.desktop
|
cp %{buildroot}/%{_datadir}/applications/gvim.desktop ./%{_sysconfdir}/X11/applnk/Applications/gvim.desktop
|
||||||
%endif
|
%endif
|
||||||
# ja_JP.ujis is obsolete, ja_JP.eucJP is recommended.
|
# ja_JP.ujis is obsolete, ja_JP.eucJP is recommended.
|
||||||
( cd ./%{_datadir}/%{name}/%{vimdir}/lang; \
|
( cd ./%{_datadir}/%{name}/%{vimdir}/lang; \
|
||||||
@ -794,6 +793,9 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
|||||||
%{_datadir}/icons/locolor/*/apps/*
|
%{_datadir}/icons/locolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 06 2019 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.1471-1
|
||||||
|
- patchlevel 1471
|
||||||
|
|
||||||
* Tue May 28 2019 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.1413-1
|
* Tue May 28 2019 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.1.1413-1
|
||||||
- patchlevel 1413
|
- patchlevel 1413
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user