- Rawhide prerelease build as vim, opposed to vim7 prerelease which could

coexist with vim-6
- conflict with older man-pages-{it,fr} packages
- cleanup lang stuff
This commit is contained in:
Karsten Hopp 2006-03-23 13:07:01 +00:00
parent 773765264d
commit 6cabe3c636
8 changed files with 157 additions and 55 deletions

View File

@ -1,4 +1,4 @@
vim-7.0aa-extra.tar.gz
vim-7.0aa-lang.tar.gz
vim-7.0aa.tar.bz2
cvim.zip
vim-6.4-extra.tar.gz
vim-6.4-lang.tar.gz
vim-6.4.tar.bz2

View File

@ -1,4 +1,4 @@
67ac6821f0f61e8dc8384a2c4eaae5d2 vim-7.0aa-extra.tar.gz
1e59128c0c39e2d48c90bb0f7bd76e00 vim-7.0aa-lang.tar.gz
e3466da8a1025093cb93735486d66f8b vim-7.0aa.tar.bz2
1f17af2008ae94359a48be7e865b084f cvim.zip
5f4489776cafcb3588223f79eb26e287 vim-6.4-extra.tar.gz
3cca6128fe5439e89d3828b5e708bddb vim-6.4-lang.tar.gz
774c14d93ce58674b3b2c880edd12d77 vim-6.4.tar.bz2

10
vim-7.0-crv.patch Normal file
View File

@ -0,0 +1,10 @@
--- vim70aa/src/term.c.orig 2006-03-14 15:40:15.000000000 +0100
+++ vim70aa/src/term.c 2006-03-14 15:43:54.000000000 +0100
@@ -1284,7 +1284,6 @@
{(int)KS_CWS, "[%dCWS%d]"},
{(int)KS_CWP, "[%dCWP%d]"},
# endif
- {(int)KS_CRV, "[CRV]"},
{K_UP, "[KU]"},
{K_DOWN, "[KD]"},
{K_LEFT, "[KL]"},

25
vim-7.0-fixkeys.patch Normal file
View File

@ -0,0 +1,25 @@
--- vim70aa/src/term.c.orig 2006-03-01 23:07:55.000000000 +0100
+++ vim70aa/src/term.c 2006-03-14 15:39:12.000000000 +0100
@@ -1008,14 +1008,14 @@
{K_XRIGHT, IF_EB("\033[1;*C", ESC_STR "[1;*C")},
{K_XLEFT, IF_EB("\033[1;*D", ESC_STR "[1;*D")},
/* An extra set of function keys for vt100 mode */
- {K_XF1, IF_EB("\033O*P", ESC_STR "O*P")},
- {K_XF2, IF_EB("\033O*Q", ESC_STR "O*Q")},
- {K_XF3, IF_EB("\033O*R", ESC_STR "O*R")},
- {K_XF4, IF_EB("\033O*S", ESC_STR "O*S")},
- {K_F1, IF_EB("\033[11;*~", ESC_STR "[11;*~")},
- {K_F2, IF_EB("\033[12;*~", ESC_STR "[12;*~")},
- {K_F3, IF_EB("\033[13;*~", ESC_STR "[13;*~")},
- {K_F4, IF_EB("\033[14;*~", ESC_STR "[14;*~")},
+ {K_XF1, IF_EB("\033[11~", ESC_STR "[11~")},
+ {K_XF2, IF_EB("\033[12~", ESC_STR "[12~")},
+ {K_XF3, IF_EB("\033[13~", ESC_STR "[13~")},
+ {K_XF4, IF_EB("\033[14~", ESC_STR "[14~")},
+ {K_F1, IF_EB("\033OP", ESC_STR "OP")},
+ {K_F2, IF_EB("\033OQ", ESC_STR "OQ")},
+ {K_F3, IF_EB("\033OR", ESC_STR "OR")},
+ {K_F4, IF_EB("\033OS", ESC_STR "OS")},
{K_F5, IF_EB("\033[15;*~", ESC_STR "[15;*~")},
{K_F6, IF_EB("\033[17;*~", ESC_STR "[17;*~")},
{K_F7, IF_EB("\033[18;*~", ESC_STR "[18;*~")},

20
vim-7.0-fstabsyntax.patch Normal file
View File

@ -0,0 +1,20 @@
--- vim70aa/runtime/syntax/fstab.vim.orig 2006-03-14 15:57:25.000000000 +0100
+++ vim70aa/runtime/syntax/fstab.vim 2006-03-14 16:01:05.000000000 +0100
@@ -32,7 +32,7 @@
" Type
syn cluster fsTypeCluster contains=fsTypeKeyword,fsTypeError
syn match fsTypeError /\s\+\zs\w\+/ contained
-syn keyword fsTypeKeyword contained adfs affs auto autofs cd9660 coda cramfs devfs devpts efs ext2 ext3 fdesc hfs hpfs iso9660 kernfs linprocfs mfs minix msdos ncpfs nfs ntfs nwfs null portal proc procfs qnx4 reiserfs romfs smbfs std sysv swap tmpfs udf ufs umap umsdos union usbfs vfat xfs
+syn keyword fsTypeKeyword contained adfs affs auto autofs cd9660 coda cramfs devfs devpts efs ext2 ext3 fdesc hfs hpfs iso9660 kernfs linprocfs mfs minix msdos ncpfs nfs ntfs nwfs null portal proc procfs qnx4 reiserfs romfs smbfs std sysfs sysv swap tmpfs udf ufs umap umsdos union usbfs vfat xfs
" Options
" -------
@@ -44,7 +44,7 @@
syn keyword fsOptionsYesNo yes no
syn cluster fsOptionsCheckCluster contains=fsOptionsExt2Check,fsOptionsFatCheck
syn keyword fsOptionsSize 512 1024 2048
-syn keyword fsOptionsGeneral async atime auto current defaults dev exec force fstab noatime noauto noclusterr noclusterw nodev noexec nosuid nosymfollow nouser owner ro rdonly rw rq sw xx suid suiddir sync kudzu union update user supermount users loop
+syn keyword fsOptionsGeneral async atime auto current defaults dev exec force fstab managed noatime noauto noclusterr noclusterw nodev noexec nosuid nosymfollow nouser owner pamconsole ro rdonly rw rq sw xx suid suiddir sync kudzu union update user supermount users loop
syn match fsOptionsGeneral /_netdev/
" Options: adfs

15
vim-7.0-rclocation.patch Normal file
View File

@ -0,0 +1,15 @@
--- vim62/src/os_unix.h.rcloc 2003-08-04 15:38:05.000000000 +0200
+++ vim62/src/os_unix.h 2003-08-04 15:39:25.000000000 +0200
@@ -230,10 +230,10 @@
* Unix system-dependent file names
*/
#ifndef SYS_VIMRC_FILE
-# define SYS_VIMRC_FILE "$VIM/vimrc"
+# define SYS_VIMRC_FILE "/etc/vim7rc"
#endif
#ifndef SYS_GVIMRC_FILE
-# define SYS_GVIMRC_FILE "$VIM/gvimrc"
+# define SYS_GVIMRC_FILE "/etc/gvim7rc"
#endif
#ifndef DFLT_HELPFILE
# define DFLT_HELPFILE "$VIMRUNTIME/doc/help.txt"

11
vim-7.0-syntax.patch Normal file
View File

@ -0,0 +1,11 @@
--- vim70aa/runtime/filetype.vim.orig 2006-03-13 23:15:53.000000000 +0100
+++ vim70aa/runtime/filetype.vim 2006-03-14 15:56:13.000000000 +0100
@@ -103,7 +103,7 @@
" Apache config file
au BufNewFile,BufRead .htaccess setf apache
-au BufNewFile,BufRead httpd.conf*,srm.conf*,access.conf*,apache.conf*,apache2.conf*,/etc/apache2/*.conf* call s:StarSetf('apache')
+au BufNewFile,BufRead httpd.conf*,srm.conf*,access.conf*,apache.conf*,apache2.conf*,/etc/apache2/*.conf* auth_mysql.conf*,auth_pgsql.conf*,ssl.conf*,perl.conf*,php.conf*,python.conf*,squirrelmail.conf* call s:StarSetf('apache')
" XA65 MOS6510 cross assembler
au BufNewFile,BufRead *.a65 setf a65

119
vim.spec
View File

@ -12,20 +12,20 @@
%define withruby 0
%else
%define withruby 0
%define withnetbeans 0
%define withnetbeans 1
%endif
%define withcvim 1
%define withcvim 0
%define baseversion 6.4
%define vimdir vim64
%define patchlevel 007
%define baseversion 7.0aa
%define vimdir vim70aa
%define patchlevel 000
Summary: The VIM editor.
Name: vim
Version: %{baseversion}.%{patchlevel}
Release: 4
Release: 3
License: freeware
Group: Applications/Editors
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}.tar.bz2
@ -33,7 +33,7 @@ Source1: ftp://ftp.vim.org/pub/vim/extra/vim-%{baseversion}-lang.tar.gz
Source2: ftp://ftp.vim.org/pub/vim/extra/vim-%{baseversion}-extra.tar.gz
Source3: gvim.desktop
Source4: vimrc
Source5: ftp://ftp.vim.org/pub/vim/patches/README.patches
#Source5: ftp://ftp.vim.org/pub/vim/patches/README.patches
Source6: spec.vim
Source7: gvim16.png
Source8: gvim32.png
@ -41,36 +41,26 @@ Source9: gvim48.png
Source10: gvim64.png
Source11: Changelog.rpm
# Source at http://www.vim.org/scripts/script.php?script_id=213 :
Source12: cvim.zip
Patch2000: vim-4.2-speed_t.patch
Patch2001: vim-5.6a-paths.patch
Patch2002: vim-6.0-fixkeys.patch
#Source12: cvim.zip
Patch2002: vim-7.0-fixkeys.patch
Patch2003: vim-6.2-specsyntax.patch
Patch2004: vim-6.0r-crv.patch
Patch2005: vim-6.4-tmpfile.patch
Patch2004: vim-7.0-crv.patch
Patch2010: xxd-locale.patch
# Patches 001 < 999 are patches from the base maintainer.
# If you're as lazy as me, generate the list using
# for i in `seq 1 14`; do printf "Patch%03d: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.%03d\n" $i $i; done
#Patch001: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.001
Patch002: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.002
Patch003: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.003
Patch004: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.004
Patch005: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.005
Patch006: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.006
Patch007: ftp://ftp.vim.org/pub/vim/patches/6.4/6.4.007
Patch3000: vim-6.1-syntax.patch
Patch3000: vim-7.0-syntax.patch
Patch3001: vim-6.2-rh1.patch
Patch3002: vim-6.1-rh2.patch
Patch3003: vim-6.1-rh3.patch
Patch3004: vim-6.2-rclocation.patch
Patch3004: vim-7.0-rclocation.patch
Patch3005: vim-6.2-rh4.patch
Patch3006: vim-6.2-rh5.patch
Patch3007: vim-6.3-dnssyntax.patch
Patch3008: vim-6.4-cvim.patch
#Patch3008: vim-6.4-cvim.patch
Patch3009: vim-6.4-checkhl.patch
Patch3010: vim-6.4-fstabsyntax.patch
Patch3010: vim-7.0-fstabsyntax.patch
Patch3011: vim-6.4-lib64.patch
Patch3100: vim-selinux.patch
@ -99,6 +89,9 @@ multiple windows, multi-level undo, block highlighting and more.
%package common
Summary: The common files needed by any version of the VIM editor.
Group: Applications/Editors
Obsoletes: vim7-common
Conflicts: man-pages-fr < 0.9.7-14
Conflicts: man-pages-it < 0.3.0-17
%description common
VIM (VIsual editor iMproved) is an updated and improved version of the
@ -114,7 +107,8 @@ to install the vim-common package.
%package minimal
Summary: A minimal version of the VIM editor.
Group: Applications/Editors
Obsoletes: vim
Obsoletes: vim
Obsoletes: vim7-minimal
%description minimal
VIM (VIsual editor iMproved) is an updated and improved version of the
@ -130,10 +124,8 @@ package is installed.
Summary: A version of the VIM editor which includes recent enhancements.
Group: Applications/Editors
Requires: vim-common = %{epoch}:%{version}-%{release}
#Requires: %(perl -le 'printf("perl >= %vd\n",$^V);')
#Requires: perl >= %(rpm -q --qf "%%{epoch}:%%{version}\n" perl)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Obsoletes: vim-color
Obsoletes: vim7-enhanced
%description enhanced
VIM (VIsual editor iMproved) is an updated and improved version of the
@ -154,6 +146,7 @@ Group: Applications/Editors
Requires: vim-common = %{epoch}:%{version}-%{release} libattr
BuildRequires: gtk2-devel libSM-devel libXt-devel
Prereq: gtk2 >= 2.6
Obsoletes: vim7-X11
%description X11
VIM (VIsual editor iMproved) is an updated and improved version of the
@ -171,26 +164,16 @@ vim-common package.
%prep
%setup -q -b 1 -n %{vimdir}
cp -f %{SOURCE6} runtime/ftplugin/spec.vim
%patch2000 -p1
# fix rogue dependencies from sample code
chmod -x runtime/tools/mve.awk
%patch2001 -p1
%patch2002 -p1
%patch2003 -p1
%patch2004 -p1
%patch2005 -p1
%patch2010 -p1
perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
# Base patches...
# for i in `seq 1 14`; do printf "%%patch%03d -p0 \n" $i; done
#%patch001 -p0
%patch002 -p0
%patch003 -p0
%patch004 -p0
%patch005 -p0
%patch006 -p0
%patch007 -p0
%patch3000 -p1
@ -278,7 +261,7 @@ make
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT/bin
mkdir -p $RPM_BUILD_ROOT/usr/{bin,share/vim}
cp -f %{SOURCE5} .
#cp -f %{SOURCE5} .
%if "%{withcvim}" == "1"
# cvim plugin stuff:
@ -301,10 +284,10 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/vim/%{vimdir}/ftplugin
cd src
%makeinstall BINDIR=/bin DESTDIR=$RPM_BUILD_ROOT
mv $RPM_BUILD_ROOT/bin/xxd $RPM_BUILD_ROOT/usr/bin
mv $RPM_BUILD_ROOT/bin/xxd $RPM_BUILD_ROOT/usr/bin/xxd
make installmacros DESTDIR=$RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,32x32,48x48,64x64}/apps
install -m755 gvim $RPM_BUILD_ROOT/usr/bin
install -m755 gvim $RPM_BUILD_ROOT/usr/bin/gvim
install -m644 %{SOURCE7} \
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/gvim.png
install -m644 %{SOURCE8} \
@ -316,13 +299,13 @@ install -m644 %{SOURCE10} \
install -m755 enhanced-vim $RPM_BUILD_ROOT/usr/bin/vim
( cd $RPM_BUILD_ROOT
mv ./bin/vimtutor ./usr/bin
mv ./bin/vimtutor ./usr/bin/vimtutor
mv ./bin/vim ./bin/vi
rm -f ./bin/rvim
ln -sf vi ./bin/view
ln -sf vi ./bin/ex
ln -sf vi ./bin/rvi
ln -sf vi ./bin/rview
ln -sf vi ./bin/view
ln -sf vim ./usr/bin/ex
ln -sf vim ./usr/bin/rvim
ln -sf vim ./usr/bin/vimdiff
@ -402,10 +385,7 @@ install -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/vimrc
(cd $RPM_BUILD_ROOT/usr/share/vim/%{vimdir}/doc;
gzip -9 *.txt; gzip -d help.txt.gz
cat tags | sed -e 's/\t\(.*.txt\)\t/\t\1.gz\t/;s/\thelp.txt.gz\t/\thelp.txt\t/' > tags.new; mv -f tags.new tags)
(cd ../runtime; rm -rf doc; ln -svf ../../vim/%{vimdir}/doc docs;
mv -f macros/README.txt ../README.macros;
mv -f tools/README.txt ../README.tools;
)
(cd ../runtime; rm -rf doc; ln -svf ../../vim/%{vimdir}/doc docs;)
%post X11
touch --no-create %{_datadir}/icons/hicolor
@ -428,21 +408,47 @@ rm -rf $RPM_BUILD_ROOT
%doc README*
%doc runtime/docs
%doc $RPM_SOURCE_DIR/Changelog.rpm
/usr/share/vim
%dir /usr/share/vim
%dir /usr/share/vim/%{vimdir}
/usr/share/vim/%{vimdir}/autoload
/usr/share/vim/%{vimdir}/colors
/usr/share/vim/%{vimdir}/compiler
/usr/share/vim/%{vimdir}/doc
/usr/share/vim/%{vimdir}/*.vim
/usr/share/vim/%{vimdir}/ftplugin
/usr/share/vim/%{vimdir}/indent
/usr/share/vim/%{vimdir}/keymap
/usr/share/vim/%{vimdir}/lang/*.vim
/usr/share/vim/%{vimdir}/lang/*.txt
/usr/share/vim/%{vimdir}/macros
/usr/share/vim/%{vimdir}/plugin
/usr/share/vim/%{vimdir}/print
/usr/share/vim/%{vimdir}/spell
/usr/share/vim/%{vimdir}/syntax
/usr/share/vim/%{vimdir}/tools
/usr/share/vim/%{vimdir}/tutor
%lang(af) /usr/share/vim/%{vimdir}/lang/af/*
%lang(ca) /usr/share/vim/%{vimdir}/lang/ca/*
%lang(cs) /usr/share/vim/%{vimdir}/lang/cs/*
%lang(de) /usr/share/vim/%{vimdir}/lang/de/*
%lang(en_GB) /usr/share/vim/%{vimdir}/lang/en_GB/*
%lang(es) /usr/share/vim/%{vimdir}/lang/es/*
%lang(fr) /usr/share/vim/%{vimdir}/lang/fr/*
%lang(ga) /usr/share/vim/%{vimdir}/lang/ga/*
%lang(it) /usr/share/vim/%{vimdir}/lang/it/*
%lang(ja) /usr/share/vim/%{vimdir}/lang/ja/*
%lang(ko) /usr/share/vim/%{vimdir}/lang/ko/*
%lang(no) /usr/share/vim/%{vimdir}/lang/no/*
%lang(pl) /usr/share/vim/%{vimdir}/lang/pl/*
%lang(ru) /usr/share/vim/%{vimdir}/lang/ru/*
%lang(sk) /usr/share/vim/%{vimdir}/lang/sk/*
%lang(sv) /usr/share/vim/%{vimdir}/lang/sv/*
%lang(uk) /usr/share/vim/%{vimdir}/lang/uk/*
%lang(vi) /usr/share/vim/%{vimdir}/lang/vi/*
%lang(zh_CN) /usr/share/vim/%{vimdir}/lang/zh_CN/*
%lang(zh_CN.UTF-8) /usr/share/vim/%{vimdir}/lang/zh_CN.UTF-8/*
%lang(zh_TW) /usr/share/vim/%{vimdir}/lang/zh_TW/*
%lang(zh_CN.UTF-8) /usr/share/vim/%{vimdir}/lang/zh_CN.UTF-8/*
%lang(zh_TW.UTF-8) /usr/share/vim/%{vimdir}/lang/zh_TW.UTF-8/*
/usr/bin/xxd
%{_mandir}/man1/vim.*
%{_mandir}/man1/ex.*
@ -451,6 +457,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/rvi.*
%{_mandir}/man1/rview.*
%{_mandir}/man1/xxd.*
%lang(fr) %{_mandir}/fr*/*
%lang(it) %{_mandir}/it*/*
%lang(ru) %{_mandir}/ru*/*
%files minimal
%defattr(-,root,root)
@ -491,6 +500,18 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/icons/hicolor/*/apps/*
%changelog
* Wed Mar 22 2006 Karsten Hopp <karsten@redhat.de> 7.0aa.000-3
- Rawhide build as vim, opposed to vim7 (prerelease)
- conflict with older man-pages-{it,fr} packages
- cleanup lang stuff
* Thu Mar 16 2006 Karsten Hopp <karsten@redhat.de> 7.0aa.000-2
- make it coexist with vim-6 (temporarily)
- new CVS snapshot
* Tue Mar 14 2006 Karsten Hopp <karsten@redhat.de> 7.0aa.000-1
- vim7 pre Release
* Thu Mar 09 2006 Karsten Hopp <karsten@redhat.de> 6.4.007-4
- fix configure check for python (#184478)