2015517 - [s390x] Vim needs to be compiled with -D_REENTRANT
Resolves: rhbz#2015517
This commit is contained in:
parent
90b5f69d52
commit
6477489e4a
@ -0,0 +1,49 @@
|
||||
From 3ae5fc9a6a881e0be381e4cc70080ac5908d7520 Mon Sep 17 00:00:00 2001
|
||||
From: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Mon, 6 Sep 2021 18:57:30 +0200
|
||||
Subject: [PATCH] patch 8.2.3406: on some systems tests fail without _REENTRANT
|
||||
|
||||
Problem: On some systems tests fail without _REENTRANT. (Elimar
|
||||
Riesebieter)
|
||||
Solution: Add -D_REENTRANT in configure. (closes #7402)
|
||||
---
|
||||
src/auto/configure | 4 ++++
|
||||
src/configure.ac | 6 ++++++
|
||||
src/version.c | 2 ++
|
||||
3 files changed, 12 insertions(+)
|
||||
|
||||
diff --git a/src/auto/configure b/src/auto/configure
|
||||
index fba6a19b5..4f4363224 100755
|
||||
--- a/src/auto/configure
|
||||
+++ b/src/auto/configure
|
||||
@@ -14960,6 +14960,10 @@ $as_echo "no" >&6; }
|
||||
fi
|
||||
fi
|
||||
|
||||
+if `echo "$CFLAGS" | grep -v D_XEENTRANT >/dev/null`; then
|
||||
+ CFLAGS="$CFLAGS -D_REENTRANT"
|
||||
+fi
|
||||
+
|
||||
DEPEND_CFLAGS_FILTER=
|
||||
if test "$GCC" = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GCC 3 or later" >&5
|
||||
diff --git a/src/configure.ac b/src/configure.ac
|
||||
index 5ec955757..4cd6dea1f 100644
|
||||
--- a/src/configure.ac
|
||||
+++ b/src/configure.ac
|
||||
@@ -4504,6 +4504,12 @@ if test "$MACOS_X" = "yes"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
+dnl On some systems REENTRANT needs to be defined. It should not hurt to use
|
||||
+dnl it everywhere.
|
||||
+if `echo "$CFLAGS" | grep -v D_REENTRANT >/dev/null`; then
|
||||
+ CFLAGS="$CFLAGS -D_REENTRANT"
|
||||
+fi
|
||||
+
|
||||
dnl gcc 3.1 changed the meaning of -MM. The only solution appears to be to
|
||||
dnl use "-isystem" instead of "-I" for all non-Vim include dirs.
|
||||
dnl But only when making dependencies, cproto and lint don't take "-isystem".
|
||||
--
|
||||
2.31.1
|
||||
|
8
vim.spec
8
vim.spec
@ -27,7 +27,7 @@ Summary: The VIM editor
|
||||
URL: http://www.vim.org/
|
||||
Name: vim
|
||||
Version: %{baseversion}.%{patchlevel}
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: Vim and MIT
|
||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
||||
Source1: virc
|
||||
@ -76,6 +76,8 @@ Patch3021: vim-cve-var-retab.patch
|
||||
Patch3022: 0001-patch-8.2.3409-reading-beyond-end-of-line-with-inval.patch
|
||||
# 2004976 - CVE-2021-3796 vim: use-after-free in nv_replace() in normal.c [rhel-9.0]
|
||||
Patch3023: 0001-patch-8.2.3428-using-freed-memory-when-replacing.patch
|
||||
# 2015517 - [s390x] Vim needs to be compiled with -D_REENTRANT
|
||||
Patch3024: 0001-patch-8.2.3406-on-some-systems-tests-fail-without-_R.patch
|
||||
|
||||
# gcc is no longer in buildroot by default
|
||||
BuildRequires: gcc
|
||||
@ -286,6 +288,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch3021 -p1 -b .cve-var-retab
|
||||
%patch3022 -p1 -b .cve-utf-ptrchar
|
||||
%patch3023 -p1 -b .cve-nv-replace
|
||||
%patch3024 -p1 -b .reentrant
|
||||
|
||||
%build
|
||||
cd src
|
||||
@ -843,6 +846,9 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 19 2021 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.2637-7
|
||||
- 2015517 - [s390x] Vim needs to be compiled with -D_REENTRANT
|
||||
|
||||
* Thu Oct 14 2021 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.2637-6
|
||||
- 2011412 - test suite fails on apache/httpd filetype tests
|
||||
- 2011424 - Remove vim-7.4-syncolor.patch
|
||||
|
Loading…
Reference in New Issue
Block a user