f24->f25 vim: copy paste no longer works (bug #1401410) - revert previous changes, set mouse=v in defaults.vim
This commit is contained in:
parent
708719cf70
commit
43f7831c2c
12
vim-8.0-copy-paste.patch
Normal file
12
vim-8.0-copy-paste.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up vim80/runtime/defaults.vim.copy-paste vim80/runtime/defaults.vim
|
||||||
|
--- vim80/runtime/defaults.vim.copy-paste 2016-12-19 07:57:32.295973442 +0100
|
||||||
|
+++ vim80/runtime/defaults.vim 2016-12-19 07:58:44.760101540 +0100
|
||||||
|
@@ -67,7 +67,7 @@ inoremap <C-U> <C-G>u<C-U>
|
||||||
|
" In many terminal emulators the mouse works just fine. By enabling it you
|
||||||
|
" can position the cursor, Visually select and scroll with the mouse.
|
||||||
|
if has('mouse')
|
||||||
|
- set mouse=a
|
||||||
|
+ set mouse=v
|
||||||
|
endif
|
||||||
|
|
||||||
|
" Switch syntax highlighting on when the terminal has colors or when using the
|
3
vim.spec
3
vim.spec
@ -63,6 +63,7 @@ Patch3011: vim-manpagefixes-948566.patch
|
|||||||
Patch3012: vim-7.4-licensemacro-1151450.patch
|
Patch3012: vim-7.4-licensemacro-1151450.patch
|
||||||
Patch3013: vim-7.4-globalsyntax.patch
|
Patch3013: vim-7.4-globalsyntax.patch
|
||||||
Patch3014: vim-7.4-releasestring-1318991.patch
|
Patch3014: vim-7.4-releasestring-1318991.patch
|
||||||
|
Patch3015: vim-8.0-copy-paste.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
|
||||||
@ -216,6 +217,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3012 -p1
|
%patch3012 -p1
|
||||||
%patch3013 -p1
|
%patch3013 -p1
|
||||||
%patch3014 -p1
|
%patch3014 -p1
|
||||||
|
%patch3015 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cp -f %{SOURCE6} .
|
cp -f %{SOURCE6} .
|
||||||
@ -756,6 +758,7 @@ rm -rf %{buildroot}
|
|||||||
%changelog
|
%changelog
|
||||||
* Mon Dec 19 2016 Karsten Hopp <karsten@redhat.com> 8.0.134-1
|
* Mon Dec 19 2016 Karsten Hopp <karsten@redhat.com> 8.0.134-1
|
||||||
- patchlevel 134
|
- patchlevel 134
|
||||||
|
- f24->f25 vim: copy paste no longer works (bug #1401410) - revert previous changes, set mouse=v in defaults.vim
|
||||||
|
|
||||||
* Thu Dec 15 2016 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.0.133-2
|
* Thu Dec 15 2016 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.0.133-2
|
||||||
- f24->f25 vim: copy paste no longer works (bug #1401410) - change mouse default setting to 'v'
|
- f24->f25 vim: copy paste no longer works (bug #1401410) - change mouse default setting to 'v'
|
||||||
|
1
vimrc
1
vimrc
@ -10,7 +10,6 @@ set viminfo='20,\"50 " read/write a .viminfo file, don't store more
|
|||||||
" than 50 lines of registers
|
" than 50 lines of registers
|
||||||
set history=50 " keep 50 lines of command line history
|
set history=50 " keep 50 lines of command line history
|
||||||
set ruler " show the cursor position all the time
|
set ruler " show the cursor position all the time
|
||||||
set mouse=v
|
|
||||||
|
|
||||||
" Only do this part when compiled with support for autocommands
|
" Only do this part when compiled with support for autocommands
|
||||||
if has("autocmd")
|
if has("autocmd")
|
||||||
|
Loading…
Reference in New Issue
Block a user