Remove python310 specific patch - no longer needed
This commit is contained in:
parent
51104b3f82
commit
38f1b86de2
@ -1,13 +0,0 @@
|
||||
diff --git a/src/testdir/test_python3.vim b/src/testdir/test_python3.vim
|
||||
index 66d5db5..a7b3570 100644
|
||||
--- a/src/testdir/test_python3.vim
|
||||
+++ b/src/testdir/test_python3.vim
|
||||
@@ -3094,7 +3094,7 @@ func Test_python3_errors()
|
||||
<<< Finished
|
||||
> VimForeachRTP
|
||||
vim.foreach_rtp(None):(<class 'TypeError'>, TypeError("'NoneType' object is not callable",))
|
||||
- vim.foreach_rtp(NoArgsCall()):(<class 'TypeError'>, TypeError('__call__() takes exactly 1 positional argument (2 given)',))
|
||||
+ vim.foreach_rtp(NoArgsCall()):(<class 'TypeError'>, TypeError('__call__() takes 1 positional argument but 2 were given',))
|
||||
vim.foreach_rtp(FailingCall()):(<class 'NotImplementedError'>, NotImplementedError('call',))
|
||||
vim.foreach_rtp(int, 2):(<class 'TypeError'>, TypeError('foreach_rtp() takes exactly one argument (2 given)',))
|
||||
> import
|
6
vim.spec
6
vim.spec
@ -70,8 +70,6 @@ Patch3005: vim-python3-tests.patch
|
||||
Patch3006: vim-crypto-warning.patch
|
||||
# don't ever set mouse (Fedora downstream patch)
|
||||
Patch3007: vim-8.0-copy-paste.patch
|
||||
# F35+: Python changed the error message which test suite expects
|
||||
Patch3008: vim-python310-new-errmsg.patch
|
||||
|
||||
|
||||
# uses autoconf in spec file
|
||||
@ -333,10 +331,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch3006 -p1 -b .fips-warning
|
||||
%patch3007 -p1 -b .copypaste
|
||||
|
||||
%if 0%{?fedora} >= 35
|
||||
%patch3008 -p1 -b .python310-new-errmsg
|
||||
%endif
|
||||
|
||||
%build
|
||||
cd src
|
||||
autoconf
|
||||
|
Loading…
Reference in New Issue
Block a user