add support for license macro (Petr Šabata)
This commit is contained in:
parent
0ccd2610ff
commit
35af1a9703
@ -495,3 +495,5 @@ Individual patches for Vim 7.4:
|
|||||||
2350 7.4.471 MS-Windows: multi-byte printer name is displayed as ???
|
2350 7.4.471 MS-Windows: multi-byte printer name is displayed as ???
|
||||||
1527 7.4.472 drawing "precedes" entry of 'listchar' when 'list' is not set
|
1527 7.4.472 drawing "precedes" entry of 'listchar' when 'list' is not set
|
||||||
1554 7.4.473 cursor position incorrect with number column and 'sbr'
|
1554 7.4.473 cursor position incorrect with number column and 'sbr'
|
||||||
|
1293 7.4.474 AIX compiler can't handle // comment
|
||||||
|
7374 7.4.475 can't compile if Xutf8SetWMProperties() is not in X11 library
|
||||||
|
15
vim-7.4-licensemacro-1151450.patch
Normal file
15
vim-7.4-licensemacro-1151450.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up vim74_new/runtime/syntax/spec.vim.1151450 vim74_new/runtime/syntax/spec.vim
|
||||||
|
--- vim74_new/runtime/syntax/spec.vim.1151450 2014-10-13 10:45:07.570944538 +0200
|
||||||
|
+++ vim74_new/runtime/syntax/spec.vim 2014-10-13 10:44:09.046945965 +0200
|
||||||
|
@@ -88,9 +88,9 @@ syn region specSectionMacroBracketArea o
|
||||||
|
"%% Files Section %%
|
||||||
|
"TODO %config valid parameters: missingok\|noreplace
|
||||||
|
"TODO %verify valid parameters: \(not\)\= \(md5\|atime\|...\)
|
||||||
|
-syn region specFilesArea matchgroup=specSection start='^%[Ff][Ii][Ll][Ee][Ss]\>' skip='%\(attrib\|defattr\|attr\|dir\|config\|docdir\|doc\|lang\|verify\|ghost\)\>' end='^%[a-zA-Z]'me=e-2 contains=specFilesOpts,specFilesDirective,@specListedFiles,specComment,specCommandSpecial,specMacroIdentifier
|
||||||
|
+syn region specFilesArea matchgroup=specSection start='^%[Ff][Ii][Ll][Ee][Ss]\>' skip='%\(attrib\|defattr\|attr\|dir\|config\|docdir\|doc\|lang\|verify\|ghost\|license\)\>' end='^%[a-zA-Z]'me=e-2 contains=specFilesOpts,specFilesDirective,@specListedFiles,specComment,specCommandSpecial,specMacroIdentifier
|
||||||
|
"tip: remember to include new itens in specFilesArea above
|
||||||
|
-syn match specFilesDirective contained '%\(attrib\|defattr\|attr\|dir\|config\|docdir\|doc\|lang\|verify\|ghost\)\>'
|
||||||
|
+syn match specFilesDirective contained '%\(attrib\|defattr\|attr\|dir\|config\|docdir\|doc\|lang\|verify\|ghost\|license\)\>'
|
||||||
|
|
||||||
|
"valid options for certain section headers
|
||||||
|
syn match specDescriptionOpts contained '\s-[ln]\s*\a'ms=s+1,me=e-1
|
16
vim.spec
16
vim.spec
@ -1,4 +1,4 @@
|
|||||||
%define patchlevel 473
|
%define patchlevel 475
|
||||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||||
%define WITH_SELINUX 1
|
%define WITH_SELINUX 1
|
||||||
%endif
|
%endif
|
||||||
@ -21,7 +21,7 @@ Summary: The VIM editor
|
|||||||
URL: http://www.vim.org/
|
URL: http://www.vim.org/
|
||||||
Name: vim
|
Name: vim
|
||||||
Version: %{baseversion}.%{patchlevel}
|
Version: %{baseversion}.%{patchlevel}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: Vim
|
License: Vim
|
||||||
Group: Applications/Editors
|
Group: Applications/Editors
|
||||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}.tar.bz2
|
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}.tar.bz2
|
||||||
@ -520,6 +520,8 @@ Patch470: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.470
|
|||||||
Patch471: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.471
|
Patch471: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.471
|
||||||
Patch472: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.472
|
Patch472: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.472
|
||||||
Patch473: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.473
|
Patch473: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.473
|
||||||
|
Patch474: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.474
|
||||||
|
Patch475: ftp://ftp.vim.org/pub/vim/patches/7.4/7.4.475
|
||||||
|
|
||||||
Patch3000: vim-7.4-syntax.patch
|
Patch3000: vim-7.4-syntax.patch
|
||||||
Patch3002: vim-7.1-nowarnings.patch
|
Patch3002: vim-7.1-nowarnings.patch
|
||||||
@ -532,6 +534,7 @@ Patch3010: vim-7.0-specedit.patch
|
|||||||
Patch3011: vim72-rh514717.patch
|
Patch3011: vim72-rh514717.patch
|
||||||
Patch3012: vim-7.3-manpage-typo-668894-675480.patch
|
Patch3012: vim-7.3-manpage-typo-668894-675480.patch
|
||||||
Patch3013: vim-manpagefixes-948566.patch
|
Patch3013: vim-manpagefixes-948566.patch
|
||||||
|
Patch3014: vim-7.4-licensemacro-1151450.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: python-devel ncurses-devel gettext perl-devel
|
BuildRequires: python-devel ncurses-devel gettext perl-devel
|
||||||
@ -1139,6 +1142,8 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch471 -p0
|
%patch471 -p0
|
||||||
%patch472 -p0
|
%patch472 -p0
|
||||||
%patch473 -p0
|
%patch473 -p0
|
||||||
|
%patch474 -p0
|
||||||
|
%patch475 -p0
|
||||||
|
|
||||||
# install spell files
|
# install spell files
|
||||||
%if %{withvimspell}
|
%if %{withvimspell}
|
||||||
@ -1157,6 +1162,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3012 -p1
|
%patch3012 -p1
|
||||||
|
|
||||||
%patch3013 -p1
|
%patch3013 -p1
|
||||||
|
%patch3014 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cp -f %{SOURCE5} .
|
cp -f %{SOURCE5} .
|
||||||
@ -1655,6 +1661,12 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/icons/hicolor/*/apps/*
|
%{_datadir}/icons/hicolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 13 2014 Karsten Hopp <karsten@redhat.com> 7.4.475-2
|
||||||
|
- add support for %%license macro (Petr Šabata)
|
||||||
|
|
||||||
|
* Sat Oct 11 2014 Karsten Hopp <karsten@redhat.com> 7.4.475-1
|
||||||
|
- patchlevel 475
|
||||||
|
|
||||||
* Fri Oct 10 2014 Karsten Hopp <karsten@redhat.com> 7.4.473-1
|
* Fri Oct 10 2014 Karsten Hopp <karsten@redhat.com> 7.4.473-1
|
||||||
- patchlevel 473
|
- patchlevel 473
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user