- update to patchlevel 109 to fix some redraw problems
- fix invisible comments in diff mode
This commit is contained in:
parent
1e4dad2df4
commit
2d83a54e4c
@ -125,3 +125,12 @@ Individual patches for Vim 7.0:
|
||||
2196 7.0.098 redirection didn't work inside cmdline completion
|
||||
2189 7.0.099 GUI: scrolling causes problems for the popup menu
|
||||
2086 7.0.100 "zug" may report the wrong filename
|
||||
2732 7.0.101 "zw" mostly doesn't work; "zg" may create wrong directory
|
||||
1634 7.0.102 redraw problem in cmdline when using SCIM
|
||||
1617 7.0.103 (after 7.0.101) compiler warning for uninitialized variable
|
||||
2522 7.0.104 CursorHold[I] may trigger when it is not wanted
|
||||
1513 7.0.105 during incremental search the ruler is not updated
|
||||
5102 7.0.106 spell popup menu may have side effects
|
||||
1805 7.0.107 tab pages line was not redrawn when using 'incsearch'
|
||||
2583 7.0.108 (extra) Amiga: compilation error for mch_mkdir()
|
||||
1923 7.0.109 Lisp indenting gets confused by an escaped quote in a string
|
||||
|
@ -1,11 +1,24 @@
|
||||
--- vim70/runtime/syntax/syncolor.vim.orig 2006-08-25 14:58:29.000000000 +0200
|
||||
+++ vim70/runtime/syntax/syncolor.vim 2006-08-25 14:59:24.000000000 +0200
|
||||
@@ -41,7 +41,7 @@
|
||||
SynColor Underlined term=underline cterm=underline ctermfg=LightBlue gui=underline guifg=#80a0ff
|
||||
SynColor Ignore term=NONE cterm=NONE ctermfg=black ctermbg=NONE gui=NONE guifg=bg guibg=NONE
|
||||
else
|
||||
- SynColor Comment term=bold cterm=NONE ctermfg=DarkBlue ctermbg=NONE gui=NONE guifg=Blue guibg=NONE
|
||||
+ SynColor Comment term=bold cterm=NONE ctermfg=DarkRed ctermbg=NONE gui=NONE guifg=red2 guibg=NONE
|
||||
SynColor Constant term=underline cterm=NONE ctermfg=DarkRed ctermbg=NONE gui=NONE guifg=Magenta guibg=NONE
|
||||
SynColor Special term=bold cterm=NONE ctermfg=DarkMagenta ctermbg=NONE gui=NONE guifg=SlateBlue guibg=NONE
|
||||
SynColor Identifier term=underline cterm=NONE ctermfg=DarkCyan ctermbg=NONE gui=NONE guifg=DarkCyan guibg=NONE
|
||||
--- vim70/src/syntax.c.syn1 2006-04-26 14:49:45.000000000 +0200
|
||||
+++ vim70/src/syntax.c 2006-09-19 13:15:41.000000000 +0200
|
||||
@@ -6176,8 +6176,8 @@
|
||||
"Visual term=reverse guibg=LightGrey"),
|
||||
#endif
|
||||
#ifdef FEAT_DIFF
|
||||
- CENT("DiffAdd term=bold ctermbg=LightBlue",
|
||||
- "DiffAdd term=bold ctermbg=LightBlue guibg=LightBlue"),
|
||||
+ CENT("DiffAdd term=bold ctermbg=LightRed",
|
||||
+ "DiffAdd term=bold ctermbg=LightRed guibg=LightBlue"),
|
||||
CENT("DiffChange term=bold ctermbg=LightMagenta",
|
||||
"DiffChange term=bold ctermbg=LightMagenta guibg=LightMagenta"),
|
||||
CENT("DiffDelete term=bold ctermfg=Blue ctermbg=LightCyan",
|
||||
@@ -6256,8 +6256,8 @@
|
||||
"Visual term=reverse guibg=DarkGrey"),
|
||||
#endif
|
||||
#ifdef FEAT_DIFF
|
||||
- CENT("DiffAdd term=bold ctermbg=DarkBlue",
|
||||
- "DiffAdd term=bold ctermbg=DarkBlue guibg=DarkBlue"),
|
||||
+ CENT("DiffAdd term=bold ctermbg=DarkRed",
|
||||
+ "DiffAdd term=bold ctermbg=DarkRed guibg=DarkBlue"),
|
||||
CENT("DiffChange term=bold ctermbg=DarkMagenta",
|
||||
"DiffChange term=bold ctermbg=DarkMagenta guibg=DarkMagenta"),
|
||||
CENT("DiffDelete term=bold ctermfg=Blue ctermbg=DarkCyan",
|
||||
|
25
vim.spec
25
vim.spec
@ -15,7 +15,7 @@
|
||||
#used for pre-releases:
|
||||
%define beta %{nil}
|
||||
%define vimdir vim70%{?beta}
|
||||
%define patchlevel 100
|
||||
%define patchlevel 109
|
||||
|
||||
Summary: The VIM editor.
|
||||
Name: vim
|
||||
@ -148,6 +148,15 @@ Patch097: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.097
|
||||
Patch098: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.098
|
||||
Patch099: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.099
|
||||
Patch100: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.100
|
||||
Patch101: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.101
|
||||
Patch102: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.102
|
||||
Patch103: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.103
|
||||
Patch104: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.104
|
||||
Patch105: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.105
|
||||
Patch106: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.106_patched
|
||||
Patch107: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.107
|
||||
Patch108: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.108
|
||||
Patch109: ftp://ftp.vim.org/pub/vim/patches/7.0/7.0.109
|
||||
|
||||
|
||||
Patch3000: vim-7.0-syntax.patch
|
||||
@ -404,6 +413,16 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
||||
%patch098 -p0
|
||||
%patch099 -p0
|
||||
%patch100 -p0
|
||||
%patch101 -p0
|
||||
%patch102 -p0
|
||||
%patch103 -p0
|
||||
%patch104 -p0
|
||||
%patch105 -p0
|
||||
%patch106 -p0
|
||||
%patch107 -p0
|
||||
# Amiga:
|
||||
#patch108 -p0
|
||||
%patch109 -p0
|
||||
|
||||
# install spell files
|
||||
%{__tar} xjf %{SOURCE14}
|
||||
@ -784,6 +803,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Tue Sep 19 2006 Karsten Hopp <karsten@redhat.com> 7.0.109-9
|
||||
- update to patchlevel 109 to fix some redraw problems
|
||||
- fix invisible comments in diff mode
|
||||
|
||||
* Tue Sep 12 2006 Karsten Hopp <karsten@redhat.com> 7.0.100-1
|
||||
- Patchlevel 100
|
||||
- replace runtime files with newer ones
|
||||
|
Loading…
Reference in New Issue
Block a user