vim-7.4-syntax.patch: remove downstream patch, got merged upstream
This commit is contained in:
parent
1ec0e33929
commit
158097f739
@ -1,43 +0,0 @@
|
|||||||
From c669d497d34e4b57f40c19d58e3703401075a6d5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Zdenek Dohnal <zdohnal@redhat.com>
|
|
||||||
Date: Fri, 17 Sep 2021 07:54:56 +0200
|
|
||||||
Subject: [PATCH] runtime/filetype.vim: Register more httpd files as apache
|
|
||||||
filetype
|
|
||||||
|
|
||||||
Several files under /etc/httpd wasn't recognized as 'apache' filetype -
|
|
||||||
add them to filetype.vim and add tests for checking if recognizition
|
|
||||||
works.
|
|
||||||
---
|
|
||||||
runtime/filetype.vim | 2 +-
|
|
||||||
src/testdir/test_filetype.vim | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/runtime/filetype.vim b/runtime/filetype.vim
|
|
||||||
index d0d40539d..39a772740 100644
|
|
||||||
--- a/runtime/filetype.vim
|
|
||||||
+++ b/runtime/filetype.vim
|
|
||||||
@@ -2138,7 +2138,7 @@ au BufNewFile,BufRead proftpd.conf* call s:StarSetf('apachestyle')
|
|
||||||
|
|
||||||
" More Apache config files
|
|
||||||
au BufNewFile,BufRead access.conf*,apache.conf*,apache2.conf*,httpd.conf*,srm.conf* call s:StarSetf('apache')
|
|
||||||
-au BufNewFile,BufRead */etc/apache2/*.conf*,*/etc/apache2/conf.*/*,*/etc/apache2/mods-*/*,*/etc/apache2/sites-*/*,*/etc/httpd/conf.d/*.conf* call s:StarSetf('apache')
|
|
||||||
+au BufNewFile,BufRead */etc/apache2/*.conf*,*/etc/apache2/conf.*/*,*/etc/apache2/mods-*/*,*/etc/apache2/sites-*/*,*/etc/httpd/conf.*/*,*/etc/httpd/mods-*/*,*/etc/httpd/sites-*/*,*/etc/httpd/conf.d/*.conf* call s:StarSetf('apache')
|
|
||||||
|
|
||||||
" Asterisk config file
|
|
||||||
au BufNewFile,BufRead *asterisk/*.conf* call s:StarSetf('asterisk')
|
|
||||||
diff --git a/src/testdir/test_filetype.vim b/src/testdir/test_filetype.vim
|
|
||||||
index cd6e71d1b..f1404808f 100644
|
|
||||||
--- a/src/testdir/test_filetype.vim
|
|
||||||
+++ b/src/testdir/test_filetype.vim
|
|
||||||
@@ -59,7 +59,7 @@ let s:filename_checks = {
|
|
||||||
\ 'aml': ['file.aml'],
|
|
||||||
\ 'ampl': ['file.run'],
|
|
||||||
\ 'ant': ['build.xml'],
|
|
||||||
- \ 'apache': ['.htaccess', '/etc/httpd/file.conf', '/etc/apache2/sites-2/file.com', '/etc/apache2/some.config', '/etc/apache2/conf.file/conf', '/etc/apache2/mods-some/file', '/etc/apache2/sites-some/file', '/etc/httpd/conf.d/file.config', '/etc/apache2/conf.file/file', '/etc/apache2/file.conf', '/etc/apache2/file.conf-file', '/etc/apache2/mods-file/file', '/etc/apache2/sites-file/file', '/etc/apache2/sites-file/file.com', '/etc/httpd/conf.d/file.conf', '/etc/httpd/conf.d/file.conf-file', 'access.conf', 'access.conf-file', 'any/etc/apache2/conf.file/file', 'any/etc/apache2/file.conf', 'any/etc/apache2/file.conf-file', 'any/etc/apache2/mods-file/file', 'any/etc/apache2/sites-file/file', 'any/etc/apache2/sites-file/file.com', 'any/etc/httpd/conf.d/file.conf', 'any/etc/httpd/conf.d/file.conf-file', 'any/etc/httpd/file.conf', 'apache.conf', 'apache.conf-file', 'apache2.conf', 'apache2.conf-file', 'httpd.conf', 'httpd.conf-file', 'srm.conf', 'srm.conf-file'],
|
|
||||||
+ \ 'apache': ['.htaccess', '/etc/httpd/file.conf', '/etc/apache2/sites-2/file.com', '/etc/apache2/some.config', '/etc/apache2/conf.file/conf', '/etc/apache2/mods-some/file', '/etc/apache2/sites-some/file', '/etc/httpd/conf.d/file.config', '/etc/apache2/conf.file/file', '/etc/apache2/file.conf', '/etc/apache2/file.conf-file', '/etc/apache2/mods-file/file', '/etc/apache2/sites-file/file', '/etc/apache2/sites-file/file.com', '/etc/httpd/conf.d/file.conf', '/etc/httpd/conf.d/file.conf-file', 'access.conf', 'access.conf-file', 'any/etc/apache2/conf.file/file', 'any/etc/apache2/file.conf', 'any/etc/apache2/file.conf-file', 'any/etc/apache2/mods-file/file', 'any/etc/apache2/sites-file/file', 'any/etc/apache2/sites-file/file.com', 'any/etc/httpd/conf.d/file.conf', 'any/etc/httpd/conf.d/file.conf-file', 'any/etc/httpd/file.conf', 'apache.conf', 'apache.conf-file', 'apache2.conf', 'apache2.conf-file', 'httpd.conf', 'httpd.conf-file', 'srm.conf', 'srm.conf-file', '/etc/httpd/mods-some/file', '/etc/httpd/sites-some/file', '/etc/httpd/conf.file/conf'],
|
|
||||||
\ 'apachestyle': ['/etc/proftpd/file.config,/etc/proftpd/conf.file/file', '/etc/proftpd/conf.file/file', '/etc/proftpd/file.conf', '/etc/proftpd/file.conf-file', 'any/etc/proftpd/conf.file/file', 'any/etc/proftpd/file.conf', 'any/etc/proftpd/file.conf-file', 'proftpd.conf', 'proftpd.conf-file'],
|
|
||||||
\ 'applescript': ['file.scpt'],
|
|
||||||
\ 'aptconf': ['apt.conf', '/.aptitude/config', 'any/.aptitude/config'],
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
3
vim.spec
3
vim.spec
@ -59,8 +59,6 @@ Patch2011: vim-7.0-hunspell.patch
|
|||||||
BuildRequires: hunspell-devel
|
BuildRequires: hunspell-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# reported upstream as https://github.com/vim/vim/pull/8882
|
|
||||||
Patch3000: vim-7.4-syntax.patch
|
|
||||||
Patch3007: vim-7.4-fstabsyntax.patch
|
Patch3007: vim-7.4-fstabsyntax.patch
|
||||||
Patch3010: vim-7.3-manpage-typo-668894-675480.patch
|
Patch3010: vim-7.3-manpage-typo-668894-675480.patch
|
||||||
Patch3011: vim-manpagefixes-948566.patch
|
Patch3011: vim-manpagefixes-948566.patch
|
||||||
@ -322,7 +320,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%{__tar} xjf %{SOURCE100}
|
%{__tar} xjf %{SOURCE100}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch3000 -p1
|
|
||||||
%patch3007 -p1 -b .fstabsyntax
|
%patch3007 -p1 -b .fstabsyntax
|
||||||
%patch3010 -p1
|
%patch3010 -p1
|
||||||
%patch3011 -p1
|
%patch3011 -p1
|
||||||
|
Loading…
Reference in New Issue
Block a user