2169641 - Syntax highlight for sh files broken
This commit is contained in:
parent
026537cfee
commit
0849f86b22
13
vim-sh-syntax.patch
Normal file
13
vim-sh-syntax.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/runtime/syntax/sh.vim b/runtime/syntax/sh.vim
|
||||||
|
index 13d74db..4f7fafb 100644
|
||||||
|
--- a/runtime/syntax/sh.vim
|
||||||
|
+++ b/runtime/syntax/sh.vim
|
||||||
|
@@ -335,7 +335,7 @@ syn match shEscape contained '\%(^\)\@!\%(\\\\\)*\\.' nextgroup=shComment
|
||||||
|
" systems too, however, so the following syntax will flag $(..) as
|
||||||
|
" an Error under /bin/sh. By consensus of vimdev'ers!
|
||||||
|
if exists("b:is_kornshell") || exists("b:is_bash") || exists("b:is_posix")
|
||||||
|
- syn region shCommandSub matchgroup=shCmdSubRegion start="\$(\ze[^(]\|$" skip='\\\\\|\\.' end=")" contains=@shCommandSubList
|
||||||
|
+ syn region shCommandSub matchgroup=shCmdSubRegion start="\$(\ze[^(]" skip='\\\\\|\\.' end=")" contains=@shCommandSubList
|
||||||
|
syn region shArithmetic matchgroup=shArithRegion start="\$((" skip='\\\\\|\\.' end="))" contains=@shArithList
|
||||||
|
syn region shArithmetic matchgroup=shArithRegion start="\$\[" skip='\\\\\|\\.' end="\]" contains=@shArithList
|
||||||
|
syn match shSkipInitWS contained "^\s\+"
|
8
vim.spec
8
vim.spec
@ -50,7 +50,7 @@ Summary: The VIM editor
|
|||||||
URL: http://www.vim.org/
|
URL: http://www.vim.org/
|
||||||
Name: vim
|
Name: vim
|
||||||
Version: %{baseversion}.%{patchlevel}
|
Version: %{baseversion}.%{patchlevel}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: Vim and MIT
|
License: Vim and MIT
|
||||||
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
|
||||||
@ -90,6 +90,8 @@ Patch3003: vim-python3-tests.patch
|
|||||||
Patch3004: vim-crypto-warning.patch
|
Patch3004: vim-crypto-warning.patch
|
||||||
# don't ever set mouse (Fedora downstream patch)
|
# don't ever set mouse (Fedora downstream patch)
|
||||||
Patch3005: vim-8.0-copy-paste.patch
|
Patch3005: vim-8.0-copy-paste.patch
|
||||||
|
# 2169641 - Syntax highlight for sh files broken
|
||||||
|
Patch3006: vim-sh-syntax.patch
|
||||||
|
|
||||||
|
|
||||||
# uses autoconf in spec file
|
# uses autoconf in spec file
|
||||||
@ -386,6 +388,7 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
|
|||||||
%patch3003 -p1 -b .python-tests
|
%patch3003 -p1 -b .python-tests
|
||||||
%patch3004 -p1 -b .fips-warning
|
%patch3004 -p1 -b .fips-warning
|
||||||
%patch3005 -p1 -b .copypaste
|
%patch3005 -p1 -b .copypaste
|
||||||
|
%patch3006 -p1 -b .sh-syntax
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd src
|
cd src
|
||||||
@ -1003,6 +1006,9 @@ touch %{buildroot}/%{_datadir}/%{name}/vimfiles/doc/tags
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 14 2023 Zdenek Dohnal <zdohnal@redhat.com> - 2:9.0.1293-2
|
||||||
|
- 2169641 - Syntax highlight for sh files broken
|
||||||
|
|
||||||
* Thu Feb 09 2023 Zdenek Dohnal <zdohnal@redhat.com> - 2:9.0.1293-1
|
* Thu Feb 09 2023 Zdenek Dohnal <zdohnal@redhat.com> - 2:9.0.1293-1
|
||||||
- patchlevel 1293
|
- patchlevel 1293
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user