Port to Fedora
This commit is contained in:
parent
b6b7097a81
commit
e0e44c019e
@ -1 +1,4 @@
|
|||||||
velocity-1.4.tar.gz
|
velocity-1.4.tar.gz
|
||||||
|
velocity-1.4
|
||||||
|
noarch
|
||||||
|
*.src.rpm
|
||||||
|
46
velocity-servletapi5.patch
Normal file
46
velocity-servletapi5.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
--- velocity-1.4/src/java/org/apache/velocity/test/VelocityServletTest.java~ 2004-04-14 13:26:41.000000000 +0100
|
||||||
|
+++ velocity-1.4/src/java/org/apache/velocity/test/VelocityServletTest.java 2005-06-06 11:54:53.000000000 +0100
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
import java.net.URL;
|
||||||
|
import java.util.Enumeration;
|
||||||
|
import java.util.Properties;
|
||||||
|
+import java.util.Set;
|
||||||
|
import javax.servlet.RequestDispatcher;
|
||||||
|
import javax.servlet.Servlet;
|
||||||
|
import javax.servlet.ServletConfig;
|
||||||
|
@@ -237,6 +238,16 @@
|
||||||
|
public void setAttribute(String name, Object value)
|
||||||
|
{
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ public Set getResourcePaths(String path)
|
||||||
|
+ {
|
||||||
|
+ return null;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ public String getServletContextName()
|
||||||
|
+ {
|
||||||
|
+ return null;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
static class MockHttpServletResponse implements HttpServletResponse
|
||||||
|
@@ -391,5 +402,18 @@
|
||||||
|
public void setStatus(int i , String s)
|
||||||
|
{
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ public void setCharacterEncoding(String charset)
|
||||||
|
+ {
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ public String getContentType()
|
||||||
|
+ {
|
||||||
|
+ return null;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ public void resetBuffer()
|
||||||
|
+ {
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
}
|
@ -5,17 +5,19 @@
|
|||||||
|
|
||||||
Name: velocity
|
Name: velocity
|
||||||
Version: %{my_version}
|
Version: %{my_version}
|
||||||
Release: 3jpp_1rh
|
Release: 3jpp_0fc
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Summary: Java-based template engine
|
Summary: Java-based template engine
|
||||||
License: Apache Software License
|
License: Apache Software License
|
||||||
Source: http://jakarta.apache.org/builds/jakarta-velocity/release/v1.4/velocity-1.4.tar.gz
|
Source: http://jakarta.apache.org/builds/jakarta-velocity/release/v1.4/velocity-1.4.tar.gz
|
||||||
Patch0: velocity-AnakiaJDOMFactory-jdom-DefaultJDOMFactory.patch
|
Patch0: velocity-AnakiaJDOMFactory-jdom-DefaultJDOMFactory.patch
|
||||||
Patch1: velocity-AnakiaTask-jdom-XMLOutputter.patch
|
Patch1: velocity-AnakiaTask-jdom-XMLOutputter.patch
|
||||||
|
Patch2: velocity-servletapi5.patch
|
||||||
|
Patch3: velocity-notexentests.patch
|
||||||
URL: http://jakarta.apache.org/velocity/
|
URL: http://jakarta.apache.org/velocity/
|
||||||
Group: Development/Libraries/Java
|
Group: Development/Libraries/Java
|
||||||
Requires: jakarta-commons-collections
|
Requires: jakarta-commons-collections
|
||||||
Requires: servlet
|
Requires: servletapi5
|
||||||
Requires: oro
|
Requires: oro
|
||||||
Requires: werken.xpath
|
Requires: werken.xpath
|
||||||
Requires: jdom >= 0:1.0-1
|
Requires: jdom >= 0:1.0-1
|
||||||
@ -27,7 +29,7 @@ BuildRequires: ant
|
|||||||
BuildRequires: antlr
|
BuildRequires: antlr
|
||||||
BuildRequires: junit
|
BuildRequires: junit
|
||||||
BuildRequires: jakarta-commons-collections
|
BuildRequires: jakarta-commons-collections
|
||||||
BuildRequires: servletapi3
|
BuildRequires: servletapi5
|
||||||
BuildRequires: oro
|
BuildRequires: oro
|
||||||
BuildRequires: jdom >= 0:1.0-1
|
BuildRequires: jdom >= 0:1.0-1
|
||||||
BuildRequires: bcel
|
BuildRequires: bcel
|
||||||
@ -91,13 +93,15 @@ find build -name '*.jar' -exec rm -f \{\} \;
|
|||||||
|
|
||||||
%patch0 -b .sav
|
%patch0 -b .sav
|
||||||
%patch1 -b .sav
|
%patch1 -b .sav
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
# -----------------------------------------------------------------------------
|
# -----------------------------------------------------------------------------
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CLASSPATH=$(build-classpath \
|
export CLASSPATH=$(build-classpath \
|
||||||
antlr \
|
antlr \
|
||||||
jakarta-commons-collections \
|
jakarta-commons-collections \
|
||||||
servletapi3 \
|
servletapi5 \
|
||||||
avalon-logkit \
|
avalon-logkit \
|
||||||
junit \
|
junit \
|
||||||
oro \
|
oro \
|
||||||
@ -150,7 +154,7 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(0644,root,root,0755)
|
%defattr(0644,root,root,0755)
|
||||||
%doc LICENSE README.txt
|
%doc LICENSE NOTICE README.txt
|
||||||
%{_javadir}/*.jar
|
%{_javadir}/*.jar
|
||||||
|
|
||||||
%files manual
|
%files manual
|
||||||
@ -168,6 +172,11 @@ fi
|
|||||||
# -----------------------------------------------------------------------------
|
# -----------------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 6 2005 Gary Benson <gbenson@redhat.com>
|
||||||
|
- Build with servletapi5.
|
||||||
|
- Add NOTICE file as per Apache License version 2.0.
|
||||||
|
- Skip some failing tests.
|
||||||
|
|
||||||
* Mon Oct 18 2004 Fernando Nasser <fnasser@redhat.com> 0:1.4-3jpp_1rh
|
* Mon Oct 18 2004 Fernando Nasser <fnasser@redhat.com> 0:1.4-3jpp_1rh
|
||||||
- First Red Hat build
|
- First Red Hat build
|
||||||
|
|
||||||
@ -185,7 +194,7 @@ fi
|
|||||||
- Patch #0 is unnecessary (upstream)
|
- Patch #0 is unnecessary (upstream)
|
||||||
- We have to build velocity against servletapi3
|
- We have to build velocity against servletapi3
|
||||||
|
|
||||||
-* Wed Feb 18 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:1.4-0.rc1.2jpp
|
* Wed Feb 18 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:1.4-0.rc1.2jpp
|
||||||
- Fix a few jpackage related .spec typos, oops.
|
- Fix a few jpackage related .spec typos, oops.
|
||||||
|
|
||||||
* Wed Feb 18 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:1.4-0.rc1.1jpp
|
* Wed Feb 18 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:1.4-0.rc1.1jpp
|
||||||
|
Loading…
Reference in New Issue
Block a user