import vdo-6.2.3.107-14.el8

This commit is contained in:
CentOS Sources 2020-07-28 04:50:50 -04:00 committed by Stepan Oksanichenko
parent 6d4e6d339f
commit 6ff2041b0f
5 changed files with 104 additions and 26 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/vdo-1d6fca8.tar.gz
SOURCES/vdo-6989127.tar.gz

View File

@ -1 +1 @@
6e5424a20087704fb41dab382d9b5769cd765215 SOURCES/vdo-1d6fca8.tar.gz
5704e88d94a666e5f3b2333fce7df1668d7177c7 SOURCES/vdo-6989127.tar.gz

View File

@ -1,12 +0,0 @@
diff -Naur vdo-bebf98eac4903b7619e10b49dababad9f5cd8535.orig/vdo-manager/vdomgmnt/VDOService.py vdo-bebf98eac4903b7619e10b49dababad9f5cd8535/vdo-manager/vdomgmnt/VDOService.py
--- vdo-bebf98eac4903b7619e10b49dababad9f5cd8535.orig/vdo-manager/vdomgmnt/VDOService.py 2018-12-14 16:50:00.000000000 -0500
+++ vdo-bebf98eac4903b7619e10b49dababad9f5cd8535/vdo-manager/vdomgmnt/VDOService.py 2018-12-14 18:04:17.051668198 -0500
@@ -1395,7 +1395,7 @@
# volumes the above check won't trigger an error. So do a second
# check that catches that.
try:
- runCommand(['blkid', '-p', self.device])
+ runCommand(['blkid', '-p', '--no-part-details', self.device])
except CommandError as e:
if e.getExitCode() == 2:
return

View File

@ -1,10 +1,10 @@
diff -Naur vdo-3ec5c4fef536f8b4420581464e9053a76d61d05a.orig/utils/vdo/user/Makefile vdo-3ec5c4fef536f8b4420581464e9053a76d61d05a/utils/vdo/user/Makefile
--- vdo-3ec5c4fef536f8b4420581464e9053a76d61d05a.orig/utils/vdo/user/Makefile 2018-11-15 21:11:35.000000000 -0500
+++ vdo-3ec5c4fef536f8b4420581464e9053a76d61d05a/utils/vdo/user/Makefile 2018-11-16 13:59:51.998828080 -0500
@@ -144,7 +144,7 @@
echo "Building $@ from $^"
diff -Naur vdo-eff92d15b7e223bc0ba93fddf1486cf771e7bf17.orig/utils/vdo/user/Makefile vdo-eff92d15b7e223bc0ba93fddf1486cf771e7bf17/utils/vdo/user/Makefile
--- vdo-eff92d15b7e223bc0ba93fddf1486cf771e7bf17.orig/utils/vdo/user/Makefile 2020-05-29 22:20:46.000000000 -0400
+++ vdo-eff92d15b7e223bc0ba93fddf1486cf771e7bf17/utils/vdo/user/Makefile 2020-06-02 19:07:57.986213915 -0400
@@ -151,7 +151,7 @@
$(CC) $(LDFLAGS) $^ $(LDPRFLAGS) -o $@
vdoformat: LDPRFLAGS += "-lblkid"
-vdodmeventd: LDPRFLAGS += "-ldevmapper-event"
+vdodmeventd: LDPRFLAGS += -ldevmapper -ldevmapper-event

View File

@ -1,8 +1,8 @@
%global commit 1d6fca8ffd8d8c3a5e969fdd935a7b3899b93659
%global gittag 6.2.2.33
%global commit 6989127a57b5886da96fdf07f3687029fc6688e6
%global gittag 6.2.3.107
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%define spec_release 12
%define spec_release 14
Summary: Management tools for Virtual Data Optimizer
Name: vdo
Version: %{gittag}
@ -10,9 +10,8 @@ Release: %{spec_release}%{?dist}
License: GPLv2
Source0: https://github.com/dm-vdo/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
Patch0: fix_dmeventd_linking.patch
Patch1: bz1658224-fix_blkid_call.patch
URL: http://github.com/dm-vdo/vdo
Requires: lvm2 >= 2.02
Requires: lvm2 >= 2.03
Requires: python3-PyYAML >= 3.10
Requires: libuuid >= 2.23
Requires: kmod-kvdo >= 6.2
@ -23,6 +22,7 @@ ExcludeArch: ppc
ExcludeArch: ppc64
ExcludeArch: i686
BuildRequires: gcc
BuildRequires: libblkid-devel
BuildRequires: libuuid-devel
BuildRequires: device-mapper-devel
BuildRequires: device-mapper-event-devel
@ -47,7 +47,6 @@ This package provides the user-space management tools for VDO.
%prep
%setup -q -n %{name}-%{commit}
%patch0 -p1
%patch1 -p1
%build
make
@ -77,12 +76,12 @@ done
%files
#defattr(-,root,root)
%{_bindir}/vdo
%{_bindir}/vdo-by-dev
%{_bindir}/vdostats
%{_bindir}/vdodmeventd
%{_bindir}/vdodumpconfig
%{_bindir}/vdoforcerebuild
%{_bindir}/vdoformat
%{_bindir}/vdoreadonly
%{_bindir}/vdosetuuid
%dir %{python3_sitelib}/%{name}
%{python3_sitelib}/%{name}/__init__.py
@ -182,10 +181,12 @@ done
%{python3_sitelib}/%{name}/utils/__pycache__/__init__.cpython-36.opt-1.pyc
%{python3_sitelib}/%{name}/utils/__pycache__/__init__.cpython-36.pyc
%{_unitdir}/vdo.service
%{_unitdir}/vdo-start-by-dev@.service
%{_presetdir}/97-vdo.preset
%dir %{_sysconfdir}/bash_completion.d
%{_sysconfdir}/bash_completion.d/vdostats
%{_sysconfdir}/bash_completion.d/vdo
%{_sysconfdir}/udev/rules.d/69-vdo-start-by-dev.rules
%dir %{_defaultdocdir}/%{name}
%license %{_defaultdocdir}/%{name}/COPYING
%dir %{_defaultdocdir}/%{name}/examples
@ -208,7 +209,96 @@ done
%{_mandir}/man8/vdoformat.8.gz
%{_mandir}/man8/vdosetuuid.8.gz
%package support
Summary: Support tools for Virtual Data Optimizer
License: GPLv2
Requires: libuuid >= 2.23
%description support
Virtual Data Optimizer (VDO) is a device mapper target that delivers
block-level deduplication, compression, and thin provisioning.
This package provides the user-space support tools for VDO.
%files support
%{_bindir}/vdoaudit
%{_bindir}/vdodebugmetadata
%{_bindir}/vdodumpblockmap
%{_bindir}/vdodumpmetadata
%{_bindir}/vdolistmetadata
%{_bindir}/vdoreadonly
%{_bindir}/vdoregenerategeometry
%{_mandir}/man8/vdoaudit.8.gz
%{_mandir}/man8/vdodebugmetadata.8.gz
%{_mandir}/man8/vdodumpblockmap.8.gz
%{_mandir}/man8/vdodumpmetadata.8.gz
%{_mandir}/man8/vdolistmetadata.8.gz
%{_mandir}/man8/vdoreadonly.8.gz
%{_mandir}/man8/vdoregenerategeometry.8.gz
%changelog
* Fri Jun 19 2020 - Andy Walsh <awalsh@redhat.com> - 6.2.3.107-14
- Fixed more Coverity errors.
- Resolves: rhbz#1827763
* Tue Jun 09 2020 - Andy Walsh <awalsh@redhat.com> - 6.2.3.100-14
- Modified vdoformat to display the minimum required physical size for the
specified parameters if the format fails due to insufficient space.
- Resolves: rhbz#1683945
- Modified the vdo status command to report values from running devices
rather than the config file when the devices are running.
- Resolves: rhbz#1790983
- Actually made the new summary mode of vdoaudit the default.
- Resolves: rhbz#1687996
- Fixed a bug in vdodumpmetadata and vdodumpblockmap which could result in
the wrong block(s) being dumped.
- Resolves: rhbz#1643297
* Tue Jun 02 2020 - Andy Walsh <awalsh@redhat.com> - 6.2.3.91-14
- Removed unused UDS bio statistics
- Resolves: rhbz#1827762
- Added a summary mode to vdoaudit and made this mode the default. Also
added histograms.
- Resolves: rhbz#1687996
- Modified vdostats to accept short (one character) options.
- Resolves: rhbz#1787472
- Modified vdo script to use lsblk to identify LVM created VDO volumes.
- Resolves: rhbz#1825344
- Modified vdo script to avoid unnecessary config file updates when
removing VDO volumes.
- Resolves: rhbz#1804440
- Fixed a cast which caused a Coverity complaint.
- Resolves: rhbz#1827763
- Fixed a cut&paste error in the vdosetuuid man page.
- Resolves: rhbz#1643297
- Fixed documentation of logical threads.
- Resolves: rhbz#1827764
- Began creation of a package of binaries for investigating VDO issues.
- Resolves: rhbz#1643297
- Updated VDO to use udev/systemd rules for startup.
- Resolves: rhbz#1837759
- Modified VDO volume creation to use libblkid instead of pvcreate to
determine whether the underlying storage is already in use. Moved
these checks from the vdo script into the vdoformat utility.
- Resolves: rhbz#1771698
- Modified the vdo status command to treat a running vdo volume is
authoratative over the config file.
- Resolves: rhbz#1790983
- Added a new utility, vdoregenerategeometry, which can be used to
recover a VDO whose initial blocks have been overwritten
accidentaly.
- Resolves: rhbz#1773421
* Tue Feb 11 2020 - Andy Walsh <awalsh@redhat.com> - 6.2.2.117-13
- Improved man pages and help text for vdo script and vdo utilities.
- Resolves: rhbz#1505748
- Resolves: rhbz#1636043
- Resolves: rhbz#1746539
- Modified vdoformat to display the maximum VDO size based on the
configured slab size when formatting a volume. Modified vdo script to
also display this output when creating a new VDO.
- Resolves: rhbz#1659173
* Mon Nov 25 2019 - Andy Walsh <awalsh@redhat.com> - 6.2.2.33-12
- Fixed bug in the import command of the vdo script which would fail if
there were no active dm devices.