* Tue Nov 25 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.0.2-1
- New upstream release - Rebased sphinx makefile patch - Added systemd services patch from Federico Schwindt
This commit is contained in:
parent
25ed9eda10
commit
b69bd435f9
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@ varnish-2.1.3.tar.gz
|
||||
/varnish-3.0.5.tar.gz
|
||||
/varnish-4.0.0.tar.gz
|
||||
/varnish-4.0.1.tar.gz
|
||||
/varnish-4.0.2.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
53e272f448b2109ab370e03d794a243f varnish-4.0.1.tar.gz
|
||||
bf86f3630605c273b1bbadbbe518237a varnish-4.0.2.tar.gz
|
||||
|
37
varnish-4.0.2-systemd_service_fixes.patch
Normal file
37
varnish-4.0.2-systemd_service_fixes.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff --git a/redhat/varnish.service b/redhat/varnish.service
|
||||
index 659dba2..a4f3355 100644
|
||||
--- a/redhat/varnish.service
|
||||
+++ b/redhat/varnish.service
|
||||
@@ -27,6 +27,7 @@ EnvironmentFile=/etc/varnish/varnish.params
|
||||
Type=forking
|
||||
PIDFile=/var/run/varnish.pid
|
||||
PrivateTmp=true
|
||||
+ExecStartPre=/usr/sbin/varnishd -C -f $VARNISH_VCL_CONF
|
||||
ExecStart=/usr/sbin/varnishd \
|
||||
-P /var/run/varnish.pid \
|
||||
-f $VARNISH_VCL_CONF \
|
||||
diff --git a/redhat/varnishlog.service b/redhat/varnishlog.service
|
||||
index 1e3e274..c7a0193 100644
|
||||
--- a/redhat/varnishlog.service
|
||||
+++ b/redhat/varnishlog.service
|
||||
@@ -1,6 +1,6 @@
|
||||
[Unit]
|
||||
Description=Varnish HTTP accelerator logging daemon
|
||||
-After=network.target
|
||||
+After=varnish.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
diff --git a/redhat/varnishncsa.service b/redhat/varnishncsa.service
|
||||
index df5f19f..e2ebdcd 100644
|
||||
--- a/redhat/varnishncsa.service
|
||||
+++ b/redhat/varnishncsa.service
|
||||
@@ -1,6 +1,6 @@
|
||||
[Unit]
|
||||
-Description=Varnish NCSA logging
|
||||
-After=network.target
|
||||
+Description=Varnish HTTP accelerator NCSA daemon
|
||||
+After=varnish.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
10
varnish-4.0.2.fix_ld_library_path_in_sphinx_build.patch
Normal file
10
varnish-4.0.2.fix_ld_library_path_in_sphinx_build.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- doc/sphinx/Makefile.in.orig 2014-10-08 09:48:47.000000000 +0200
|
||||
+++ doc/sphinx/Makefile.in 2014-11-25 22:49:55.137641462 +0100
|
||||
@@ -517,6 +517,7 @@
|
||||
rm -rf $(BUILDDIR)
|
||||
|
||||
include/params.rst: $(top_builddir)/bin/varnishd/varnishd
|
||||
+ LD_LIBRARY_PATH=$(top_builddir)/lib/libvarnish/.libs:$(top_builddir)/lib/libvarnishcompat/.libs:$(top_builddir)/lib/libvcc/.libs:$(top_builddir)/lib/libvgz/.libs \
|
||||
$(top_builddir)/bin/varnishd/varnishd -x dumprstparam > include/params.rst
|
||||
|
||||
# XXX add varnishstat here when it's been _opt2rst'ed
|
13
varnish.spec
13
varnish.spec
@ -5,8 +5,8 @@
|
||||
%define __find_provides %{_builddir}/%{name}-%{version}%{?v_rc:-%{?v_rc}}/redhat/find-provides
|
||||
Summary: High-performance HTTP accelerator
|
||||
Name: varnish
|
||||
Version: 4.0.1
|
||||
Release: 2%{?v_rc}%{?dist}.1
|
||||
Version: 4.0.2
|
||||
Release: 1%{?v_rc}%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.varnish-cache.org/
|
||||
@ -14,8 +14,9 @@ Source0: http://repo.varnish-cache.org/source/%{name}-%{version}.tar.gz
|
||||
#Source0: %{name}-%{version}%{?vd_rc}.tar.gz
|
||||
#Source0: %{name}-trunk.tar.gz
|
||||
#Source0: http://repo.varnish-cache.org/snapshots/%{name}-%{version}%{?vd_rc}.tar.gz
|
||||
Patch1: varnish-4.0.0.fix_ld_library_path_in_sphinx_build.patch
|
||||
Patch1: varnish-4.0.2.fix_ld_library_path_in_sphinx_build.patch
|
||||
Patch2: varnish-4.0.1_fix_Werror_el6.patch
|
||||
Patch3: varnish-4.0.2-systemd_service_fixes.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# To build from git, start with a make dist, see redhat/README.redhat
|
||||
# You will need at least automake autoconf libtool python-docutils
|
||||
@ -96,6 +97,7 @@ Documentation files for %name
|
||||
%if 0%{?rhel} <= 6 && 0%{?fedora} <= 12
|
||||
%patch2 -p0
|
||||
%endif
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
#export CFLAGS="$CFLAGS -Wp,-D_FORTIFY_SOURCE=0"
|
||||
@ -300,6 +302,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Nov 25 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.0.2-1
|
||||
- New upstream release
|
||||
- Rebased sphinx makefile patch
|
||||
- Added systemd services patch from Federico Schwindt
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-2.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user