New upstream release

- Rebased sphinx build patch
- Removed patch for dns corner case, it has been fixed upstream
- Removed patch for pcre madness test. It has been removed
- Added new source pkg-varnish-cache from github, replacing varnish-cache-redhat
- Also stop varnishlog and varnishncsa on package removal
- Removed redhat/README.rst. It is no longer included upstream
This commit is contained in:
Ingvar Hagelund 2016-02-01 09:16:54 +01:00
parent e580accdf7
commit 741f0ce2c6
4 changed files with 36 additions and 28 deletions

1
.gitignore vendored
View File

@ -13,3 +13,4 @@ varnish-2.1.3.tar.gz
/varnish-4.0.3.tar.gz /varnish-4.0.3.tar.gz
/varnish-4.1.0.tar.gz /varnish-4.1.0.tar.gz
/varnish-cache-redhat-f3dbcce.tar.gz /varnish-cache-redhat-f3dbcce.tar.gz
/pkg-varnish-cache-105f20b.tar.gz

View File

@ -1,2 +1,3 @@
d93e32b59c0c7487180a37781aae13f7 varnish-4.1.0.tar.gz d93e32b59c0c7487180a37781aae13f7 varnish-4.1.0.tar.gz
fcc87f5801ee05c6d808e8962893ecc1 varnish-cache-redhat-f3dbcce.tar.gz fcc87f5801ee05c6d808e8962893ecc1 varnish-cache-redhat-f3dbcce.tar.gz
d340e74053e589189cdb4a0e2a97b59b pkg-varnish-cache-105f20b.tar.gz

View File

@ -0,0 +1,10 @@
--- doc/sphinx/Makefile.in.orig 2016-01-29 08:47:23.963344825 +0100
+++ doc/sphinx/Makefile.in 2016-01-29 08:49:30.290601970 +0100
@@ -531,6 +531,7 @@
rm -rf $(BUILDDIR)
include/params.rst: $(top_builddir)/bin/varnishd/varnishd
+ LD_LIBRARY_PATH=$(top_builddir)/lib/libvarnish/.libs:$(top_builddir)/lib/libvarnishcompat/.libs:$(top_builddir)/lib/libvcc/.libs:$(top_builddir)/lib/libvgz/.libs \
$(top_builddir)/bin/varnishd/varnishd -x dumprstparam > include/params.rst
include/counters.rst: $(top_builddir)/bin/varnishstat/vsc2rst

View File

@ -5,26 +5,24 @@
%define __find_provides %{_builddir}/%{name}-%{version}%{?v_rc:-%{?v_rc}}/redhat/find-provides %define __find_provides %{_builddir}/%{name}-%{version}%{?v_rc:-%{?v_rc}}/redhat/find-provides
# Package scripts are now external # Package scripts are now external
# https://github.com/varnish/varnish-cache-redhat # https://github.com/varnishcache/pkg-varnish-cache
%define commit1 f3dbcce7ac81165af2d4796ec222e10adfb11544 %define commit1 105f20b89664f081c216d6e2c168cb8a6c090089
%global shortcommit1 %(c=%{commit1}; echo ${c:0:7}) %global shortcommit1 %(c=%{commit1}; echo ${c:0:7})
Summary: High-performance HTTP accelerator Summary: High-performance HTTP accelerator
Name: varnish Name: varnish
Version: 4.1.0 Version: 4.1.1
Release: 2%{?v_rc}%{?dist} Release: 1%{?v_rc}%{?dist}
License: BSD License: BSD
Group: System Environment/Daemons Group: System Environment/Daemons
URL: http://www.varnish-cache.org/ URL: http://www.varnish-cache.org/
Source0: http://repo.varnish-cache.org/source/%{name}-%{version}%{?vd_rc}.tar.gz Source0: http://repo.varnish-cache.org/source/%{name}-%{version}%{?vd_rc}.tar.gz
Source1: http://github.com/varnish/varnish-cache-redhat/archive/%{commit1}.tar.gz#/varnish-cache-redhat-%{shortcommit1}.tar.gz Source1: https://github.com/varnishcache/pkg-varnish-cache/archive/%{commit1}.tar.gz#/pkg-varnish-cache-%{shortcommit1}.tar.gz
Patch1: varnish-4.1.0.fix_ld_library_path_in_sphinx_build.patch Patch1: varnish-4.1.1.fix_ld_library_path_in_sphinx_build.patch
Patch2: varnish-4.0.3_fix_Werror_el6.patch Patch2: varnish-4.0.3_fix_Werror_el6.patch
Patch3: varnish-4.0.3_fix_python24.el5.patch Patch3: varnish-4.0.3_fix_python24.el5.patch
Patch4: varnish-4.0.3_fix_varnish4_selinux.el6.patch Patch4: varnish-4.0.3_fix_varnish4_selinux.el6.patch
Patch6: varnish-4.1.0.fix_find-provides.patch Patch6: varnish-4.1.0.fix_find-provides.patch
Patch7: varnish-4.1.0.fix_dns_test_corner_case_v00017.patch
Patch8: varnish-4.1.0.adjust_pcre_test_r01576.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# To build from git, start with a make dist, see redhat/README.redhat # To build from git, start with a make dist, see redhat/README.redhat
@ -84,7 +82,7 @@ Requires: gcc
%description %description
This is Varnish Cache, a high-performance HTTP accelerator. This is Varnish Cache, a high-performance HTTP accelerator.
Varnish Cache stores web pages in memory so web servers don\'t have to Varnish Cache stores web pages in memory so web servers don't have to
create the same web page over and over again. Varnish Cache serves create the same web page over and over again. Varnish Cache serves
pages much faster than any application server; giving the website a pages much faster than any application server; giving the website a
significant speed up. significant speed up.
@ -94,7 +92,7 @@ available on the following web site: https://www.varnish-cache.org/
%package libs %package libs
Summary: Libraries for %{name} Summary: Libraries for %{name}
Group: Development/Libraries Group: System Environment/Libraries
BuildRequires: ncurses-devel BuildRequires: ncurses-devel
#Obsoletes: libvarnish1 #Obsoletes: libvarnish1
%description libs %description libs
@ -141,7 +139,7 @@ Minimal selinux policy for running varnish4
%prep %prep
%setup -q -n varnish-%{version}%{?vd_rc} %setup -q -n varnish-%{version}%{?vd_rc}
tar xvzf %SOURCE1 tar xvzf %SOURCE1
ln -s varnish-cache-redhat-%{commit1} redhat ln -s pkg-varnish-cache-%{commit1}/redhat redhat
%patch1 -p0 %patch1 -p0
%if 0%{?rhel} <= 6 && 0%{?fedora} <= 12 %if 0%{?rhel} <= 6 && 0%{?fedora} <= 12
%patch2 -p0 %patch2 -p0
@ -153,8 +151,6 @@ ln -s varnish-cache-redhat-%{commit1} redhat
%patch4 -p0 %patch4 -p0
%endif %endif
%patch6 -p0 %patch6 -p0
%patch7 -p0
%patch8 -p0
%build %build
%if 0%{?rhel} == 6 %if 0%{?rhel} == 6
@ -257,7 +253,7 @@ rm -rf %{buildroot}
%else %else
%doc LICENSE %doc LICENSE
%endif %endif
%doc README redhat/README.rst ChangeLog %doc README ChangeLog
%doc etc/builtin.vcl etc/example.vcl %doc etc/builtin.vcl etc/example.vcl
%dir %{_sysconfdir}/varnish/ %dir %{_sysconfdir}/varnish/
%config(noreplace) %{_sysconfdir}/varnish/default.vcl %config(noreplace) %{_sysconfdir}/varnish/default.vcl
@ -288,10 +284,10 @@ rm -rf %{buildroot}
%files libs-devel %files libs-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_libdir}/lib*.so %{_libdir}/lib*.so
%{_includedir}/varnish %{_includedir}/%{name}
%{_libdir}/pkgconfig/varnishapi.pc %{_libdir}/pkgconfig/varnishapi.pc
%{_datadir}/%{name} %{_datadir}/%{name}
%{_datadir}/aclocal/varnish.m4 %{_datadir}/aclocal/%{name}.m4
%doc LICENSE %doc LICENSE
@ -326,18 +322,7 @@ exit 0
%post %post
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7 %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
# Fedora 17
%if 0%{?fedora} == 17
# Initial installation
if [ $1 -eq 1 ] ; then
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
fi
# Fedora 18+, rhel7+
%else
%systemd_post varnish.service %systemd_post varnish.service
%endif
# Other distros: Use chkconfig # Other distros: Use chkconfig
%else %else
@ -391,6 +376,8 @@ if [ $1 -lt 1 ]; then
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7 %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
/bin/systemctl --no-reload disable varnish.service > /dev/null 2>&1 || : /bin/systemctl --no-reload disable varnish.service > /dev/null 2>&1 || :
/bin/systemctl stop varnish.service > /dev/null 2>&1 || : /bin/systemctl stop varnish.service > /dev/null 2>&1 || :
/bin/systemctl stop varnishlog.service > /dev/null 2>&1 || :
/bin/systemctl stop varnishncsa.service > /dev/null 2>&1 || :
%else %else
/sbin/service varnish stop > /dev/null 2>&1 /sbin/service varnish stop > /dev/null 2>&1
/sbin/service varnishlog stop > /dev/null 2>&1 /sbin/service varnishlog stop > /dev/null 2>&1
@ -411,7 +398,16 @@ fi
%endif %endif
%changelog %changelog
* Thu Oct 21 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.1.0-2 * Fri Jan 29 2016 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.1.1-1
- New upstream release
- Rebased sphinx build patch
- Removed patch for dns corner case, it has been fixed upstream
- Removed patch for pcre madness test. It has been removed
- Added new source pkg-varnish-cache from github, replacing varnish-cache-redhat
- Also stop varnishlog and varnishncsa on package removal
- Removed redhat/README.rst. It is no longer included upstream
* Wed Oct 21 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.1.0-2
- Moved LICENSE to license catalog for fedora and el7 - Moved LICENSE to license catalog for fedora and el7
* Fri Oct 09 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.1.0-1 * Fri Oct 09 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> 4.1.0-1