- Added a test that enables jemalloc on ppc if the kernel is not a rhel5
kernel (as on redhat builders) - Removed tests c00031.vtc and r00387on rhel4/ppc as they fail on the Red Hat ppc builders (but works on my rhel4 ppc instance) - Added a patch that fixes broken changes-2.0.6.html in doc
This commit is contained in:
parent
9906dd3a3d
commit
044964ba12
9
varnish.changes-2.0.6.patch
Normal file
9
varnish.changes-2.0.6.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- doc/changes-2.0.5-2.0.6.xml.orig 2009-12-23 11:42:58.168643121 +0100
|
||||||
|
+++ doc/changes-2.0.5-2.0.6.xml 2009-12-23 11:43:05.827643574 +0100
|
||||||
|
@@ -49,5 +49,5 @@
|
||||||
|
<para>Document the <code>-C</code> option
|
||||||
|
to <code>varnishd</code>.</para>
|
||||||
|
</change>
|
||||||
|
- <subsystem>
|
||||||
|
+ </subsystem>
|
||||||
|
</group>
|
35
varnish.spec
35
varnish.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: High-performance HTTP accelerator
|
Summary: High-performance HTTP accelerator
|
||||||
Name: varnish
|
Name: varnish
|
||||||
Version: 2.0.6
|
Version: 2.0.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.varnish-cache.org/
|
URL: http://www.varnish-cache.org/
|
||||||
Source0: http://downloads.sourceforge.net/varnish/varnish-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/varnish/varnish-%{version}.tar.gz
|
||||||
Patch0: varnish.varnishtest_debugflag.patch
|
Patch0: varnish.varnishtest_debugflag.patch
|
||||||
|
Patch1: varnish.changes-2.0.6.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
# The svn sources needs autoconf, automake and libtool to generate a suitable
|
# The svn sources needs autoconf, automake and libtool to generate a suitable
|
||||||
# configure script. Release tarballs would not need this
|
# configure script. Release tarballs would not need this
|
||||||
@ -68,7 +69,8 @@ Varnish is a high-performance HTTP accelerator
|
|||||||
# Release tarballs would not need this
|
# Release tarballs would not need this
|
||||||
#./autogen.sh
|
#./autogen.sh
|
||||||
|
|
||||||
%patch0 -p0
|
%patch0
|
||||||
|
%patch1
|
||||||
|
|
||||||
# Hack to get 32- and 64-bits tests run concurrently on the same build machine
|
# Hack to get 32- and 64-bits tests run concurrently on the same build machine
|
||||||
case `uname -m` in
|
case `uname -m` in
|
||||||
@ -93,9 +95,12 @@ cp bin/varnishd/default.vcl etc/zope-plone.vcl examples
|
|||||||
# Remove "--disable static" if you want to build static libraries
|
# Remove "--disable static" if you want to build static libraries
|
||||||
# jemalloc is not compatible with Red Hat's ppc* RHEL5 kernel koji server :-(
|
# jemalloc is not compatible with Red Hat's ppc* RHEL5 kernel koji server :-(
|
||||||
%ifarch ppc64 ppc
|
%ifarch ppc64 ppc
|
||||||
%configure --disable-static --localstatedir=/var/lib --disable-jemalloc
|
if [[ `uname -r` =~ "2.6.18-.*" ]]
|
||||||
|
then %configure --disable-static --localstatedir=/var/lib --disable-jemalloc
|
||||||
|
else %configure --disable-static --localstatedir=/var/lib
|
||||||
|
fi
|
||||||
%else
|
%else
|
||||||
%configure --disable-static --localstatedir=/var/lib
|
%configure --disable-static --localstatedir=/var/lib
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# We have to remove rpath - not allowed in Fedora
|
# We have to remove rpath - not allowed in Fedora
|
||||||
@ -124,6 +129,11 @@ tail -n +11 etc/default.vcl >> redhat/default.vcl
|
|||||||
redhat/varnish.initrc redhat/varnishlog.initrc redhat/varnishncsa.initrc
|
redhat/varnish.initrc redhat/varnishlog.initrc redhat/varnishncsa.initrc
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Fix for broken changes-2.0.6.html
|
||||||
|
pushd doc
|
||||||
|
%{__make} clean; %{__make}
|
||||||
|
popd
|
||||||
|
|
||||||
%check
|
%check
|
||||||
# rhel5 on ppc64 is just too strange
|
# rhel5 on ppc64 is just too strange
|
||||||
%ifarch ppc64
|
%ifarch ppc64
|
||||||
@ -132,6 +142,15 @@ tail -n +11 etc/default.vcl >> redhat/default.vcl
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# The redhat ppc builders seem to have some ulimit problems?
|
||||||
|
# These tests work on a rhel4 ppc/ppc64 instance outside the builders
|
||||||
|
%ifarch ppc64 ppc
|
||||||
|
%if 0%{?rhel} == 4
|
||||||
|
rm bin/varnishtest/tests/c00031.vtc
|
||||||
|
rm bin/varnishtest/tests/r00387.vtc
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
LD_LIBRARY_PATH="lib/libvarnish/.libs:lib/libvarnishcompat/.libs:lib/libvarnishapi/.libs:lib/libvcl/.libs" bin/varnishd/varnishd -b 127.0.0.1:80 -C -n /tmp/foo
|
LD_LIBRARY_PATH="lib/libvarnish/.libs:lib/libvarnishcompat/.libs:lib/libvarnishapi/.libs:lib/libvcl/.libs" bin/varnishd/varnishd -b 127.0.0.1:80 -C -n /tmp/foo
|
||||||
%{__make} check LD_LIBRARY_PATH="../../lib/libvarnish/.libs:../../lib/libvarnishcompat/.libs:../../lib/libvarnishapi/.libs:../../lib/libvcl/.libs"
|
%{__make} check LD_LIBRARY_PATH="../../lib/libvarnish/.libs:../../lib/libvarnishcompat/.libs:../../lib/libvarnishapi/.libs:../../lib/libvcl/.libs"
|
||||||
|
|
||||||
@ -235,8 +254,16 @@ fi
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 23 2009 Ingvar Hagelund <ingvar@linpro.no> - 2.0.6-2
|
||||||
|
- Added a test that enables jemalloc on ppc if the kernel is
|
||||||
|
not a rhel5 kernel (as on redhat builders)
|
||||||
|
- Removed tests c00031.vtc and r00387on rhel4/ppc as they fail
|
||||||
|
on the Red Hat ppc builders (but works on my rhel4 ppc instance)
|
||||||
|
- Added a patch that fixes broken changes-2.0.6.html in doc
|
||||||
|
|
||||||
* Mon Dec 14 2009 Ingvar Hagelund <ingvar@linpro.no> - 2.0.6-1
|
* Mon Dec 14 2009 Ingvar Hagelund <ingvar@linpro.no> - 2.0.6-1
|
||||||
- New upstream release
|
- New upstream release
|
||||||
|
- Removed patches for libjemalloc, as they are added upstream
|
||||||
|
|
||||||
* Mon Nov 09 2009 Ingvar Hagelund <ingvar@linpro.no> - 2.0.5-1
|
* Mon Nov 09 2009 Ingvar Hagelund <ingvar@linpro.no> - 2.0.5-1
|
||||||
- New upstream release
|
- New upstream release
|
||||||
|
Loading…
Reference in New Issue
Block a user