108b6d34c2
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/valgrind.git#a37c73550f3cda4b379c1269aae78bda01a7619f
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
diff --git a/none/tests/ppc64/ldst_multiple.vgtest b/none/tests/ppc64/ldst_multiple.vgtest
|
|
index 87e668e09..22dd46c99 100644
|
|
--- a/none/tests/ppc64/ldst_multiple.vgtest
|
|
+++ b/none/tests/ppc64/ldst_multiple.vgtest
|
|
@@ -1 +1,2 @@
|
|
+prereq: ../../../tests/is_ppc64_BE
|
|
prog: ldst_multiple
|
|
--- valgrind-3.16.1/none/tests/ppc64/Makefile.am.orig 2020-10-18 20:43:34.579699246 +0200
|
|
+++ valgrind-3.16.1/none/tests/ppc64/Makefile.am 2020-10-18 20:44:52.950198040 +0200
|
|
@@ -54,17 +54,22 @@
|
|
|
|
check_PROGRAMS = \
|
|
allexec \
|
|
- lsw jm-insns round \
|
|
+ jm-insns round \
|
|
test_isa_2_06_part1 test_isa_2_06_part2 test_isa_2_06_part3 \
|
|
test_dfp1 test_dfp2 test_dfp3 test_dfp4 test_dfp5 \
|
|
test_isa_2_07_part1 test_isa_2_07_part2 \
|
|
test_isa_3_0 \
|
|
subnormal_test \
|
|
- test_tm test_touch_tm ldst_multiple data-cache-instructions \
|
|
+ test_tm test_touch_tm data-cache-instructions \
|
|
power6_mf_gpr std_reg_imm \
|
|
twi_tdi tw_td power6_bcmp
|
|
|
|
|
|
+# lsw and ldst_multiple compile (and run) only on big endian.
|
|
+if VGCONF_PLATFORMS_INCLUDE_PPC64BE_LINUX
|
|
+check_PROGRAMS += lsw ldst_multiple
|
|
+endif
|
|
+
|
|
AM_CFLAGS += @FLAG_M64@
|
|
AM_CXXFLAGS += @FLAG_M64@
|
|
AM_CCASFLAGS += @FLAG_M64@
|