valgrind/valgrind-3.10.1-kernel-4.0.patch
2015-06-19 11:40:21 +02:00

97 lines
3.2 KiB
Diff

commit bf803555d10b5b4c9223b24bf13845ee88d8f3b5
Author: cborntra <cborntra@a5019735-40e9-0310-863c-91ae7b9d1cf9>
Date: Mon Feb 23 20:19:03 2015 +0000
Fix configure for Linux kernel >= 4.0-rc1
In addition raise the minimal Linux version to 2.6 as there is almost
no test coverage for 2.4 and 2.6 was released in 2003.
git-svn-id: svn://svn.valgrind.org/valgrind/trunk@14955 a5019735-40e9-0310-863c-91ae7b9d1cf9
diff --git a/configure.ac b/configure.ac
index fe2897b..ebb0798 100644
--- a/configure.ac
+++ b/configure.ac
@@ -325,20 +325,14 @@ case "${host_os}" in
kernel=`uname -r`
case "${kernel}" in
- 2.6.*|3.*)
- AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
- AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
- ;;
-
- 2.4.*)
- AC_MSG_RESULT([2.4 family (${kernel})])
- AC_DEFINE([KERNEL_2_4], 1, [Define to 1 if you're using Linux 2.4.x])
- ;;
-
- *)
+ 0.*|1.*|2.0.*|2.1.*|2.2.*|2.3.*|2.4.*|2.5.*)
AC_MSG_RESULT([unsupported (${kernel})])
- AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
+ AC_MSG_ERROR([Valgrind needs a Linux kernel >= 2.6])
;;
+
+ *)
+ AC_MSG_RESULT([2.6 or later (${kernel})])
+ ;;
esac
;;
diff -ur valgrind-3.10.1.orig/config.h.in valgrind-3.10.1/config.h.in
--- valgrind-3.10.1.orig/config.h.in 2015-06-19 11:36:36.495314032 +0200
+++ valgrind-3.10.1/config.h.in 2015-06-19 11:36:50.000000000 +0200
@@ -280,12 +280,6 @@
/* Define to 1 if you have the `utimensat' function. */
#undef HAVE_UTIMENSAT
-/* Define to 1 if you're using Linux 2.4.x */
-#undef KERNEL_2_4
-
-/* Define to 1 if you're using Linux 2.6.x or Linux 3.x */
-#undef KERNEL_2_6
-
/* configured default page size 4k */
#undef MIPS_PAGE_SHIFT
diff -ur valgrind-3.10.1.orig/configure valgrind-3.10.1/configure
--- valgrind-3.10.1.orig/configure 2015-06-19 11:36:36.496314042 +0200
+++ valgrind-3.10.1/configure 2015-06-19 11:36:56.837523466 +0200
@@ -5554,27 +5554,16 @@
kernel=`uname -r`
case "${kernel}" in
- 2.6.*|3.*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6.x/3.x family (${kernel})" >&5
-$as_echo "2.6.x/3.x family (${kernel})" >&6; }
-
-$as_echo "#define KERNEL_2_6 1" >>confdefs.h
-
- ;;
-
- 2.4.*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.4 family (${kernel})" >&5
-$as_echo "2.4 family (${kernel})" >&6; }
-
-$as_echo "#define KERNEL_2_4 1" >>confdefs.h
-
- ;;
-
- *)
+ 0.*|1.*|2.0.*|2.1.*|2.2.*|2.3.*|2.4.*|2.5.*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: unsupported (${kernel})" >&5
$as_echo "unsupported (${kernel})" >&6; }
- as_fn_error $? "Valgrind works on kernels 2.4, 2.6" "$LINENO" 5
+ as_fn_error $? "Valgrind needs a Linux kernel >= 2.6" "$LINENO" 5
;;
+
+ *)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6 or later (${kernel})" >&5
+$as_echo "2.6 or later (${kernel})" >&6; }
+ ;;
esac
;;