import valgrind-3.16.0-2.el8
This commit is contained in:
commit
f8e239c505
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/valgrind-3.16.0.tar.bz2
|
1
.valgrind.metadata
Normal file
1
.valgrind.metadata
Normal file
@ -0,0 +1 @@
|
||||
cf9fba00b597d9baa3f673cc0960b23a40473ff1 SOURCES/valgrind-3.16.0.tar.bz2
|
64
SOURCES/valgrind-3.16.0-387-float.patch
Normal file
64
SOURCES/valgrind-3.16.0-387-float.patch
Normal file
@ -0,0 +1,64 @@
|
||||
commit 6aa4f7e7e76b40c183fb29650540d119ce1b4a4a
|
||||
Author: Julian Seward <jseward@acm.org>
|
||||
Date: Thu Jun 11 09:01:52 2020 +0200
|
||||
|
||||
expr_is_guardable, stmt_is_guardable, add_guarded_stmt_to_end_of: handle GetI/PutI cases.
|
||||
|
||||
This fixes #422715.
|
||||
|
||||
diff --git a/VEX/priv/guest_generic_bb_to_IR.c b/VEX/priv/guest_generic_bb_to_IR.c
|
||||
index 2f204c5b0..0cee970e4 100644
|
||||
--- a/VEX/priv/guest_generic_bb_to_IR.c
|
||||
+++ b/VEX/priv/guest_generic_bb_to_IR.c
|
||||
@@ -425,6 +425,7 @@ static Bool expr_is_guardable ( const IRExpr* e )
|
||||
case Iex_ITE:
|
||||
case Iex_CCall:
|
||||
case Iex_Get:
|
||||
+ case Iex_GetI:
|
||||
case Iex_Const:
|
||||
case Iex_RdTmp:
|
||||
return True;
|
||||
@@ -450,6 +451,7 @@ static Bool stmt_is_guardable ( const IRStmt* st )
|
||||
case Ist_NoOp:
|
||||
case Ist_IMark:
|
||||
case Ist_Put:
|
||||
+ case Ist_PutI:
|
||||
return True;
|
||||
// These are definitely not guardable, or at least it's way too much
|
||||
// hassle to do so.
|
||||
@@ -506,7 +508,7 @@ static void add_guarded_stmt_to_end_of ( /*MOD*/IRSB* bb,
|
||||
// Put(offs, e) ==> Put(offs, ITE(guard, e, Get(offs, sizeof(e))))
|
||||
// Which when flattened out is:
|
||||
// t1 = Get(offs, sizeof(e))
|
||||
- // t2 = ITE(guard, e, t2)
|
||||
+ // t2 = ITE(guard, e, t1)
|
||||
// Put(offs, t2)
|
||||
Int offset = st->Ist.Put.offset;
|
||||
IRExpr* e = st->Ist.Put.data;
|
||||
@@ -519,6 +521,26 @@ static void add_guarded_stmt_to_end_of ( /*MOD*/IRSB* bb,
|
||||
addStmtToIRSB(bb, IRStmt_Put(offset, IRExpr_RdTmp(t2)));
|
||||
break;
|
||||
}
|
||||
+ case Ist_PutI: {
|
||||
+ // PutI(descr,ix,bias, e) ==> Put(descr,ix,bias, ITE(guard, e, GetI(descr,ix,bias)))
|
||||
+ // Which when flattened out is:
|
||||
+ // t1 = GetI(descr,ix,bias)
|
||||
+ // t2 = ITE(guard, e, t1)
|
||||
+ // PutI(descr,ix,bias, t2)
|
||||
+ IRPutI* details = st->Ist.PutI.details;
|
||||
+ IRRegArray* descr = details->descr;
|
||||
+ IRExpr* ix = details->ix;
|
||||
+ Int bias = details->bias;
|
||||
+ IRExpr* e = details->data;
|
||||
+ IRType ty = typeOfIRExpr(bb->tyenv, e);
|
||||
+ IRTemp t1 = newIRTemp(bb->tyenv, ty);
|
||||
+ IRTemp t2 = newIRTemp(bb->tyenv, ty);
|
||||
+ addStmtToIRSB(bb, IRStmt_WrTmp(t1, IRExpr_GetI(descr,ix,bias)));
|
||||
+ addStmtToIRSB(bb, IRStmt_WrTmp(t2, IRExpr_ITE(IRExpr_RdTmp(guard),
|
||||
+ e, IRExpr_RdTmp(t1))));
|
||||
+ addStmtToIRSB(bb, IRStmt_PutI(mkIRPutI(descr,ix,bias, IRExpr_RdTmp(t2))));
|
||||
+ break;
|
||||
+ }
|
||||
case Ist_Exit: {
|
||||
// Exit(xguard, dst, jk, offsIP)
|
||||
// ==> t1 = And1(xguard, guard)
|
117
SOURCES/valgrind-3.16.0-pkglibexecdir.patch
Normal file
117
SOURCES/valgrind-3.16.0-pkglibexecdir.patch
Normal file
@ -0,0 +1,117 @@
|
||||
diff --git a/Makefile.all.am b/Makefile.all.am
|
||||
index 3786e34..1befef5 100644
|
||||
--- a/Makefile.all.am
|
||||
+++ b/Makefile.all.am
|
||||
@@ -50,20 +50,20 @@ inplace-noinst_DSYMS: build-noinst_DSYMS
|
||||
done
|
||||
|
||||
# This is used by coregrind/Makefile.am and by <tool>/Makefile.am for doing
|
||||
-# "make install". It copies $(noinst_PROGRAMS) into $prefix/lib/valgrind/.
|
||||
+# "make install". It copies $(noinst_PROGRAMS) into $prefix/libexec/valgrind/.
|
||||
# It needs to be depended on by an 'install-exec-local' rule.
|
||||
install-noinst_PROGRAMS: $(noinst_PROGRAMS)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(pkglibdir); \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir); \
|
||||
for f in $(noinst_PROGRAMS); do \
|
||||
- $(INSTALL_PROGRAM) $$f $(DESTDIR)$(pkglibdir); \
|
||||
+ $(INSTALL_PROGRAM) $$f $(DESTDIR)$(pkglibexecdir); \
|
||||
done
|
||||
|
||||
# This is used by coregrind/Makefile.am and by <tool>/Makefile.am for doing
|
||||
-# "make uninstall". It removes $(noinst_PROGRAMS) from $prefix/lib/valgrind/.
|
||||
+# "make uninstall". It removes $(noinst_PROGRAMS) from $prefix/libexec/valgrind/.
|
||||
# It needs to be depended on by an 'uninstall-local' rule.
|
||||
uninstall-noinst_PROGRAMS:
|
||||
for f in $(noinst_PROGRAMS); do \
|
||||
- rm -f $(DESTDIR)$(pkglibdir)/$$f; \
|
||||
+ rm -f $(DESTDIR)$(pkglibexecdir)/$$f; \
|
||||
done
|
||||
|
||||
# Similar to install-noinst_PROGRAMS.
|
||||
@@ -71,15 +71,15 @@ uninstall-noinst_PROGRAMS:
|
||||
# directories. XXX: not sure whether the resulting permissions will be
|
||||
# correct when using 'cp -R'...
|
||||
install-noinst_DSYMS: build-noinst_DSYMS
|
||||
- $(mkinstalldirs) $(DESTDIR)$(pkglibdir); \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir); \
|
||||
for f in $(noinst_DSYMS); do \
|
||||
- cp -R $$f.dSYM $(DESTDIR)$(pkglibdir); \
|
||||
+ cp -R $$f.dSYM $(DESTDIR)$(pkglibexecdir); \
|
||||
done
|
||||
|
||||
# Similar to uninstall-noinst_PROGRAMS.
|
||||
uninstall-noinst_DSYMS:
|
||||
for f in $(noinst_DSYMS); do \
|
||||
- rm -f $(DESTDIR)$(pkglibdir)/$$f.dSYM; \
|
||||
+ rm -f $(DESTDIR)$(pkglibexecdir)/$$f.dSYM; \
|
||||
done
|
||||
|
||||
# This needs to be depended on by a 'clean-local' rule.
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 242b38a..3b7c806 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -58,7 +58,7 @@ DEFAULT_SUPP_FILES = @DEFAULT_SUPP@
|
||||
# default.supp, as it is built from the base .supp files at compile-time.
|
||||
dist_noinst_DATA = $(SUPP_FILES)
|
||||
|
||||
-vglibdir = $(pkglibdir)
|
||||
+vglibdir = $(pkglibexecdir)
|
||||
vglib_DATA = default.supp
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
diff --git a/coregrind/Makefile.am b/coregrind/Makefile.am
|
||||
index 94030fd..f09763a 100644
|
||||
--- a/coregrind/Makefile.am
|
||||
+++ b/coregrind/Makefile.am
|
||||
@@ -11,12 +11,12 @@ include $(top_srcdir)/Makefile.all.am
|
||||
|
||||
AM_CPPFLAGS_@VGCONF_PLATFORM_PRI_CAPS@ += \
|
||||
-I$(top_srcdir)/coregrind \
|
||||
- -DVG_LIBDIR="\"$(pkglibdir)"\" \
|
||||
+ -DVG_LIBDIR="\"$(pkglibexecdir)"\" \
|
||||
-DVG_PLATFORM="\"@VGCONF_ARCH_PRI@-@VGCONF_OS@\""
|
||||
if VGCONF_HAVE_PLATFORM_SEC
|
||||
AM_CPPFLAGS_@VGCONF_PLATFORM_SEC_CAPS@ += \
|
||||
-I$(top_srcdir)/coregrind \
|
||||
- -DVG_LIBDIR="\"$(pkglibdir)"\" \
|
||||
+ -DVG_LIBDIR="\"$(pkglibexecdir)"\" \
|
||||
-DVG_PLATFORM="\"@VGCONF_ARCH_SEC@-@VGCONF_OS@\""
|
||||
endif
|
||||
|
||||
@@ -714,7 +714,7 @@ GDBSERVER_XML_FILES = \
|
||||
m_gdbserver/mips64-fpu.xml
|
||||
|
||||
# so as to make sure these get copied into the install tree
|
||||
-vglibdir = $(pkglibdir)
|
||||
+vglibdir = $(pkglibexecdir)
|
||||
vglib_DATA = $(GDBSERVER_XML_FILES)
|
||||
|
||||
# so as to make sure these get copied into the tarball
|
||||
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
|
||||
index 7ad9a25..471fee0 100644
|
||||
--- a/mpi/Makefile.am
|
||||
+++ b/mpi/Makefile.am
|
||||
@@ -18,16 +18,18 @@ EXTRA_DIST = \
|
||||
# libmpiwrap-<platform>.so
|
||||
#----------------------------------------------------------------------------
|
||||
|
||||
-noinst_PROGRAMS =
|
||||
+# These are really real libraries, so they should go to libdir, not libexec.
|
||||
+mpidir = $(pkglibdir)
|
||||
+mpi_PROGRAMS =
|
||||
if BUILD_MPIWRAP_PRI
|
||||
-noinst_PROGRAMS += libmpiwrap-@VGCONF_ARCH_PRI@-@VGCONF_OS@.so
|
||||
+mpi_PROGRAMS += libmpiwrap-@VGCONF_ARCH_PRI@-@VGCONF_OS@.so
|
||||
endif
|
||||
if BUILD_MPIWRAP_SEC
|
||||
-noinst_PROGRAMS += libmpiwrap-@VGCONF_ARCH_SEC@-@VGCONF_OS@.so
|
||||
+mpi_PROGRAMS += libmpiwrap-@VGCONF_ARCH_SEC@-@VGCONF_OS@.so
|
||||
endif
|
||||
|
||||
if VGCONF_OS_IS_DARWIN
|
||||
-noinst_DSYMS = $(noinst_PROGRAMS)
|
||||
+mpi_DSYMS = $(mpi_PROGRAMS)
|
||||
endif
|
||||
|
||||
|
29
SOURCES/valgrind-3.16.0-ppc-L-field.patch
Normal file
29
SOURCES/valgrind-3.16.0-ppc-L-field.patch
Normal file
@ -0,0 +1,29 @@
|
||||
commit fb6f7abcbc92506d302fb18a2c5fc853d2929248
|
||||
Author: Carl Love <cel@us.ibm.com>
|
||||
Date: Tue Jun 9 10:42:03 2020 -0500
|
||||
|
||||
Power PC Fix extraction of the L field for sync instruction
|
||||
|
||||
The L field is currently a two bit[22:21] field in ISA 3.0. The size of the
|
||||
L field has changed over time.
|
||||
|
||||
Currently the ISA 3.0 Valgrind sync instruction support code sets the
|
||||
flag_L for the instruction L field to a five bit value that includes bits
|
||||
that are marked reserved the sync instruction. This patch fixes the issue for ISA 3.0
|
||||
to only setting flag_L the specified two bits.
|
||||
|
||||
Valgrind bugzilla: https://bugs.kde.org/show_bug.cgi?id=422677
|
||||
|
||||
diff --git a/VEX/priv/guest_ppc_toIR.c b/VEX/priv/guest_ppc_toIR.c
|
||||
index 582c59ec0..c4965a19e 100644
|
||||
--- a/VEX/priv/guest_ppc_toIR.c
|
||||
+++ b/VEX/priv/guest_ppc_toIR.c
|
||||
@@ -8777,7 +8777,7 @@ static Bool dis_memsync ( UInt theInstr )
|
||||
/* X-Form, XL-Form */
|
||||
UChar opc1 = ifieldOPC(theInstr);
|
||||
UInt b11to25 = IFIELD(theInstr, 11, 15);
|
||||
- UChar flag_L = ifieldRegDS(theInstr);
|
||||
+ UChar flag_L = IFIELD(theInstr, 21, 2); //ISA 3.0
|
||||
UInt b11to20 = IFIELD(theInstr, 11, 10);
|
||||
UInt M0 = IFIELD(theInstr, 11, 5);
|
||||
UChar rD_addr = ifieldRegDS(theInstr);
|
72
SOURCES/valgrind-3.16.0-some-Wl-z-now.patch
Normal file
72
SOURCES/valgrind-3.16.0-some-Wl-z-now.patch
Normal file
@ -0,0 +1,72 @@
|
||||
commit d3c977726064ba09fed6dfc7daf22b16824c97b4
|
||||
Author: Mark Wielaard <mark@klomp.org>
|
||||
Date: Fri May 24 18:24:56 2019 +0200
|
||||
|
||||
Add -Wl,-z,now to some binaries.
|
||||
|
||||
diff --git a/auxprogs/Makefile.am b/auxprogs/Makefile.am
|
||||
index 1b7842b..e211eec 100644
|
||||
--- a/auxprogs/Makefile.am
|
||||
+++ b/auxprogs/Makefile.am
|
||||
@@ -32,7 +32,7 @@ valgrind_listener_SOURCES = valgrind-listener.c
|
||||
valgrind_listener_CPPFLAGS = $(AM_CPPFLAGS_PRI) -I$(top_srcdir)/coregrind
|
||||
valgrind_listener_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
valgrind_listener_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-valgrind_listener_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
+valgrind_listener_LDFLAGS = $(AM_CFLAGS_PRI) -Wl,-z,now
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
||||
valgrind_listener_CFLAGS += -static
|
||||
endif
|
||||
@@ -51,7 +51,7 @@ valgrind_di_server_SOURCES = valgrind-di-server.c
|
||||
valgrind_di_server_CPPFLAGS = $(AM_CPPFLAGS_PRI) -I$(top_srcdir)/coregrind
|
||||
valgrind_di_server_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
valgrind_di_server_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-valgrind_di_server_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
+valgrind_di_server_LDFLAGS = $(AM_CFLAGS_PRI) -Wl,-z,now
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
||||
valgrind_di_server_CFLAGS += -static
|
||||
endif
|
||||
@@ -86,7 +86,7 @@ getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_SOURCES = getoff.c
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CPPFLAGS = $(AM_CPPFLAGS_@VGCONF_PLATFORM_PRI_CAPS@)
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CFLAGS = $(AM_CFLAGS_@VGCONF_PLATFORM_PRI_CAPS@) -fstack-protector-strong
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
+getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@ -Wl,-z,now
|
||||
if HAVE_DLINFO_RTLD_DI_TLS_MODID
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDADD = $(LDADD) -ldl
|
||||
endif
|
||||
diff --git a/cachegrind/Makefile.am b/cachegrind/Makefile.am
|
||||
index f572741..1c07e50 100644
|
||||
--- a/cachegrind/Makefile.am
|
||||
+++ b/cachegrind/Makefile.am
|
||||
@@ -27,7 +27,7 @@ cg_merge_SOURCES = cg_merge.c
|
||||
cg_merge_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
cg_merge_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
cg_merge_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-cg_merge_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
+cg_merge_LDFLAGS = $(AM_CFLAGS_PRI) -Wl,-z,now
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
# then the primary platform must be x86-darwin. Hence:
|
||||
if ! VGCONF_HAVE_PLATFORM_SEC
|
||||
diff --git a/coregrind/Makefile.am b/coregrind/Makefile.am
|
||||
index 3c73210..fb6b7bb 100644
|
||||
--- a/coregrind/Makefile.am
|
||||
+++ b/coregrind/Makefile.am
|
||||
@@ -57,7 +57,7 @@ RANLIB = ${LTO_RANLIB}
|
||||
valgrind_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
valgrind_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS) -fstack-protector-strong
|
||||
valgrind_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-valgrind_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
+valgrind_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@ -Wl,-z,now
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
# then the primary platform must be x86-darwin. Hence:
|
||||
if ! VGCONF_HAVE_PLATFORM_SEC
|
||||
@@ -96,7 +96,7 @@ endif
|
||||
vgdb_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
vgdb_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS) -fstack-protector-strong
|
||||
vgdb_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-vgdb_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
+vgdb_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@ -Wl,-z,now
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
||||
vgdb_CFLAGS += -static
|
||||
endif
|
118
SOURCES/valgrind-3.16.0-some-stack-protector.patch
Normal file
118
SOURCES/valgrind-3.16.0-some-stack-protector.patch
Normal file
@ -0,0 +1,118 @@
|
||||
commit b73fb7a614e1b5d60af23fb0752b5cead995e02e
|
||||
Author: Mark Wielaard <mark@klomp.org>
|
||||
Date: Sun Apr 14 00:30:05 2019 +0200
|
||||
|
||||
Remove no-stack-protector, add stack-protector-strong to some.
|
||||
|
||||
diff --git a/auxprogs/Makefile.am b/auxprogs/Makefile.am
|
||||
index 56cc5ef..1b7842b 100644
|
||||
--- a/auxprogs/Makefile.am
|
||||
+++ b/auxprogs/Makefile.am
|
||||
@@ -30,7 +30,7 @@ bin_PROGRAMS = valgrind-listener valgrind-di-server
|
||||
|
||||
valgrind_listener_SOURCES = valgrind-listener.c
|
||||
valgrind_listener_CPPFLAGS = $(AM_CPPFLAGS_PRI) -I$(top_srcdir)/coregrind
|
||||
-valgrind_listener_CFLAGS = $(AM_CFLAGS_PRI)
|
||||
+valgrind_listener_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
valgrind_listener_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
valgrind_listener_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
||||
@@ -49,7 +49,7 @@ endif
|
||||
|
||||
valgrind_di_server_SOURCES = valgrind-di-server.c
|
||||
valgrind_di_server_CPPFLAGS = $(AM_CPPFLAGS_PRI) -I$(top_srcdir)/coregrind
|
||||
-valgrind_di_server_CFLAGS = $(AM_CFLAGS_PRI)
|
||||
+valgrind_di_server_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
valgrind_di_server_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
valgrind_di_server_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
||||
@@ -84,7 +84,7 @@ endif
|
||||
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_SOURCES = getoff.c
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CPPFLAGS = $(AM_CPPFLAGS_@VGCONF_PLATFORM_PRI_CAPS@)
|
||||
-getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CFLAGS = $(AM_CFLAGS_@VGCONF_PLATFORM_PRI_CAPS@)
|
||||
+getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CFLAGS = $(AM_CFLAGS_@VGCONF_PLATFORM_PRI_CAPS@) -fstack-protector-strong
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
if HAVE_DLINFO_RTLD_DI_TLS_MODID
|
||||
diff --git a/cachegrind/Makefile.am b/cachegrind/Makefile.am
|
||||
index f8447a1..f572741 100644
|
||||
--- a/cachegrind/Makefile.am
|
||||
+++ b/cachegrind/Makefile.am
|
||||
@@ -25,7 +25,7 @@ bin_PROGRAMS = cg_merge
|
||||
|
||||
cg_merge_SOURCES = cg_merge.c
|
||||
cg_merge_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
-cg_merge_CFLAGS = $(AM_CFLAGS_PRI)
|
||||
+cg_merge_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
cg_merge_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
cg_merge_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f8c798b..ccc8f52 100755
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2188,24 +2188,24 @@ AC_LANG(C)
|
||||
AC_SUBST(FLAG_FALIGNED_NEW)
|
||||
|
||||
# does this compiler support -fno-stack-protector ?
|
||||
-AC_MSG_CHECKING([if gcc accepts -fno-stack-protector])
|
||||
-
|
||||
-safe_CFLAGS=$CFLAGS
|
||||
-CFLAGS="-fno-stack-protector -Werror"
|
||||
-
|
||||
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
|
||||
- return 0;
|
||||
-]])], [
|
||||
-no_stack_protector=yes
|
||||
-FLAG_FNO_STACK_PROTECTOR="-fno-stack-protector"
|
||||
-AC_MSG_RESULT([yes])
|
||||
-], [
|
||||
-no_stack_protector=no
|
||||
+#AC_MSG_CHECKING([if gcc accepts -fno-stack-protector])
|
||||
+#
|
||||
+#safe_CFLAGS=$CFLAGS
|
||||
+#CFLAGS="-fno-stack-protector -Werror"
|
||||
+#
|
||||
+#AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
|
||||
+# return 0;
|
||||
+#]])], [
|
||||
+#no_stack_protector=yes
|
||||
+#FLAG_FNO_STACK_PROTECTOR="-fno-stack-protector"
|
||||
+#AC_MSG_RESULT([yes])
|
||||
+#], [
|
||||
+#no_stack_protector=no
|
||||
FLAG_FNO_STACK_PROTECTOR=""
|
||||
-AC_MSG_RESULT([no])
|
||||
-])
|
||||
-CFLAGS=$safe_CFLAGS
|
||||
-
|
||||
+#AC_MSG_RESULT([no])
|
||||
+#])
|
||||
+#CFLAGS=$safe_CFLAGS
|
||||
+#
|
||||
AC_SUBST(FLAG_FNO_STACK_PROTECTOR)
|
||||
|
||||
# does this compiler support -finline-functions ?
|
||||
diff --git a/coregrind/Makefile.am b/coregrind/Makefile.am
|
||||
index 94030fd..3c73210 100644
|
||||
--- a/coregrind/Makefile.am
|
||||
+++ b/coregrind/Makefile.am
|
||||
@@ -55,7 +55,7 @@ AR = ${LTO_AR}
|
||||
RANLIB = ${LTO_RANLIB}
|
||||
|
||||
valgrind_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
-valgrind_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS)
|
||||
+valgrind_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS) -fstack-protector-strong
|
||||
valgrind_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
valgrind_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
@@ -94,7 +94,7 @@ vgdb_SOURCES += vgdb-invoker-solaris.c
|
||||
endif
|
||||
|
||||
vgdb_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
-vgdb_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS)
|
||||
+vgdb_CFLAGS = $(AM_CFLAGS_PRI) $(LTO_CFLAGS) -fstack-protector-strong
|
||||
vgdb_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
vgdb_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
if VGCONF_PLATVARIANT_IS_ANDROID
|
54
SOURCES/valgrind-3.9.0-cachegrind-improvements.patch
Normal file
54
SOURCES/valgrind-3.9.0-cachegrind-improvements.patch
Normal file
@ -0,0 +1,54 @@
|
||||
--- valgrind-3.8.1/cachegrind/cg_sim.c.jj 2011-10-26 23:24:32.000000000 +0200
|
||||
+++ valgrind-3.8.1/cachegrind/cg_sim.c 2011-12-09 17:31:19.256023683 +0100
|
||||
@@ -42,27 +42,30 @@ typedef struct {
|
||||
Int size; /* bytes */
|
||||
Int assoc;
|
||||
Int line_size; /* bytes */
|
||||
- Int sets;
|
||||
Int sets_min_1;
|
||||
Int line_size_bits;
|
||||
Int tag_shift;
|
||||
- HChar desc_line[128]; /* large enough */
|
||||
UWord* tags;
|
||||
-} cache_t2;
|
||||
+ HChar desc_line[128];
|
||||
+} cache_t2
|
||||
+#ifdef __GNUC__
|
||||
+__attribute__ ((aligned (8 * sizeof (Int))))
|
||||
+#endif
|
||||
+;
|
||||
|
||||
/* By this point, the size/assoc/line_size has been checked. */
|
||||
static void cachesim_initcache(cache_t config, cache_t2* c)
|
||||
{
|
||||
- Int i;
|
||||
+ Int sets;
|
||||
|
||||
c->size = config.size;
|
||||
c->assoc = config.assoc;
|
||||
c->line_size = config.line_size;
|
||||
|
||||
- c->sets = (c->size / c->line_size) / c->assoc;
|
||||
- c->sets_min_1 = c->sets - 1;
|
||||
+ sets = (c->size / c->line_size) / c->assoc;
|
||||
+ c->sets_min_1 = sets - 1;
|
||||
c->line_size_bits = VG_(log2)(c->line_size);
|
||||
- c->tag_shift = c->line_size_bits + VG_(log2)(c->sets);
|
||||
+ c->tag_shift = c->line_size_bits + VG_(log2)(sets);
|
||||
|
||||
if (c->assoc == 1) {
|
||||
VG_(sprintf)(c->desc_line, "%d B, %d B, direct-mapped",
|
||||
@@ -72,11 +75,8 @@ static void cachesim_initcache(cache_t c
|
||||
c->size, c->line_size, c->assoc);
|
||||
}
|
||||
|
||||
- c->tags = VG_(malloc)("cg.sim.ci.1",
|
||||
- sizeof(UWord) * c->sets * c->assoc);
|
||||
-
|
||||
- for (i = 0; i < c->sets * c->assoc; i++)
|
||||
- c->tags[i] = 0;
|
||||
+ c->tags = VG_(calloc)("cg.sim.ci.1",
|
||||
+ sizeof(UWord), sets * c->assoc);
|
||||
}
|
||||
|
||||
/* This attribute forces GCC to inline the function, getting rid of a
|
15
SOURCES/valgrind-3.9.0-helgrind-race-supp.patch
Normal file
15
SOURCES/valgrind-3.9.0-helgrind-race-supp.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- valgrind/glibc-2.34567-NPTL-helgrind.supp.jj 2009-08-19 15:37:48.000000000 +0200
|
||||
+++ valgrind/glibc-2.34567-NPTL-helgrind.supp 2009-10-21 16:46:31.000000000 +0200
|
||||
@@ -88,6 +88,12 @@
|
||||
obj:*/lib*/libpthread-2.*so*
|
||||
}
|
||||
{
|
||||
+ helgrind-glibc2X-102a
|
||||
+ Helgrind:Race
|
||||
+ fun:mythread_wrapper
|
||||
+ obj:*vgpreload_helgrind*.so
|
||||
+}
|
||||
+{
|
||||
helgrind-glibc2X-103
|
||||
Helgrind:Race
|
||||
fun:pthread_cond_*@@GLIBC_2.*
|
28
SOURCES/valgrind-3.9.0-ldso-supp.patch
Normal file
28
SOURCES/valgrind-3.9.0-ldso-supp.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- valgrind/glibc-2.X.supp.in.jj 2011-10-26 23:24:45.000000000 +0200
|
||||
+++ valgrind/glibc-2.X.supp.in 2012-05-07 10:55:20.395942656 +0200
|
||||
@@ -124,7 +124,7 @@
|
||||
glibc-2.5.x-on-SUSE-10.2-(PPC)-2a
|
||||
Memcheck:Cond
|
||||
fun:index
|
||||
- obj:*ld-@GLIBC_VERSION@.*.so
|
||||
+ obj:*ld-@GLIBC_VERSION@*.so
|
||||
}
|
||||
{
|
||||
glibc-2.5.x-on-SuSE-10.2-(PPC)-2b
|
||||
@@ -136,14 +136,14 @@
|
||||
glibc-2.5.5-on-SuSE-10.2-(PPC)-2c
|
||||
Memcheck:Addr4
|
||||
fun:index
|
||||
- obj:*ld-@GLIBC_VERSION@.*.so
|
||||
+ obj:*ld-@GLIBC_VERSION@*.so
|
||||
}
|
||||
{
|
||||
glibc-2.3.5-on-SuSE-10.1-(PPC)-3
|
||||
Memcheck:Addr4
|
||||
fun:*wordcopy_fwd_dest_aligned*
|
||||
fun:mem*cpy
|
||||
- obj:*lib*@GLIBC_VERSION@.*.so
|
||||
+ obj:*lib*@GLIBC_VERSION@*.so
|
||||
}
|
||||
|
||||
{
|
1774
SPECS/valgrind.spec
Normal file
1774
SPECS/valgrind.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user