3.8.1-26 Allow building against glibc 2.18. (#999169)
This commit is contained in:
parent
c0730c1d63
commit
e9da74b7d6
@ -76,3 +76,76 @@ diff -ur valgrind-3.8.1/configure valgrind-3.8.1/configure
|
|||||||
as_fn_error "or Darwin libc" "$LINENO" 5
|
as_fn_error "or Darwin libc" "$LINENO" 5
|
||||||
;;
|
;;
|
||||||
esac
|
esac
|
||||||
|
commit 73f797992296ec0f23db6d97d15f48de8da1304c
|
||||||
|
Author: mjw <mjw@a5019735-40e9-0310-863c-91ae7b9d1cf9>
|
||||||
|
Date: Wed Aug 21 14:47:52 2013 +0000
|
||||||
|
|
||||||
|
Accept glibc 2.18 as valid.
|
||||||
|
|
||||||
|
git-svn-id: svn://svn.valgrind.org/valgrind/trunk@13504 a5019735-40e9-0310-863c-91ae7b9d1cf9
|
||||||
|
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index c51f465..58dc221 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -906,6 +906,13 @@ case "${GLIBC_VERSION}" in
|
||||||
|
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
;;
|
||||||
|
+ 2.18)
|
||||||
|
+ AC_MSG_RESULT(2.18 family)
|
||||||
|
+ AC_DEFINE([GLIBC_2_18], 1, [Define to 1 if you're using glibc 2.18.x])
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
+ ;;
|
||||||
|
darwin)
|
||||||
|
AC_MSG_RESULT(Darwin)
|
||||||
|
AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
|
||||||
|
Only in valgrind-3.8.1: autom4te.cache
|
||||||
|
diff -ur valgrind-3.8.1.orig/config.h.in valgrind-3.8.1/config.h.in
|
||||||
|
--- valgrind-3.8.1.orig/config.h.in 2013-08-21 17:11:19.960147623 +0200
|
||||||
|
+++ valgrind-3.8.1/config.h.in 2013-08-21 17:12:32.000000000 +0200
|
||||||
|
@@ -51,6 +51,9 @@
|
||||||
|
/* Define to 1 if you're using glibc 2.17.x */
|
||||||
|
#undef GLIBC_2_17
|
||||||
|
|
||||||
|
+/* Define to 1 if you're using glibc 2.18.x */
|
||||||
|
+#undef GLIBC_2_18
|
||||||
|
+
|
||||||
|
/* Define to 1 if you're using glibc 2.2.x */
|
||||||
|
#undef GLIBC_2_2
|
||||||
|
|
||||||
|
Only in valgrind-3.8.1: config.h.in~
|
||||||
|
diff -ur valgrind-3.8.1.orig/configure valgrind-3.8.1/configure
|
||||||
|
--- valgrind-3.8.1.orig/configure 2013-08-21 17:11:20.000147954 +0200
|
||||||
|
+++ valgrind-3.8.1/configure 2013-08-21 17:12:37.875793204 +0200
|
||||||
|
@@ -6623,6 +6623,16 @@
|
||||||
|
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
;;
|
||||||
|
+ 2.18)
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.18 family" >&5
|
||||||
|
+$as_echo "2.18 family" >&6; }
|
||||||
|
+
|
||||||
|
+$as_echo "#define GLIBC_2_18 1" >>confdefs.h
|
||||||
|
+
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
+ ;;
|
||||||
|
darwin)
|
||||||
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Darwin" >&5
|
||||||
|
$as_echo "Darwin" >&6; }
|
||||||
|
diff -ur valgrind-3.8.1.orig/Makefile.in valgrind-3.8.1/Makefile.in
|
||||||
|
--- valgrind-3.8.1.orig/Makefile.in 2013-08-21 17:11:19.983147813 +0200
|
||||||
|
+++ valgrind-3.8.1/Makefile.in 2013-08-21 17:12:37.559790584 +0200
|
||||||
|
@@ -871,7 +871,7 @@
|
||||||
|
*.zip*) \
|
||||||
|
unzip $(distdir).zip ;;\
|
||||||
|
esac
|
||||||
|
- chmod -R a-w $(distdir); chmod a+w $(distdir)
|
||||||
|
+ chmod -R a-w $(distdir); chmod u+w $(distdir)
|
||||||
|
mkdir $(distdir)/_build
|
||||||
|
mkdir $(distdir)/_inst
|
||||||
|
chmod a-w $(distdir)
|
@ -3,7 +3,7 @@
|
|||||||
Summary: Tool for finding memory management bugs in programs
|
Summary: Tool for finding memory management bugs in programs
|
||||||
Name: %{?scl_prefix}valgrind
|
Name: %{?scl_prefix}valgrind
|
||||||
Version: 3.8.1
|
Version: 3.8.1
|
||||||
Release: 25%{?dist}
|
Release: 26%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://www.valgrind.org/
|
URL: http://www.valgrind.org/
|
||||||
@ -136,7 +136,8 @@ Patch31: valgrind-3.8.1-ppc-32-mode-64-bit-instr.patch
|
|||||||
Patch32: valgrind-3.8.1-sigill_diag.patch
|
Patch32: valgrind-3.8.1-sigill_diag.patch
|
||||||
|
|
||||||
# Allow building against glibc-2.17. Upstream commit svn 13228.
|
# Allow building against glibc-2.17. Upstream commit svn 13228.
|
||||||
Patch33: valgrind-3.8.1-glibc-2.17.patch
|
# Allow building against glibc-2.18. Upstream commit svn 13504.
|
||||||
|
Patch33: valgrind-3.8.1-glibc-2.17-18.patch
|
||||||
|
|
||||||
# KDE#315441 - sendmsg syscall should ignore unset msghdr msg_flags
|
# KDE#315441 - sendmsg syscall should ignore unset msghdr msg_flags
|
||||||
Patch34: valgrind-3.8.1-sendmsg-flags.patch
|
Patch34: valgrind-3.8.1-sendmsg-flags.patch
|
||||||
@ -497,6 +498,9 @@ echo ===============END TESTING===============
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 21 2013 Mark Wielaard <mjw@redhat.com> - 3.8.1-26
|
||||||
|
- Allow building against glibc 2.18.
|
||||||
|
|
||||||
* Thu Aug 15 2013 Mark Wielaard <mjw@redhat.com> - 3.8.1-25
|
* Thu Aug 15 2013 Mark Wielaard <mjw@redhat.com> - 3.8.1-25
|
||||||
- Add valgrind-3.8.1-s390-STFLE.patch
|
- Add valgrind-3.8.1-s390-STFLE.patch
|
||||||
s390 message-security assist (MSA) instruction extension not implemented.
|
s390 message-security assist (MSA) instruction extension not implemented.
|
||||||
|
Loading…
Reference in New Issue
Block a user