import valgrind-3.18.1-1.el8
This commit is contained in:
parent
c01b9b3e45
commit
d54d710772
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/valgrind-3.17.0.tar.bz2
|
||||
SOURCES/valgrind-3.18.1.tar.bz2
|
||||
|
@ -1 +1 @@
|
||||
7770912c7465f93a90c5a9d5c1b1b036ebec04fd SOURCES/valgrind-3.17.0.tar.bz2
|
||||
0a694a8d0c2152978bf64b67ad0b3dd972bbeb54 SOURCES/valgrind-3.18.1.tar.bz2
|
||||
|
@ -1,21 +0,0 @@
|
||||
commit e08a82991a9b9dc87c13f2b89273f25f97d14baf
|
||||
Author: Tom Hughes <tom@compton.nu>
|
||||
Date: Tue Apr 6 22:44:36 2021 +0100
|
||||
|
||||
Only process clone results in the parent thread
|
||||
|
||||
Fixes BZ#423963
|
||||
|
||||
diff --git a/coregrind/m_syswrap/syswrap-linux.c b/coregrind/m_syswrap/syswrap-linux.c
|
||||
index 5ae4e6613..c59d8ee26 100644
|
||||
--- a/coregrind/m_syswrap/syswrap-linux.c
|
||||
+++ b/coregrind/m_syswrap/syswrap-linux.c
|
||||
@@ -940,7 +940,7 @@ PRE(sys_clone)
|
||||
("Valgrind does not support general clone().");
|
||||
}
|
||||
|
||||
- if (SUCCESS) {
|
||||
+ if (SUCCESS && RES != 0) {
|
||||
if (ARG_FLAGS & (VKI_CLONE_PARENT_SETTID | VKI_CLONE_PIDFD))
|
||||
POST_MEM_WRITE(ARG3, sizeof(Int));
|
||||
if (ARG_FLAGS & (VKI_CLONE_CHILD_SETTID | VKI_CLONE_CHILD_CLEARTID))
|
@ -1,30 +0,0 @@
|
||||
commit 93104368952c37268da724231487058ea3eaf1dc
|
||||
Author: Tom Hughes <tom@compton.nu>
|
||||
Date: Thu May 20 17:16:06 2021 +0100
|
||||
|
||||
Don't look for separate debuginfo if the image has a .debug_info section
|
||||
|
||||
Fixes BZ#435908
|
||||
|
||||
diff --git a/coregrind/m_debuginfo/readelf.c b/coregrind/m_debuginfo/readelf.c
|
||||
index b0f062ddc..e424e3e7e 100644
|
||||
--- a/coregrind/m_debuginfo/readelf.c
|
||||
+++ b/coregrind/m_debuginfo/readelf.c
|
||||
@@ -2879,13 +2879,15 @@ Bool ML_(read_elf_debug_info) ( struct _DebugInfo* di )
|
||||
/* Look for a build-id */
|
||||
HChar* buildid = find_buildid(mimg, False, False);
|
||||
|
||||
- /* Look for a debug image that matches either the build-id or
|
||||
+ /* If we don't have a .debug_info section in the main image then
|
||||
+ look for a debug image that matches either the build-id or
|
||||
the debuglink-CRC32 in the main image. If the main image
|
||||
doesn't contain either of those then this won't even bother
|
||||
to try looking. This looks in all known places, including
|
||||
the --extra-debuginfo-path if specified and on the
|
||||
--debuginfo-server if specified. */
|
||||
- if (buildid != NULL || debuglink_escn.img != NULL) {
|
||||
+ if (debug_info_escn.img == NULL &&
|
||||
+ (buildid != NULL || debuglink_escn.img != NULL)) {
|
||||
/* Do have a debuglink section? */
|
||||
if (debuglink_escn.img != NULL) {
|
||||
UInt crc_offset
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,46 +0,0 @@
|
||||
commit 124ae6cfa303f0cc71ffd685620cb57c4f8f02bb
|
||||
Author: Andreas Arnez <arnez@linux.ibm.com>
|
||||
Date: Mon Jun 7 14:01:53 2021 +0200
|
||||
|
||||
s390x: Don't emit "vector or with complement" on z13
|
||||
|
||||
The z/Architecture instruction "vector or with complement" (VOC) can be
|
||||
used as an optimization to combine "vector or" with "vector nor". This is
|
||||
exploited in Valgrind since commit 6c1cb1a0128b00858b973e. However, VOC
|
||||
requires the vector-enhancements facility 1, which is not installed on a
|
||||
z13 CPU. Thus Valgrind can now run into SIGILL on z13 when trying to
|
||||
execute vector string instructions.
|
||||
|
||||
Fix this by suppressing the VOC optimization unless the
|
||||
vector-enhancements facility 1 is recognized on the host.
|
||||
|
||||
diff --git a/VEX/priv/host_s390_isel.c b/VEX/priv/host_s390_isel.c
|
||||
index ee20c6711..15ca92a6b 100644
|
||||
--- a/VEX/priv/host_s390_isel.c
|
||||
+++ b/VEX/priv/host_s390_isel.c
|
||||
@@ -4102,14 +4102,17 @@ s390_isel_vec_expr_wrk(ISelEnv *env, IRExpr *expr)
|
||||
case Iop_OrV128:
|
||||
size = 16;
|
||||
vec_binop = S390_VEC_OR;
|
||||
- if (arg1->tag == Iex_Unop && arg1->Iex.Unop.op == Iop_NotV128) {
|
||||
- IRExpr* orig_arg1 = arg1;
|
||||
- arg1 = arg2;
|
||||
- arg2 = orig_arg1->Iex.Unop.arg;
|
||||
- vec_binop = S390_VEC_ORC;
|
||||
- } else if (arg2->tag == Iex_Unop && arg2->Iex.Unop.op == Iop_NotV128) {
|
||||
- arg2 = arg2->Iex.Unop.arg;
|
||||
- vec_binop = S390_VEC_ORC;
|
||||
+ if (s390_host_has_vxe) {
|
||||
+ if (arg1->tag == Iex_Unop && arg1->Iex.Unop.op == Iop_NotV128) {
|
||||
+ IRExpr* orig_arg1 = arg1;
|
||||
+ arg1 = arg2;
|
||||
+ arg2 = orig_arg1->Iex.Unop.arg;
|
||||
+ vec_binop = S390_VEC_ORC;
|
||||
+ } else if (arg2->tag == Iex_Unop &&
|
||||
+ arg2->Iex.Unop.op == Iop_NotV128) {
|
||||
+ arg2 = arg2->Iex.Unop.arg;
|
||||
+ vec_binop = S390_VEC_ORC;
|
||||
+ }
|
||||
}
|
||||
goto Iop_VV_wrk;
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,54 +0,0 @@
|
||||
commit 45873298ff2d17accc65654d64758360616aade5
|
||||
Author: Andreas Arnez <arnez@linux.ibm.com>
|
||||
Date: Tue Mar 30 18:10:43 2021 +0200
|
||||
|
||||
s390x: Add missing UNOP insns to s390_insn_as_string
|
||||
|
||||
Some unary operator insns are not handled by s390_insn_as_string(). If
|
||||
they are encountered while the appropriate trace flag is set, a vpanic
|
||||
occurs. Fix this: add handling for the missing insns.
|
||||
|
||||
diff --git a/VEX/priv/host_s390_defs.c b/VEX/priv/host_s390_defs.c
|
||||
index 8762975b2..6e0734ae0 100644
|
||||
--- a/VEX/priv/host_s390_defs.c
|
||||
+++ b/VEX/priv/host_s390_defs.c
|
||||
@@ -7860,12 +7860,24 @@ s390_insn_as_string(const s390_insn *insn)
|
||||
op = "v-vunpacku";
|
||||
break;
|
||||
|
||||
- case S390_VEC_FLOAT_NEG:
|
||||
- op = "v-vfloatneg";
|
||||
+ case S390_VEC_ABS:
|
||||
+ op = "v-vabs";
|
||||
break;
|
||||
|
||||
- case S390_VEC_FLOAT_SQRT:
|
||||
- op = "v-vfloatsqrt";
|
||||
+ case S390_VEC_COUNT_LEADING_ZEROES:
|
||||
+ op = "v-vclz";
|
||||
+ break;
|
||||
+
|
||||
+ case S390_VEC_COUNT_TRAILING_ZEROES:
|
||||
+ op = "v-vctz";
|
||||
+ break;
|
||||
+
|
||||
+ case S390_VEC_COUNT_ONES:
|
||||
+ op = "v-vpopct";
|
||||
+ break;
|
||||
+
|
||||
+ case S390_VEC_FLOAT_NEG:
|
||||
+ op = "v-vfloatneg";
|
||||
break;
|
||||
|
||||
case S390_VEC_FLOAT_ABS:
|
||||
@@ -7876,6 +7888,10 @@ s390_insn_as_string(const s390_insn *insn)
|
||||
op = "v-vfloatnabs";
|
||||
break;
|
||||
|
||||
+ case S390_VEC_FLOAT_SQRT:
|
||||
+ op = "v-vfloatsqrt";
|
||||
+ break;
|
||||
+
|
||||
default:
|
||||
goto fail;
|
||||
}
|
@ -1,15 +0,0 @@
|
||||
--- valgrind/glibc-2.34567-NPTL-helgrind.supp.jj 2009-08-19 15:37:48.000000000 +0200
|
||||
+++ valgrind/glibc-2.34567-NPTL-helgrind.supp 2009-10-21 16:46:31.000000000 +0200
|
||||
@@ -88,6 +88,12 @@
|
||||
obj:*/lib*/libpthread-2.*so*
|
||||
}
|
||||
{
|
||||
+ helgrind-glibc2X-102a
|
||||
+ Helgrind:Race
|
||||
+ fun:mythread_wrapper
|
||||
+ obj:*vgpreload_helgrind*.so
|
||||
+}
|
||||
+{
|
||||
helgrind-glibc2X-103
|
||||
Helgrind:Race
|
||||
fun:pthread_cond_*@@GLIBC_2.*
|
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Tool for finding memory management bugs in programs
|
||||
Name: %{?scl_prefix}valgrind
|
||||
Version: 3.17.0
|
||||
Release: 5%{?dist}
|
||||
Version: 3.18.1
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
URL: http://www.valgrind.org/
|
||||
@ -72,14 +72,11 @@ Group: Development/Debuggers
|
||||
# So those will already have their full symbol table.
|
||||
%undefine _include_minidebuginfo
|
||||
|
||||
Source0: ftp://sourceware.org/pub/valgrind/valgrind-%{version}.tar.bz2
|
||||
Source0: https://sourceware.org/pub/valgrind/valgrind-%{version}.tar.bz2
|
||||
|
||||
# Needs investigation and pushing upstream
|
||||
Patch1: valgrind-3.9.0-cachegrind-improvements.patch
|
||||
|
||||
# KDE#211352 - helgrind races in helgrind's own mythread_wrapper
|
||||
Patch2: valgrind-3.9.0-helgrind-race-supp.patch
|
||||
|
||||
# Make ld.so supressions slightly less specific.
|
||||
Patch3: valgrind-3.9.0-ldso-supp.patch
|
||||
|
||||
@ -89,67 +86,6 @@ Patch4: valgrind-3.16.0-some-stack-protector.patch
|
||||
# Add some -Wl,z,now.
|
||||
Patch5: valgrind-3.16.0-some-Wl-z-now.patch
|
||||
|
||||
# Upstream commits that provide additional ppc64le ISA 3.1 support
|
||||
# commit 3cc0232c46a5905b4a6c2fbd302b58bf5f90b3d5
|
||||
# PPC64: ISA 3.1 VSX PCV Generate Operations
|
||||
# commit 078f89e99b6f62e043f6138c6a7ae238befc1f2a
|
||||
# PPC64: Reduced-Precision bfloat16 Outer Product & Format Conversion Operations
|
||||
# commit e09fdaf569b975717465ed8043820d0198d4d47d
|
||||
# PPC64: Reduced-Precision: Missing Integer-based Outer Product Operations
|
||||
Patch6: valgrind-3.17.0-ppc64-isa-3.1.patch
|
||||
|
||||
# Upstream commits that provide extra tests for ppc64le ISA 3.1 support
|
||||
# commit c8fa838be405d7ac43035dcf675bf490800c26ec
|
||||
# Reduced Precision bfloat16 outer product tests
|
||||
# commit 4bcc6c8a97c10c4dd41b35bd3b3035ec4037d524
|
||||
# VSX Permute Control Vector Generate Operation tests.
|
||||
# commit c589b652939655090c005a982a71f50c489fb5ce
|
||||
# Reduced precision Missing Integer based outer tests
|
||||
Patch7: valgrind-3.17.0-ppc64-isa-3.1-tests.patch
|
||||
|
||||
# commit 45873298ff2d17accc65654d64758360616aade5
|
||||
# s390x: Add missing UNOP insns to s390_insn_as_string
|
||||
Patch8: valgrind-3.17.0-s390_insn_as_string.patch
|
||||
|
||||
# KDE#435908 Don't look for separate debuginfo if image already has .debug_info
|
||||
Patch9: valgrind-3.17.0-debuginfod.patch
|
||||
|
||||
# KDE#423963 Only process clone results in the parent thread
|
||||
Patch10: valgrind-3.17.0-clone-parent-res.patch
|
||||
|
||||
# commit d74a637206ef5532ccd2ccb2e31ee2762f184e60
|
||||
# Bug 433863 - s390x: Remove memcheck test cases for cs, cds, and csg
|
||||
# commit 18ddcc47c951427efd3b790ba2481159b9bd1598
|
||||
# s390x: Support "expensive" comparisons Iop_ExpCmpNE32/64
|
||||
# commit 5db3f929c43bf46f4707178706cfe90f43acdd19
|
||||
# s390x: Add convenience function mkV128()
|
||||
# commit e78bd78d3043729033b426218ab8c6dae9c51e96
|
||||
# Bug 434296 - s390x: Rework IR conversion of VSTRC, VFAE, and VFEE
|
||||
# commit 4f17a067c4f8245c05611d6e8aa36e8841bab376
|
||||
# Bug 434296 - s390x: Rework IR conversion of VFENE
|
||||
# commit 9bd78ebd8bb5cd4ebb3f081ceba46836cc485551
|
||||
# Bug 434296 - s390x: Rework IR conversion of VISTR
|
||||
# commit 32312d588b77c5b5b5a0145bb0cc6f795b447790
|
||||
# Bug 434296 - s390x: Add memcheck test cases for vector string insns
|
||||
# commit a0bb049ace14ab52d386bb1d49a399f39eec4986
|
||||
# s390x: Improve handling of amodes without base register
|
||||
# commit fd935e238d907d9c523a311ba795077d95ad6912
|
||||
# s390x: Rework insn "v-vdup" and add "v-vrep"
|
||||
# commit 6c1cb1a0128b00858b973ef9344e12d6ddbaaf57
|
||||
# s390x: Add support for emitting "vector or with complement"
|
||||
# commit 0bd4263326b2d48f782339a9bbe1a069c7de45c7
|
||||
# s390x: Fix/optimize Iop_64HLtoV128
|
||||
# commit cae5062b05b95e0303b1122a0ea9aadc197e4f0a
|
||||
# s390x: Add missing stdout.exp for vector string memcheck test
|
||||
Patch11: valgrind-3.17.0-s390-prep.patch
|
||||
|
||||
# KDE#432387 - s390x: z15 instructions support
|
||||
Patch12: valgrind-3.17.0-s390-z15.patch
|
||||
|
||||
# commit 124ae6cfa303f0cc71ffd685620cb57c4f8f02bb
|
||||
# s390x: Don't emit "vector or with complement" on z13
|
||||
Patch13: valgrind-3.17.0-s390-z13-vec-fix.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: glibc-devel
|
||||
|
||||
@ -180,9 +116,6 @@ BuildRequires: autoconf
|
||||
# For make check validating the documentation
|
||||
BuildRequires: docbook-dtds
|
||||
|
||||
# configure might use which
|
||||
BuildRequires: which
|
||||
|
||||
# For testing debuginfod-find
|
||||
%if 0%{?fedora} > 29 || 0%{?rhel} > 7
|
||||
BuildRequires: elfutils-debuginfod-client
|
||||
@ -285,7 +218,6 @@ Valgrind User Manual for details.
|
||||
%setup -q -n %{?scl:%{pkg_name}}%{!?scl:%{name}}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# Old rhel gcc doesn't have -fstack-protector-strong.
|
||||
@ -294,18 +226,6 @@ Valgrind User Manual for details.
|
||||
%patch5 -p1
|
||||
%endif
|
||||
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
%patch11 -p1
|
||||
touch memcheck/tests/s390x/vistr.stdout.exp
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
%build
|
||||
|
||||
# Some patches (might) touch Makefile.am or configure.ac files.
|
||||
@ -473,8 +393,11 @@ fi
|
||||
cat diffs
|
||||
echo ===============END TESTING===============
|
||||
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
|
||||
%files
|
||||
%doc COPYING NEWS README_*
|
||||
%license COPYING COPYING.DOCS
|
||||
%doc NEWS README_*
|
||||
%doc docs/installed/html docs/installed/*.pdf
|
||||
%{_bindir}/*
|
||||
%dir %{_libexecdir}/valgrind
|
||||
@ -498,6 +421,7 @@ echo ===============END TESTING===============
|
||||
|
||||
%if %{build_tools_devel}
|
||||
%files tools-devel
|
||||
%license COPYING
|
||||
%{_includedir}/valgrind/config.h
|
||||
%{_includedir}/valgrind/libvex*h
|
||||
%{_includedir}/valgrind/pub_tool_*h
|
||||
@ -526,6 +450,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 20 2021 Mark Wielaard <mjw@redhat.com> - 3.18.1-1
|
||||
- Update to upstream 3.18.1 final
|
||||
|
||||
* Thu Jun 24 2021 Mark Wielaard <mjw@redhat.com> - 3.17.0-5
|
||||
- Add valgrind-3.17.0-s390-prep.patch
|
||||
- Add valgrind-3.17.0-s390-z15.patch
|
||||
|
Loading…
Reference in New Issue
Block a user