Add valgrind-3.18.1-dhat-tests-copy.patch
This commit is contained in:
parent
f24346e6a4
commit
a8914b410d
20
valgrind-3.18.1-dhat-tests-copy.patch
Normal file
20
valgrind-3.18.1-dhat-tests-copy.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
commit 33aba8eef68b1745d3de96b609ff8296b70d9a1c
|
||||||
|
Author: Paul Floyd <pjfloyd@wanadoo.fr>
|
||||||
|
Date: Wed Oct 27 21:37:00 2021 +0200
|
||||||
|
|
||||||
|
Bug 444495 - dhat/tests/copy fails on s390x
|
||||||
|
|
||||||
|
Add -fno-builtin to ensure that the copy functions get called and so dhat
|
||||||
|
can intercept and count them.
|
||||||
|
|
||||||
|
diff --git a/dhat/tests/Makefile.am b/dhat/tests/Makefile.am
|
||||||
|
index 86a9b6d64..b86fc416d 100644
|
||||||
|
--- a/dhat/tests/Makefile.am
|
||||||
|
+++ b/dhat/tests/Makefile.am
|
||||||
|
@@ -29,3 +29,6 @@ AM_CXXFLAGS += $(AM_FLAG_M3264_PRI)
|
||||||
|
# We don't care about uninitialized or unused malloc results
|
||||||
|
basic_CFLAGS = $(AM_CFLAGS) -Wno-uninitialized
|
||||||
|
big_CFLAGS = $(AM_CFLAGS) -Wno-unused-result
|
||||||
|
+
|
||||||
|
+# Prevent the copying functions from being inlined
|
||||||
|
+copy_CFLAGS = $(AM_CFLAGS) -fno-builtin
|
@ -85,6 +85,9 @@ Patch4: valgrind-3.16.0-some-stack-protector.patch
|
|||||||
# Add some -Wl,z,now.
|
# Add some -Wl,z,now.
|
||||||
Patch5: valgrind-3.16.0-some-Wl-z-now.patch
|
Patch5: valgrind-3.16.0-some-Wl-z-now.patch
|
||||||
|
|
||||||
|
# KDE#444495 dhat/tests/copy fails on s390x
|
||||||
|
Patch6: valgrind-3.18.1-dhat-tests-copy.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
|
||||||
@ -222,6 +225,8 @@ Valgrind User Manual for details.
|
|||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# LTO triggers undefined symbols in valgrind. Valgrind has a --enable-lto
|
# LTO triggers undefined symbols in valgrind. Valgrind has a --enable-lto
|
||||||
# configure time option, but that doesn't seem to help.
|
# configure time option, but that doesn't seem to help.
|
||||||
@ -450,6 +455,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 1 2021 Mark Wielaard <mjw@fedoraproject.org>
|
||||||
|
- Add valgrind-3.18.1-dhat-tests-copy.patch
|
||||||
|
|
||||||
* Fri Oct 15 2021 Mark Wielaard <mjw@fedoraproject.org> - 3.18.0-1
|
* Fri Oct 15 2021 Mark Wielaard <mjw@fedoraproject.org> - 3.18.0-1
|
||||||
- Update to upstream 3.18.1 final
|
- Update to upstream 3.18.1 final
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user