3.21.0-0.1.RC1
This commit is contained in:
parent
068f90a110
commit
a1bab0364c
1
.gitignore
vendored
1
.gitignore
vendored
@ -45,3 +45,4 @@
|
||||
/valgrind-3.18.1.tar.bz2
|
||||
/valgrind-3.19.0.tar.bz2
|
||||
/valgrind-3.20.0.tar.bz2
|
||||
/valgrind-3.21.0.RC1.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (valgrind-3.20.0.tar.bz2) = d6bfb9284d0410134ee7e2a5975b13c01508dd5587b562947d8197b3c113b76fdfac88c4072948be68bbf0dbeb17b4d1acb1412ce898adaa83c30ae2c6a1c12b
|
||||
SHA512 (valgrind-3.21.0.RC1.tar.bz2) = 7c2a3ea34969a94ce221043007f14c7e5d40387dc2e44e28bdede59188a2d4b171e5ea4ce7c761007348bffe4e99265817dedd8cc932e8b94f5055786b418b58
|
||||
|
@ -35,19 +35,6 @@ index 1b7842b..e211eec 100644
|
||||
if HAVE_DLINFO_RTLD_DI_TLS_MODID
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDADD = $(LDADD) -ldl
|
||||
endif
|
||||
diff --git a/cachegrind/Makefile.am b/cachegrind/Makefile.am
|
||||
index f572741..1c07e50 100644
|
||||
--- a/cachegrind/Makefile.am
|
||||
+++ b/cachegrind/Makefile.am
|
||||
@@ -27,7 +27,7 @@ cg_merge_SOURCES = cg_merge.c
|
||||
cg_merge_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
cg_merge_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
cg_merge_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
-cg_merge_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
+cg_merge_LDFLAGS = $(AM_CFLAGS_PRI) -Wl,-z,now
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
# then the primary platform must be x86-darwin. Hence:
|
||||
if ! VGCONF_HAVE_PLATFORM_SEC
|
||||
diff --git a/coregrind/Makefile.am b/coregrind/Makefile.am
|
||||
index 3c73210..fb6b7bb 100644
|
||||
--- a/coregrind/Makefile.am
|
||||
|
@ -35,19 +35,6 @@ index 56cc5ef..1b7842b 100644
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
getoff_@VGCONF_ARCH_PRI@_@VGCONF_OS@_LDFLAGS = $(AM_CFLAGS_PRI) @LIB_UBSAN@
|
||||
if HAVE_DLINFO_RTLD_DI_TLS_MODID
|
||||
diff --git a/cachegrind/Makefile.am b/cachegrind/Makefile.am
|
||||
index f8447a1..f572741 100644
|
||||
--- a/cachegrind/Makefile.am
|
||||
+++ b/cachegrind/Makefile.am
|
||||
@@ -25,7 +25,7 @@ bin_PROGRAMS = cg_merge
|
||||
|
||||
cg_merge_SOURCES = cg_merge.c
|
||||
cg_merge_CPPFLAGS = $(AM_CPPFLAGS_PRI)
|
||||
-cg_merge_CFLAGS = $(AM_CFLAGS_PRI)
|
||||
+cg_merge_CFLAGS = $(AM_CFLAGS_PRI) -fstack-protector-strong
|
||||
cg_merge_CCASFLAGS = $(AM_CCASFLAGS_PRI)
|
||||
cg_merge_LDFLAGS = $(AM_CFLAGS_PRI)
|
||||
# If there is no secondary platform, and the platforms include x86-darwin,
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f8c798b..ccc8f52 100755
|
||||
--- a/configure.ac
|
||||
|
@ -1,17 +0,0 @@
|
||||
Add the missing int, to avoid a compilation failure in strict C99 mode.
|
||||
|
||||
Submitted upstream: <https://bugs.kde.org/show_bug.cgi?id=462007>
|
||||
|
||||
diff --git a/none/tests/faultstatus.c b/none/tests/faultstatus.c
|
||||
index 458ea8264593af4e..92a8350ab2285092 100644
|
||||
--- a/none/tests/faultstatus.c
|
||||
+++ b/none/tests/faultstatus.c
|
||||
@@ -190,7 +190,7 @@ int main()
|
||||
return 0;
|
||||
}
|
||||
|
||||
-static volatile s_zero;
|
||||
+static volatile int s_zero;
|
||||
|
||||
static int zero()
|
||||
{
|
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Dynamic analysis tools to detect memory or thread bugs and profile
|
||||
Name: %{?scl_prefix}valgrind
|
||||
Version: 3.20.0
|
||||
Release: 3%{?dist}
|
||||
Version: 3.21.0
|
||||
Release: 0.1.RC1%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
URL: https://www.valgrind.org/
|
||||
@ -69,7 +69,7 @@ URL: https://www.valgrind.org/
|
||||
# So those will already have their full symbol table.
|
||||
%undefine _include_minidebuginfo
|
||||
|
||||
Source0: https://sourceware.org/pub/valgrind/valgrind-%{version}.tar.bz2
|
||||
Source0: https://sourceware.org/pub/valgrind/valgrind-%{version}.RC1.tar.bz2
|
||||
|
||||
# Needs investigation and pushing upstream
|
||||
Patch1: valgrind-3.9.0-cachegrind-improvements.patch
|
||||
@ -83,8 +83,6 @@ Patch3: valgrind-3.16.0-some-stack-protector.patch
|
||||
# Add some -Wl,z,now.
|
||||
Patch4: valgrind-3.16.0-some-Wl-z-now.patch
|
||||
|
||||
Patch5: valgrind-faultstatus-implicit-int.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: glibc-devel
|
||||
|
||||
@ -211,7 +209,7 @@ Valgrind User Manual for details.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n %{?scl:%{pkg_name}}%{!?scl:%{name}}-%{version}
|
||||
%setup -q -n %{?scl:%{pkg_name}}%{!?scl:%{name}}-%{version}.RC1
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
@ -220,7 +218,6 @@ Valgrind User Manual for details.
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
@ -451,8 +448,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.20.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
* Fri Apr 21 2022 Mark Wielaard <mjw@fedoraproject.org> - 3.21.0-0.1.RC1
|
||||
- Upstream 3.21.0-RC1
|
||||
- Remove upstreamed valgrind-faultstatus-implicit-int.patch
|
||||
- Adjust valgrind-3.16.0-some-{Wl-z-now,stack-protector}.patch
|
||||
cg_merge is now a pything script.
|
||||
|
||||
* Fri Nov 18 2022 Florian Weimer <fweimer@redhat.com> - 1:3.20.0-2
|
||||
- Avoid using implicit int C89 feature
|
||||
|
Loading…
Reference in New Issue
Block a user