3.8.0-8 - Add configure fixup valgrind-3.8.0-bmi-conf-check.patch

This commit is contained in:
Mark Wielaard 2012-09-13 19:27:23 +02:00
parent a9c6142734
commit 9bef860b35
2 changed files with 36 additions and 1 deletions

View File

@ -0,0 +1,28 @@
--- valgrind-3.8.0/configure 2012-09-12 20:20:29.868427602 +0200
+++ valgrind-3.8.0/configure 2012-09-13 18:28:42.354382238 +0200
@@ -8389,9 +8389,9 @@
do { unsigned int h, l;
__asm__ __volatile__(
- "andn %2, %1, %0" : "=r" (h) : "r" (0x1234567), "r" (0x7654321) ); }
+ "andn %2, %1, %0" : "=r" (h) : "r" (0x1234567), "r" (0x7654321) );
__asm__ __volatile__(
- "movl %2, %%edx; mulx %3, %1, %0" : "=r" (h), "=r" (l) : "g" (0x1234567), "g" (0x7654321) : "edx" ); }
+ "movl %2, %%edx; mulx %3, %1, %0" : "=r" (h), "=r" (l) : "g" (0x1234567), "rm" (0x7654321) : "edx" ); }
while (0)
;
--- valgrind-3.8.0/configure.in 2012-09-13 14:53:45.826948006 +0200
+++ valgrind-3.8.0/configure.in 2012-09-13 18:28:20.725057751 +0200
@@ -1822,9 +1822,9 @@
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
do { unsigned int h, l;
__asm__ __volatile__(
- "andn %2, %1, %0" : "=r" (h) : "r" (0x1234567), "r" (0x7654321) ); }
+ "andn %2, %1, %0" : "=r" (h) : "r" (0x1234567), "r" (0x7654321) );
__asm__ __volatile__(
- "movl %2, %%edx; mulx %3, %1, %0" : "=r" (h), "=r" (l) : "g" (0x1234567), "g" (0x7654321) : "edx" ); }
+ "movl %2, %%edx; mulx %3, %1, %0" : "=r" (h), "=r" (l) : "g" (0x1234567), "rm" (0x7654321) : "edx" ); }
while (0)
]])], [
ac_have_as_bmi=yes

View File

@ -1,7 +1,7 @@
Summary: Tool for finding memory management bugs in programs
Name: valgrind
Version: 3.8.0
Release: 7%{?dist}
Release: 8%{?dist}
Epoch: 1
License: GPLv2
URL: http://www.valgrind.org/
@ -45,6 +45,9 @@ Patch15: valgrind-3.8.0-avx-alignment-check.patch
# ./none/tests/amd64/fma.stderr.exp
# ./none/tests/amd64/bmi.stderr.exp
Patch16: valgrind-3.8.0-avx2-bmi-fma.patch.gz
# Small fixup for above patch, just a configure check.
# This is equivalent to valgrind-bmi-5.patch from KDE#305728
Patch17: valgrind-3.8.0-bmi-conf-check.patch
Obsoletes: valgrind-callgrind
%ifarch x86_64 ppc64
@ -144,6 +147,7 @@ for details.
touch ./none/tests/amd64/avx2-1.stderr.exp
touch ./none/tests/amd64/fma.stderr.exp
touch ./none/tests/amd64/bmi.stderr.exp
%patch17 -p1
%build
CC=gcc
@ -254,6 +258,9 @@ echo ===============END TESTING===============
%endif
%changelog
* Wed Sep 12 2012 Mark Wielaard <mjw@redhat.com> 3.8.0-8
- Add configure fixup valgrind-3.8.0-bmi-conf-check.patch
* Wed Sep 12 2012 Mark Wielaard <mjw@redhat.com> 3.8.0-7
- Add valgrind-3.8.0-avx2-bmi-fma.patch (KDE#305728)