import valgrind-3.16.0-4.el8
This commit is contained in:
parent
79651c28f7
commit
9bc9a0e7f1
27
SOURCES/valgrind-3.16.1-s390_emit_load_mem.patch
Normal file
27
SOURCES/valgrind-3.16.1-s390_emit_load_mem.patch
Normal file
@ -0,0 +1,27 @@
|
||||
commit ba73f8d2ebe4b5fe8163ee5ab806f0e50961ebdf
|
||||
Author: Andreas Arnez <arnez@linux.ibm.com>
|
||||
Date: Tue Nov 3 18:17:30 2020 +0100
|
||||
|
||||
Bug 428648 - s390x: Force 12-bit amode for vector loads in isel
|
||||
|
||||
Similar to Bug 417452, where the instruction selector sometimes attempted
|
||||
to generate vector stores with a 20-bit displacement, the same problem has
|
||||
now been reported with vector loads.
|
||||
|
||||
The problem is caused in s390_isel_vec_expr_wrk(), where the addressing
|
||||
mode is generated with s390_isel_amode() instead of
|
||||
s390_isel_amode_short(). This is fixed.
|
||||
|
||||
diff --git a/VEX/priv/host_s390_isel.c b/VEX/priv/host_s390_isel.c
|
||||
index 2f80dd850..134f3eb6f 100644
|
||||
--- a/VEX/priv/host_s390_isel.c
|
||||
+++ b/VEX/priv/host_s390_isel.c
|
||||
@@ -3741,7 +3741,7 @@ s390_isel_vec_expr_wrk(ISelEnv *env, IRExpr *expr)
|
||||
/* --------- LOAD --------- */
|
||||
case Iex_Load: {
|
||||
HReg dst = newVRegV(env);
|
||||
- s390_amode *am = s390_isel_amode(env, expr->Iex.Load.addr);
|
||||
+ s390_amode *am = s390_isel_amode_short(env, expr->Iex.Load.addr);
|
||||
|
||||
if (expr->Iex.Load.end != Iend_BE)
|
||||
goto irreducible;
|
2977
SOURCES/valgrind-3.16.1-s390x-z14-vector.patch
Normal file
2977
SOURCES/valgrind-3.16.1-s390x-z14-vector.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -3,7 +3,7 @@
|
||||
Summary: Tool for finding memory management bugs in programs
|
||||
Name: %{?scl_prefix}valgrind
|
||||
Version: 3.16.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
URL: http://www.valgrind.org/
|
||||
@ -112,6 +112,13 @@ Patch11: valgrind-3.16.1-sched_getsetattr.patch
|
||||
# KDE#415293 Incorrect call-graph tracking due to new _dl_runtime_resolve*
|
||||
Patch12: valgrind-3.16.1-dl_runtime_resolve.patch
|
||||
|
||||
|
||||
# KDE#428648 s390_emit_load_mem panics due to 20-bit offset for vector load
|
||||
Patch15: valgrind-3.16.1-s390_emit_load_mem.patch
|
||||
|
||||
# KDE#133812 s390x: z14 vector instructions not implemented
|
||||
Patch16: valgrind-3.16.1-s390x-z14-vector.patch
|
||||
|
||||
BuildRequires: glibc-devel
|
||||
|
||||
%if %{build_openmpi}
|
||||
@ -253,6 +260,9 @@ Valgrind User Manual for details.
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
|
||||
%build
|
||||
|
||||
# Some patches (might) touch Makefile.am or configure.ac files.
|
||||
@ -472,6 +482,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 4 2020 Mark Wielaard <mjw@redhat.com> - 3.16.0-4
|
||||
- Add valgrind-3.16.1-s390_emit_load_mem.patch
|
||||
- Add valgrind-3.16.1-s390x-z14-vector.patch
|
||||
|
||||
* Tue Oct 20 2020 Mark Wielaard <mjw@redhat.com> - 3.16.0-3
|
||||
- Add valgrind-3.16.1-REX-prefix-JMP.patch
|
||||
- Add valgrind-3.16.1-epoll.patch
|
||||
|
Loading…
Reference in New Issue
Block a user