3.8.1-6 Allow building against glibc-2.17.
This commit is contained in:
parent
464c3fa639
commit
46403fedf9
78
valgrind-3.8.1-glibc-2.17.patch
Normal file
78
valgrind-3.8.1-glibc-2.17.patch
Normal file
@ -0,0 +1,78 @@
|
|||||||
|
commit 3781ac11ff374b3517011c1710ec517d52f25cd2
|
||||||
|
Author: tom <tom@a5019735-40e9-0310-863c-91ae7b9d1cf9>
|
||||||
|
Date: Mon Jan 14 09:48:49 2013 +0000
|
||||||
|
|
||||||
|
Accept glibc 2.17 as valid.
|
||||||
|
|
||||||
|
|
||||||
|
git-svn-id: svn://svn.valgrind.org/valgrind/trunk@13228 a5019735-40e9-0310-863c-91ae7b9d1cf9
|
||||||
|
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index e0fb12d..0f3b3df 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -906,6 +906,13 @@ case "${GLIBC_VERSION}" in
|
||||||
|
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
;;
|
||||||
|
+ 2.17)
|
||||||
|
+ AC_MSG_RESULT(2.17 family)
|
||||||
|
+ AC_DEFINE([GLIBC_2_17], 1, [Define to 1 if you're using glibc 2.17.x])
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
+ ;;
|
||||||
|
darwin)
|
||||||
|
AC_MSG_RESULT(Darwin)
|
||||||
|
AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
|
||||||
|
@@ -919,7 +926,7 @@ case "${GLIBC_VERSION}" in
|
||||||
|
|
||||||
|
*)
|
||||||
|
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
|
||||||
|
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.16])
|
||||||
|
+ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.17])
|
||||||
|
AC_MSG_ERROR([or Darwin libc])
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
diff -ur valgrind-3.8.1/config.h.in valgrind-3.8.1/config.h.in
|
||||||
|
--- valgrind-3.8.1/config.h.in 2013-01-16 17:15:33.531018561 +0100
|
||||||
|
+++ valgrind-3.8.1/config.h.in 2013-01-16 17:19:21.000000000 +0100
|
||||||
|
@@ -48,6 +48,9 @@
|
||||||
|
/* Define to 1 if you're using glibc 2.16.x */
|
||||||
|
#undef GLIBC_2_16
|
||||||
|
|
||||||
|
+/* Define to 1 if you're using glibc 2.17.x */
|
||||||
|
+#undef GLIBC_2_17
|
||||||
|
+
|
||||||
|
/* Define to 1 if you're using glibc 2.2.x */
|
||||||
|
#undef GLIBC_2_2
|
||||||
|
|
||||||
|
diff -ur valgrind-3.8.1/configure valgrind-3.8.1/configure
|
||||||
|
--- valgrind-3.8.1/configure 2013-01-16 17:15:33.563018480 +0100
|
||||||
|
+++ valgrind-3.8.1/configure 2013-01-16 17:19:21.373643238 +0100
|
||||||
|
@@ -6610,6 +6610,16 @@
|
||||||
|
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
;;
|
||||||
|
+ 2.17)
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.17 family" >&5
|
||||||
|
+$as_echo "2.17 family" >&6; }
|
||||||
|
+
|
||||||
|
+$as_echo "#define GLIBC_2_17 1" >>confdefs.h
|
||||||
|
+
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||||
|
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||||
|
+ ;;
|
||||||
|
darwin)
|
||||||
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Darwin" >&5
|
||||||
|
$as_echo "Darwin" >&6; }
|
||||||
|
@@ -6630,7 +6640,7 @@
|
||||||
|
*)
|
||||||
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: unsupported version ${GLIBC_VERSION}" >&5
|
||||||
|
$as_echo "unsupported version ${GLIBC_VERSION}" >&6; }
|
||||||
|
- as_fn_error "Valgrind requires glibc version 2.2 - 2.16" "$LINENO" 5
|
||||||
|
+ as_fn_error "Valgrind requires glibc version 2.2 - 2.17" "$LINENO" 5
|
||||||
|
as_fn_error "or Darwin libc" "$LINENO" 5
|
||||||
|
;;
|
||||||
|
esac
|
@ -3,7 +3,7 @@
|
|||||||
Summary: Tool for finding memory management bugs in programs
|
Summary: Tool for finding memory management bugs in programs
|
||||||
Name: %{?scl_prefix}valgrind
|
Name: %{?scl_prefix}valgrind
|
||||||
Version: 3.8.1
|
Version: 3.8.1
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://www.valgrind.org/
|
URL: http://www.valgrind.org/
|
||||||
@ -135,6 +135,9 @@ Patch31: valgrind-3.8.1-ppc-32-mode-64-bit-instr.patch
|
|||||||
# illegal instruction reporting
|
# illegal instruction reporting
|
||||||
Patch32: valgrind-3.8.1-sigill_diag.patch
|
Patch32: valgrind-3.8.1-sigill_diag.patch
|
||||||
|
|
||||||
|
# Allow building against glibc-2.17. Upstream commit svn 13228.
|
||||||
|
Patch33: valgrind-3.8.1-glibc-2.17.patch
|
||||||
|
|
||||||
Obsoletes: valgrind-callgrind
|
Obsoletes: valgrind-callgrind
|
||||||
%ifarch x86_64 ppc64
|
%ifarch x86_64 ppc64
|
||||||
# Ensure glibc{,-devel} is installed for both multilib arches
|
# Ensure glibc{,-devel} is installed for both multilib arches
|
||||||
@ -268,6 +271,7 @@ touch ./none/tests/amd64/bmi.stderr.exp
|
|||||||
%patch30 -p1
|
%patch30 -p1
|
||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
|
%patch33 -p1
|
||||||
|
|
||||||
# To suppress eventual automake warnings/errors
|
# To suppress eventual automake warnings/errors
|
||||||
rm -f gdbserver_tests/filter_gdb.orig
|
rm -f gdbserver_tests/filter_gdb.orig
|
||||||
@ -417,6 +421,9 @@ echo ===============END TESTING===============
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 16 2013 Mark Wielaard <mjw@redhat.com> 3.8.1-6
|
||||||
|
- Allow building against glibc-2.17.
|
||||||
|
|
||||||
* Sun Nov 4 2012 Mark Wielaard <mjw@redhat.com> 3.8.1-5
|
* Sun Nov 4 2012 Mark Wielaard <mjw@redhat.com> 3.8.1-5
|
||||||
- Add valgrind-3.8.1-stpncpy.patch (KDE#309427)
|
- Add valgrind-3.8.1-stpncpy.patch (KDE#309427)
|
||||||
- Add valgrind-3.8.1-ppc-32-mode-64-bit-instr.patch (#810992, KDE#308573)
|
- Add valgrind-3.8.1-ppc-32-mode-64-bit-instr.patch (#810992, KDE#308573)
|
||||||
|
Loading…
Reference in New Issue
Block a user