From 3e42d1130e8c7faeb650bbb578b3d8fc07b8e7e4 Mon Sep 17 00:00:00 2001
From: Jakub Jelinek <jakub@redhat.com>
Date: Wed, 8 Jun 2011 19:14:11 +0200
Subject: [PATCH] valgrind-3.6.1-3

---
 valgrind-3.6.1-tests-_GNU_SOURCE.patch | 90 ++++++++++++++++++++++++++
 valgrind.spec                          |  7 +-
 2 files changed, 96 insertions(+), 1 deletion(-)
 create mode 100644 valgrind-3.6.1-tests-_GNU_SOURCE.patch

diff --git a/valgrind-3.6.1-tests-_GNU_SOURCE.patch b/valgrind-3.6.1-tests-_GNU_SOURCE.patch
new file mode 100644
index 0000000..a54d545
--- /dev/null
+++ b/valgrind-3.6.1-tests-_GNU_SOURCE.patch
@@ -0,0 +1,90 @@
+--- valgrind/memcheck/tests/x86-linux/scalar.c	(revision 11801)
++++ valgrind/memcheck/tests/x86-linux/scalar.c	(revision 11802)
+@@ -1,3 +1,5 @@
++#define _GNU_SOURCE
++
+ #include "../../memcheck.h"
+ #include "scalar.h"
+ #include <unistd.h>
+--- valgrind/memcheck/tests/x86-linux/scalar.stderr.exp	(revision 11801)
++++ valgrind/memcheck/tests/x86-linux/scalar.stderr.exp	(revision 11802)
+@@ -578,25 +578,25 @@
+    ...
+  Address 0x........ is 0 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param sigaction(act->sa_mask) points to unaddressable byte(s)
+    ...
+  Address 0x........ is 4 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param sigaction(act->sa_flags) points to unaddressable byte(s)
+    ...
+  Address 0x........ is 8 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param sigaction(oldact) points to unaddressable byte(s)
+    ...
+  Address 0x........ is 0 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ -----------------------------------------------------
+  68:       __NR_sgetmask n/a
+@@ -1228,13 +1228,13 @@
+    ...
+  Address 0x........ is 0 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param sigprocmask(oldset) points to unaddressable byte(s)
+    ...
+  Address 0x........ is 0 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ -----------------------------------------------------
+ 127:  __NR_create_module ni
+@@ -1747,7 +1747,7 @@
+    ...
+  Address 0x........ is 4 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param rt_sigaction(act->sa_mask) points to unaddressable byte(s)
+    ...
+@@ -1757,13 +1757,13 @@
+    ...
+  Address 0x........ is 8 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ Syscall param rt_sigaction(oldact) points to unaddressable byte(s)
+    ...
+  Address 0x........ is 4 bytes after a block of size 4 alloc'd
+    at 0x........: malloc (vg_replace_malloc.c:...)
+-   by 0x........: main (scalar.c:28)
++   by 0x........: main (scalar.c:30)
+ 
+ -----------------------------------------------------
+ 175: __NR_rt_sigprocmask 4s 2m
+--- valgrind/memcheck/tests/linux/stack_switch.c	(revision 11801)
++++ valgrind/memcheck/tests/linux/stack_switch.c	(revision 11802)
+@@ -1,5 +1,6 @@
+ #define _XOPEN_SOURCE 600
+ #define _BSD_SOURCE
++#define _GNU_SOURCE
+ 
+ #include <stdio.h>
+ 
diff --git a/valgrind.spec b/valgrind.spec
index 23e8247..d1ef115 100644
--- a/valgrind.spec
+++ b/valgrind.spec
@@ -1,7 +1,7 @@
 Summary: Tool for finding memory management bugs in programs
 Name: valgrind
 Version: 3.6.1
-Release: 2%{?dist}
+Release: 3%{?dist}
 Epoch: 1
 Source0: http://www.valgrind.org/downloads/valgrind-%{version}.tar.bz2
 Patch1: valgrind-3.6.1-cachegrind-improvements.patch
@@ -23,6 +23,7 @@ Patch16: valgrind-3.6.1-pie.patch
 Patch17: valgrind-3.6.1-gen_insn_test.patch
 Patch18: valgrind-3.6.1-x86-ldso-strlen.patch
 Patch19: valgrind-3.6.1-ppc64-build.patch
+Patch20: valgrind-3.6.1-tests-_GNU_SOURCE.patch
 License: GPLv2
 URL: http://www.valgrind.org/
 Group: Development/Debuggers
@@ -116,6 +117,7 @@ for details.
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
+%patch20 -p1
 
 chmod 755 none/tests/s390x/filter_stderr || :
 
@@ -217,6 +219,9 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %changelog
+* Wed Jun  8 2011 Jakub Jelinek <jakub@redhat.com> 3.6.1-3
+- fix testing against glibc 2.14
+
 * Wed Jun  8 2011 Jakub Jelinek <jakub@redhat.com> 3.6.1-2
 - fix build on ppc64 (#711608)
 - don't fail if s390x support patch hasn't been applied,